]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blame_incremental - perl-Test-Simple.spec
- updated to 1.302183
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Test
6%define pnam Simple
7Summary: Test::Simple - basic utilities for writing tests
8Summary(pl.UTF-8): Test::Simple - podstawowe narzędzia do pisania testów
9Name: perl-Test-Simple
10Version: 1.302140
11%define fver %(echo %{version} | tr -d _)
12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{fver}.tar.gz
17# Source0-md5: 2a3eba9fbafe80a24ce75b604ab045f1
18URL: https://metacpan.org/release/Test-Simple
19%{?with_tests:BuildRequires: perl-Test-Harness >= 2.03}
20BuildRequires: perl-devel >= 1:5.8.0
21BuildRequires: rpm-perlprov >= 4.1-13
22# see lib/Test/Builder/Tester.pm /VERSION
23Provides: perl-Test-Builder-Tester = %{version}
24# see lib/Test/Tester.pm /VERSION
25Provides: perl-Test-Tester = %{version}
26# see lib/Test/use/ok.pm /VERSION
27Provides: perl-Test-use-ok = %{version}
28# obsolete only versions up to last standalone release to avoid obsoleting perl-modules
29# Test::Builder::Tester 1.01
30# Test::Tester 0.109
31# Test::use::ok 0.11
32Obsoletes: perl-Test-Builder-Tester < 1.02
33Obsoletes: perl-Test-Tester < 0.110
34Obsoletes: perl-Test-use-ok < 0.12
35BuildArch: noarch
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%define _noautoreq 'perl(threads)' 'perl(threads::shared)'
39
40%description
41AHHHHHHH!!!! NOT TESTING! Anything but testing! Beat me, whip me, send
42me to Detroit, but don't make me write tests!
43 -- perldoc Test::Tutorial
44
45Test::Simple is an extremely simple, extremely basic module for
46writing tests suitable for CPAN modules and other pursuits. If you
47wish to do more complicated testing, use the Test::More module (a
48drop-in replacement for this one).
49
50The purpose of Test::More is to provide a wide range of testing
51utilities. Various ways to say "ok" with better diagnostics,
52facilities to skip tests, test future features and compare complicated
53data structures. While you can do almost anything with a simple "ok()"
54function, it doesn't provide good diagnostic output.
55
56%description -l pl.UTF-8
57AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie
58mnie, biczujcie mnie, wyślijcie do Detroit, ale nie każcie pisać
59testów!
60 -- perldoc Test::Tutorial
61
62Test::Simple jest bardzo prostym, bardzo podstawowym modułem do
63pisania testów pasujących do modułów CPAN i innych. Do bardziej
64skomplikowanych testów lepiej używać modułu Test::More (zastępującego
65ten).
66
67Celem Test::More jest dostarczenie szerokiego zakresu narzędzi do
68testowania. Różne sposoby powiedzenia "ok" z lepszą diagnostyką,
69ułatwienia przy pomijaniu testów, testowaniu przyszłych możliwości i
70porównywaniu skomplikowanych struktur danych. O ile można zrobić
71prawie wszystko prostą funkcją "ok()", nie daje ona dobrego wyjścia
72diagnostycznego.
73
74%prep
75%setup -q -n %{pdir}-%{pnam}-%{fver}
76%{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
77
78%build
79%{__perl} Makefile.PL \
80 INSTALLDIRS=vendor
81%{__make}
82
83%{?with_tests:%{__make} test}
84
85%install
86rm -rf $RPM_BUILD_ROOT
87
88%{__make} install \
89 DESTDIR=$RPM_BUILD_ROOT
90
91%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%files
97%defattr(644,root,root,755)
98%doc Changes README
99%{perl_vendorlib}/ok.pm
100%{perl_vendorlib}/Test/Builder
101%{perl_vendorlib}/Test/Builder.pm
102%{perl_vendorlib}/Test/More.pm
103%{perl_vendorlib}/Test/Simple.pm
104%{perl_vendorlib}/Test/Tester
105%{perl_vendorlib}/Test/Tester.pm
106%{perl_vendorlib}/Test/use
107%{perl_vendorlib}/Test2.pm
108%{perl_vendorlib}/Test2
109%{_mandir}/man3/Test::Builder*.3pm*
110%{_mandir}/man3/Test::More.3pm*
111%{_mandir}/man3/Test::Simple.3pm*
112%{_mandir}/man3/Test::Tester*.3pm*
113%{_mandir}/man3/Test::Tutorial.3pm*
114%{_mandir}/man3/Test::use::ok.3pm*
115%{_mandir}/man3/Test2*.3pm*
116%{_mandir}/man3/ok.3pm*
This page took 0.096957 seconds and 4 git commands to generate.