]> git.pld-linux.org Git - packages/cronie.git/blame - cronie.spec
- obsoleted should not obsolete version we provide
[packages/cronie.git] / cronie.spec
CommitLineData
955f0d7d
ER
1# TODO
2# - update paths in manuals (create .in files and send upstream)
3# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
64e4eafc
ER
4# - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5# Mar 3 09:30:01 ravenous CROND[2528]: 4ÿ
9088c091
AM
6#
7# Conditional build:
946518b7 8%bcond_without inotify # without inotify support
0d2f2c46
ER
9%if "%{pld_release}" == "ac"
10%bcond_with selinux # without SELinux support
11%bcond_with audit # without audit support
12%else
13%bcond_without selinux # without SELinux support
828712ad 14%bcond_without audit # without audit support
0d2f2c46
ER
15%endif
16
9088c091
AM
17Summary: Cron daemon for executing programs at set times
18Name: cronie
eb52456a 19Version: 1.4.8
bf8f51cd 20Release: 3
fd39f74d 21License: MIT and BSD and GPL v2
9088c091 22Group: Daemons
fd39f74d 23Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
eb52456a 24# Source0-md5: 9b1d2ce6db8d1883e06635f437170657
9088c091
AM
25Source1: %{name}.init
26Source2: cron.logrotate
27Source3: cron.sysconfig
28Source4: %{name}.crontab
29Source5: %{name}.pam
bb090c53 30Source6: %{name}.upstart
f440f0d0 31Patch0: inotify-nosys.patch
9c2aa177 32Patch1: %{name}-nosyscrontab.patch
cb620710 33Patch2: sendmail-path.patch
9088c091 34URL: https://fedorahosted.org/cronie/
828712ad
ER
35%{?with_audit:BuildRequires: audit-libs-devel}
36BuildRequires: autoconf
37BuildRequires: automake
9088c091
AM
38%{?with_selinux:BuildRequires: libselinux-devel}
39BuildRequires: pam-devel
0d2f2c46 40BuildRequires: rpm >= 4.4.9-56
bb090c53 41BuildRequires: rpmbuild(macros) >= 1.561
9088c091
AM
42Requires(post): fileutils
43Requires(post,preun): /sbin/chkconfig
9088c091
AM
44Requires(postun): /usr/sbin/groupdel
45Requires(pre): /usr/bin/getgid
46Requires(pre): /usr/sbin/groupadd
47Requires: /bin/run-parts
9088c091 48Requires: psmisc >= 20.1
bb090c53 49Requires: rc-scripts >= 0.4.3.0
f440f0d0 50%{?with_inotify:Requires: uname(release) >= 2.6.13}
9088c091
AM
51Provides: crondaemon
52Provides: crontabs = 1.7
53Provides: group(crontab)
0d2f2c46 54%if "%{pld_release}" == "th"
bf8f51cd 55Provides: vixie-cron = 4.3-1
daf76cdc 56%endif
9088c091
AM
57Obsoletes: crondaemon
58Obsoletes: crontabs
0d2f2c46 59%if "%{pld_release}" == "th"
bf8f51cd 60Obsoletes: vixie-cron < 4.3-1
daf76cdc 61%endif
9088c091
AM
62BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64%description
84a870a4
AM
65Cronie contains the standard UNIX daemon crond that runs specified
66programs at scheduled times and related tools. It is based on the
67original cron and has security and configuration enhancements like the
68ability to use pam and SELinux.
9088c091
AM
69
70%package anacron
84a870a4
AM
71Summary: Utility for running regular jobs
72Group: Base
73Provides: anacron = 2.4
74Obsoletes: anacron <= 2.3
9088c091
AM
75
76%description anacron
84a870a4
AM
77Anacron becames part of cronie. Anacron is used only for running
78regular jobs. The default settings execute regular jobs by anacron,
79however this could be overloaded in settings.
9088c091 80
bb090c53
JK
81%package upstart
82Summary: Upstart job description for Cronie
83Summary(pl.UTF-8): Opis zadania Upstart dla Cronie
84Group: Daemons
85Requires: %{name} = %{version}-%{release}
86Requires: upstart >= 0.6
87
88%description upstart
89Upstart job description for Cronie.
90
91%description upstart -l pl.UTF-8
92Opis zadania Upstart dla Cronie.
93
9088c091
AM
94%prep
95%setup -q
f440f0d0 96%patch0 -p1
9c2aa177 97%patch1 -p1
cb620710 98%patch2 -p1
9088c091
AM
99
100%build
828712ad
ER
101%{__aclocal}
102%{__autoconf}
103%{__autoheader}
104%{__automake}
9088c091 105%configure \
d39ca4fd 106 SYSCRONTAB=/etc/crontab \
695ed2ed 107 SYS_CROND_DIR=/etc/cron.d \
72768a3d 108 --sysconfdir=/etc/cron \
9088c091 109 --with-pam \
45b0067d 110 --with%{!?with_selinux:out}-selinux \
828712ad 111 --with%{!?with_audit:out}-audit \
946518b7 112 --with%{!?with_inotify:out}-inotify \
5ab1b510
ER
113 --enable-pie \
114 --enable-relro \
9088c091
AM
115 --enable-anacron
116
117%{__make}
118
119%install
120rm -rf $RPM_BUILD_ROOT
d07a95b8 121install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir}} \
bb090c53 122 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
9088c091
AM
123 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
124
125%{__make} install \
0d2f2c46 126 pamdir=/etc/pam.d \
9088c091
AM
127 DESTDIR=$RPM_BUILD_ROOT
128
fd39f74d
ER
129install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
130cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
131cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
132cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
133cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
134cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
bb090c53 135cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
9088c091
AM
136
137touch $RPM_BUILD_ROOT/var/log/cron
138
139cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
140# cron.allow This file describes the names of the users which are
141# allowed to use the local cron daemon
142root
143EOF
144
145cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
146# cron.deny This file describes the names of the users which are
147# NOT allowed to use the local cron daemon
148EOF
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%pre
154%groupadd -g 117 -r -f crontab
155
156%post
fd39f74d 157if [ ! -f /var/log/cron ]; then
7ff8f944 158 install -m 660 -g crontab /dev/null /var/log/cron
fd39f74d 159fi
9088c091 160/sbin/chkconfig --add crond
9088c091
AM
161%service crond restart "Cron Daemon"
162
163%preun
164if [ "$1" = "0" ]; then
165 %service crond stop
166 /sbin/chkconfig --del crond
167fi
168
169%postun
170if [ "$1" = "0" ]; then
171 %groupremove crontab
172fi
173
8609ee66 174%triggerun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
175# Prevent preun from crond from working
176chmod a-x /etc/rc.d/init.d/crond
177
8609ee66 178%triggerpostun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
179# Restore what triggerun removed
180chmod 754 /etc/rc.d/init.d/crond
8609ee66
ER
181# reinstall crond init.d links, which could be different
182/sbin/chkconfig --del crond
77af6cfd
AM
183/sbin/chkconfig --add crond
184
bb090c53
JK
185%post upstart
186%upstart_post crond
187
188%postun upstart
189%upstart_postun crond
190
9088c091
AM
191%files
192%defattr(644,root,root,755)
193%doc AUTHORS ChangeLog README
194%attr(750,root,crontab) %dir %{_sysconfdir}/cron*
195%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
196%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
197%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
198%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
199%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
200%attr(754,root,root) /etc/rc.d/init.d/crond
201%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
202%attr(755,root,root) %{_sbindir}/crond
203%attr(2755,root,crontab) %{_bindir}/crontab
204
205%{_mandir}/man8/crond.8*
206%{_mandir}/man8/cron.8*
207%{_mandir}/man5/crontab.5*
208%{_mandir}/man1/crontab.1*
209
210%attr(1730,root,crontab) /var/spool/cron
211%attr(660,root,crontab) %ghost /var/log/cron
212
213%files anacron
214%defattr(644,root,root,755)
215%attr(755,root,root) %{_sbindir}/anacron
84a870a4 216%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
9088c091
AM
217%{_mandir}/man5/anacrontab.5*
218%{_mandir}/man8/anacron.8*
d07a95b8
AM
219
220%attr(1730,root,crontab) /var/spool/anacron
bb090c53 221
c69c0f5a 222%if "%{pld_release}" != "ti"
bb090c53
JK
223%files upstart
224%defattr(644,root,root,755)
225%config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
c69c0f5a 226%endif
This page took 0.101559 seconds and 4 git commands to generate.