]> git.pld-linux.org Git - packages/cronie.git/blame - cronie.spec
- bcond fix
[packages/cronie.git] / cronie.spec
CommitLineData
9088c091
AM
1#
2# Conditional build:
3%bcond_without selinux # without SELinux support
4#
5Summary: Cron daemon for executing programs at set times
6Name: cronie
7Version: 1.4.1
d07a95b8 8Release: 2
9088c091
AM
9License: MIT and BSD and GPLv2
10Group: Daemons
836fe967 11Source0: %{name}-%{version}.tar.gz
9088c091
AM
12# Source0-md5: 9c089d2035b9fa8263bc71da3eb31cdd
13Source1: %{name}.init
14Source2: cron.logrotate
15Source3: cron.sysconfig
16Source4: %{name}.crontab
17Source5: %{name}.pam
18URL: https://fedorahosted.org/cronie/
84a870a4 19BuildRequires: audit-libs-devel
9088c091
AM
20%{?with_selinux:BuildRequires: libselinux-devel}
21BuildRequires: pam-devel
9088c091
AM
22BuildRequires: rpmbuild(macros) >= 1.268
23Requires(post): fileutils
24Requires(post,preun): /sbin/chkconfig
25Requires(post,preun): rc-scripts
26Requires(postun): /usr/sbin/groupdel
27Requires(pre): /usr/bin/getgid
28Requires(pre): /usr/sbin/groupadd
29Requires: /bin/run-parts
30Requires: /sbin/chkconfig
31Requires: psmisc >= 20.1
32Requires: rc-scripts
33Provides: crondaemon
34Provides: crontabs = 1.7
35Provides: group(crontab)
84a870a4 36Provides: vixie-cron = 4:4.4
9088c091
AM
37Obsoletes: crondaemon
38Obsoletes: crontabs
84a870a4 39Obsoletes: vixie-cron <= 4:4.3
9088c091
AM
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
84a870a4
AM
43Cronie contains the standard UNIX daemon crond that runs specified
44programs at scheduled times and related tools. It is based on the
45original cron and has security and configuration enhancements like the
46ability to use pam and SELinux.
9088c091
AM
47
48%package anacron
84a870a4
AM
49Summary: Utility for running regular jobs
50Group: Base
51Provides: anacron = 2.4
52Obsoletes: anacron <= 2.3
9088c091
AM
53
54%description anacron
84a870a4
AM
55Anacron becames part of cronie. Anacron is used only for running
56regular jobs. The default settings execute regular jobs by anacron,
57however this could be overloaded in settings.
9088c091
AM
58
59%prep
60%setup -q
61
62%build
63%configure \
695ed2ed
AM
64 SYSCRONTAB=/etc/cron.d/crontab \
65 SYS_CROND_DIR=/etc/cron.d \
72768a3d 66 --sysconfdir=/etc/cron \
9088c091 67 --with-pam \
45b0067d 68 --with%{!?with_selinux:out}-selinux \
9088c091
AM
69 --with-audit \
70 --with-inotify \
71 --enable-anacron
72
73%{__make}
74
75%install
76rm -rf $RPM_BUILD_ROOT
d07a95b8 77install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir}} \
9088c091
AM
78 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
79 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
80
81%{__make} install \
82 DESTDIR=$RPM_BUILD_ROOT
83
84install contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
9088c091
AM
85install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
86install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
87install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
88install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
89install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
90
91for a in fi fr id ja ko pl; do
92 if test -f $a/man1/crontab.1; then
93 install -d $RPM_BUILD_ROOT%{_mandir}/$a/man1
94 install $a/man1/crontab.1 $RPM_BUILD_ROOT%{_mandir}/$a/man1
95 fi
96 if test -f $a/man5/crontab.5; then
97 install -d $RPM_BUILD_ROOT%{_mandir}/$a/man5
98 install $a/man5/crontab.5 $RPM_BUILD_ROOT%{_mandir}/$a/man5
99 fi
100 if test -f $a/man8/cron.8; then
101 install -d $RPM_BUILD_ROOT%{_mandir}/$a/man8
102 install $a/man8/cron.8 $RPM_BUILD_ROOT%{_mandir}/$a/man8
103 fi
104done
105
106touch $RPM_BUILD_ROOT/var/log/cron
107
108cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
109# cron.allow This file describes the names of the users which are
110# allowed to use the local cron daemon
111root
112EOF
113
114cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
115# cron.deny This file describes the names of the users which are
116# NOT allowed to use the local cron daemon
117EOF
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%pre
123%groupadd -g 117 -r -f crontab
124
125%post
126/sbin/chkconfig --add crond
127umask 027
128touch /var/log/cron
129chgrp crontab /var/log/cron
130chmod 660 /var/log/cron
131%service crond restart "Cron Daemon"
132
133%preun
134if [ "$1" = "0" ]; then
135 %service crond stop
136 /sbin/chkconfig --del crond
137fi
138
139%postun
140if [ "$1" = "0" ]; then
141 %groupremove crontab
142fi
143
144%triggerpostun -- hc-cron
145# reinstall crond init.d links, which could be different
146/sbin/chkconfig --del crond
147/sbin/chkconfig --add crond
148
77af6cfd
AM
149%triggerun -- vixie-cron
150# Prevent preun from crond from working
151chmod a-x /etc/rc.d/init.d/crond
152
153%triggerpostun -- vixie-cron
154# Restore what triggerun removed
155chmod 754 /etc/rc.d/init.d/crond
156/sbin/chkconfig --add crond
157
9088c091
AM
158%files
159%defattr(644,root,root,755)
160%doc AUTHORS ChangeLog README
161%attr(750,root,crontab) %dir %{_sysconfdir}/cron*
162%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
163%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
164%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
165%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
166%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
167%attr(754,root,root) /etc/rc.d/init.d/crond
168%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
169%attr(755,root,root) %{_sbindir}/crond
170%attr(2755,root,crontab) %{_bindir}/crontab
171
172%{_mandir}/man8/crond.8*
173%{_mandir}/man8/cron.8*
174%{_mandir}/man5/crontab.5*
175%{_mandir}/man1/crontab.1*
176
177%attr(1730,root,crontab) /var/spool/cron
178%attr(660,root,crontab) %ghost /var/log/cron
179
180%files anacron
181%defattr(644,root,root,755)
182%attr(755,root,root) %{_sbindir}/anacron
84a870a4 183%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
9088c091
AM
184%{_mandir}/man5/anacrontab.5*
185%{_mandir}/man8/anacron.8*
d07a95b8
AM
186
187%attr(1730,root,crontab) /var/spool/anacron
This page took 0.050889 seconds and 4 git commands to generate.