]> git.pld-linux.org Git - packages/cronie.git/blame - cronie.spec
- pam trigger in pam package, where it is more natural; rel 4
[packages/cronie.git] / cronie.spec
CommitLineData
955f0d7d
ER
1# TODO
2# - update paths in manuals (create .in files and send upstream)
3# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
64e4eafc
ER
4# - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5# Mar 3 09:30:01 ravenous CROND[2528]: 4ÿ
9088c091
AM
6#
7# Conditional build:
946518b7 8%bcond_without inotify # without inotify support
0d2f2c46
ER
9%if "%{pld_release}" == "ac"
10%bcond_with selinux # without SELinux support
11%bcond_with audit # without audit support
12%else
13%bcond_without selinux # without SELinux support
828712ad 14%bcond_without audit # without audit support
0d2f2c46
ER
15%endif
16
9088c091
AM
17Summary: Cron daemon for executing programs at set times
18Name: cronie
61bce44d 19Version: 1.4.6
933bc212 20Release: 4
fd39f74d 21License: MIT and BSD and GPL v2
9088c091 22Group: Daemons
fd39f74d 23Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
61bce44d 24# Source0-md5: 968e3d3e7c8e1d0588d533883482d3fa
9088c091
AM
25Source1: %{name}.init
26Source2: cron.logrotate
27Source3: cron.sysconfig
28Source4: %{name}.crontab
29Source5: %{name}.pam
bb090c53 30Source6: %{name}.upstart
f440f0d0 31Patch0: inotify-nosys.patch
9c2aa177 32Patch1: %{name}-nosyscrontab.patch
cb620710 33Patch2: sendmail-path.patch
9088c091 34URL: https://fedorahosted.org/cronie/
828712ad
ER
35%{?with_audit:BuildRequires: audit-libs-devel}
36BuildRequires: autoconf
37BuildRequires: automake
9088c091
AM
38%{?with_selinux:BuildRequires: libselinux-devel}
39BuildRequires: pam-devel
0d2f2c46 40BuildRequires: rpm >= 4.4.9-56
bb090c53 41BuildRequires: rpmbuild(macros) >= 1.561
9088c091
AM
42Requires(post): fileutils
43Requires(post,preun): /sbin/chkconfig
9088c091
AM
44Requires(postun): /usr/sbin/groupdel
45Requires(pre): /usr/bin/getgid
46Requires(pre): /usr/sbin/groupadd
47Requires: /bin/run-parts
48Requires: /sbin/chkconfig
49Requires: psmisc >= 20.1
bb090c53 50Requires: rc-scripts >= 0.4.3.0
f440f0d0 51%{?with_inotify:Requires: uname(release) >= 2.6.13}
9088c091
AM
52Provides: crondaemon
53Provides: crontabs = 1.7
54Provides: group(crontab)
0d2f2c46 55%if "%{pld_release}" == "th"
84a870a4 56Provides: vixie-cron = 4:4.4
daf76cdc 57%endif
9088c091
AM
58Obsoletes: crondaemon
59Obsoletes: crontabs
0d2f2c46 60%if "%{pld_release}" == "th"
84a870a4 61Obsoletes: vixie-cron <= 4:4.3
daf76cdc 62%endif
9088c091
AM
63BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65%description
84a870a4
AM
66Cronie contains the standard UNIX daemon crond that runs specified
67programs at scheduled times and related tools. It is based on the
68original cron and has security and configuration enhancements like the
69ability to use pam and SELinux.
9088c091
AM
70
71%package anacron
84a870a4
AM
72Summary: Utility for running regular jobs
73Group: Base
74Provides: anacron = 2.4
75Obsoletes: anacron <= 2.3
9088c091
AM
76
77%description anacron
84a870a4
AM
78Anacron becames part of cronie. Anacron is used only for running
79regular jobs. The default settings execute regular jobs by anacron,
80however this could be overloaded in settings.
9088c091 81
bb090c53
JK
82%package upstart
83Summary: Upstart job description for Cronie
84Summary(pl.UTF-8): Opis zadania Upstart dla Cronie
85Group: Daemons
86Requires: %{name} = %{version}-%{release}
87Requires: upstart >= 0.6
88
89%description upstart
90Upstart job description for Cronie.
91
92%description upstart -l pl.UTF-8
93Opis zadania Upstart dla Cronie.
94
9088c091
AM
95%prep
96%setup -q
f440f0d0 97%patch0 -p1
9c2aa177 98%patch1 -p1
cb620710 99%patch2 -p1
9088c091
AM
100
101%build
828712ad
ER
102%{__aclocal}
103%{__autoconf}
104%{__autoheader}
105%{__automake}
9088c091 106%configure \
d39ca4fd 107 SYSCRONTAB=/etc/crontab \
695ed2ed 108 SYS_CROND_DIR=/etc/cron.d \
72768a3d 109 --sysconfdir=/etc/cron \
9088c091 110 --with-pam \
45b0067d 111 --with%{!?with_selinux:out}-selinux \
828712ad 112 --with%{!?with_audit:out}-audit \
946518b7 113 --with%{!?with_inotify:out}-inotify \
9088c091
AM
114 --enable-anacron
115
116%{__make}
117
118%install
119rm -rf $RPM_BUILD_ROOT
d07a95b8 120install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir}} \
bb090c53 121 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
9088c091
AM
122 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
123
124%{__make} install \
0d2f2c46 125 pamdir=/etc/pam.d \
9088c091
AM
126 DESTDIR=$RPM_BUILD_ROOT
127
fd39f74d
ER
128install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
129cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
130cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
131cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
132cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
133cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
bb090c53 134cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
9088c091
AM
135
136touch $RPM_BUILD_ROOT/var/log/cron
137
138cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
139# cron.allow This file describes the names of the users which are
140# allowed to use the local cron daemon
141root
142EOF
143
144cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
145# cron.deny This file describes the names of the users which are
146# NOT allowed to use the local cron daemon
147EOF
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%pre
153%groupadd -g 117 -r -f crontab
154
155%post
fd39f74d 156if [ ! -f /var/log/cron ]; then
7ff8f944 157 install -m 660 -g crontab /dev/null /var/log/cron
fd39f74d 158fi
9088c091 159/sbin/chkconfig --add crond
9088c091
AM
160%service crond restart "Cron Daemon"
161
162%preun
163if [ "$1" = "0" ]; then
164 %service crond stop
165 /sbin/chkconfig --del crond
166fi
167
168%postun
169if [ "$1" = "0" ]; then
170 %groupremove crontab
171fi
172
8609ee66 173%triggerun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
174# Prevent preun from crond from working
175chmod a-x /etc/rc.d/init.d/crond
176
8609ee66 177%triggerpostun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
178# Restore what triggerun removed
179chmod 754 /etc/rc.d/init.d/crond
8609ee66
ER
180# reinstall crond init.d links, which could be different
181/sbin/chkconfig --del crond
77af6cfd
AM
182/sbin/chkconfig --add crond
183
bb090c53
JK
184%post upstart
185%upstart_post crond
186
187%postun upstart
188%upstart_postun crond
189
9088c091
AM
190%files
191%defattr(644,root,root,755)
192%doc AUTHORS ChangeLog README
193%attr(750,root,crontab) %dir %{_sysconfdir}/cron*
194%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
195%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
196%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
197%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
198%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
199%attr(754,root,root) /etc/rc.d/init.d/crond
200%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
201%attr(755,root,root) %{_sbindir}/crond
202%attr(2755,root,crontab) %{_bindir}/crontab
203
204%{_mandir}/man8/crond.8*
205%{_mandir}/man8/cron.8*
206%{_mandir}/man5/crontab.5*
207%{_mandir}/man1/crontab.1*
208
209%attr(1730,root,crontab) /var/spool/cron
210%attr(660,root,crontab) %ghost /var/log/cron
211
212%files anacron
213%defattr(644,root,root,755)
214%attr(755,root,root) %{_sbindir}/anacron
84a870a4 215%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
9088c091
AM
216%{_mandir}/man5/anacrontab.5*
217%{_mandir}/man8/anacron.8*
d07a95b8
AM
218
219%attr(1730,root,crontab) /var/spool/anacron
bb090c53 220
c69c0f5a 221%if "%{pld_release}" != "ti"
bb090c53
JK
222%files upstart
223%defattr(644,root,root,755)
224%config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
c69c0f5a 225%endif
This page took 0.0698 seconds and 4 git commands to generate.