]> git.pld-linux.org Git - packages/cronie.git/blame - cronie.spec
- pldize paths
[packages/cronie.git] / cronie.spec
CommitLineData
9088c091
AM
1#
2# Conditional build:
3%bcond_without selinux # without SELinux support
4#
5Summary: Cron daemon for executing programs at set times
6Name: cronie
7Version: 1.4.1
8Release: 0.1
9License: MIT and BSD and GPLv2
10Group: Daemons
84a870a4 11Source0: https://fedorahosted.org/cronie/attachment/wiki/WikiStart/%{name}-%{version}.tar.gz?format=raw
9088c091
AM
12# Source0-md5: 9c089d2035b9fa8263bc71da3eb31cdd
13Source1: %{name}.init
14Source2: cron.logrotate
15Source3: cron.sysconfig
16Source4: %{name}.crontab
17Source5: %{name}.pam
84a870a4 18Patch0: %{name}-paths.patch
9088c091 19URL: https://fedorahosted.org/cronie/
84a870a4 20BuildRequires: audit-libs-devel
9088c091
AM
21%{?with_selinux:BuildRequires: libselinux-devel}
22BuildRequires: pam-devel
9088c091
AM
23BuildRequires: rpmbuild(macros) >= 1.268
24Requires(post): fileutils
25Requires(post,preun): /sbin/chkconfig
26Requires(post,preun): rc-scripts
27Requires(postun): /usr/sbin/groupdel
28Requires(pre): /usr/bin/getgid
29Requires(pre): /usr/sbin/groupadd
30Requires: /bin/run-parts
31Requires: /sbin/chkconfig
32Requires: psmisc >= 20.1
33Requires: rc-scripts
34Provides: crondaemon
35Provides: crontabs = 1.7
36Provides: group(crontab)
84a870a4 37Provides: vixie-cron = 4:4.4
9088c091
AM
38Obsoletes: crondaemon
39Obsoletes: crontabs
84a870a4 40Obsoletes: vixie-cron <= 4:4.3
9088c091
AM
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%description
84a870a4
AM
44Cronie contains the standard UNIX daemon crond that runs specified
45programs at scheduled times and related tools. It is based on the
46original cron and has security and configuration enhancements like the
47ability to use pam and SELinux.
9088c091
AM
48
49%package anacron
84a870a4
AM
50Summary: Utility for running regular jobs
51Group: Base
52Provides: anacron = 2.4
53Obsoletes: anacron <= 2.3
9088c091
AM
54
55%description anacron
84a870a4
AM
56Anacron becames part of cronie. Anacron is used only for running
57regular jobs. The default settings execute regular jobs by anacron,
58however this could be overloaded in settings.
9088c091
AM
59
60%prep
61%setup -q
84a870a4 62%patch0 -p1
9088c091
AM
63
64%build
65%configure \
66 --with-pam \
67 --with%{?!with_selinux:out}-selinux \
68 --with-audit \
69 --with-inotify \
70 --enable-anacron
71
72%{__make}
73
74%install
75rm -rf $RPM_BUILD_ROOT
76install -d $RPM_BUILD_ROOT{/var/{log,spool/cron},%{_mandir}} \
77 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
78 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
79
80%{__make} install \
81 DESTDIR=$RPM_BUILD_ROOT
82
83install contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
84
85install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
86install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
87install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
88install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
89install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
90
91for a in fi fr id ja ko pl; do
92 if test -f $a/man1/crontab.1; then
93 install -d $RPM_BUILD_ROOT%{_mandir}/$a/man1
94 install $a/man1/crontab.1 $RPM_BUILD_ROOT%{_mandir}/$a/man1
95 fi
96 if test -f $a/man5/crontab.5; then
97 install -d $RPM_BUILD_ROOT%{_mandir}/$a/man5
98 install $a/man5/crontab.5 $RPM_BUILD_ROOT%{_mandir}/$a/man5
99 fi
100 if test -f $a/man8/cron.8; then
101 install -d $RPM_BUILD_ROOT%{_mandir}/$a/man8
102 install $a/man8/cron.8 $RPM_BUILD_ROOT%{_mandir}/$a/man8
103 fi
104done
105
106touch $RPM_BUILD_ROOT/var/log/cron
107
108cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
109# cron.allow This file describes the names of the users which are
110# allowed to use the local cron daemon
111root
112EOF
113
114cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
115# cron.deny This file describes the names of the users which are
116# NOT allowed to use the local cron daemon
117EOF
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%pre
123%groupadd -g 117 -r -f crontab
124
125%post
126/sbin/chkconfig --add crond
127umask 027
128touch /var/log/cron
129chgrp crontab /var/log/cron
130chmod 660 /var/log/cron
131%service crond restart "Cron Daemon"
132
133%preun
134if [ "$1" = "0" ]; then
135 %service crond stop
136 /sbin/chkconfig --del crond
137fi
138
139%postun
140if [ "$1" = "0" ]; then
141 %groupremove crontab
142fi
143
144%triggerpostun -- hc-cron
145# reinstall crond init.d links, which could be different
146/sbin/chkconfig --del crond
147/sbin/chkconfig --add crond
148
149%files
150%defattr(644,root,root,755)
151%doc AUTHORS ChangeLog README
152%attr(750,root,crontab) %dir %{_sysconfdir}/cron*
153%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
154%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
155%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
156%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
157%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
158%attr(754,root,root) /etc/rc.d/init.d/crond
159%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
160%attr(755,root,root) %{_sbindir}/crond
161%attr(2755,root,crontab) %{_bindir}/crontab
162
163%{_mandir}/man8/crond.8*
164%{_mandir}/man8/cron.8*
165%{_mandir}/man5/crontab.5*
166%{_mandir}/man1/crontab.1*
167
168%attr(1730,root,crontab) /var/spool/cron
169%attr(660,root,crontab) %ghost /var/log/cron
170
171%files anacron
172%defattr(644,root,root,755)
173%attr(755,root,root) %{_sbindir}/anacron
84a870a4 174%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
9088c091
AM
175%{_mandir}/man5/anacrontab.5*
176%{_mandir}/man8/anacron.8*
This page took 0.079082 seconds and 4 git commands to generate.