]> git.pld-linux.org Git - packages/cronie.git/blame - cronie.spec
- up to 1.4.7, --enable-pie, --enable-relro
[packages/cronie.git] / cronie.spec
CommitLineData
955f0d7d
ER
1# TODO
2# - update paths in manuals (create .in files and send upstream)
3# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
64e4eafc
ER
4# - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5# Mar 3 09:30:01 ravenous CROND[2528]: 4ÿ
9088c091
AM
6#
7# Conditional build:
946518b7 8%bcond_without inotify # without inotify support
0d2f2c46
ER
9%if "%{pld_release}" == "ac"
10%bcond_with selinux # without SELinux support
11%bcond_with audit # without audit support
12%else
13%bcond_without selinux # without SELinux support
828712ad 14%bcond_without audit # without audit support
0d2f2c46
ER
15%endif
16
9088c091
AM
17Summary: Cron daemon for executing programs at set times
18Name: cronie
5ab1b510
ER
19Version: 1.4.7
20Release: 1
fd39f74d 21License: MIT and BSD and GPL v2
9088c091 22Group: Daemons
fd39f74d 23Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
5ab1b510 24# Source0-md5: dfc26c47756d0c40ee27ae3c7ee98e0d
9088c091
AM
25Source1: %{name}.init
26Source2: cron.logrotate
27Source3: cron.sysconfig
28Source4: %{name}.crontab
29Source5: %{name}.pam
bb090c53 30Source6: %{name}.upstart
f440f0d0 31Patch0: inotify-nosys.patch
9c2aa177 32Patch1: %{name}-nosyscrontab.patch
cb620710 33Patch2: sendmail-path.patch
9088c091 34URL: https://fedorahosted.org/cronie/
828712ad
ER
35%{?with_audit:BuildRequires: audit-libs-devel}
36BuildRequires: autoconf
37BuildRequires: automake
9088c091
AM
38%{?with_selinux:BuildRequires: libselinux-devel}
39BuildRequires: pam-devel
0d2f2c46 40BuildRequires: rpm >= 4.4.9-56
bb090c53 41BuildRequires: rpmbuild(macros) >= 1.561
9088c091
AM
42Requires(post): fileutils
43Requires(post,preun): /sbin/chkconfig
9088c091
AM
44Requires(postun): /usr/sbin/groupdel
45Requires(pre): /usr/bin/getgid
46Requires(pre): /usr/sbin/groupadd
47Requires: /bin/run-parts
48Requires: /sbin/chkconfig
49Requires: psmisc >= 20.1
bb090c53 50Requires: rc-scripts >= 0.4.3.0
f440f0d0 51%{?with_inotify:Requires: uname(release) >= 2.6.13}
9088c091
AM
52Provides: crondaemon
53Provides: crontabs = 1.7
54Provides: group(crontab)
0d2f2c46 55%if "%{pld_release}" == "th"
84a870a4 56Provides: vixie-cron = 4:4.4
daf76cdc 57%endif
9088c091
AM
58Obsoletes: crondaemon
59Obsoletes: crontabs
0d2f2c46 60%if "%{pld_release}" == "th"
84a870a4 61Obsoletes: vixie-cron <= 4:4.3
daf76cdc 62%endif
9088c091
AM
63BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65%description
84a870a4
AM
66Cronie contains the standard UNIX daemon crond that runs specified
67programs at scheduled times and related tools. It is based on the
68original cron and has security and configuration enhancements like the
69ability to use pam and SELinux.
9088c091
AM
70
71%package anacron
84a870a4
AM
72Summary: Utility for running regular jobs
73Group: Base
74Provides: anacron = 2.4
75Obsoletes: anacron <= 2.3
9088c091
AM
76
77%description anacron
84a870a4
AM
78Anacron becames part of cronie. Anacron is used only for running
79regular jobs. The default settings execute regular jobs by anacron,
80however this could be overloaded in settings.
9088c091 81
bb090c53
JK
82%package upstart
83Summary: Upstart job description for Cronie
84Summary(pl.UTF-8): Opis zadania Upstart dla Cronie
85Group: Daemons
86Requires: %{name} = %{version}-%{release}
87Requires: upstart >= 0.6
88
89%description upstart
90Upstart job description for Cronie.
91
92%description upstart -l pl.UTF-8
93Opis zadania Upstart dla Cronie.
94
9088c091
AM
95%prep
96%setup -q
f440f0d0 97%patch0 -p1
9c2aa177 98%patch1 -p1
cb620710 99%patch2 -p1
9088c091
AM
100
101%build
828712ad
ER
102%{__aclocal}
103%{__autoconf}
104%{__autoheader}
105%{__automake}
9088c091 106%configure \
d39ca4fd 107 SYSCRONTAB=/etc/crontab \
695ed2ed 108 SYS_CROND_DIR=/etc/cron.d \
72768a3d 109 --sysconfdir=/etc/cron \
9088c091 110 --with-pam \
45b0067d 111 --with%{!?with_selinux:out}-selinux \
828712ad 112 --with%{!?with_audit:out}-audit \
946518b7 113 --with%{!?with_inotify:out}-inotify \
5ab1b510
ER
114 --enable-pie \
115 --enable-relro \
9088c091
AM
116 --enable-anacron
117
118%{__make}
119
120%install
121rm -rf $RPM_BUILD_ROOT
d07a95b8 122install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir}} \
bb090c53 123 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
9088c091
AM
124 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
125
126%{__make} install \
0d2f2c46 127 pamdir=/etc/pam.d \
9088c091
AM
128 DESTDIR=$RPM_BUILD_ROOT
129
fd39f74d
ER
130install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
131cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
132cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
133cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
134cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
135cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
bb090c53 136cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
9088c091
AM
137
138touch $RPM_BUILD_ROOT/var/log/cron
139
140cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
141# cron.allow This file describes the names of the users which are
142# allowed to use the local cron daemon
143root
144EOF
145
146cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
147# cron.deny This file describes the names of the users which are
148# NOT allowed to use the local cron daemon
149EOF
150
151%clean
152rm -rf $RPM_BUILD_ROOT
153
154%pre
155%groupadd -g 117 -r -f crontab
156
157%post
fd39f74d 158if [ ! -f /var/log/cron ]; then
7ff8f944 159 install -m 660 -g crontab /dev/null /var/log/cron
fd39f74d 160fi
9088c091 161/sbin/chkconfig --add crond
9088c091
AM
162%service crond restart "Cron Daemon"
163
164%preun
165if [ "$1" = "0" ]; then
166 %service crond stop
167 /sbin/chkconfig --del crond
168fi
169
170%postun
171if [ "$1" = "0" ]; then
172 %groupremove crontab
173fi
174
8609ee66 175%triggerun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
176# Prevent preun from crond from working
177chmod a-x /etc/rc.d/init.d/crond
178
8609ee66 179%triggerpostun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
180# Restore what triggerun removed
181chmod 754 /etc/rc.d/init.d/crond
8609ee66
ER
182# reinstall crond init.d links, which could be different
183/sbin/chkconfig --del crond
77af6cfd
AM
184/sbin/chkconfig --add crond
185
bb090c53
JK
186%post upstart
187%upstart_post crond
188
189%postun upstart
190%upstart_postun crond
191
9088c091
AM
192%files
193%defattr(644,root,root,755)
194%doc AUTHORS ChangeLog README
195%attr(750,root,crontab) %dir %{_sysconfdir}/cron*
196%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
197%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
198%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
199%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
200%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
201%attr(754,root,root) /etc/rc.d/init.d/crond
202%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
203%attr(755,root,root) %{_sbindir}/crond
204%attr(2755,root,crontab) %{_bindir}/crontab
205
206%{_mandir}/man8/crond.8*
207%{_mandir}/man8/cron.8*
208%{_mandir}/man5/crontab.5*
209%{_mandir}/man1/crontab.1*
210
211%attr(1730,root,crontab) /var/spool/cron
212%attr(660,root,crontab) %ghost /var/log/cron
213
214%files anacron
215%defattr(644,root,root,755)
216%attr(755,root,root) %{_sbindir}/anacron
84a870a4 217%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
9088c091
AM
218%{_mandir}/man5/anacrontab.5*
219%{_mandir}/man8/anacron.8*
d07a95b8
AM
220
221%attr(1730,root,crontab) /var/spool/anacron
bb090c53 222
c69c0f5a 223%if "%{pld_release}" != "ti"
bb090c53
JK
224%files upstart
225%defattr(644,root,root,755)
226%config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
c69c0f5a 227%endif
This page took 0.051308 seconds and 4 git commands to generate.