]> git.pld-linux.org Git - packages/lighttpd.git/blame - lighttpd.spec
- merged modular config from DEVEL
[packages/lighttpd.git] / lighttpd.spec
CommitLineData
8c865192 1# TODO:
0ab57655 2# - test ldap and mysql (failed at this time)
fcae54a7 3# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
9c336869 4# - fam over gamin is possible, just configure doesn't check other than gamin
ffe2fc3c 5# - feature stat-cache-fam (doesn't work)
5febf716
ER
6# - lighttpd writes early startup messages to stderr, and if started from
7# rc-scripts the stderr is closed which causes lighttpd to abort():
8# 2006-07-20 21:05:52: (server.c.1233) WARNING: unknown config-key: url.rewrite-final (ignored)
05f8c491 9#
79404238
ER
10# NOTES:
11# - fcgi-devel is only used for the test-scripts
12# - disable largefile, if you have 2.4 kernel to get sendfile() support, and don't need > 2GB file requests,
13# see http://article.gmane.org/gmane.comp.web.lighttpd:722
14#
4f968063 15# Conditional build for lighttpd:
8d377a51 16%bcond_without xattr # support of extended attributes
17%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
18%bcond_without largefile # largefile support (see notes above)
19%bcond_without ssl # ssl support
5febf716 20%bcond_without mysql # mysql support in mod_mysql_vhost
8d377a51 21%bcond_with ldap # ldap support in mod_auth
5febf716 22%bcond_with lua # LUA support in mod_cml (needs LUA >= 5.1)
8d377a51 23%bcond_with memcache # memcached support in mod_cml / mod_trigger_b4_dl
2a732f8a 24%bcond_with gamin # gamin for reducing number of stat() calls.
8d377a51 25 # NOTE: must be enabled in config: server.stat-cache-engine = "fam"
26%bcond_with gdbm # gdbm in mod_trigger_b4_dl
27%bcond_with webdav_props # properties in mod_webdav (includes extra sqlite3/libxml deps)
28%bcond_with valgrind # compile code with valgrind support.
5febf716 29%bcond_with deflate # build deflate module (needs patch update with current svn)
79404238 30
5febf716
ER
31%define _rel 0.55
32# SVN snapshot
33#define _svn 1277
2abd0792 34# Prerelease snapshot: DATE-TIME
5febf716 35%define _snap 20060907-1319
2abd0792
ER
36
37%if 0%{?_snap}
38%define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
39%else
40%define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
41%endif
42
5febf716 43%define _rel 0.58
2abd0792 44
027853cc 45Summary: Fast and light HTTP server
46Summary(pl): Szybki i lekki serwer HTTP
bee4f74e 47Name: lighttpd
5febf716
ER
48Version: 1.4.12
49Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}%{?_svn:.%{_svn}}
4241e769 50License: BSD
0296e68a 51Group: Networking/Daemons
5febf716
ER
52Source0: http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
53# Source0-md5: a9c4747984235db61b9685388e9160f7
bee4f74e 54Source1: %{name}.init
2f7162ab
AM
55Source2: %{name}.conf
56Source3: %{name}.user
607835c0 57Source4: %{name}.logrotate
c54ca3d2 58Source5: %{name}.sysconfig
87c01276 59Source6: %{name}-mime.types.sh
9647a089
ER
60Source7: http://www.lighttpd.net/favicon.ico
61# Source7-md5: a358994becabd4060393a5454bde505d
62Source8: http://www.lighttpd.net/light_button.png
63# Source8-md5: 02330e2313fadc29144edfd6000879f8
64Source9: http://www.lighttpd.net/light_logo.png
65# Source9-md5: ac20784510e420d5cbe5fc1cdb53d7a7
c4128c50
ER
66Source10: http://gdl.hopto.org/~spider/pldstats/gfx/pld1.png
67# Source10-md5: 486ecec3f6f4fe7f9bf7cee757b864f4
66f5ed22 68Source11: %{name}-pld.html
5febf716
ER
69Source100: %{name}-mod_access.conf
70Source101: %{name}-mod_accesslog.conf
71Source102: %{name}-mod_alias.conf
72Source103: %{name}-mod_auth.conf
73Source104: %{name}-mod_cgi.conf
74Source105: %{name}-mod_cml.conf
75Source106: %{name}-mod_compress.conf
76Source107: %{name}-mod_deflate.conf
77Source108: %{name}-mod_dirlisting.conf
78Source109: %{name}-mod_evasive.conf
79Source110: %{name}-mod_evhost.conf
80Source111: %{name}-mod_expire.conf
81Source112: %{name}-mod_fastcgi.conf
82Source113: %{name}-mod_flv_streaming.conf
83Source114: %{name}-mod_indexfile.conf
84Source115: %{name}-mod_proxy.conf
85Source116: %{name}-mod_redirect.conf
86Source117: %{name}-mod_rewrite.conf
87Source118: %{name}-mod_rrdtool.conf
88Source119: %{name}-mod_scgi.conf
89Source120: %{name}-mod_secdownload.conf
90Source121: %{name}-mod_setenv.conf
91Source122: %{name}-mod_simple_vhost.conf
92Source123: %{name}-mod_ssi.conf
93Source124: %{name}-mod_staticfile.conf
94Source125: %{name}-mod_status.conf
95Source126: %{name}-mod_trigger_b4_dl.conf
96Source127: %{name}-mod_userdir.conf
97Source128: %{name}-mod_usertrack.conf
98Source129: %{name}-mod_webdav.conf
99Source130: %{name}-php-spawned.conf
100Source131: %{name}-php-external.conf
101Source132: %{name}-ssl.conf
102Source133: %{name}-mod_proxy_core.conf
103Source134: %{name}-mod_mysql_vhost.conf
104Source135: %{name}-mod_uploadprogress.conf
105Patch100: %{name}-branch.diff
5ef9311f 106Patch0: %{name}-mod_deflate.patch
507f6bc1
ER
107Patch1: %{name}-use_bin_sh.patch
108Patch2: %{name}-initgroups.patch
5febf716
ER
109Patch3: http://trac.lighttpd.net/trac/attachment/ticket/444/%{name}-apr1.patch?format=txt
110Patch4: %{name}-mod_evasive-status_code.patch
70373b58 111URL: http://www.lighttpd.net/
cc769ac6 112%{?with_xattr:BuildRequires: attr-devel}
1a75d3e1
JB
113BuildRequires: autoconf
114BuildRequires: automake
115BuildRequires: bzip2-devel
9c336869 116%{?with_gamin:BuildRequires: gamin-devel}
6ec064d6
KK
117%{?with_gdbm:BuildRequires: gdbm-devel}
118%{?with_memcache:BuildRequires: libmemcache-devel}
1a75d3e1 119BuildRequires: libtool
5febf716 120BuildRequires: libuuid-devel
6ec064d6 121%{?with_webdav_props:BuildRequires: libxml2-devel}
6ec064d6
KK
122%{?with_lua:BuildRequires: lua50-devel >= 5.0.2-5.1}
123BuildRequires: mailcap >= 2.1.14-4.4
cc769ac6 124%{?with_mysql:BuildRequires: mysql-devel}
6ec064d6 125%{?with_ldap:BuildRequires: openldap-devel}
49163762 126%{?with_ssl:BuildRequires: openssl-devel}
1a75d3e1 127BuildRequires: pcre-devel
6ec064d6 128BuildRequires: pkgconfig
2a732f8a 129BuildRequires: rpmbuild(macros) >= 1.268
66f5ed22 130%{?with_webdav_props:BuildRequires: sqlite3-devel}
83ca4b2b 131%{?with_valgrind:BuildRequires: valgrind}
cc769ac6 132BuildRequires: zlib-devel
66f5ed22
ER
133Requires(post,preun): /sbin/chkconfig
134Requires(postun): /usr/sbin/groupdel
135Requires(postun): /usr/sbin/userdel
bee4f74e
AM
136Requires(pre): /bin/id
137Requires(pre): /usr/bin/getgid
5febf716 138Requires(pre): /usr/lib/rpm/user_group.sh
bee4f74e
AM
139Requires(pre): /usr/sbin/groupadd
140Requires(pre): /usr/sbin/useradd
28537382 141Requires(pre): /usr/sbin/usermod
5febf716
ER
142Requires: %{name}-mod_dirlisting
143Requires: %{name}-mod_indexfile
144Requires: %{name}-mod_staticfile
66f5ed22 145Requires: rc-scripts
6230924e 146Provides: group(http)
e68efba2 147Provides: group(lighttpd)
e68efba2 148Provides: user(lighttpd)
1a75d3e1 149Provides: webserver
0296e68a
ER
150# for the posttrans scriptlet, conflicts because in vserver environment rpm package is not installed.
151Conflicts: rpm < 4.4.2-0.2
bee4f74e
AM
152BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
153
154%define _libdir %{_prefix}/%{_lib}/%{name}
8d734bed 155%define _lighttpddir /home/services/%{name}
bee4f74e
AM
156%define _sysconfdir /etc/%{name}
157
158%description
f655b1fd 159lighttpd is a secure, fast, compliant and very flexible web-server
ebd2f6ff
ER
160which has been optimized for high-performance environments. It has a
161very low memory footprint compared to other webservers and takes care
162of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
bee4f74e
AM
163Output-Compression, URL-Rewriting and many more) make lighttpd the
164perfect webserver-software for every server that is suffering load
165problems.
166
f655b1fd
MC
167%description -l pl
168lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
1a75d3e1 169