]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- removed obsolete libpng patch
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - build with system mozldap
c4ddd260 4#
44be9ed4 5# Conditional builds
6%bcond_without enigmail # don't build enigmail - GPG/PGP support
7%bcond_without gnomeui # disable gnomeui support
6458b220 8%bcond_without gnome # alias for gnomeui
44be9ed4 9%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 10%bcond_without lightning # disable Sunbird/Lightning calendar
f4114a7f 11%bcond_without xulrunner # build with xulrunner
765a3a27 12%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 13
44be9ed4 14%if %{without gnome}
15%undefine with_gnomeui
44be9ed4 16%endif
88149483 17
f4114a7f 18%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
19%undefine crashreporter
20%endif
21
6864d0a2 22%define enigmail_ver 1.3.5
af42cf6d
JB
23%define nspr_ver 4.8.8
24%define nss_ver 3.12.10
44be9ed4 25
d06a830c 26# convert firefox release number to platform version: 9.0.x -> 9.0.x
6864d0a2
AZ
27%define xulrunner_main 10.0
28%define xulrunner_ver %(v=%{version}; echo %{xulrunner_main}${v#10.0})
4f34f106 29
7d981f69
ER
30%if %{without xulrunner}
31# The actual sqlite version (see RHBZ#480989):
32%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
33%endif
34
44be9ed4 35Summary: Icedove - email client
36Summary(pl.UTF-8): Icedove - klient poczty
37Name: icedove
1a166995 38Version: 10.0.2
eca54e0f 39Release: 3
44be9ed4 40License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 41Group: X11/Applications/Networking
cadfb931 42Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
1a166995 43# Source0-md5: 624bef982d7ac610b1175737d9905150
44be9ed4 44Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
6864d0a2 45# Source1-md5: 1b008b0d106e238c11e4bead08126bc0
44be9ed4 46Source2: %{name}-branding.tar.bz2
c105f759 47# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 48Source3: %{name}-rm_nonfree.sh
49Source4: %{name}.desktop
50Source5: %{name}.sh
44be9ed4 51Patch0: %{name}-branding.patch
faa5c89d
SP
52Patch1: %{name}-enigmail-shared.patch
53Patch2: %{name}-gcc.patch
54Patch3: %{name}-fonts.patch
55Patch4: %{name}-install.patch
5e9bb798 56Patch5: %{name}-hunspell.patch
faa5c89d 57Patch6: %{name}-prefs.patch
9a743685 58Patch7: system-mozldap.patch
a85e0ecb 59Patch8: %{name}-makefile.patch
86ad1c27 60
ccc206fe 61Patch10: %{name}-extensiondir.patch
765a3a27 62Patch11: crashreporter.patch
268e7766 63Patch12: no-subshell.patch
5745d706 64URL: http://www.pld-linux.org/Packages/Icedove
6458b220 65BuildRequires: GConf2-devel >= 1.2.1
51a3b6db 66BuildRequires: alsa-lib-devel
44be9ed4 67BuildRequires: automake
51a3b6db 68BuildRequires: bzip2-devel
e820c55e
JB
69BuildRequires: cairo-devel >= 1.10
70BuildRequires: dbus-glib-devel >= 0.60
44be9ed4 71BuildRequires: freetype-devel >= 1:2.1.8
6458b220 72BuildRequires: glib2-devel >= 2.0
e820c55e 73BuildRequires: gtk+2-devel >= 2:2.10.0
5e9bb798 74BuildRequires: hunspell-devel
44be9ed4 75BuildRequires: libIDL-devel >= 0.8.0
6458b220 76%{?with_gnomeui:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 77%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 78%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 79BuildRequires: libiw-devel
44be9ed4 80BuildRequires: libjpeg-devel >= 6b
51a3b6db 81BuildRequires: libnotify-devel >= 0.4
e820c55e 82BuildRequires: libpng-devel >= 1.4.1
44be9ed4 83BuildRequires: libstdc++-devel
f4114a7f
ER
84BuildRequires: nspr-devel >= 1:%{nspr_ver}
85BuildRequires: nss-devel >= 1:%{nss_ver}
44be9ed4 86BuildRequires: pango-devel >= 1:1.1.0
e820c55e 87BuildRequires: perl-base >= 1:5.6
1c62cadb 88BuildRequires: pkgconfig
e820c55e 89BuildRequires: python >= 1:2.5
44be9ed4 90BuildRequires: sed >= 4.0
9d1bfad8 91BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 92BuildRequires: startup-notification-devel >= 0.8
44be9ed4 93BuildRequires: xorg-lib-libXext-devel
44be9ed4 94BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 95BuildRequires: xorg-lib-libXt-devel
5745d706 96BuildRequires: yasm
1c62cadb 97BuildRequires: zip
7d981f69 98%if %{with xulrunner}
4f34f106 99BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
7d981f69 100%else
44be9ed4 101Requires: myspell-common
f4114a7f
ER
102Requires: nspr >= 1:%{nspr_ver}
103Requires: nss >= 1:%{nss_ver}
4b6bc367 104Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 105%endif
4f34f106
ER
106Requires(post): mktemp >= 1.5-18
107%if %{with xulrunner}
108%requires_eq_to xulrunner xulrunner-devel
109%endif
44be9ed4 110Obsoletes: mozilla-thunderbird
111Obsoletes: mozilla-thunderbird-dictionary-en-US
112BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
9e366f18
AM
114%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
115
44be9ed4 116# iceweasel/icedove/iceape provide their own versions
c072808a 117%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
44be9ed4 118%define _noautoprovfiles %{_libdir}/%{name}/components
119# we don't want these to satisfy xulrunner-devel
c072808a 120%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 121# and as we don't provide them, don't require either
c072808a 122%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 123
9e7875fc
ER
124%define topdir %{_builddir}/%{name}-%{version}
125%define objdir %{topdir}/obj-%{_target_cpu}
126
44be9ed4 127%description
6b327de6 128Icedove is an open-source, fast and portable email client.
44be9ed4 129
130%description -l pl.UTF-8
6b327de6
JB
131Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
132poczty.
44be9ed4 133
6578c165 134%package addon-lightning
135Summary: An integrated calendar for Icedove
136Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
137License: MPL 1.1 or GPL v2+ or LGPL v2.1+
138Group: Applications/Networking
139Requires: %{name} = %{version}-%{release}
140
141%description addon-lightning
142Lightning is an calendar extension to Icedove email client.
143
144%description addon-lightning -l pl.UTF-8
145Lightning to rozszerzenie do klienta poczty Icedove dodające
146funkcjonalność kalendarza.
147
44be9ed4 148%package addon-enigmail
149Summary: Extension for the authentication and encryption features provided by GnuPG
150Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
151License: MPL/LGPL
152Group: Applications/Networking
153URL: http://enigmail.mozdev.org/
cd056caa 154Requires: %{name} = %{version}-%{release}
d076d93e 155Requires: gnupg
75991bbb 156Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 157
158%description addon-enigmail
c5e06599 159Enigmail is an extension to the Icedove mail client which allows users
160to access the authentication and encryption features provided by
161GnuPG.
44be9ed4 162
163Main Features:
164- Encrypt/sign mail when sending, decrypt/authenticate received mail
165- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
166- Per-Account based encryption and signing defaults
167- Per-Recipient rules for automated key selection, and
168 enabling/disabling encryption and signing
169- OpenPGP key management interface
170
171%description addon-enigmail -l pl.UTF-8
c5e06599 172Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
173użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
174przez GnuPG.
44be9ed4 175
176Główne możliwości:
177- szyfrowanie/podpisywanie poczty przy wysyłaniu,
178 odszyfrowywanie/uwierzytelnianie poczty odebranej
179- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
180- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
181- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
182 podpisywania dla każdego adresata
183- interfejs do zarządzania kluczami OpenPGP
184
185%prep
983562b1 186%setup -qc
f4114a7f 187mv comm-release mozilla
983562b1 188%setup -q -T -D -a2
189cd mozilla
1c70899a 190%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 191/bin/sh %{SOURCE3}
983562b1 192%patch0 -p1
faa5c89d
SP
193%{?with_enigmail:%patch1 -p1}
194%patch2 -p1
4ccc2157 195%patch3 -p1
faa5c89d 196%patch4 -p1
983562b1 197%patch6 -p1
9a743685 198%patch7 -p1
f4114a7f 199%patch8 -p2
ccc206fe 200%patch10 -p2
765a3a27 201%patch11 -p2
268e7766 202%patch12 -p1
44be9ed4 203
204%build
983562b1 205cd mozilla
cadfb931
SP
206cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
207cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
f4114a7f 208cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
44be9ed4 209
9a743685
ER
210install -d libxul-sdk
211ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
9a743685 212
fbac75ca 213cat << EOF > .mozconfig
9e7875fc 214mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 215
5745d706 216export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
217export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
765a3a27
ER
218
219%if %{with crashreporter}
220export MOZ_DEBUG_SYMBOLS=1
221%endif
222
59c5a0e8 223# Options for 'configure' (same as command-line options).
44be9ed4 224ac_add_options --prefix=%{_prefix}
225ac_add_options --exec-prefix=%{_exec_prefix}
226ac_add_options --bindir=%{_bindir}
227ac_add_options --sbindir=%{_sbindir}
228ac_add_options --sysconfdir=%{_sysconfdir}
229ac_add_options --datadir=%{_datadir}
230ac_add_options --includedir=%{_includedir}
231ac_add_options --libdir=%{_libdir}
232ac_add_options --libexecdir=%{_libexecdir}
233ac_add_options --localstatedir=%{_localstatedir}
234ac_add_options --sharedstatedir=%{_sharedstatedir}
235ac_add_options --mandir=%{_mandir}
236ac_add_options --infodir=%{_infodir}
237%if %{?debug:1}0
59c5a0e8 238ac_add_options --disable-optimize
44be9ed4 239ac_add_options --enable-debug
240ac_add_options --enable-debug-modules
59c5a0e8
SP
241ac_add_options --enable-debugger-info-modules
242ac_add_options --enable-crash-on-assert
44be9ed4 243%else
244ac_add_options --disable-debug
245ac_add_options --disable-debug-modules
59c5a0e8
SP
246ac_add_options --disable-logging
247ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 248%endif
88149483
ER
249ac_add_options --disable-strip
250ac_add_options --disable-strip-libs
44be9ed4 251%if %{with tests}
252ac_add_options --enable-tests
253%else
254ac_add_options --disable-tests
255%endif
6458b220 256ac_add_options --enable-gio
44be9ed4 257%if %{with gnomeui}
258ac_add_options --enable-gnomeui
259%else
260ac_add_options --disable-gnomeui
261%endif
44be9ed4 262ac_add_options --disable-gnomevfs
44be9ed4 263%if %{with ldap}
264ac_add_options --enable-ldap
9a743685 265ac_add_options --with-system-ldap
44be9ed4 266%else
267ac_add_options --disable-ldap
268%endif
765a3a27
ER
269%if %{with crashreporter}
270ac_add_options --enable-crashreporter
271%else
59c5a0e8 272ac_add_options --disable-crashreporter
765a3a27 273%endif
59c5a0e8 274ac_add_options --disable-xterm-updates
59c5a0e8 275ac_add_options --enable-postscript
d076d93e 276%if %{with lightning}
cb0e4412 277ac_add_options --enable-calendar
d076d93e
SP
278%else
279ac_add_options --disable-calendar
280%endif
44be9ed4 281ac_add_options --disable-installer
282ac_add_options --disable-jsd
88149483 283ac_add_options --disable-updater
44be9ed4 284ac_add_options --disable-xprint
cadfb931
SP
285ac_add_options --disable-permissions
286ac_add_options --disable-pref-extensions
44be9ed4 287ac_add_options --enable-canvas
288ac_add_options --enable-crypto
44be9ed4 289ac_add_options --enable-mathml
44be9ed4 290ac_add_options --enable-pango
291ac_add_options --enable-reorder
88149483
ER
292ac_add_options --enable-startup-notification
293ac_add_options --enable-svg
44be9ed4 294ac_add_options --enable-system-cairo
5e9bb798 295ac_add_options --enable-system-hunspell
7d981f69 296ac_add_options --enable-system-sqlite
44be9ed4 297ac_add_options --enable-xft
cadfb931
SP
298ac_add_options --enable-application=mail
299ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 300ac_add_options --enable-xinerama
88149483
ER
301ac_add_options --with-distribution-id=org.pld-linux
302ac_add_options --with-branding=icedove/branding
303%if %{with xulrunner}
f4114a7f
ER
304#ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
305ac_add_options --with-system-libxul
fbac75ca 306ac_add_options --enable-shared
f4114a7f 307ac_add_options --enable-libxul
fbac75ca 308%else
f4114a7f 309ac_add_options --disable-xul
88149483
ER
310%endif
311ac_add_options --with-pthreads
312ac_add_options --with-system-bz2
44be9ed4 313ac_add_options --with-system-jpeg
314ac_add_options --with-system-nspr
315ac_add_options --with-system-nss
316ac_add_options --with-system-png
317ac_add_options --with-system-zlib
44be9ed4 318ac_add_options --enable-single-profile
319ac_add_options --disable-profilesharing
44be9ed4 320ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
321EOF
322
90e998ba 323%{__make} -j1 -f client.mk build \
d076d93e 324 STRIP="/bin/true" \
765a3a27 325 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d076d93e 326 CC="%{__cc}" \
44be9ed4 327 CXX="%{__cxx}"
328
765a3a27
ER
329%if %{with crashreporter}
330# create debuginfo for crash-stats.mozilla.com
331%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
332%endif
333
44be9ed4 334%if %{with enigmail}
59c5a0e8 335cd mailnews/extensions/enigmail
9e7875fc
ER
336./makemake -r -o %{objdir}
337%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
338 STRIP="/bin/true" \
339 CC="%{__cc}" \
340 CXX="%{__cxx}"
44be9ed4 341%endif
342
343%install
344rm -rf $RPM_BUILD_ROOT
765a3a27 345install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 346
9e7875fc 347cd %{objdir}
ecf04393 348%{__make} -C mail/installer stage-package \
44be9ed4 349 DESTDIR=$RPM_BUILD_ROOT \
0516fc42 350 MOZ_PKG_DIR=%{_libdir}/%{name} \
44be9ed4 351 PKG_SKIP_STRIP=1
352
765a3a27
ER
353# Enable crash reporter for Firefox application
354%if %{with crashreporter}
355%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
356
357# Add debuginfo for crash-stats.mozilla.com
51a3b6db 358install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
359cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
360%endif
361
ecf04393
ER
362# copy manually lightning files, somewhy they are not installed by make
363cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
364 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
365 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
366
44be9ed4 367# move arch independant ones to datadir
368mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
369mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
44be9ed4 370mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 371mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
44be9ed4 372mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
eca54e0f 373mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
44be9ed4 374ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
375ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
44be9ed4 376ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 377ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
44be9ed4 378ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
eca54e0f 379ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
44be9ed4 380
c6ec3c1c
ER
381# dir for arch independant extensions besides arch dependant extensions
382# see mozilla/xpcom/build/nsXULAppAPI.h
383# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
384install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
385
63d8f5c3 386%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 387ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
388
e6bc19b3
ER
389%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
390ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
391
44be9ed4 392%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
393ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
394ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
395
52f5507d
ER
396cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
397cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 398
e8f4ba81 399# files created by regxpcom -register in post
52fc61e6
ER
400touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
401touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
402cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
403#!/bin/sh
404umask 022
405# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
406# dangerous if you run this with sudo with keep_env += HOME
407# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
408t=$(mktemp -d)
d50a2a28 409%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
410TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
411rm -rf $t
412EOF
413chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 414
44be9ed4 415%if %{with enigmail}
283702b9
ER
416ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
417install -d $ext_dir/{chrome,components,defaults/preferences}
52fc61e6 418cd mozilla/dist/bin
0516fc42 419#cp -rfLp chrome/enigmail.jar $ext_dir/chrome
420#cp -rfLp chrome/enigmime.jar $ext_dir/chrome
52fc61e6
ER
421cp -rfLp components/enig* $ext_dir/components
422cp -rfLp components/libenigmime.so $ext_dir/components
f6a43e2f 423cp -rfLp components/libipc.so $ext_dir/components
52fc61e6
ER
424cp -rfLp components/ipc.xpt $ext_dir/components
425cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
426cd -
52f5507d
ER
427cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
428cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 429%endif
430
9a743685 431# remove unecessary stuff
9e402408 432#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
0516fc42 433#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
434#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
44be9ed4 435
9cdc8923
ER
436# never package these. always remove
437# nss
438%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
439# nspr
440%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9 441# mozldap
9cdc8923 442%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
283702b9 443
44be9ed4 444%clean
445rm -rf $RPM_BUILD_ROOT
446
447%pretrans
448if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
449 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
450fi
eca54e0f 451for d in chrome defaults icons isp modules res searchplugins; do
44be9ed4 452 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
453 install -d %{_datadir}/%{name}
454 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
455 fi
456done
457exit 0
458
e8f4ba81
ER
459%post
460%{_libdir}/%{name}/register || :
461
44be9ed4 462%files
463%defattr(644,root,root,755)
464%attr(755,root,root) %{_bindir}/icedove
465%attr(755,root,root) %{_bindir}/mozilla-thunderbird
466%attr(755,root,root) %{_bindir}/thunderbird
467%dir %{_libdir}/%{name}
765a3a27
ER
468%{_libdir}/%{name}/application.ini
469%{_libdir}/%{name}/platform.ini
6b327de6
JB
470%{_libdir}/%{name}/blocklist.xml
471%{_libdir}/%{name}/chrome.manifest
472%{_libdir}/%{name}/greprefs.js
44be9ed4 473%dir %{_libdir}/%{name}/components
474%attr(755,root,root) %{_libdir}/%{name}/components/*.so
475%{_libdir}/%{name}/components/*.js
476%{_libdir}/%{name}/components/*.xpt
6b327de6
JB
477%{_libdir}/%{name}/components/components.manifest
478%{_libdir}/%{name}/components/interfaces.manifest
0516fc42 479%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
283702b9 480%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
0516fc42 481%attr(755,root,root) %{_libdir}/%{name}/libxul.so
44be9ed4 482%attr(755,root,root) %{_libdir}/%{name}/*.sh
483%attr(755,root,root) %{_libdir}/%{name}/*-bin
484%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
bc9cd18a 485%attr(755,root,root) %{_libdir}/%{name}/icedove
cf62736e 486%attr(755,root,root) %{_libdir}/%{name}/plugin-container
e8f4ba81 487%attr(755,root,root) %{_libdir}/%{name}/register
44be9ed4 488
489# symlinks
490%{_libdir}/%{name}/chrome
491%{_libdir}/%{name}/defaults
492%{_libdir}/%{name}/dictionaries
e6bc19b3 493%{_libdir}/%{name}/hyphenation
44be9ed4 494%{_libdir}/%{name}/isp
9e097178 495%{_libdir}/%{name}/modules
44be9ed4 496%{_libdir}/%{name}/res
eca54e0f 497%{_libdir}/%{name}/searchplugins
44be9ed4 498
293928f3 499%{_pixmapsdir}/*.png
44be9ed4 500%{_desktopdir}/*.desktop
501
502%dir %{_datadir}/%{name}
503%{_datadir}/%{name}/chrome
504%{_datadir}/%{name}/defaults
eca54e0f 505%{_datadir}/%{name}/extensions
44be9ed4 506%{_datadir}/%{name}/isp
9e097178 507%{_datadir}/%{name}/modules
44be9ed4 508%{_datadir}/%{name}/res
eca54e0f 509%{_datadir}/%{name}/searchplugins
44be9ed4 510
765a3a27
ER
511%if %{with crashreporter}
512%attr(755,root,root) %{_libdir}/%{name}/crashreporter
513%{_libdir}/%{name}/crashreporter.ini
514%{_libdir}/%{name}/Throbber-small.gif
515%endif
516
44be9ed4 517%dir %{_libdir}/%{name}/extensions
518%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 519
52fc61e6
ER
520# files created by regxpcom -register
521%ghost %{_libdir}/%{name}/components/compreg.dat
522%ghost %{_libdir}/%{name}/components/xpti.dat
523
6578c165 524%if %{with lightning}
525%files addon-lightning
526%defattr(644,root,root,755)
f3b6d696 527%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
cf62736e 528%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
f3b6d696
ER
529%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
530%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
cf62736e 531%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
f3b6d696
ER
532%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
533%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
534%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
f3b6d696 535%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
cf62736e
JB
536%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
537%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
f3b6d696
ER
538%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
539%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
540%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
6578c165 541%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
542%endif
44be9ed4 543
544%if %{with enigmail}
545%files addon-enigmail
546%defattr(644,root,root,755)
f6a43e2f
ER
547%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
548%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
549%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
550%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
551%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
552%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
553%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
554%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
555%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
44be9ed4 556%endif
This page took 0.119318 seconds and 4 git commands to generate.