]> git.pld-linux.org Git - packages/flake8.git/blame - flake8.spec
- typo
[packages/flake8.git] / flake8.spec
CommitLineData
a24e9a34
ER
1#
2# Conditional build:
37b9d23d
JB
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
a24e9a34
ER
5%bcond_without tests # do not perform "make test"
6
abcf879e 7Summary: The modular source code checker: pep8, pyflakes and co
37b9d23d 8Summary(pl.UTF-8): Modularne narzędzie do sprawdzania kodu źródłowego: pep8, pyflakes itp.
abcf879e 9Name: flake8
9bc90c26 10Version: 3.3.0
53123676 11Release: 2
abcf879e
AM
12License: MIT
13Group: Development/Tools
37b9d23d 14#Source0Download: https://pypi.python.org/simple/flake8/
9bc90c26
JR
15Source0: https://pypi.python.org/packages/47/64/382631de5fd8dab367bedeff6b5b55fd9a7c883daa44f4032636e2d203ca/%{name}-%{version}.tar.gz
16# Source0-md5: 3df622aac9bad27c04f34164609bbed8
abcf879e 17URL: https://pypi.python.org/pypi/flake8
37b9d23d 18BuildRequires: rpmbuild(macros) >= 1.714
abcf879e 19BuildRequires: rpm-pythonprov
37b9d23d
JB
20%if %{with python2}
21BuildRequires: python-modules >= 1:2.5
22BuildRequires: python-setuptools
23%if %{with tests}
9bc90c26 24BuildRequires: python-configparser
37b9d23d 25BuildRequires: python-mccabe >= 0.2.1
972dfbb9 26BuildRequires: python-mock >= 2.0.0
37b9d23d
JB
27BuildRequires: python-nose
28BuildRequires: python-pep8 >= 1.5.7
53123676 29BuildRequires: python-pycodestyle >= 2.0.0
37b9d23d
JB
30BuildRequires: python-pyflakes >= 0.8.1
31%endif
32%endif
33%if %{with python3}
34BuildRequires: python3-modules >= 1:3.2
35BuildRequires: python3-setuptools
a24e9a34
ER
36%if %{with tests}
37BuildRequires: python3-mccabe >= 0.2.1
972dfbb9 38BuildRequires: python3-mock >= 2.0.0
15a03bbe 39BuildRequires: python3-nose
a24e9a34 40BuildRequires: python3-pep8 >= 1.5.7
53123676 41BuildRequires: python3-pycodestyle >= 2.0.0
a24e9a34
ER
42BuildRequires: python3-pyflakes >= 0.8.1
43%endif
37b9d23d
JB
44%endif
45%if %{with python3}
46Requires: python3-flake8 = %{version}-%{release}
47%else
48Requires: python-flake8 = %{version}-%{release}
49%endif
abcf879e
AM
50BuildArch: noarch
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%description
54The modular source code checker. It is a wrapper around these tools:
55- PyFlakes
56- pep8
57- Ned Batchelder's McCabe script
58
37b9d23d
JB
59%description -l pl.UTF-8
60Modularne narzędzie do sprawdzania kodu źródłowego. Jest to opakowanie
61dla narzędzi:
62- PyFlakes
63- pep8
64- skrypt McCabe autorstwa Neda Batcheldera
65
66%package -n python-flake8
67Summary: The modular source code checker: pep8, pyflakes and co
68Summary(pl.UTF-8): Modularne narzędzie do sprawdzania kodu źródłowego: pep8, pyflakes itp.
69Group: Libraries/Python
70Requires: python-modules
71
72%description -n python-flake8
73The modular source code checker. It is a wrapper around these tools:
74- PyFlakes
75- pep8
76- Ned Batchelder's McCabe script
77
78%description -n python-flake8 -l pl.UTF-8
79Modularne narzędzie do sprawdzania kodu źródłowego. Jest to opakowanie
80dla narzędzi:
81- PyFlakes
82- pep8
83- skrypt McCabe autorstwa Neda Batcheldera
84
85%package -n python3-flake8
86Summary: The modular source code checker: pep8, pyflakes and co
87Summary(pl.UTF-8): Modularne narzędzie do sprawdzania kodu źródłowego: pep8, pyflakes itp.
88Group: Libraries/Python
89Requires: python3-modules
90
91%description -n python3-flake8
92The modular source code checker. It is a wrapper around these tools:
93- PyFlakes
94- pep8
95- Ned Batchelder's McCabe script
96
97%description -n python3-flake8 -l pl.UTF-8
98Modularne narzędzie do sprawdzania kodu źródłowego. Jest to opakowanie
99dla narzędzi:
100- PyFlakes
101- pep8
102- skrypt McCabe autorstwa Neda Batcheldera
103
abcf879e
AM
104%prep
105%setup -q
106
107%build
37b9d23d
JB
108%if %{with python2}
109%py_build %{?with_tests:test}
110%endif
111
112%if %{with python3}
33643bb9 113%py3_build %{?with_tests:test}
37b9d23d 114%endif
abcf879e
AM
115
116%install
117rm -rf $RPM_BUILD_ROOT
37b9d23d
JB
118
119%if %{with python2}
120%py_install
8b0b6706 121mv $RPM_BUILD_ROOT%{_bindir}/flake8{,-2}
37b9d23d
JB
122%py_postclean
123%endif
124
125%if %{with python3}
33643bb9 126%py3_install
8b0b6706 127mv $RPM_BUILD_ROOT%{_bindir}/flake8{,-3}
37b9d23d 128%endif
abcf879e 129
8b0b6706
ER
130ln -s flake-%{!?with_python3:2}%{?with_python3:3} $RPM_BUILD_ROOT%{_bindir}/flake8
131
abcf879e
AM
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%files
136%defattr(644,root,root,755)
9bc90c26 137%doc CONTRIBUTORS.txt LICENSE README.rst
abcf879e 138%attr(755,root,root) %{_bindir}/flake8
37b9d23d
JB
139
140%if %{with python2}
141%files -n python-flake8
142%defattr(644,root,root,755)
143%attr(755,root,root) %{_bindir}/flake8-2
144%{py_sitescriptdir}/flake8
145%{py_sitescriptdir}/flake8-%{version}-py*.egg-info
146%endif
147
148%if %{with python3}
149%files -n python3-flake8
150%defattr(644,root,root,755)
151%attr(755,root,root) %{_bindir}/flake8-3
152%{py3_sitescriptdir}/flake8
153%{py3_sitescriptdir}/flake8-%{version}-py*.egg-info
154%endif
This page took 0.190147 seconds and 4 git commands to generate.