]> git.pld-linux.org Git - packages/flake8.git/blame - flake8.spec
- python 3.5 rebuild
[packages/flake8.git] / flake8.spec
CommitLineData
a24e9a34
ER
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
abcf879e
AM
5Summary: The modular source code checker: pep8, pyflakes and co
6Name: flake8
7Version: 2.2.5
b6e3cac7 8Release: 2
abcf879e
AM
9License: MIT
10Group: Development/Tools
11Source0: https://pypi.python.org/packages/source/f/flake8/%{name}-%{version}.tar.gz
12# Source0-md5: 6dea927949b94c9d9495ab24bcdf9cf0
13URL: https://pypi.python.org/pypi/flake8
15a03bbe 14BuildRequires: python3-distribute
abcf879e
AM
15BuildRequires: python3-modules
16BuildRequires: rpm-pythonprov
a24e9a34
ER
17%if %{with tests}
18BuildRequires: python3-mccabe >= 0.2.1
15a03bbe 19BuildRequires: python3-nose
a24e9a34
ER
20BuildRequires: python3-pep8 >= 1.5.7
21BuildRequires: python3-pyflakes >= 0.8.1
22%endif
abcf879e
AM
23Requires: python3-modules
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28The modular source code checker. It is a wrapper around these tools:
29- PyFlakes
30- pep8
31- Ned Batchelder's McCabe script
32
33%prep
34%setup -q
35
36%build
a24e9a34 37%{__python3} setup.py build %{?with_tests:test}
abcf879e
AM
38
39%install
40rm -rf $RPM_BUILD_ROOT
a24e9a34
ER
41%{__python3} setup.py install \
42 --skip-build \
43 --optimize=2 \
44 --root=$RPM_BUILD_ROOT
abcf879e
AM
45
46%clean
47rm -rf $RPM_BUILD_ROOT
48
49%files
50%defattr(644,root,root,755)
51%doc CHANGES.rst CONTRIBUTORS.txt README.rst
52%attr(755,root,root) %{_bindir}/flake8
53%{py3_sitescriptdir}/%{name}
54%{py3_sitescriptdir}/%{name}-%{version}-py*.egg-info
This page took 0.075664 seconds and 4 git commands to generate.