]> git.pld-linux.org Git - packages/flake8.git/blame - flake8.spec
enable tests (tests bcond did not exist), update deps for tests
[packages/flake8.git] / flake8.spec
CommitLineData
a24e9a34
ER
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
abcf879e
AM
5Summary: The modular source code checker: pep8, pyflakes and co
6Name: flake8
7Version: 2.2.5
8Release: 1
9License: MIT
10Group: Development/Tools
11Source0: https://pypi.python.org/packages/source/f/flake8/%{name}-%{version}.tar.gz
12# Source0-md5: 6dea927949b94c9d9495ab24bcdf9cf0
13URL: https://pypi.python.org/pypi/flake8
14BuildRequires: python3-modules
15BuildRequires: rpm-pythonprov
a24e9a34
ER
16%if %{with tests}
17BuildRequires: python3-mccabe >= 0.2.1
18BuildRequires: python3-pep8 >= 1.5.7
19BuildRequires: python3-pyflakes >= 0.8.1
20%endif
abcf879e
AM
21Requires: python3-modules
22BuildArch: noarch
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26The modular source code checker. It is a wrapper around these tools:
27- PyFlakes
28- pep8
29- Ned Batchelder's McCabe script
30
31%prep
32%setup -q
33
34%build
a24e9a34 35%{__python3} setup.py build %{?with_tests:test}
abcf879e
AM
36
37%install
38rm -rf $RPM_BUILD_ROOT
a24e9a34
ER
39%{__python3} setup.py install \
40 --skip-build \
41 --optimize=2 \
42 --root=$RPM_BUILD_ROOT
abcf879e
AM
43
44%clean
45rm -rf $RPM_BUILD_ROOT
46
47%files
48%defattr(644,root,root,755)
49%doc CHANGES.rst CONTRIBUTORS.txt README.rst
50%attr(755,root,root) %{_bindir}/flake8
51%{py3_sitescriptdir}/%{name}
52%{py3_sitescriptdir}/%{name}-%{version}-py*.egg-info
This page took 0.088457 seconds and 4 git commands to generate.