]> git.pld-linux.org Git - packages/flake8.git/commitdiff
enable tests (tests bcond did not exist), update deps for tests auto/th/flake8-2.2.5-1
authorElan Ruusamäe <glen@delfi.ee>
Thu, 27 Nov 2014 21:36:11 +0000 (23:36 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 27 Nov 2014 21:36:11 +0000 (23:36 +0200)
flake8.spec

index 5f5876f9faa06ce6122cadbee09958da0dc4b99d..f483208c4d680398b9fcf2f5ad09876b3e1b5a49 100644 (file)
@@ -1,3 +1,7 @@
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+
 Summary:       The modular source code checker: pep8, pyflakes and co
 Name:          flake8
 Version:       2.2.5
@@ -9,6 +13,11 @@ Source0:      https://pypi.python.org/packages/source/f/flake8/%{name}-%{version}.tar
 URL:           https://pypi.python.org/pypi/flake8
 BuildRequires: python3-modules
 BuildRequires: rpm-pythonprov
+%if %{with tests}
+BuildRequires: python3-mccabe >= 0.2.1
+BuildRequires: python3-pep8 >= 1.5.7
+BuildRequires: python3-pyflakes >= 0.8.1
+%endif
 Requires:      python3-modules
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -23,16 +32,14 @@ The modular source code checker. It is a wrapper around these tools:
 %setup -q
 
 %build
-%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
+%{__python3} setup.py build %{?with_tests:test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
-%{__python3} setup.py \
-               build --build-base build-3 \
-               install --skip-build \
-               --optimize=2 \
-               --root=$RPM_BUILD_ROOT
+%{__python3} setup.py install \
+       --skip-build \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.104669 seconds and 4 git commands to generate.