]> git.pld-linux.org Git - packages/flake8.git/blame - flake8.spec
- initial
[packages/flake8.git] / flake8.spec
CommitLineData
abcf879e
AM
1Summary: The modular source code checker: pep8, pyflakes and co
2Name: flake8
3Version: 2.2.5
4Release: 1
5License: MIT
6Group: Development/Tools
7Source0: https://pypi.python.org/packages/source/f/flake8/%{name}-%{version}.tar.gz
8# Source0-md5: 6dea927949b94c9d9495ab24bcdf9cf0
9URL: https://pypi.python.org/pypi/flake8
10BuildRequires: python3-modules
11BuildRequires: rpm-pythonprov
12Requires: python3-modules
13BuildArch: noarch
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17The modular source code checker. It is a wrapper around these tools:
18- PyFlakes
19- pep8
20- Ned Batchelder's McCabe script
21
22%prep
23%setup -q
24
25%build
26%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
27
28%install
29rm -rf $RPM_BUILD_ROOT
30
31%{__python3} setup.py \
32 build --build-base build-3 \
33 install --skip-build \
34 --optimize=2 \
35 --root=$RPM_BUILD_ROOT
36
37%clean
38rm -rf $RPM_BUILD_ROOT
39
40%files
41%defattr(644,root,root,755)
42%doc CHANGES.rst CONTRIBUTORS.txt README.rst
43%attr(755,root,root) %{_bindir}/flake8
44%{py3_sitescriptdir}/%{name}
45%{py3_sitescriptdir}/%{name}-%{version}-py*.egg-info
This page took 0.070486 seconds and 4 git commands to generate.