]> git.pld-linux.org Git - packages/flake8.git/blob - flake8.spec
- initial
[packages/flake8.git] / flake8.spec
1 Summary:        The modular source code checker: pep8, pyflakes and co
2 Name:           flake8
3 Version:        2.2.5
4 Release:        1
5 License:        MIT
6 Group:          Development/Tools
7 Source0:        https://pypi.python.org/packages/source/f/flake8/%{name}-%{version}.tar.gz
8 # Source0-md5:  6dea927949b94c9d9495ab24bcdf9cf0
9 URL:            https://pypi.python.org/pypi/flake8
10 BuildRequires:  python3-modules
11 BuildRequires:  rpm-pythonprov
12 Requires:       python3-modules
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 The modular source code checker. It is a wrapper around these tools:
18 - PyFlakes
19 - pep8
20 - Ned Batchelder's McCabe script
21
22 %prep
23 %setup -q
24
25 %build
26 %{__python3} setup.py build --build-base build-3 %{?with_tests:test}
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30
31 %{__python3} setup.py \
32                 build --build-base build-3 \
33                 install --skip-build \
34                 --optimize=2 \
35                 --root=$RPM_BUILD_ROOT
36
37 %clean
38 rm -rf $RPM_BUILD_ROOT
39
40 %files
41 %defattr(644,root,root,755)
42 %doc CHANGES.rst CONTRIBUTORS.txt README.rst
43 %attr(755,root,root) %{_bindir}/flake8
44 %{py3_sitescriptdir}/%{name}
45 %{py3_sitescriptdir}/%{name}-%{version}-py*.egg-info
This page took 0.077287 seconds and 4 git commands to generate.