]> git.pld-linux.org Git - packages/flake8.git/blame - flake8.spec
BR: rpmbuild(macros) >= 1.710
[packages/flake8.git] / flake8.spec
CommitLineData
a24e9a34
ER
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
abcf879e
AM
5Summary: The modular source code checker: pep8, pyflakes and co
6Name: flake8
7Version: 2.2.5
b6e3cac7 8Release: 2
abcf879e
AM
9License: MIT
10Group: Development/Tools
11Source0: https://pypi.python.org/packages/source/f/flake8/%{name}-%{version}.tar.gz
12# Source0-md5: 6dea927949b94c9d9495ab24bcdf9cf0
13URL: https://pypi.python.org/pypi/flake8
ee25ecae 14BuildRequires: rpmbuild(macros) >= 1.710
15a03bbe 15BuildRequires: python3-distribute
abcf879e
AM
16BuildRequires: python3-modules
17BuildRequires: rpm-pythonprov
a24e9a34
ER
18%if %{with tests}
19BuildRequires: python3-mccabe >= 0.2.1
15a03bbe 20BuildRequires: python3-nose
a24e9a34
ER
21BuildRequires: python3-pep8 >= 1.5.7
22BuildRequires: python3-pyflakes >= 0.8.1
23%endif
abcf879e
AM
24Requires: python3-modules
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29The modular source code checker. It is a wrapper around these tools:
30- PyFlakes
31- pep8
32- Ned Batchelder's McCabe script
33
34%prep
35%setup -q
36
37%build
33643bb9 38%py3_build %{?with_tests:test}
abcf879e
AM
39
40%install
41rm -rf $RPM_BUILD_ROOT
33643bb9 42%py3_install
abcf879e
AM
43
44%clean
45rm -rf $RPM_BUILD_ROOT
46
47%files
48%defattr(644,root,root,755)
49%doc CHANGES.rst CONTRIBUTORS.txt README.rst
50%attr(755,root,root) %{_bindir}/flake8
51%{py3_sitescriptdir}/%{name}
52%{py3_sitescriptdir}/%{name}-%{version}-py*.egg-info
This page took 0.266307 seconds and 4 git commands to generate.