]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
updated to 2.8.9
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
b563f9dc
JB
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
77f8acdd 10
efafbc62 11Summary: Cross-platform, open-source make system
ac3ea35a 12Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 13Name: cmake
9ec4f08d 14Version: 2.8.9
c8ffae59 15Release: 1
efafbc62 16License: BSD
72a696fa 17Group: Development/Building
28f0bd6c 18Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
9ec4f08d 19# Source0-md5: 801f4c87f8b604f727df5bf1f05a59e7
6342daf8 20Patch0: %{name}-lib64.patch
9ec4f08d 21Patch1: %{name}-helpers.patch
a315a797 22URL: http://www.cmake.org/
33042d59 23%{?with_gui:BuildRequires: QtGui-devel}
fef12180 24BuildRequires: libarchive-devel
ece9e155 25BuildRequires: libstdc++-devel
59917d1a 26BuildRequires: ncurses-devel > 5.9-3
33042d59
KK
27%{?with_gui:BuildRequires: qt4-build}
28%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 29BuildRequires: rpmbuild(macros) >= 1.167
ab02ad6a 30%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
75cb386f 31Requires: filesystem >= 3.0-52
efafbc62 32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
33
34%description
efafbc62
AG
35CMake is used to control the software compilation process using simple
36platform and compiler independent configuration files. CMake generates
37native makefiles and workspaces that can be used in the compiler
38environment of your choice. CMake is quite sophisticated: it is
39possible to support complex environments requiring system
40configuration, pre-processor generation, code generation, and template
41instantiation.
3fcbc09a 42
520c9eb8
JR
43%description -l pl.UTF-8
44CMake służy do sterowania procesem kompilacji oprogramowania przy
ca760f29 45użyciu prostych plików konfiguracyjnych niezależnych od platformy i
46kompilatora. CMake generuje natywne pliki makefile i workspace,
485d9a7a 47których można używać w wybranym środowisku kompilatora. CMake jest
59787775 48dość wyrafinowany: może obsłużyć złożone środowiska wymagające
ca760f29 49konfiguracji systemu, generowanie preprocesora, generowanie kodu i
50dziedziczenie szablonów.
33042d59
KK
51
52%package gui
b563f9dc
JB
53Summary: Qt GUI for CMake
54Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
55Group: Development/Tools
56Requires: %{name} = %{version}-%{release}
57
b563f9dc
JB
58%description gui
59This package contains the Qt based GUI for CMake.
60
61%description gui -l pl.UTF-8
62Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
63CMake.
72a696fa 64
9ec4f08d
KK
65%package emacs
66Summary: Emacs mode for cmake
67Group: Development/Tools
68
69%description emacs
70Emacs mode for cmake.
71
72%package -n bash-completion-%{name}
73Summary: bash-completion for cmake
74Group: Applications/Shells
75Requires: %{name}
76
77%description -n bash-completion-%{name}
78bash-completion for Yum Utils.
79
3fcbc09a 80%prep
923851a2 81%setup -q
286b1479 82%if "%{_lib}" == "lib64"
6342daf8 83%patch0 -p1
286b1479 84%endif
9ec4f08d 85%patch1 -p1
3fcbc09a 86
ece9e155 87cat > "init.cmake" <<EOF
286b1479 88SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
9ec4f08d
KK
89SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
90SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
ece9e155
KK
91EOF
92
3fcbc09a 93%build
ece9e155
KK
94export CC="%{__cc}"
95export CXX="%{__cxx}"
96export CFLAGS="%{rpmcflags}"
97export CXXFLAGS="%{rpmcxxflags}"
ccca321d 98export LDFLAGS="%{rpmldflags}"
923851a2
AG
99./bootstrap \
100 --prefix=%{_prefix} \
101 --mandir=/share/man \
102 --datadir=/share/cmake \
ece9e155 103 --init=init.cmake \
c342f103 104 %{!?with_bootstrap:--system-libs} \
33042d59 105 %{?with_gui:--qt-gui} \
08bb5e07 106 --qt-qmake=/usr/bin/qmake-qt4 \
923851a2
AG
107 --verbose
108
28f0bd6c 109%{__make} VERBOSE=1
3fcbc09a
AG
110
111%install
efafbc62 112rm -rf $RPM_BUILD_ROOT
75cb386f 113
72a696fa
JB
114%{__make} install \
115 DESTDIR=$RPM_BUILD_ROOT
116
75cb386f 117%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%files
efafbc62 123%defattr(644,root,root,755)
51ed65c6 124%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
125%attr(755,root,root) %{_bindir}/ccmake
126%attr(755,root,root) %{_bindir}/cmake
08b6790a 127%attr(755,root,root) %{_bindir}/cpack
72a696fa 128%attr(755,root,root) %{_bindir}/ctest
08bb5e07
JB
129%{_mandir}/man1/ccmake.1*
130%{_mandir}/man1/cmake.1*
131%{_mandir}/man1/cmakecommands.1*
132%{_mandir}/man1/cmakecompat.1*
133%{_mandir}/man1/cmakemodules.1*
134%{_mandir}/man1/cmakepolicies.1*
135%{_mandir}/man1/cmakeprops.1*
136%{_mandir}/man1/cmakevars.1*
137%{_mandir}/man1/cpack.1*
138%{_mandir}/man1/ctest.1*
b24a2e64
JB
139# top cmake/Modules dirs belong to filesystem
140%{_datadir}/cmake/Modules/.NoDartCoverage
141%{_datadir}/cmake/Modules/*
142%{_datadir}/cmake/Templates
143%{_datadir}/cmake/include
09f5d631 144%{_aclocaldir}/cmake.m4
33042d59 145
1a3a9dcd 146%if %{with gui}
33042d59
KK
147%files gui
148%defattr(644,root,root,755)
149%attr(755,root,root) %{_bindir}/cmake-gui
150%{_datadir}/mime/packages/cmakecache.xml
151%{_desktopdir}/CMake.desktop
ca760f29 152%{_pixmapsdir}/CMakeSetup32.png
08bb5e07 153%{_mandir}/man1/cmake-gui.1*
1a3a9dcd 154%endif
9ec4f08d
KK
155
156%files emacs
157%defattr(644,root,root,755)
158%{_datadir}/emacs/site-lisp/cmake-mode.el
159
160%files -n bash-completion-%{name}
161%defattr(644,root,root,755)
162/etc/bash_completion.d/*
This page took 0.093468 seconds and 4 git commands to generate.