]> git.pld-linux.org Git - packages/cmake.git/commitdiff
updated to 2.8.9
authorKacper Kornet <draenog@pld-linux.org>
Thu, 16 Aug 2012 12:44:01 +0000 (14:44 +0200)
committerKacper Kornet <draenog@pld-linux.org>
Thu, 23 Aug 2012 11:33:40 +0000 (13:33 +0200)
Files for vim are not packaged as the ones with the same functionality
are already provided by vim-rt.

cmake-helpers.patch [new file with mode: 0644]
cmake.spec

diff --git a/cmake-helpers.patch b/cmake-helpers.patch
new file mode 100644 (file)
index 0000000..101756d
--- /dev/null
@@ -0,0 +1,16 @@
+--- a/Docs/bash-completion/CMakeLists.txt      2012-08-09 20:15:18.000000000 +0200
++++ b/Docs/bash-completion/CMakeLists.txt      2012-08-15 13:46:38.124245369 +0200
+@@ -5,4 +5,4 @@
+ # add symlinks to the files in appropriate places
+ #  /etc/bash_completion.d/
+ #  DATADIR/completions (may be /usr/share/<package>/completions
+-install(FILES cmake cpack ctest DESTINATION ${REL_CMAKE_DATA_DIR}/completions)
++install(FILES cmake cpack ctest DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/bash_completion.d)
+--- a/Docs/CMakeLists.txt      2012-08-09 20:15:18.000000000 +0200
++++ b/Docs/CMakeLists.txt      2012-08-16 13:29:07.401201870 +0200
+@@ -1,4 +1,4 @@
+ string(REGEX REPLACE "^/(.*)" "\\1" REL_CMAKE_DATA_DIR "${CMAKE_DATA_DIR}")
+ install(FILES cmake-help.vim cmake-indent.vim cmake-syntax.vim DESTINATION ${REL_CMAKE_DATA_DIR}/editors/vim)
+-install(FILES cmake-mode.el DESTINATION ${REL_CMAKE_DATA_DIR}/editors/emacs)
++install(FILES cmake-mode.el DESTINATION ${CMAKE_INSTALL_DATADIR}/emacs/site-lisp)
+ ADD_SUBDIRECTORY (bash-completion)
index 00f5ed229898fca664e61a753bbffaf39c12669b..18210a88b9872c36b1a2c3f273ab21abd3b903ec 100644 (file)
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       2.8.8
+Version:       2.8.9
 Release:       1
 License:       BSD
 Group:         Development/Building
 Source0:       http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
-# Source0-md5: ba74b22c788a0c8547976b880cd02b17
+# Source0-md5: 801f4c87f8b604f727df5bf1f05a59e7
 Patch0:                %{name}-lib64.patch
+Patch1:                %{name}-helpers.patch
 URL:           http://www.cmake.org/
 %{?with_gui:BuildRequires:     QtGui-devel}
 BuildRequires: libarchive-devel
@@ -61,14 +62,32 @@ This package contains the Qt based GUI for CMake.
 Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
 CMake.
 
+%package emacs
+Summary:       Emacs mode for cmake
+Group:         Development/Tools
+
+%description emacs
+Emacs mode for cmake.
+
+%package -n bash-completion-%{name}
+Summary:       bash-completion for cmake
+Group:         Applications/Shells
+Requires:      %{name}
+
+%description -n bash-completion-%{name}
+bash-completion for Yum Utils.
+
 %prep
 %setup -q
 %if "%{_lib}" == "lib64"
 %patch0 -p1
 %endif
+%patch1 -p1
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
+SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
+SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
 EOF
 
 %build
@@ -133,3 +152,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_pixmapsdir}/CMakeSetup32.png
 %{_mandir}/man1/cmake-gui.1*
 %endif
+
+%files emacs
+%defattr(644,root,root,755)
+%{_datadir}/emacs/site-lisp/cmake-mode.el
+
+%files -n bash-completion-%{name}
+%defattr(644,root,root,755)
+/etc/bash_completion.d/*
This page took 0.099849 seconds and 4 git commands to generate.