]> git.pld-linux.org Git - packages/libvpx.git/blame - libvpx.spec
- updated to 1.3.0 (from git tag, not available on webm downloads)
[packages/libvpx.git] / libvpx.spec
CommitLineData
c9ee805b
ER
1#
2# Conditional build:
d5d82930 3%bcond_without asm # x86 assembler
3c828a1d 4
bccc9f86 5Summary: VP8, a high-quality video codec
d5d82930 6Summary(pl.UTF-8): VP8 - kodek obrazu wysokiej jakości
bccc9f86 7Name: libvpx
1e757208 8Version: 1.3.0
1c3357c1 9Release: 1
bccc9f86
AM
10License: BSD
11Group: Libraries
1e757208
JB
12#Source0Download: http://code.google.com/p/webm/downloads/list
13#Source0: https://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
14Source0: https://chromium.googlesource.com/webm/libvpx/+archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
15# Source0-md5: dcf436a5dc8b56bdfb4aec63b2fe6729
bccc9f86 16URL: http://www.webmproject.org/
13542557 17BuildRequires: /usr/bin/php
a28e5963 18BuildRequires: doxygen
47f853c3 19BuildRequires: php-common >= 4:5.0.0
13542557 20BuildRequires: php-pcre
9026bd8c 21BuildRequires: sed >= 4.0
d5d82930 22%ifarch %{ix86} %{x8664}
3c828a1d 23%{?with_asm:BuildRequires: yasm >= 0.8}
d5d82930 24%endif
bccc9f86
AM
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
e1331b3a
ER
27%define generic_target generic-gnu
28%define vpxtarget %{generic_target}
29%ifarch %{x8664}
30%define vpxtarget x86_64-linux-gcc
31%endif
32%ifarch %{ix86}
33%define vpxtarget x86-linux-gcc
34%endif
35%ifarch ppc
36%define vpxtarget ppc32-linux-gcc
37%endif
38%ifarch ppc64
39%define vpxtarget ppc64-linux-gcc
40%endif
41
bccc9f86
AM
42%description
43VP8, a high-quality video codec.
44
d5d82930
JB
45%description -l pl.UTF-8
46VP8 - kodek obrazu wysokiej jakości.
47
bccc9f86 48%package devel
d5d82930
JB
49Summary: Header files for libvpx
50Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libvpx
bccc9f86 51Group: Development/Libraries
d5d82930 52Requires: %{name} = %{version}-%{release}
bccc9f86
AM
53
54%description devel
d5d82930
JB
55Header files for libvpx library.
56
57%description devel -l pl.UTF-8
58Pliki nagłówkowe biblioteki libvpx.
bccc9f86
AM
59
60%package static
61Summary: Static libvpx library
d5d82930 62Summary(pl.UTF-8): Statyczna biblioteka libvpx
bccc9f86 63Group: Development/Libraries
d5d82930 64Requires: %{name}-devel = %{version}-%{release}
bccc9f86
AM
65
66%description static
67Static libvpx library.
68
d5d82930
JB
69%description static -l pl.UTF-8
70Statyczna biblioteka libvpx.
71
bccc9f86 72%prep
1e757208
JB
73#%setup -q -n %{name}-v%{version}
74%setup -q -c
bccc9f86
AM
75
76%build
d5d82930
JB
77install -d obj
78cd obj
bccc9f86 79# not autoconf configure
d5d82930 80CFLAGS="%{rpmcflags} %{rpmcppflags}" \
bccc9f86 81../configure \
7b991969 82%if %{with asm}
dcde509e 83 --as=yasm \
61956466 84%endif
e1331b3a
ER
85 --target=%{vpxtarget} \
86%if "%{vpxtarget}" != "%{generic_target}"
6c7c0f8b 87 --enable-shared \
e1331b3a 88%endif
0257ab6e 89 --disable-optimizations \
bccc9f86
AM
90 --enable-vp8 \
91 --enable-postproc \
92 --enable-runtime-cpu-detect
0257ab6e 93
0257ab6e 94%{__make} verbose=true target=libs \
938aec6f 95 HAVE_GNU_STRIP=no \
6c7c0f8b 96 CC="%{__cc}" \
7fb20346 97 LD="%{__cc}" \
6c7c0f8b 98 LDFLAGS="%{rpmldflags}"
0257ab6e
AM
99
100%{__make} verbose=true target=examples \
6c7c0f8b 101 CC="%{__cc}" \
7fb20346 102 LD="%{__cc}" \
dcde509e 103 LDFLAGS="%{rpmldflags} -L."
0257ab6e
AM
104%{__make} verbose=true target=docs
105
bccc9f86
AM
106%install
107rm -rf $RPM_BUILD_ROOT
464fefd2 108install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
0257ab6e 109
6c7c0f8b 110%{__make} -C obj verbose=true install \
938aec6f
ER
111 LIBSUBDIR=%{_lib} \
112 DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
0257ab6e 113
1e757208 114%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.1.3
9026bd8c
JB
115
116# adjust prefix and libdir
3c828a1d 117%{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
bccc9f86
AM
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post -p /sbin/ldconfig
123%postun -p /sbin/ldconfig
124
125%files
126%defattr(644,root,root,755)
d5d82930 127%doc AUTHORS CHANGELOG LICENSE PATENTS README
1c3357c1 128%attr(755,root,root) %{_bindir}/vp8_scalable_patterns
1e757208 129%attr(755,root,root) %{_bindir}/vp9_spatial_scalable_encoder
d5d82930
JB
130%attr(755,root,root) %{_bindir}/vpxdec
131%attr(755,root,root) %{_bindir}/vpxenc
47f853c3 132%attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
1c3357c1 133%attr(755,root,root) %ghost %{_libdir}/libvpx.so.1
bccc9f86
AM
134
135%files devel
136%defattr(644,root,root,755)
47f853c3 137%attr(755,root,root) %{_libdir}/libvpx.so
464fefd2 138%{_includedir}/vpx
9026bd8c 139%{_pkgconfigdir}/vpx.pc
bccc9f86
AM
140
141%files static
142%defattr(644,root,root,755)
0257ab6e 143%{_libdir}/libvpx.a
This page took 0.123282 seconds and 4 git commands to generate.