]> git.pld-linux.org Git - packages/libvpx.git/blame - libvpx.spec
- updated to 1.2.0
[packages/libvpx.git] / libvpx.spec
CommitLineData
c9ee805b
ER
1#
2# Conditional build:
d5d82930 3%bcond_without asm # x86 assembler
3c828a1d 4
bccc9f86 5Summary: VP8, a high-quality video codec
d5d82930 6Summary(pl.UTF-8): VP8 - kodek obrazu wysokiej jakości
bccc9f86 7Name: libvpx
2001cd1a 8Version: 1.2.0
1c3357c1 9Release: 1
bccc9f86
AM
10License: BSD
11Group: Libraries
3c828a1d 12# Source0Download: http://code.google.com/p/webm/downloads/list
1c3357c1 13Source0: https://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
2001cd1a 14# Source0-md5: f8de058e6ba14555144583a2d031fe19
bccc9f86 15URL: http://www.webmproject.org/
13542557 16BuildRequires: /usr/bin/php
a28e5963 17BuildRequires: doxygen
47f853c3 18BuildRequires: php-common >= 4:5.0.0
13542557 19BuildRequires: php-pcre
9026bd8c 20BuildRequires: sed >= 4.0
d5d82930 21%ifarch %{ix86} %{x8664}
3c828a1d 22%{?with_asm:BuildRequires: yasm >= 0.8}
d5d82930 23%endif
bccc9f86
AM
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
e1331b3a
ER
26%define generic_target generic-gnu
27%define vpxtarget %{generic_target}
28%ifarch %{x8664}
29%define vpxtarget x86_64-linux-gcc
30%endif
31%ifarch %{ix86}
32%define vpxtarget x86-linux-gcc
33%endif
34%ifarch ppc
35%define vpxtarget ppc32-linux-gcc
36%endif
37%ifarch ppc64
38%define vpxtarget ppc64-linux-gcc
39%endif
40
bccc9f86
AM
41%description
42VP8, a high-quality video codec.
43
d5d82930
JB
44%description -l pl.UTF-8
45VP8 - kodek obrazu wysokiej jakości.
46
bccc9f86 47%package devel
d5d82930
JB
48Summary: Header files for libvpx
49Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libvpx
bccc9f86 50Group: Development/Libraries
d5d82930 51Requires: %{name} = %{version}-%{release}
bccc9f86
AM
52
53%description devel
d5d82930
JB
54Header files for libvpx library.
55
56%description devel -l pl.UTF-8
57Pliki nagłówkowe biblioteki libvpx.
bccc9f86
AM
58
59%package static
60Summary: Static libvpx library
d5d82930 61Summary(pl.UTF-8): Statyczna biblioteka libvpx
bccc9f86 62Group: Development/Libraries
d5d82930 63Requires: %{name}-devel = %{version}-%{release}
bccc9f86
AM
64
65%description static
66Static libvpx library.
67
d5d82930
JB
68%description static -l pl.UTF-8
69Statyczna biblioteka libvpx.
70
bccc9f86 71%prep
1c3357c1 72%setup -q -n %{name}-v%{version}
bccc9f86
AM
73
74%build
d5d82930
JB
75install -d obj
76cd obj
bccc9f86 77# not autoconf configure
d5d82930 78CFLAGS="%{rpmcflags} %{rpmcppflags}" \
bccc9f86 79../configure \
7b991969 80%if %{with asm}
dcde509e 81 --as=yasm \
61956466 82%endif
e1331b3a
ER
83 --target=%{vpxtarget} \
84%if "%{vpxtarget}" != "%{generic_target}"
6c7c0f8b 85 --enable-shared \
e1331b3a 86%endif
0257ab6e 87 --disable-optimizations \
bccc9f86
AM
88 --enable-vp8 \
89 --enable-postproc \
90 --enable-runtime-cpu-detect
0257ab6e 91
0257ab6e 92%{__make} verbose=true target=libs \
938aec6f 93 HAVE_GNU_STRIP=no \
6c7c0f8b 94 CC="%{__cc}" \
7fb20346 95 LD="%{__cc}" \
6c7c0f8b 96 LDFLAGS="%{rpmldflags}"
0257ab6e
AM
97
98%{__make} verbose=true target=examples \
6c7c0f8b 99 CC="%{__cc}" \
7fb20346 100 LD="%{__cc}" \
dcde509e 101 LDFLAGS="%{rpmldflags} -L."
0257ab6e
AM
102%{__make} verbose=true target=docs
103
bccc9f86
AM
104%install
105rm -rf $RPM_BUILD_ROOT
464fefd2 106install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
0257ab6e 107
6c7c0f8b 108%{__make} -C obj verbose=true install \
938aec6f
ER
109 LIBSUBDIR=%{_lib} \
110 DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
0257ab6e 111
2001cd1a 112%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.1.2
9026bd8c
JB
113
114# adjust prefix and libdir
3c828a1d 115%{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
bccc9f86
AM
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post -p /sbin/ldconfig
121%postun -p /sbin/ldconfig
122
123%files
124%defattr(644,root,root,755)
d5d82930 125%doc AUTHORS CHANGELOG LICENSE PATENTS README
1c3357c1 126%attr(755,root,root) %{_bindir}/vp8_scalable_patterns
d5d82930
JB
127%attr(755,root,root) %{_bindir}/vpxdec
128%attr(755,root,root) %{_bindir}/vpxenc
47f853c3 129%attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
1c3357c1 130%attr(755,root,root) %ghost %{_libdir}/libvpx.so.1
bccc9f86
AM
131
132%files devel
133%defattr(644,root,root,755)
47f853c3 134%attr(755,root,root) %{_libdir}/libvpx.so
464fefd2 135%{_includedir}/vpx
9026bd8c 136%{_pkgconfigdir}/vpx.pc
bccc9f86
AM
137
138%files static
139%defattr(644,root,root,755)
0257ab6e 140%{_libdir}/libvpx.a
This page took 0.068926 seconds and 4 git commands to generate.