]> git.pld-linux.org Git - packages/libvpx.git/blame - libvpx.spec
- updated to 1.0.0 (note: new soname; also fixes an OOB read decoder crash)
[packages/libvpx.git] / libvpx.spec
CommitLineData
c9ee805b
ER
1#
2# Conditional build:
d5d82930 3%bcond_without asm # x86 assembler
9026bd8c 4#
bccc9f86 5Summary: VP8, a high-quality video codec
d5d82930 6Summary(pl.UTF-8): VP8 - kodek obrazu wysokiej jakości
bccc9f86 7Name: libvpx
1c3357c1
JB
8Version: 1.0.0
9Release: 1
bccc9f86
AM
10License: BSD
11Group: Libraries
9026bd8c 12#Source0Download: http://code.google.com/p/webm/downloads/list
1c3357c1
JB
13Source0: https://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
14# Source0-md5: d987b5140412edd37d2c6b10c29ad484
bccc9f86 15URL: http://www.webmproject.org/
13542557 16BuildRequires: /usr/bin/php
a28e5963 17BuildRequires: doxygen
47f853c3 18BuildRequires: php-common >= 4:5.0.0
13542557 19BuildRequires: php-pcre
9026bd8c 20BuildRequires: sed >= 4.0
d5d82930 21%ifarch %{ix86} %{x8664}
7b991969 22%{?with_asm:BuildRequires: yasm}
d5d82930 23%endif
bccc9f86
AM
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27VP8, a high-quality video codec.
28
d5d82930
JB
29%description -l pl.UTF-8
30VP8 - kodek obrazu wysokiej jakości.
31
bccc9f86 32%package devel
d5d82930
JB
33Summary: Header files for libvpx
34Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libvpx
bccc9f86 35Group: Development/Libraries
d5d82930 36Requires: %{name} = %{version}-%{release}
bccc9f86
AM
37
38%description devel
d5d82930
JB
39Header files for libvpx library.
40
41%description devel -l pl.UTF-8
42Pliki nagłówkowe biblioteki libvpx.
bccc9f86
AM
43
44%package static
45Summary: Static libvpx library
d5d82930 46Summary(pl.UTF-8): Statyczna biblioteka libvpx
bccc9f86 47Group: Development/Libraries
d5d82930 48Requires: %{name}-devel = %{version}-%{release}
bccc9f86
AM
49
50%description static
51Static libvpx library.
52
d5d82930
JB
53%description static -l pl.UTF-8
54Statyczna biblioteka libvpx.
55
bccc9f86 56%prep
1c3357c1 57%setup -q -n %{name}-v%{version}
bccc9f86
AM
58
59%build
d5d82930
JB
60install -d obj
61cd obj
bccc9f86 62# not autoconf configure
d5d82930 63CFLAGS="%{rpmcflags} %{rpmcppflags}" \
bccc9f86 64../configure \
7b991969 65%if %{with asm}
dcde509e 66 --as=yasm \
bccc9f86
AM
67%ifarch %{x8664}
68 --target=x86_64-linux-gcc \
69%endif
70%ifarch %{ix86}
71 --target=x86-linux-gcc \
7b991969
AM
72%endif
73%else
74 --target=generic-gnu \
bccc9f86 75%endif
6c7c0f8b 76 --enable-shared \
0257ab6e 77 --disable-optimizations \
bccc9f86
AM
78 --enable-vp8 \
79 --enable-postproc \
80 --enable-runtime-cpu-detect
0257ab6e 81
0257ab6e 82%{__make} verbose=true target=libs \
938aec6f 83 HAVE_GNU_STRIP=no \
6c7c0f8b
JP
84 CC="%{__cc}" \
85 LDFLAGS="%{rpmldflags}"
0257ab6e
AM
86
87%{__make} verbose=true target=examples \
6c7c0f8b 88 CC="%{__cc}" \
dcde509e 89 LDFLAGS="%{rpmldflags} -L."
0257ab6e
AM
90%{__make} verbose=true target=docs
91
bccc9f86
AM
92%install
93rm -rf $RPM_BUILD_ROOT
464fefd2 94install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
0257ab6e 95
6c7c0f8b 96%{__make} -C obj verbose=true install \
938aec6f
ER
97 LIBSUBDIR=%{_lib} \
98 DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
0257ab6e 99
1c3357c1 100%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.1.0
9026bd8c
JB
101
102# adjust prefix and libdir
103sed -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
bccc9f86
AM
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post -p /sbin/ldconfig
109%postun -p /sbin/ldconfig
110
111%files
112%defattr(644,root,root,755)
d5d82930 113%doc AUTHORS CHANGELOG LICENSE PATENTS README
1c3357c1 114%attr(755,root,root) %{_bindir}/vp8_scalable_patterns
d5d82930
JB
115%attr(755,root,root) %{_bindir}/vpxdec
116%attr(755,root,root) %{_bindir}/vpxenc
47f853c3 117%attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
1c3357c1 118%attr(755,root,root) %ghost %{_libdir}/libvpx.so.1
bccc9f86
AM
119
120%files devel
121%defattr(644,root,root,755)
1c3357c1 122%doc vp8_api1_migration.txt
47f853c3 123%attr(755,root,root) %{_libdir}/libvpx.so
464fefd2 124%{_includedir}/vpx
9026bd8c 125%{_pkgconfigdir}/vpx.pc
bccc9f86
AM
126
127%files static
128%defattr(644,root,root,755)
0257ab6e 129%{_libdir}/libvpx.a
This page took 0.091449 seconds and 4 git commands to generate.