]> git.pld-linux.org Git - packages/libvpx.git/blob - libvpx.spec
- updated to 1.2.0
[packages/libvpx.git] / libvpx.spec
1 #
2 # Conditional build:
3 %bcond_without  asm     # x86 assembler
4
5 Summary:        VP8, a high-quality video codec
6 Summary(pl.UTF-8):      VP8 - kodek obrazu wysokiej jakości
7 Name:           libvpx
8 Version:        1.2.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 # Source0Download: http://code.google.com/p/webm/downloads/list
13 Source0:        https://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
14 # Source0-md5:  f8de058e6ba14555144583a2d031fe19
15 URL:            http://www.webmproject.org/
16 BuildRequires:  /usr/bin/php
17 BuildRequires:  doxygen
18 BuildRequires:  php-common >= 4:5.0.0
19 BuildRequires:  php-pcre
20 BuildRequires:  sed >= 4.0
21 %ifarch %{ix86} %{x8664}
22 %{?with_asm:BuildRequires:      yasm >= 0.8}
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define generic_target  generic-gnu
27 %define vpxtarget       %{generic_target}
28 %ifarch %{x8664}
29 %define vpxtarget       x86_64-linux-gcc
30 %endif
31 %ifarch %{ix86}
32 %define vpxtarget       x86-linux-gcc
33 %endif
34 %ifarch ppc
35 %define vpxtarget       ppc32-linux-gcc
36 %endif
37 %ifarch ppc64
38 %define vpxtarget       ppc64-linux-gcc
39 %endif
40
41 %description
42 VP8, a high-quality video codec.
43
44 %description -l pl.UTF-8
45 VP8 - kodek obrazu wysokiej jakości.
46
47 %package devel
48 Summary:        Header files for libvpx
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libvpx
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52
53 %description devel
54 Header files for libvpx library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki libvpx.
58
59 %package static
60 Summary:        Static libvpx library
61 Summary(pl.UTF-8):      Statyczna biblioteka libvpx
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static libvpx library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka libvpx.
70
71 %prep
72 %setup -q -n %{name}-v%{version}
73
74 %build
75 install -d obj
76 cd obj
77 # not autoconf configure
78 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
79 ../configure \
80 %if %{with asm}
81         --as=yasm \
82 %endif
83         --target=%{vpxtarget} \
84 %if "%{vpxtarget}" != "%{generic_target}"
85         --enable-shared \
86 %endif
87         --disable-optimizations \
88         --enable-vp8 \
89         --enable-postproc \
90         --enable-runtime-cpu-detect
91
92 %{__make} verbose=true target=libs \
93         HAVE_GNU_STRIP=no \
94         CC="%{__cc}" \
95         LD="%{__cc}" \
96         LDFLAGS="%{rpmldflags}"
97
98 %{__make} verbose=true target=examples \
99         CC="%{__cc}" \
100         LD="%{__cc}" \
101         LDFLAGS="%{rpmldflags} -L."
102 %{__make} verbose=true target=docs
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
107
108 %{__make} -C obj verbose=true install \
109         LIBSUBDIR=%{_lib} \
110         DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
111
112 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.1.2
113
114 # adjust prefix and libdir
115 %{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS CHANGELOG LICENSE PATENTS README
126 %attr(755,root,root) %{_bindir}/vp8_scalable_patterns
127 %attr(755,root,root) %{_bindir}/vpxdec
128 %attr(755,root,root) %{_bindir}/vpxenc
129 %attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libvpx.so.1
131
132 %files devel
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/libvpx.so
135 %{_includedir}/vpx
136 %{_pkgconfigdir}/vpx.pc
137
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/libvpx.a
This page took 0.04269 seconds and 4 git commands to generate.