]> git.pld-linux.org Git - packages/libvpx.git/blob - libvpx.spec
- updated to 1.3.0 (from git tag, not available on webm downloads)
[packages/libvpx.git] / libvpx.spec
1 #
2 # Conditional build:
3 %bcond_without  asm     # x86 assembler
4
5 Summary:        VP8, a high-quality video codec
6 Summary(pl.UTF-8):      VP8 - kodek obrazu wysokiej jakości
7 Name:           libvpx
8 Version:        1.3.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: http://code.google.com/p/webm/downloads/list
13 #Source0:       https://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
14 Source0:        https://chromium.googlesource.com/webm/libvpx/+archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
15 # Source0-md5:  dcf436a5dc8b56bdfb4aec63b2fe6729
16 URL:            http://www.webmproject.org/
17 BuildRequires:  /usr/bin/php
18 BuildRequires:  doxygen
19 BuildRequires:  php-common >= 4:5.0.0
20 BuildRequires:  php-pcre
21 BuildRequires:  sed >= 4.0
22 %ifarch %{ix86} %{x8664}
23 %{?with_asm:BuildRequires:      yasm >= 0.8}
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define generic_target  generic-gnu
28 %define vpxtarget       %{generic_target}
29 %ifarch %{x8664}
30 %define vpxtarget       x86_64-linux-gcc
31 %endif
32 %ifarch %{ix86}
33 %define vpxtarget       x86-linux-gcc
34 %endif
35 %ifarch ppc
36 %define vpxtarget       ppc32-linux-gcc
37 %endif
38 %ifarch ppc64
39 %define vpxtarget       ppc64-linux-gcc
40 %endif
41
42 %description
43 VP8, a high-quality video codec.
44
45 %description -l pl.UTF-8
46 VP8 - kodek obrazu wysokiej jakości.
47
48 %package devel
49 Summary:        Header files for libvpx
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libvpx
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description devel
55 Header files for libvpx library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki libvpx.
59
60 %package static
61 Summary:        Static libvpx library
62 Summary(pl.UTF-8):      Statyczna biblioteka libvpx
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static libvpx library.
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka libvpx.
71
72 %prep
73 #%setup -q -n %{name}-v%{version}
74 %setup -q -c
75
76 %build
77 install -d obj
78 cd obj
79 # not autoconf configure
80 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
81 ../configure \
82 %if %{with asm}
83         --as=yasm \
84 %endif
85         --target=%{vpxtarget} \
86 %if "%{vpxtarget}" != "%{generic_target}"
87         --enable-shared \
88 %endif
89         --disable-optimizations \
90         --enable-vp8 \
91         --enable-postproc \
92         --enable-runtime-cpu-detect
93
94 %{__make} verbose=true target=libs \
95         HAVE_GNU_STRIP=no \
96         CC="%{__cc}" \
97         LD="%{__cc}" \
98         LDFLAGS="%{rpmldflags}"
99
100 %{__make} verbose=true target=examples \
101         CC="%{__cc}" \
102         LD="%{__cc}" \
103         LDFLAGS="%{rpmldflags} -L."
104 %{__make} verbose=true target=docs
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
109
110 %{__make} -C obj verbose=true install \
111         LIBSUBDIR=%{_lib} \
112         DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
113
114 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.1.3
115
116 # adjust prefix and libdir
117 %{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc AUTHORS CHANGELOG LICENSE PATENTS README
128 %attr(755,root,root) %{_bindir}/vp8_scalable_patterns
129 %attr(755,root,root) %{_bindir}/vp9_spatial_scalable_encoder
130 %attr(755,root,root) %{_bindir}/vpxdec
131 %attr(755,root,root) %{_bindir}/vpxenc
132 %attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libvpx.so.1
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libvpx.so
138 %{_includedir}/vpx
139 %{_pkgconfigdir}/vpx.pc
140
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/libvpx.a
This page took 0.087433 seconds and 4 git commands to generate.