]> git.pld-linux.org Git - packages/python3.git/blame - python3.spec
- BR: tar > 1.22 (xz support)
[packages/python3.git] / python3.spec
CommitLineData
19221b23
AG
1#
2# TODO:
3# - fix tests
4# - check unpackaged files
9416f74d
AM
5
6# Conditional build:
7%bcond_with info # info pages (requires emacs)
8%bcond_without tkinter # disables tkinter module building
9%bcond_without tests # disables Python testing
10%bcond_with verbose_tests # runs tests in verbose mode
9416f74d
AM
11#
12# tests which will not work on 64-bit platforms
13%define no64bit_tests test_audioop test_rgbimg test_imageop
14# tests which may fail because of builder environment limitations (no /proc or /dev/pts)
15%define nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
16# tests which fail because of some unknown/unresolved reason (this list should be empty)
be43ead0 17%define broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib test_zlib
9416f74d 18
a0694bb8 19%define py_ver 3.2
c7fdbe10 20%define py_abi %{py_ver}mu
9416f74d
AM
21%define py_prefix %{_prefix}
22%define py_libdir %{py_prefix}/%{_lib}/python%{py_ver}
c7fdbe10 23%define py_incdir %{_includedir}/python%{py_abi}
9416f74d
AM
24%define py_sitedir %{py_libdir}/site-packages
25%define py_dyndir %{py_libdir}/lib-dynload
26
27Summary: Very high level scripting language with X interface
28Summary(es.UTF-8): Lenguaje script de alto nivel con interfaz X
29Summary(fr.UTF-8): Langage de script de très haut niveau avec interface X
30Summary(pl.UTF-8): Python - język obiektowy wysokiego poziomu
31Summary(pt_BR.UTF-8): Linguagem de programação interpretada de alto nível
32Summary(ru.UTF-8): Язык программирования очень высокого уровня с X-интерфейсом
33Summary(tr.UTF-8): X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
34Summary(uk.UTF-8): Мова програмування дуже високого рівня з X-інтерфейсом
2072c60e 35Name: python3
a0694bb8 36Version: %{py_ver}
51865898 37Release: 1
9416f74d
AM
38Epoch: 1
39License: PSF
40Group: Applications
0cf503a8 41Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
efe92a87 42# Source0-md5: 563c0b4b8c8596e332cc076c4f013971
a20e3138
AG
43Patch0: %{name}-pythonpath.patch
44Patch1: %{name}-ac_fixes.patch
45Patch2: %{name}-lib64.patch
46Patch3: %{name}-noarch_to_datadir.patch
7dd2ca46 47Patch4: %{name}-bug11254.patch
9416f74d 48URL: http://www.python.org/
7daf2f83 49BuildRequires: autoconf >= 2.65
9416f74d
AM
50BuildRequires: bluez-libs-devel
51BuildRequires: bzip2-devel
52BuildRequires: db-devel >= 4
53%{?with_info:BuildRequires: emacs >= 21}
54BuildRequires: expat-devel >= 1:1.95.7
55BuildRequires: file
56BuildRequires: gdbm-devel >= 1.8.3
57BuildRequires: gmp-devel >= 4.0
3ba70ac2 58BuildRequires: libffi-devel
9416f74d
AM
59BuildRequires: libstdc++-devel
60BuildRequires: ncurses-ext-devel >= 5.2
9416f74d 61BuildRequires: openssl-devel >= 0.9.8
9416f74d
AM
62BuildRequires: readline-devel >= 5.0
63BuildRequires: rpm-pythonprov
64BuildRequires: sed >= 4.0
65BuildRequires: sqlite3-devel >= 3.3.5
7daf2f83 66BuildRequires: tar >= 1.22
9416f74d
AM
67%{?with_info:BuildRequires: tetex-makeindex}
68%{?with_tkinter:BuildRequires: tix-devel >= 1:8.1.4-4}
69%{?with_tkinter:BuildRequires: tk-devel >= 8.4.3}
70BuildRequires: zlib-devel
71Requires: %{name}-libs = %{epoch}:%{version}-%{release}
9416f74d 72BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34dfde61 73
8d0b0882 74%define specflags_ppc -D__ppc__=1
34dfde61 75%define specflags_ppc64 -D__ppc64__=1
9416f74d
AM
76
77%if %{with verbose_tests}
78%define test_flags -v -l -x
79%else
f488a705 80%define test_flags -w -l -x
9416f74d
AM
81%endif
82
83%ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
84%define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
85%else
86%define test_list %{nobuilder_tests} %{broken_tests}
87%endif
88
89%ifarch sparc
90%define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
91%endif
92
93%description
94Python is an interpreted, interactive, object-oriented programming
95language. It incorporates modules, exceptions, dynamic typing, very
96high level dynamic data types, and classes. Python combines remarkable
97power with very clear syntax. It has interfaces to many system calls
98and libraries, as well as to various window systems, and is extensible
99in C or C++. It is also usable as an extension language for
100applications that need a programmable interface. Finally, Python is
101portable: it runs on many brands of UNIX, on the Mac, and on PCs under
102MS-DOS, Windows, Windows NT, and OS/2.
103
104This package contains the Python binary.
105
106%description -l de.UTF-8
107Python ist eine interpretierte, interaktive, objektorientierte
108Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
109Python enthält Module, Klassen, Exceptions, High-Level dynamische
110Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
111zu vielen Systemaufrufen und Libraries, sowie verschiedene
112Fenstersysteme (X11, Motif, Tk, Mac und MFC)
113
114Programmierer können neue built-in-Module für Python in C oder C++
115schreiben. Python kann auch als Erweiterungssprache für Applikationen
116benutzt werden, die ein programmierbares Interface brauchen. Dieses
117Paket enthält die meisten Standard-Python-Module, und Module zum
118Ansprechen von Tix (Tk-widget set) und RPM.
119
120%description -l es.UTF-8
121Python es un lenguaje de scripts interpretado orientado a objetos.
122Contiene soporte para carga dinámica de objetos, clases, módulos y
123excepciones.
124
125Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
126través de código C, tornando Python fácil de usar en ambientes
127particulares/personalizados. Este paquete Python incluye la mayoría de
128los módulos padrón Python, junto con módulos para crear interfaces
129para el conjunto de componentes Tix para Tk y RPM.
130
131%description -l fr.UTF-8
132Python est un langage de script interprété et orienté objet. Il gère
133le chargement dynamique des objets, les classes, les modules et les
134exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
135avec du code C est simple, ce qui rend Python facile à utiliser dans
136des configs personnalisées.
137
138Ce paquetage Python contient la plupart des modules Python standards,
139ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
140et RPM.
141
142%description -l pl.UTF-8
143Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
144językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
145typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
146sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
147wielu wywołań systemowych i bibliotek, w tym również do różnych
148bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
149poprzez odpowiednie moduły pisane w C lub C++. Python może być również
150użyty jako element aplikacji, którym potrzebny jest interpreter do
151skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
152odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
153OS/2.
154
155Ten pakiet zawiera binarkę Pythona.
156
157%description -l pt_BR.UTF-8
158Python é uma linguagem de scripts interpretada orientada a objetos.
159Contém suporte para carga dinâmica de objetos, classes, módulos e
160exceções. Adicionar interfaces para novos sistemas de biblioteca
161através de código C é simples, tornando Python fácil de usar em
162ambientes particulares/personalizados.
163
164Este pacote Python inclui a maioria do módulos padrão Python, junto
165com módulos para interfaceamento para o conjunto de componentes Tix
166para Tk e RPM.
167
168%description -l ru.UTF-8
169Python - это интерпретируемый, объектно-ориентированный язык
170программирования. Он поддерживает динамическую загрузку объектов,
171классы, модули и обработку исключительных ситуаций (exceptions).
172Простота добавления интерфейсов к новым системным библиотекам через
173код на языке C делает Python хорошим выбором для использования в
174специальных конфигурациях.
175
176%description -l tr.UTF-8
177Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
178sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
179destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
180paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
181arayüz birimlerini de içerir.
182
183%description -l uk.UTF-8
184Python - це інтерпретована, об'єктно-орієнтована мова програмування.
185Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
186виключних ситуацій (exceptions). Простота додавання інтерфейсів для
187нових системних бібліотек через код на мові C робить Python добрим
188вибором для використання в спеціальних конфігураціях.
189
190%package libs
191Summary: Python library
192Summary(pl.UTF-8): Biblioteka języka Python
193Group: Libraries/Python
194# broken detection in rpm/pythondeps.sh
195Provides: python(abi) = %{py_ver}
196# for compatibility with existing Ac packages
197Provides: python(bytecode) = %{py_ver}
2072c60e 198%{!?with_info:Obsoletes: python3-doc-info}
9416f74d
AM
199
200%description libs
201Python shared library and very essental modules for Python binary.
202
203%description libs -l pl.UTF-8
204Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
205dla Pythona.
206
207%package modules
208Summary: Python modules
209Summary(pl.UTF-8): Moduły języka Python
210Group: Libraries/Python
211Requires: %{name}-libs = %{epoch}:%{version}-%{release}
fef40d51 212Obsoletes: python3-modules-sqlite
9416f74d
AM
213
214%description modules
215Python officially distributed modules.
216
217%description modules -l pl.UTF-8
218Oficjalnie rozprowadzane moduły języka Python.
219
2072c60e 220%package -n pydoc3
9416f74d
AM
221Summary: Python interactive module documentation access support
222Summary(pl.UTF-8): Interaktywne korzystanie z dokumentacji modułów języka Python
223Group: Applications
224Requires: %{name}-modules = %{epoch}:%{version}-%{release}
225
2072c60e 226%description -n pydoc3
9416f74d
AM
227Python interactive module documentation access support.
228
2072c60e 229%description -n pydoc3 -l pl.UTF-8
9416f74d
AM
230Interaktywne korzystanie z dokumentacji modułów języka Python.
231
2072c60e 232%package -n idle3
9416f74d
AM
233Summary: IDE for Python language
234Summary(pl.UTF-8): IDE dla języka Python
235Group: Applications
236Requires: %{name}-tkinter = %{epoch}:%{version}-%{release}
237
2072c60e 238%description -n idle3
9416f74d
AM
239IDE for Python language.
240
2072c60e 241%description -n idle3 -l pl.UTF-8
9416f74d
AM
242IDE dla języka Python.
243
244%package devel
245Summary: Libraries and header files for building python code
246Summary(de.UTF-8): Libraries und Header-Dateien zum Erstellen von Python-Code
247Summary(es.UTF-8): Bibliotecas y archivos de inclusión para construir programas en python
248Summary(fr.UTF-8): Bibliothèques et en-têtes pour construire du code python
249Summary(pl.UTF-8): Pliki nagłówkowe i biblioteki Pythona
250Summary(pt_BR.UTF-8): Bibliotecas e arquivos de inclusão para o Python
251Summary(ru.UTF-8): Библиотеки и хедеры для построения кода на языке Python
252Summary(tr.UTF-8): Python ile geliştirme yapmak için gerekli dosyalar
253Summary(uk.UTF-8): Бібліотеки та хедери для програмування на мові Python
254Group: Development/Languages/Python
255Requires: %{name}-libs = %{epoch}:%{version}-%{release}
256
257%description devel
258The Python interpreter is relatively easy to extend with dynamically
259loaded extensions and to embed in other programs. This package
260contains the header files and libraries which are needed to do both of
261these tasks.
262
263%description devel -l de.UTF-8
264Der Python-Interpretierer ist relativ einfach anhand von dynamisch
265ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
266integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
267die für beide Aufgaben erforderlich sind.
268
269%description devel -l es.UTF-8
270El interpretador Python permite incluir con facilidad extensiones
271cargadas dinámicamente. Python es también fácil de ser empotrado en
272otros programas. Este paquete contiene los archivos de inclusión y
273bibliotecas necesarios para estas dos tareas.
274
275%description devel -l fr.UTF-8
276L'interpréteur Python est relativement facile à étendre avec des
277extensions chargées dynamiquement et à insérer dans d'autres
278programmes. Ce paquetage contient les en-têtes et les bibliothèques
279nécessaires à ces deux tâches.
280
281%description devel -l pl.UTF-8
282Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
283dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
284osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
285wszystko inne co potrzebne do tych celów.
286
287%description devel -l pt_BR.UTF-8
288O interpretador Python permite incluir com facilidade extensões
289carregadas dinamicamente. Python é também fácil de ser embutido em
290outros programas. Este pacote contém os arquivos de inclusão e
291bibliotecas necessários para estas duas tarefas.
292
293%description devel -l ru.UTF-8
294Интерпретатор Python относительно легко расширяется при помощи
295динамически загружаемых расширений и встраивается в другие программы.
296Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
297задач.
298
299%description devel -l tr.UTF-8
300Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
301dosyalarını ve kitaplıkları içerir.
302
303%description devel -l uk.UTF-8
304Інтерпретатор Python відносно легко розширюється за допомогою
305розширень з динамічною загрузкою та вбудовується в інші програми. Цей
306пакет містить хедери та бібліотеки, необхідні для обох цих задач.
307
308%package devel-src
309Summary: Python module sources
310Summary(pl.UTF-8): Pliki źródłowe modułów Pythona
311Group: Development/Languages/Python
312Requires: %{name}-modules = %{epoch}:%{version}-%{release}
313
314%description devel-src
315Python module sources.
316
317%description devel-src -l pl.UTF-8
318Pliki źródłowe modułów Pythona.
319
320%package devel-tools
321Summary: Python development tools
322Summary(pl.UTF-8): Narzędzia programistyczne języka Python
323Group: Development/Languages/Python
324Requires: %{name}-modules = %{epoch}:%{version}-%{release}
325
326%description devel-tools
327Python development tools such as profilers and debugger.
328
329%description devel-tools -l pl.UTF-8
330Narzędzia programistyczne języka Python takie jak profiler oraz
331debugger.
332
30b0ff7b
AF
333%package 2to3
334Summary: Automated Python 2 to 3 code translation
0cf503a8 335Summary(pl.UTF-8): Automatyczne tłumaczenie kodu Pythona 2 do 3
30b0ff7b
AF
336Group: Development/Languages/Pythona
337
338%description 2to3
0cf503a8
JB
3392to3 is a Python program that reads Python 2.x source code and applies
340a series of fixers to transform it into valid Python 3.x code. The
341standard library contains a rich set of fixers that will handle almost
342all code. 2to3 supporting library lib2to3 is, however, a flexible and
343generic library, so it is possible to write your own fixers for 2to3.
344lib2to3 could also be adapted to custom applications in which Python
345code needs to be edited automatically.
346
347%description 2to3 -l pl.UTF-8
3482to3 to program w Pythonie czytający od źródłowy w Pythonie 2.x i
349aplikujący serię poprawek przekształcających go w poprawny kod w
350Pythonie 3.x. Biblioteka standardowa zawiera duży zbiór poprawek
351obsługujących większość kodu. Biblioteka wspierająca 2to3 (lib2to3)
352jest jednak elastyczną i ogólną biblioteką, więc można pisać własne
353poprawki dla 2to3. lib2to3 można także zaadaptować na potrzeby
354własnych zastosowań, w których kod w Pythonie musi być modyfikowany
355automatycznie.
30b0ff7b 356
9416f74d
AM
357%package static
358Summary: Static python library
359Summary(pl.UTF-8): Statyczna biblioteka Pythona
360Group: Development/Languages/Python
361Requires: %{name}-devel = %{epoch}:%{version}-%{release}
362
363%description static
364Static python library.
365
366%description static -l pl.UTF-8
367Statyczna biblioteka Pythona.
368
9416f74d
AM
369%package doc-info
370Summary: Documentation on Python in texinfo format
371Summary(pl.UTF-8): Dokumentacja do Pythona w formacie texinfo
372Group: Documentation
373
374%description doc-info
375Documentation on Python in texinfo format.
376
377%description doc-info -l pl.UTF-8
378Dokumentacja do Pythona w formacie texinfo.
379
380%package tkinter
381Summary: Standard Python interface to the Tk GUI toolkit
382Summary(de.UTF-8): Grafische Tk-Schnittstelle für Python
383Summary(es.UTF-8): Interfaz de GUI Tk para Python
384Summary(fr.UTF-8): Interface graphique Tk pour Python
385Summary(pl.UTF-8): Standardowy interfejs Pythona do biblioteki Tk
386Summary(pt_BR.UTF-8): Interface GUI Tk para Phyton
387Summary(tr.UTF-8): Python için grafik kullanıcı arayüzü
388Group: Libraries/Python
389Requires: %{name}-modules = %{epoch}:%{version}-%{release}
390Requires: tcl >= 8.4.3
391Requires: tix >= 1:8.1.4-4
392Requires: tk >= 8.4.3
393
394%description tkinter
395Standard Python interface to the Tk GUI toolkit.
396
397%description tkinter -l de.UTF-8
398Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
399vielen Konfigurations-Tools genutzt.
400
401%description tkinter -l es.UTF-8
402Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
403herramientas de configuración.
404
405%description tkinter -l fr.UTF-8
406Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
407beaucoup des outils de configuration.
408
409%description tkinter -l pl.UTF-8
410Standardowy interfejs Pythona do biblioteki Tk.
411
412%description tkinter -l pt_BR.UTF-8
413Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
414muitas ferramentas de configuração.
415
416%description tkinter -l ru.UTF-8
417Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
418
419%description tkinter -l tr.UTF-8
420Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
421kullanılan grafik bir arayüzdür.
422
423%description tkinter -l uk.UTF-8
424Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
425
426%package examples
427Summary: Example programs in Python
428Summary(pl.UTF-8): Przykładowe programy w Pythonie
429Group: Development/Languages/Python
430
431%description examples
432Example programs in Python.
433
434These are for Python 2.3.4, not %{version}.
435
436%description examples -l pl.UTF-8
437Przykładowe programy w Pythonie.
438
439Przykłady te są dla Pythona 2.3.4, nie %{version}.
440
441%prep
0cf503a8 442%setup -q -n Python-%{version}
a20e3138 443%patch0 -p1
30b0ff7b 444%patch1 -p1
e3852288
JB
445%patch2 -p1
446%patch3 -p1
7dd2ca46 447%patch4 -p1
9416f74d
AM
448
449%build
9416f74d 450%{__autoconf}
31552fa6 451CPPFLAGS="-I/usr/include/ncursesw %{rpmcppflags}"; export CPPFLAGS
9416f74d 452%configure \
3ba70ac2 453 --with-cxx-main="%{__cxx}" \
9416f74d
AM
454 --enable-shared \
455 --enable-ipv6 \
19221b23 456 --with-dbmliborder=gdbm:bdb \
3ba70ac2 457 --with-wide-unicode \
9416f74d
AM
458 --with-signal-module \
459 --with-tsc \
460 --with-threads \
461 --with-doc-strings \
9416f74d 462 --with-fpectl \
3ba70ac2 463 --with-system-ffi \
23f5417d 464 --with-computed-gotos \
9416f74d
AM
465 LINKCC='$(PURIFY) $(CXX)' \
466 LDSHARED='$(CC) $(CFLAGS) -shared' \
467 BLDSHARED='$(CC) $(CFLAGS) -shared' \
468 LDFLAGS="%{rpmcflags} %{rpmldflags}"
469
470%{__make} \
23f5417d 471 OPT="%{rpmcflags} -fno-caller-saves" 2>&1 | awk '
9416f74d
AM
472BEGIN { fail = 0; logmsg = ""; }
473{
474 if ($0 ~ /\*\*\* WARNING:/) {
475 fail = 1;
476 logmsg = logmsg $0;
477 }
478 print $0;
479}
480END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
481
482LC_ALL=C
483export LC_ALL
484%if %{with tests}
485binlibdir=`echo build/lib.*`
486%{__make} test \
487 TESTOPTS="%{test_flags} %{test_list}" \
3ba70ac2 488 TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
9416f74d
AM
489%endif
490
491%install
492rm -rf $RPM_BUILD_ROOT
493install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
494 $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
495 $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
496 $RPM_BUILD_ROOT%{_infodir} \
497 $RPM_BUILD_ROOT/etc/shrc.d
498
499%{__make} install \
500 DESTDIR=$RPM_BUILD_ROOT
501
502%if %{with info}
503%{__make} -C Doc/info
504install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
505%endif
506
9416f74d 507install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
4449431f 508cp -a Tools $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
9416f74d
AM
509
510#
511# create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
512#
513
514# for python devel tools
515for script in timeit profile pdb pstats; do
24586eb0
AM
516 echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
517done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
9416f74d 518
24586eb0
AM
519echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
520 >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
9416f74d
AM
521
522sed 's/=/ /' \
24586eb0
AM
523 < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
524 > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
9416f74d
AM
525
526# for python modules
527for script in smtpd webbrowser; do
24586eb0
AM
528 echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
529done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
9416f74d
AM
530
531sed 's/=/ /' \
24586eb0
AM
532 < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
533 > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
9416f74d
AM
534
535# xgettext specific for Python code
536#
537# we will have two commands: pygettext.py (an alias) and pygettext;
538# this way there are no import (which is impossible now) conflicts and
539# pygettext.py is provided for compatibility
24586eb0
AM
540install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
541
9416f74d
AM
542# just to cut the noise, as they are not packaged (now)
543# first tests
e3852288
JB
544%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/test
545%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
546%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
547%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/email/test
548%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/importlib/test
549%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
550%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
551%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/tkinter/test
dceb7408 552%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/unittest/test
9416f74d
AM
553
554# other files
e3852288
JB
555%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
556%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
557%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
558%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
559%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
560%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
acd14a9e 561# already in %%doc
e3852288 562%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
9416f74d
AM
563
564%clean
565rm -rf $RPM_BUILD_ROOT
566
567%post libs -p /sbin/ldconfig
568%postun libs -p /sbin/ldconfig
569
e3852288 570%post doc-info -p /sbin/postshell
a20bb9dc 571-/usr/sbin/fix-info-dir -c %{_infodir}
9416f74d 572
e3852288 573%postun doc-info -p /sbin/postshell
a20bb9dc 574-/usr/sbin/fix-info-dir -c %{_infodir}
9416f74d
AM
575
576%files
577%defattr(644,root,root,755)
24586eb0 578%attr(755,root,root) %{_bindir}/python%{py_ver}
c7fdbe10 579%attr(755,root,root) %{_bindir}/python%{py_abi}
306c0f2d 580%attr(755,root,root) %{_bindir}/python3
c7fdbe10
JB
581%{_mandir}/man1/python%{py_ver}.1*
582
583%files libs
584%defattr(644,root,root,755)
585%doc LICENSE
586%attr(755,root,root) %{_libdir}/libpython%{py_abi}.so.*.*
587
588%dir %{py_libdir}
589%dir %{py_dyndir}
590%dir %{py_sitedir}
591%dir %{py_scriptdir}
592%dir %{py_sitescriptdir}
dceb7408 593%{py_scriptdir}/__pycache__
c7fdbe10
JB
594
595# shared modules required by python library
596%attr(755,root,root) %{py_dyndir}/_struct.cpython-*.so
597
598# modules required by python library
dceb7408 599%{py_scriptdir}/_abcoll.py
600%{py_scriptdir}/_weakrefset.py
601%{py_scriptdir}/abc.py
602%{py_scriptdir}/codecs.py
603%{py_scriptdir}/copyreg.py
604%{py_scriptdir}/genericpath.py
605%{py_scriptdir}/locale.py
606%{py_scriptdir}/io.py
607%{py_scriptdir}/posixpath.py
608%{py_scriptdir}/site.py
609%{py_scriptdir}/stat.py
610%{py_scriptdir}/os.py
c7fdbe10 611# needed by the dynamic sys.lib patch
dceb7408 612%{py_scriptdir}/types.py
c7fdbe10
JB
613
614# encodings required by python library
615%dir %{py_scriptdir}/encodings
dceb7408 616%{py_scriptdir}/encodings/__pycache__
617%{py_scriptdir}/encodings/*.py
9416f74d
AM
618
619%files modules
620%defattr(644,root,root,755)
24586eb0 621/etc/shrc.d/python*-modules*
dceb7408 622%exclude %{py_scriptdir}/_abcoll.py
623%exclude %{py_scriptdir}/_weakrefset.py
624%exclude %{py_scriptdir}/abc.py
625%exclude %{py_scriptdir}/codecs.py
626%exclude %{py_scriptdir}/copyreg.py
627%exclude %{py_scriptdir}/genericpath.py
628%exclude %{py_scriptdir}/io.py
629%exclude %{py_scriptdir}/locale.py
630%exclude %{py_scriptdir}/posixpath.py
631%exclude %{py_scriptdir}/pdb.py
632%exclude %{py_scriptdir}/profile.py
633%exclude %{py_scriptdir}/pstats.py
634%exclude %{py_scriptdir}/pydoc.py
635%exclude %{py_scriptdir}/site.py
636%exclude %{py_scriptdir}/stat.py
637%exclude %{py_scriptdir}/timeit.py
638%exclude %{py_scriptdir}/os.py
639%exclude %{py_scriptdir}/encodings/*.py
640%exclude %{py_scriptdir}/types.py
641
642%{py_scriptdir}/*.py
9416f74d 643
c7fdbe10 644%{py_dyndir}/Python-%{py_ver}-py*.egg-info
9416f74d
AM
645
646#
647# list .so modules to be sure that all of them are built
648#
649
929a5a93 650# modules below do not work on 64-bit architectures
9416f74d
AM
651# see Python README file for explanation
652%ifnarch alpha ia64 ppc64 sparc64 %{x8664}
c7fdbe10 653%attr(755,root,root) %{py_dyndir}/audioop.cpython-*.so
9416f74d
AM
654%endif
655
c7fdbe10
JB
656%attr(755,root,root) %{py_dyndir}/_bisect.cpython-*.so
657%attr(755,root,root) %{py_dyndir}/_codecs_cn.cpython-*.so
658%attr(755,root,root) %{py_dyndir}/_codecs_hk.cpython-*.so
659%attr(755,root,root) %{py_dyndir}/_codecs_iso2022.cpython-*.so
660%attr(755,root,root) %{py_dyndir}/_codecs_jp.cpython-*.so
661%attr(755,root,root) %{py_dyndir}/_codecs_kr.cpython-*.so
662%attr(755,root,root) %{py_dyndir}/_codecs_tw.cpython-*.so
663%attr(755,root,root) %{py_dyndir}/_csv.cpython-*.so
664%attr(755,root,root) %{py_dyndir}/_ctypes*.cpython-*.so
665%attr(755,root,root) %{py_dyndir}/_curses_panel.cpython-*.so
666%attr(755,root,root) %{py_dyndir}/_curses.cpython-*.so
667%attr(755,root,root) %{py_dyndir}/_datetime.cpython-*.so
9416f74d 668%ifnarch sparc64
c7fdbe10 669%attr(755,root,root) %{py_dyndir}/_dbm.cpython-*.so
9416f74d 670%endif
c7fdbe10
JB
671%attr(755,root,root) %{py_dyndir}/_elementtree.cpython-*.so
672%attr(755,root,root) %{py_dyndir}/_gdbm.cpython-*.so
673%attr(755,root,root) %{py_dyndir}/_hashlib.cpython-*.so
674%attr(755,root,root) %{py_dyndir}/_heapq.cpython-*.so
675%attr(755,root,root) %{py_dyndir}/_json.cpython-*.so
676%attr(755,root,root) %{py_dyndir}/_lsprof.cpython-*.so
677%attr(755,root,root) %{py_dyndir}/_multibytecodec.cpython-*.so
678%attr(755,root,root) %{py_dyndir}/_multiprocessing.cpython-*.so
679%attr(755,root,root) %{py_dyndir}/_pickle.cpython-*.so
dceb7408 680%attr(755,root,root) %{py_dyndir}/_posixsubprocess.cpython-*.so
c7fdbe10
JB
681%attr(755,root,root) %{py_dyndir}/_random.cpython-*.so
682%attr(755,root,root) %{py_dyndir}/_socket.cpython-*.so
683%attr(755,root,root) %{py_dyndir}/_ssl.cpython-*.so
684%attr(755,root,root) %{py_dyndir}/_testcapi.cpython-*.so
685%attr(755,root,root) %{py_dyndir}/array.cpython-*.so
686%attr(755,root,root) %{py_dyndir}/atexit.cpython-*.so
dceb7408 687%attr(755,root,root) %{py_dyndir}/audioop.cpython-*.so
c7fdbe10
JB
688%attr(755,root,root) %{py_dyndir}/binascii.cpython-*.so
689%attr(755,root,root) %{py_dyndir}/bz2.cpython-*.so
690%attr(755,root,root) %{py_dyndir}/cmath.cpython-*.so
691%attr(755,root,root) %{py_dyndir}/crypt.cpython-*.so
692%attr(755,root,root) %{py_dyndir}/fcntl.cpython-*.so
693%attr(755,root,root) %{py_dyndir}/grp.cpython-*.so
694%attr(755,root,root) %{py_dyndir}/math.cpython-*.so
695%attr(755,root,root) %{py_dyndir}/mmap.cpython-*.so
696%attr(755,root,root) %{py_dyndir}/nis.cpython-*.so
697%attr(755,root,root) %{py_dyndir}/ossaudiodev.cpython-*.so
698%attr(755,root,root) %{py_dyndir}/parser.cpython-*.so
699%attr(755,root,root) %{py_dyndir}/pyexpat.cpython-*.so
700%attr(755,root,root) %{py_dyndir}/readline.cpython-*.so
701%attr(755,root,root) %{py_dyndir}/resource.cpython-*.so
702%attr(755,root,root) %{py_dyndir}/select.cpython-*.so
703%attr(755,root,root) %{py_dyndir}/syslog.cpython-*.so
704%attr(755,root,root) %{py_dyndir}/termios.cpython-*.so
705%attr(755,root,root) %{py_dyndir}/time.cpython-*.so
706%attr(755,root,root) %{py_dyndir}/spwd.cpython-*.so
707%attr(755,root,root) %{py_dyndir}/unicodedata.cpython-*.so
708%attr(755,root,root) %{py_dyndir}/zlib.cpython-*.so
9416f74d
AM
709
710%dir %{py_scriptdir}/plat-*
dceb7408 711%{py_scriptdir}/plat-*/__pycache__
712%{py_scriptdir}/plat-*/*.py
713
714%{py_scriptdir}/concurrent
9416f74d 715
9416f74d
AM
716%dir %{py_scriptdir}/ctypes
717%dir %{py_scriptdir}/ctypes/macholib
dceb7408 718%{py_scriptdir}/ctypes/__pycache__
719%{py_scriptdir}/ctypes/macholib/__pycache__
35ff21ac 720
dceb7408 721%{py_scriptdir}/ctypes/*.py
722%{py_scriptdir}/ctypes/macholib/*.py
acd14a9e 723%doc %{py_scriptdir}/ctypes/macholib/README.ctypes
9416f74d
AM
724
725%dir %{py_scriptdir}/curses
dceb7408 726%{py_scriptdir}/curses/__pycache__
727%{py_scriptdir}/curses/*.py
9416f74d 728
acd14a9e 729%dir %{py_scriptdir}/dbm
dceb7408 730%{py_scriptdir}/dbm/__pycache__
731%{py_scriptdir}/dbm/*.py
acd14a9e 732
9416f74d
AM
733%dir %{py_scriptdir}/distutils
734%dir %{py_scriptdir}/distutils/command
acd14a9e 735%doc %{py_scriptdir}/distutils/README
dceb7408 736%{py_scriptdir}/distutils/__pycache__
737%{py_scriptdir}/distutils/command/__pycache__
738%{py_scriptdir}/distutils/*.py
739%{py_scriptdir}/distutils/command/*.py
acd14a9e 740%{py_scriptdir}/distutils/command/command_template
9416f74d
AM
741
742%dir %{py_scriptdir}/email
743%dir %{py_scriptdir}/email/mime
dceb7408 744%{py_scriptdir}/email/__pycache__
745%{py_scriptdir}/email/mime/__pycache__
746%{py_scriptdir}/email/*.py
747%{py_scriptdir}/email/mime/*.py
9416f74d 748
acd14a9e 749%dir %{py_scriptdir}/html
dceb7408 750%{py_scriptdir}/html/*.py
751%{py_scriptdir}/html/__pycache__
acd14a9e
AF
752
753%dir %{py_scriptdir}/http
dceb7408 754%{py_scriptdir}/http/__pycache__
755%{py_scriptdir}/http/*.py
acd14a9e 756
fef40d51 757%dir %{py_scriptdir}/importlib
dceb7408 758%{py_scriptdir}/importlib/__pycache__
759%{py_scriptdir}/importlib/*.py
fef40d51 760
acd14a9e 761%dir %{py_scriptdir}/json
dceb7408 762%{py_scriptdir}/json/__pycache__
763%{py_scriptdir}/json/*.py
acd14a9e 764
9416f74d 765%dir %{py_scriptdir}/logging
dceb7408 766%{py_scriptdir}/logging/__pycache__
767%{py_scriptdir}/logging/*.py
9416f74d 768
acd14a9e 769%dir %{py_scriptdir}/multiprocessing
dceb7408 770%{py_scriptdir}/multiprocessing/__pycache__
771%{py_scriptdir}/multiprocessing/*.py
acd14a9e 772%dir %{py_scriptdir}/multiprocessing/dummy
dceb7408 773%{py_scriptdir}/multiprocessing/dummy/__pycache__
774%{py_scriptdir}/multiprocessing/dummy/*.py
775
776%{py_scriptdir}/turtledemo
777%{py_scriptdir}/unittest
acd14a9e
AF
778
779%dir %{py_scriptdir}/urllib
dceb7408 780%{py_scriptdir}/urllib/__pycache__
781%{py_scriptdir}/urllib/*.py
acd14a9e 782
9416f74d 783%dir %{py_scriptdir}/wsgiref
dceb7408 784%{py_scriptdir}/wsgiref/__pycache__
785%{py_scriptdir}/wsgiref/*.py
acd14a9e 786%{py_scriptdir}/wsgiref.egg-info
9416f74d
AM
787
788%dir %{py_scriptdir}/xml
789%dir %{py_scriptdir}/xml/dom
790%dir %{py_scriptdir}/xml/etree
791%dir %{py_scriptdir}/xml/parsers
792%dir %{py_scriptdir}/xml/sax
dceb7408 793%{py_scriptdir}/xml/__pycache__
794%{py_scriptdir}/xml/dom/__pycache__
795%{py_scriptdir}/xml/etree/__pycache__
796%{py_scriptdir}/xml/parsers/__pycache__
797%{py_scriptdir}/xml/sax/__pycache__
798%{py_scriptdir}/xml/*.py
799%{py_scriptdir}/xml/dom/*.py
800%{py_scriptdir}/xml/etree/*.py
801%{py_scriptdir}/xml/parsers/*.py
802%{py_scriptdir}/xml/sax/*.py
9416f74d 803
acd14a9e 804%dir %{py_scriptdir}/xmlrpc
dceb7408 805%{py_scriptdir}/xmlrpc/__pycache__
806%{py_scriptdir}/xmlrpc/*.py
acd14a9e 807
c7fdbe10 808%attr(755,root,root) %{py_dyndir}/_sqlite3.cpython-*.so
9416f74d 809%dir %{py_scriptdir}/sqlite3
dceb7408 810%{py_scriptdir}/sqlite3/__pycache__
811%{py_scriptdir}/sqlite3/*.py
9416f74d 812
2072c60e 813%files -n pydoc3
9416f74d 814%defattr(644,root,root,755)
19221b23 815%attr(755,root,root) %{_bindir}/pydoc3
dceb7408 816%attr(755,root,root) %{_bindir}/pydoc3.2
817%{py_scriptdir}/pydoc.py
fef40d51 818%dir %{py_scriptdir}/pydoc_data
dceb7408 819%{py_scriptdir}/pydoc_data/__pycache__
820%{py_scriptdir}/pydoc_data/*.py
821%{py_scriptdir}/pydoc_data/*.css
9416f74d 822
2072c60e 823%files -n idle3
9416f74d 824%defattr(644,root,root,755)
19221b23 825%attr(755,root,root) %{_bindir}/idle3
dceb7408 826%attr(755,root,root) %{_bindir}/idle3.2
9416f74d
AM
827%dir %{py_scriptdir}/idlelib
828%dir %{py_scriptdir}/idlelib/Icons
dceb7408 829%{py_scriptdir}/idlelib/__pycache__
830%{py_scriptdir}/idlelib/*.py
acd14a9e
AF
831%doc %{py_scriptdir}/idlelib/*.txt
832%doc %{py_scriptdir}/idlelib/ChangeLog
9416f74d
AM
833%{py_scriptdir}/idlelib/Icons/*
834%{py_scriptdir}/idlelib/*.def
835
836%files devel
837%defattr(644,root,root,755)
838%doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
c7fdbe10
JB
839%attr(755,root,root) %{_bindir}/python%{py_ver}-config
840%attr(755,root,root) %{_bindir}/python%{py_abi}-config
841%attr(755,root,root) %{_bindir}/python3-config
842%attr(755,root,root) %{_libdir}/libpython%{py_abi}.so
843%attr(755,root,root) %{_libdir}/libpython3.so
9416f74d
AM
844%dir %{py_incdir}
845%{py_incdir}/*.h
c7fdbe10 846%{_pkgconfigdir}/python-%{py_ver}.pc
c7fdbe10
JB
847
848%dir %{py_libdir}/config-%{py_abi}
849%attr(755,root,root) %{py_libdir}/config-%{py_abi}/makesetup
850%attr(755,root,root) %{py_libdir}/config-%{py_abi}/install-sh
851%{py_libdir}/config-%{py_abi}/Makefile
852%{py_libdir}/config-%{py_abi}/Setup
853%{py_libdir}/config-%{py_abi}/Setup.config
854%{py_libdir}/config-%{py_abi}/Setup.local
855%{py_libdir}/config-%{py_abi}/config.c
856%{py_libdir}/config-%{py_abi}/config.c.in
857%{py_libdir}/config-%{py_abi}/python.o
9416f74d 858
9416f74d
AM
859%files devel-tools
860%defattr(644,root,root,755)
24586eb0 861/etc/shrc.d/python*-devel*
9416f74d 862
24586eb0 863%attr(755,root,root) %{_bindir}/pygettext%{py_ver}
9416f74d 864
dceb7408 865%{py_scriptdir}/pdb.py
866%{py_scriptdir}/profile.py
867%{py_scriptdir}/pstats.py
868%{py_scriptdir}/timeit.py
9416f74d 869
30b0ff7b 870%files 2to3
eb7b678c 871%attr(755,root,root) %{_bindir}/2to3-%{py_ver}
30b0ff7b 872%dir %{py_scriptdir}/lib2to3
dceb7408 873%{py_scriptdir}/lib2to3/__pycache__
30b0ff7b
AF
874%{py_scriptdir}/lib2to3/*.txt
875%{py_scriptdir}/lib2to3/*.pickle
dceb7408 876%{py_scriptdir}/lib2to3/*.py
30b0ff7b 877%dir %{py_scriptdir}/lib2to3/fixes
dceb7408 878%{py_scriptdir}/lib2to3/fixes/__pycache__
be43ead0 879%{py_scriptdir}/lib2to3/fixes/*.py
30b0ff7b 880%dir %{py_scriptdir}/lib2to3/pgen2
dceb7408 881%{py_scriptdir}/lib2to3/pgen2/__pycache__
882%{py_scriptdir}/lib2to3/pgen2/*.py
30b0ff7b 883
9416f74d
AM
884%files static
885%defattr(644,root,root,755)
6eede82b 886%{_libdir}/libpython%{py_abi}.a
9416f74d
AM
887
888%files examples
889%defattr(644,root,root,755)
890%{_examplesdir}/%{name}-%{version}
891
9416f74d
AM
892%if %{with info}
893%files doc-info
894%defattr(644,root,root,755)
895%{_infodir}/*.info*
896%endif
897
898%if %{with tkinter}
899%files tkinter
900%defattr(644,root,root,755)
acd14a9e 901%dir %{py_scriptdir}/tkinter
dceb7408 902%{py_scriptdir}/tkinter/__pycache__
903%{py_scriptdir}/tkinter/*.py
c7fdbe10 904%attr(755,root,root) %{py_dyndir}/_tkinter.cpython-*.so
9416f74d 905%endif
This page took 0.201581 seconds and 4 git commands to generate.