]> git.pld-linux.org Git - packages/python3.git/blame - python3.spec
- started to update to version 3.2
[packages/python3.git] / python3.spec
CommitLineData
19221b23
AG
1#
2# TODO:
3# - fix tests
4# - check unpackaged files
9416f74d
AM
5
6# Conditional build:
7%bcond_with info # info pages (requires emacs)
8%bcond_without tkinter # disables tkinter module building
9%bcond_without tests # disables Python testing
10%bcond_with verbose_tests # runs tests in verbose mode
9416f74d
AM
11#
12# tests which will not work on 64-bit platforms
13%define no64bit_tests test_audioop test_rgbimg test_imageop
14# tests which may fail because of builder environment limitations (no /proc or /dev/pts)
15%define nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
16# tests which fail because of some unknown/unresolved reason (this list should be empty)
be43ead0 17%define broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib test_zlib
9416f74d 18
3da62d7c 19%define beta %{nil}
9416f74d 20
a0694bb8 21%define py_ver 3.2
9416f74d
AM
22%define py_prefix %{_prefix}
23%define py_libdir %{py_prefix}/%{_lib}/python%{py_ver}
24%define py_incdir %{_includedir}/python%{py_ver}
25%define py_sitedir %{py_libdir}/site-packages
26%define py_dyndir %{py_libdir}/lib-dynload
27
28Summary: Very high level scripting language with X interface
29Summary(es.UTF-8): Lenguaje script de alto nivel con interfaz X
30Summary(fr.UTF-8): Langage de script de très haut niveau avec interface X
31Summary(pl.UTF-8): Python - język obiektowy wysokiego poziomu
32Summary(pt_BR.UTF-8): Linguagem de programação interpretada de alto nível
33Summary(ru.UTF-8): Язык программирования очень высокого уровня с X-интерфейсом
34Summary(tr.UTF-8): X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
35Summary(uk.UTF-8): Мова програмування дуже високого рівня з X-інтерфейсом
2072c60e 36Name: python3
a0694bb8 37Version: %{py_ver}
38Release: 0.%{beta}.1
9416f74d
AM
39Epoch: 1
40License: PSF
41Group: Applications
3ba70ac2 42Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}%{beta}.tar.bz2
3da62d7c 43# Source0-md5: 92e94b5b6652b96349d6362b8337811d
a20e3138
AG
44Patch0: %{name}-pythonpath.patch
45Patch1: %{name}-ac_fixes.patch
46Patch2: %{name}-lib64.patch
47Patch3: %{name}-noarch_to_datadir.patch
48Patch4: %{name}-cast-fix.patch
9416f74d
AM
49URL: http://www.python.org/
50BuildRequires: autoconf
51BuildRequires: bluez-libs-devel
52BuildRequires: bzip2-devel
53BuildRequires: db-devel >= 4
54%{?with_info:BuildRequires: emacs >= 21}
55BuildRequires: expat-devel >= 1:1.95.7
56BuildRequires: file
57BuildRequires: gdbm-devel >= 1.8.3
58BuildRequires: gmp-devel >= 4.0
3ba70ac2 59BuildRequires: libffi-devel
9416f74d
AM
60BuildRequires: libstdc++-devel
61BuildRequires: ncurses-ext-devel >= 5.2
9416f74d 62BuildRequires: openssl-devel >= 0.9.8
9416f74d
AM
63BuildRequires: readline-devel >= 5.0
64BuildRequires: rpm-pythonprov
65BuildRequires: sed >= 4.0
66BuildRequires: sqlite3-devel >= 3.3.5
67%{?with_info:BuildRequires: tetex-makeindex}
68%{?with_tkinter:BuildRequires: tix-devel >= 1:8.1.4-4}
69%{?with_tkinter:BuildRequires: tk-devel >= 8.4.3}
70BuildRequires: zlib-devel
71Requires: %{name}-libs = %{epoch}:%{version}-%{release}
9416f74d 72BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34dfde61 73
8d0b0882 74%define specflags_ppc -D__ppc__=1
34dfde61 75%define specflags_ppc64 -D__ppc64__=1
9416f74d
AM
76
77%if %{with verbose_tests}
78%define test_flags -v -l -x
79%else
f488a705 80%define test_flags -w -l -x
9416f74d
AM
81%endif
82
83%ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
84%define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
85%else
86%define test_list %{nobuilder_tests} %{broken_tests}
87%endif
88
89%ifarch sparc
90%define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
91%endif
92
93%description
94Python is an interpreted, interactive, object-oriented programming
95language. It incorporates modules, exceptions, dynamic typing, very
96high level dynamic data types, and classes. Python combines remarkable
97power with very clear syntax. It has interfaces to many system calls
98and libraries, as well as to various window systems, and is extensible
99in C or C++. It is also usable as an extension language for
100applications that need a programmable interface. Finally, Python is
101portable: it runs on many brands of UNIX, on the Mac, and on PCs under
102MS-DOS, Windows, Windows NT, and OS/2.
103
104This package contains the Python binary.
105
106%description -l de.UTF-8
107Python ist eine interpretierte, interaktive, objektorientierte
108Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
109Python enthält Module, Klassen, Exceptions, High-Level dynamische
110Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
111zu vielen Systemaufrufen und Libraries, sowie verschiedene
112Fenstersysteme (X11, Motif, Tk, Mac und MFC)
113
114Programmierer können neue built-in-Module für Python in C oder C++
115schreiben. Python kann auch als Erweiterungssprache für Applikationen
116benutzt werden, die ein programmierbares Interface brauchen. Dieses
117Paket enthält die meisten Standard-Python-Module, und Module zum
118Ansprechen von Tix (Tk-widget set) und RPM.
119
120%description -l es.UTF-8
121Python es un lenguaje de scripts interpretado orientado a objetos.
122Contiene soporte para carga dinámica de objetos, clases, módulos y
123excepciones.
124
125Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
126través de código C, tornando Python fácil de usar en ambientes
127particulares/personalizados. Este paquete Python incluye la mayoría de
128los módulos padrón Python, junto con módulos para crear interfaces
129para el conjunto de componentes Tix para Tk y RPM.
130
131%description -l fr.UTF-8
132Python est un langage de script interprété et orienté objet. Il gère
133le chargement dynamique des objets, les classes, les modules et les
134exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
135avec du code C est simple, ce qui rend Python facile à utiliser dans
136des configs personnalisées.
137
138Ce paquetage Python contient la plupart des modules Python standards,
139ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
140et RPM.
141
142%description -l pl.UTF-8
143Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
144językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
145typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
146sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
147wielu wywołań systemowych i bibliotek, w tym również do różnych
148bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
149poprzez odpowiednie moduły pisane w C lub C++. Python może być również
150użyty jako element aplikacji, którym potrzebny jest interpreter do
151skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
152odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
153OS/2.
154
155Ten pakiet zawiera binarkę Pythona.
156
157%description -l pt_BR.UTF-8
158Python é uma linguagem de scripts interpretada orientada a objetos.
159Contém suporte para carga dinâmica de objetos, classes, módulos e
160exceções. Adicionar interfaces para novos sistemas de biblioteca
161através de código C é simples, tornando Python fácil de usar em
162ambientes particulares/personalizados.
163
164Este pacote Python inclui a maioria do módulos padrão Python, junto
165com módulos para interfaceamento para o conjunto de componentes Tix
166para Tk e RPM.
167
168%description -l ru.UTF-8
169Python - это интерпретируемый, объектно-ориентированный язык
170программирования. Он поддерживает динамическую загрузку объектов,
171классы, модули и обработку исключительных ситуаций (exceptions).
172Простота добавления интерфейсов к новым системным библиотекам через
173код на языке C делает Python хорошим выбором для использования в
174специальных конфигурациях.
175
176%description -l tr.UTF-8
177Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
178sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
179destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
180paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
181arayüz birimlerini de içerir.
182
183%description -l uk.UTF-8
184Python - це інтерпретована, об'єктно-орієнтована мова програмування.
185Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
186виключних ситуацій (exceptions). Простота додавання інтерфейсів для
187нових системних бібліотек через код на мові C робить Python добрим
188вибором для використання в спеціальних конфігураціях.
189
190%package libs
191Summary: Python library
192Summary(pl.UTF-8): Biblioteka języka Python
193Group: Libraries/Python
194# broken detection in rpm/pythondeps.sh
195Provides: python(abi) = %{py_ver}
196# for compatibility with existing Ac packages
197Provides: python(bytecode) = %{py_ver}
2072c60e 198%{!?with_info:Obsoletes: python3-doc-info}
9416f74d
AM
199
200%description libs
201Python shared library and very essental modules for Python binary.
202
203%description libs -l pl.UTF-8
204Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
205dla Pythona.
206
207%package modules
208Summary: Python modules
209Summary(pl.UTF-8): Moduły języka Python
210Group: Libraries/Python
211Requires: %{name}-libs = %{epoch}:%{version}-%{release}
fef40d51 212Obsoletes: python3-modules-sqlite
9416f74d
AM
213
214%description modules
215Python officially distributed modules.
216
217%description modules -l pl.UTF-8
218Oficjalnie rozprowadzane moduły języka Python.
219
2072c60e 220%package -n pydoc3
9416f74d
AM
221Summary: Python interactive module documentation access support
222Summary(pl.UTF-8): Interaktywne korzystanie z dokumentacji modułów języka Python
223Group: Applications
224Requires: %{name}-modules = %{epoch}:%{version}-%{release}
225
2072c60e 226%description -n pydoc3
9416f74d
AM
227Python interactive module documentation access support.
228
2072c60e 229%description -n pydoc3 -l pl.UTF-8
9416f74d
AM
230Interaktywne korzystanie z dokumentacji modułów języka Python.
231
2072c60e 232%package -n idle3
9416f74d
AM
233Summary: IDE for Python language
234Summary(pl.UTF-8): IDE dla języka Python
235Group: Applications
236Requires: %{name}-tkinter = %{epoch}:%{version}-%{release}
237
2072c60e 238%description -n idle3
9416f74d
AM
239IDE for Python language.
240
2072c60e 241%description -n idle3 -l pl.UTF-8
9416f74d
AM
242IDE dla języka Python.
243
244%package devel
245Summary: Libraries and header files for building python code
246Summary(de.UTF-8): Libraries und Header-Dateien zum Erstellen von Python-Code
247Summary(es.UTF-8): Bibliotecas y archivos de inclusión para construir programas en python
248Summary(fr.UTF-8): Bibliothèques et en-têtes pour construire du code python
249Summary(pl.UTF-8): Pliki nagłówkowe i biblioteki Pythona
250Summary(pt_BR.UTF-8): Bibliotecas e arquivos de inclusão para o Python
251Summary(ru.UTF-8): Библиотеки и хедеры для построения кода на языке Python
252Summary(tr.UTF-8): Python ile geliştirme yapmak için gerekli dosyalar
253Summary(uk.UTF-8): Бібліотеки та хедери для програмування на мові Python
254Group: Development/Languages/Python
255Requires: %{name}-libs = %{epoch}:%{version}-%{release}
256
257%description devel
258The Python interpreter is relatively easy to extend with dynamically
259loaded extensions and to embed in other programs. This package
260contains the header files and libraries which are needed to do both of
261these tasks.
262
263%description devel -l de.UTF-8
264Der Python-Interpretierer ist relativ einfach anhand von dynamisch
265ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
266integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
267die für beide Aufgaben erforderlich sind.
268
269%description devel -l es.UTF-8
270El interpretador Python permite incluir con facilidad extensiones
271cargadas dinámicamente. Python es también fácil de ser empotrado en
272otros programas. Este paquete contiene los archivos de inclusión y
273bibliotecas necesarios para estas dos tareas.
274
275%description devel -l fr.UTF-8
276L'interpréteur Python est relativement facile à étendre avec des
277extensions chargées dynamiquement et à insérer dans d'autres
278programmes. Ce paquetage contient les en-têtes et les bibliothèques
279nécessaires à ces deux tâches.
280
281%description devel -l pl.UTF-8
282Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
283dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
284osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
285wszystko inne co potrzebne do tych celów.
286
287%description devel -l pt_BR.UTF-8
288O interpretador Python permite incluir com facilidade extensões
289carregadas dinamicamente. Python é também fácil de ser embutido em
290outros programas. Este pacote contém os arquivos de inclusão e
291bibliotecas necessários para estas duas tarefas.
292
293%description devel -l ru.UTF-8
294Интерпретатор Python относительно легко расширяется при помощи
295динамически загружаемых расширений и встраивается в другие программы.
296Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
297задач.
298
299%description devel -l tr.UTF-8
300Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
301dosyalarını ve kitaplıkları içerir.
302
303%description devel -l uk.UTF-8
304Інтерпретатор Python відносно легко розширюється за допомогою
305розширень з динамічною загрузкою та вбудовується в інші програми. Цей
306пакет містить хедери та бібліотеки, необхідні для обох цих задач.
307
308%package devel-src
309Summary: Python module sources
310Summary(pl.UTF-8): Pliki źródłowe modułów Pythona
311Group: Development/Languages/Python
312Requires: %{name}-modules = %{epoch}:%{version}-%{release}
313
314%description devel-src
315Python module sources.
316
317%description devel-src -l pl.UTF-8
318Pliki źródłowe modułów Pythona.
319
320%package devel-tools
321Summary: Python development tools
322Summary(pl.UTF-8): Narzędzia programistyczne języka Python
323Group: Development/Languages/Python
324Requires: %{name}-modules = %{epoch}:%{version}-%{release}
325
326%description devel-tools
327Python development tools such as profilers and debugger.
328
329%description devel-tools -l pl.UTF-8
330Narzędzia programistyczne języka Python takie jak profiler oraz
331debugger.
332
30b0ff7b
AF
333%package 2to3
334Summary: Automated Python 2 to 3 code translation
335Summary(pl.UTF-8): Automatyczne tłumaczenie kody Pythona 2 do 3
336Group: Development/Languages/Pythona
337
338%description 2to3
3392to3 is a Python program that reads Python 2.x source code and applies a series
340of fixers to transform it into valid Python 3.x code. The standard library
341contains a rich set of fixers that will handle almost all code. 2to3 supporting
342library lib2to3 is, however, a flexible and generic library, so it is possible
343to write your own fixers for 2to3. lib2to3 could also be adapted to custom
344applications in which Python code needs to be edited automatically.
345
9416f74d
AM
346%package static
347Summary: Static python library
348Summary(pl.UTF-8): Statyczna biblioteka Pythona
349Group: Development/Languages/Python
350Requires: %{name}-devel = %{epoch}:%{version}-%{release}
351
352%description static
353Static python library.
354
355%description static -l pl.UTF-8
356Statyczna biblioteka Pythona.
357
9416f74d
AM
358%package doc-info
359Summary: Documentation on Python in texinfo format
360Summary(pl.UTF-8): Dokumentacja do Pythona w formacie texinfo
361Group: Documentation
362
363%description doc-info
364Documentation on Python in texinfo format.
365
366%description doc-info -l pl.UTF-8
367Dokumentacja do Pythona w formacie texinfo.
368
369%package tkinter
370Summary: Standard Python interface to the Tk GUI toolkit
371Summary(de.UTF-8): Grafische Tk-Schnittstelle für Python
372Summary(es.UTF-8): Interfaz de GUI Tk para Python
373Summary(fr.UTF-8): Interface graphique Tk pour Python
374Summary(pl.UTF-8): Standardowy interfejs Pythona do biblioteki Tk
375Summary(pt_BR.UTF-8): Interface GUI Tk para Phyton
376Summary(tr.UTF-8): Python için grafik kullanıcı arayüzü
377Group: Libraries/Python
378Requires: %{name}-modules = %{epoch}:%{version}-%{release}
379Requires: tcl >= 8.4.3
380Requires: tix >= 1:8.1.4-4
381Requires: tk >= 8.4.3
382
383%description tkinter
384Standard Python interface to the Tk GUI toolkit.
385
386%description tkinter -l de.UTF-8
387Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
388vielen Konfigurations-Tools genutzt.
389
390%description tkinter -l es.UTF-8
391Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
392herramientas de configuración.
393
394%description tkinter -l fr.UTF-8
395Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
396beaucoup des outils de configuration.
397
398%description tkinter -l pl.UTF-8
399Standardowy interfejs Pythona do biblioteki Tk.
400
401%description tkinter -l pt_BR.UTF-8
402Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
403muitas ferramentas de configuração.
404
405%description tkinter -l ru.UTF-8
406Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
407
408%description tkinter -l tr.UTF-8
409Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
410kullanılan grafik bir arayüzdür.
411
412%description tkinter -l uk.UTF-8
413Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
414
415%package examples
416Summary: Example programs in Python
417Summary(pl.UTF-8): Przykładowe programy w Pythonie
418Group: Development/Languages/Python
419
420%description examples
421Example programs in Python.
422
423These are for Python 2.3.4, not %{version}.
424
425%description examples -l pl.UTF-8
426Przykładowe programy w Pythonie.
427
428Przykłady te są dla Pythona 2.3.4, nie %{version}.
429
430%prep
431%setup -q -n Python-%{version}%{beta}
a20e3138 432%patch0 -p1
30b0ff7b 433%patch1 -p1
a0694bb8 434#%patch2 -p1
435#%patch3 -p1
436#%patch4 -p1
9416f74d
AM
437
438%build
439sed -i -e 's#-ltermcap#-ltinfo#g' configure*
440%{__autoconf}
31552fa6 441CPPFLAGS="-I/usr/include/ncursesw %{rpmcppflags}"; export CPPFLAGS
9416f74d 442%configure \
3ba70ac2 443 --with-cxx-main="%{__cxx}" \
9416f74d
AM
444 --enable-shared \
445 --enable-ipv6 \
19221b23 446 --with-dbmliborder=gdbm:bdb \
3ba70ac2 447 --with-wide-unicode \
9416f74d
AM
448 --with-signal-module \
449 --with-tsc \
450 --with-threads \
451 --with-doc-strings \
9416f74d 452 --with-fpectl \
3ba70ac2 453 --with-system-ffi \
23f5417d 454 --with-computed-gotos \
9416f74d
AM
455 LINKCC='$(PURIFY) $(CXX)' \
456 LDSHARED='$(CC) $(CFLAGS) -shared' \
457 BLDSHARED='$(CC) $(CFLAGS) -shared' \
458 LDFLAGS="%{rpmcflags} %{rpmldflags}"
459
460%{__make} \
23f5417d 461 OPT="%{rpmcflags} -fno-caller-saves" 2>&1 | awk '
9416f74d
AM
462BEGIN { fail = 0; logmsg = ""; }
463{
464 if ($0 ~ /\*\*\* WARNING:/) {
465 fail = 1;
466 logmsg = logmsg $0;
467 }
468 print $0;
469}
470END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
471
472LC_ALL=C
473export LC_ALL
474%if %{with tests}
475binlibdir=`echo build/lib.*`
476%{__make} test \
477 TESTOPTS="%{test_flags} %{test_list}" \
3ba70ac2 478 TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
9416f74d
AM
479%endif
480
481%install
482rm -rf $RPM_BUILD_ROOT
483install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
484 $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
485 $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
486 $RPM_BUILD_ROOT%{_infodir} \
487 $RPM_BUILD_ROOT/etc/shrc.d
488
489%{__make} install \
490 DESTDIR=$RPM_BUILD_ROOT
491
492%if %{with info}
493%{__make} -C Doc/info
494install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
495%endif
496
9416f74d
AM
497install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
498cp -a Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
499
500#
501# create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
502#
503
504# for python devel tools
505for script in timeit profile pdb pstats; do
24586eb0
AM
506 echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
507done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
9416f74d 508
24586eb0
AM
509echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
510 >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
9416f74d
AM
511
512sed 's/=/ /' \
24586eb0
AM
513 < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
514 > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
9416f74d
AM
515
516# for python modules
517for script in smtpd webbrowser; do
24586eb0
AM
518 echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
519done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
9416f74d
AM
520
521sed 's/=/ /' \
24586eb0
AM
522 < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
523 > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
9416f74d
AM
524
525# xgettext specific for Python code
526#
527# we will have two commands: pygettext.py (an alias) and pygettext;
528# this way there are no import (which is impossible now) conflicts and
529# pygettext.py is provided for compatibility
24586eb0
AM
530install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
531
eb7b678c
AF
532# rename file conflicting with python 2.*
533mv $RPM_BUILD_ROOT%{_bindir}/2to3{,-%{py_ver}}
534
9416f74d
AM
535# just to cut the noise, as they are not packaged (now)
536# first tests
537rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/test
538rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/bsddb/test
539rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
540rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
541rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/email/test
542rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
acd14a9e
AF
543rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/json/tests
544rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
fef40d51 545rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/importlib/test
eb7b678c 546rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/tkinter/test
9416f74d
AM
547
548# other files
549rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
acd14a9e
AF
550rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
551rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
552rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
30b0ff7b
AF
553rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
554rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
555rm -rf $RPM_BUILD_ROOT%{_bindir}/smtpd.py
acd14a9e
AF
556# already in %%doc
557rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/pdb.doc
558rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
9416f74d
AM
559
560%clean
561rm -rf $RPM_BUILD_ROOT
562
563%post libs -p /sbin/ldconfig
564%postun libs -p /sbin/ldconfig
565
a20bb9dc
ER
566%post doc-info -p /sbin/postshell
567-/usr/sbin/fix-info-dir -c %{_infodir}
9416f74d 568
a20bb9dc
ER
569%postun doc-info -p /sbin/postshell
570-/usr/sbin/fix-info-dir -c %{_infodir}
9416f74d
AM
571
572%files
573%defattr(644,root,root,755)
24586eb0 574%attr(755,root,root) %{_bindir}/python%{py_ver}
306c0f2d 575%attr(755,root,root) %{_bindir}/python3
19221b23 576%{_mandir}/man1/python*.1*
9416f74d
AM
577
578%files modules
579%defattr(644,root,root,755)
24586eb0 580/etc/shrc.d/python*-modules*
b2f86a67
AF
581%exclude %{py_scriptdir}/_abcoll.py[co]
582%exclude %{py_scriptdir}/_weakrefset.py[co]
583%exclude %{py_scriptdir}/abc.py[co]
9416f74d 584%exclude %{py_scriptdir}/codecs.py[co]
acd14a9e 585%exclude %{py_scriptdir}/copyreg.py[co]
b2f86a67
AF
586%exclude %{py_scriptdir}/genericpath.py[co]
587%exclude %{py_scriptdir}/io.py[co]
9416f74d
AM
588%exclude %{py_scriptdir}/locale.py[co]
589%exclude %{py_scriptdir}/posixpath.py[co]
590%exclude %{py_scriptdir}/pdb.py[co]
591%exclude %{py_scriptdir}/profile.py[co]
592%exclude %{py_scriptdir}/pstats.py[co]
593%exclude %{py_scriptdir}/pydoc.py[co]
594%exclude %{py_scriptdir}/site.py[co]
595%exclude %{py_scriptdir}/stat.py[co]
596%exclude %{py_scriptdir}/timeit.py[co]
597%exclude %{py_scriptdir}/os.py[co]
598%exclude %{py_scriptdir}/encodings/*.py[co]
599%exclude %{py_scriptdir}/types.py[co]
600
601%{py_scriptdir}/*.py[co]
602
603%{py_dyndir}/*.egg-info
604
605#
606# list .so modules to be sure that all of them are built
607#
608
929a5a93 609# modules below do not work on 64-bit architectures
9416f74d
AM
610# see Python README file for explanation
611%ifnarch alpha ia64 ppc64 sparc64 %{x8664}
612%attr(755,root,root) %{py_dyndir}/audioop.so
9416f74d
AM
613%endif
614
615%attr(755,root,root) %{py_dyndir}/array.so
35ff21ac
AM
616%attr(755,root,root) %{py_dyndir}/atexit.so
617%attr(755,root,root) %{py_dyndir}/audioop.so
9416f74d
AM
618%attr(755,root,root) %{py_dyndir}/binascii.so
619%attr(755,root,root) %{py_dyndir}/_bisect.so
9416f74d
AM
620%attr(755,root,root) %{py_dyndir}/bz2.so
621%attr(755,root,root) %{py_dyndir}/cmath.so
622%attr(755,root,root) %{py_dyndir}/_codecs_cn.so
623%attr(755,root,root) %{py_dyndir}/_codecs_hk.so
624%attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
625%attr(755,root,root) %{py_dyndir}/_codecs_jp.so
626%attr(755,root,root) %{py_dyndir}/_codecs_kr.so
627%attr(755,root,root) %{py_dyndir}/_codecs_tw.so
35ff21ac 628%attr(755,root,root) %{py_dyndir}/_collections.so
9416f74d 629%attr(755,root,root) %{py_dyndir}/crypt.so
9416f74d
AM
630%attr(755,root,root) %{py_dyndir}/_csv.so
631%attr(755,root,root) %{py_dyndir}/_ctypes*.so
632%attr(755,root,root) %{py_dyndir}/_curses_panel.so
633%attr(755,root,root) %{py_dyndir}/_curses.so
634%attr(755,root,root) %{py_dyndir}/datetime.so
635%attr(755,root,root) %{py_dyndir}/_elementtree.so
19221b23 636#%attr(755,root,root) %{py_dyndir}/_functools.so
9416f74d
AM
637%attr(755,root,root) %{py_dyndir}/_hashlib.so
638%attr(755,root,root) %{py_dyndir}/_heapq.so
acd14a9e 639%attr(755,root,root) %{py_dyndir}/_json.so
19221b23 640#%attr(755,root,root) %{py_dyndir}/_locale.so
9416f74d
AM
641%attr(755,root,root) %{py_dyndir}/_lsprof.so
642%attr(755,root,root) %{py_dyndir}/_multibytecodec.so
acd14a9e
AF
643%attr(755,root,root) %{py_dyndir}/_multiprocessing.so
644%attr(755,root,root) %{py_dyndir}/_pickle.so
9416f74d 645%attr(755,root,root) %{py_dyndir}/_random.so
9416f74d
AM
646%attr(755,root,root) %{py_dyndir}/_socket.so
647%attr(755,root,root) %{py_dyndir}/_ssl.so
648%attr(755,root,root) %{py_dyndir}/_testcapi.so
9416f74d 649%ifnarch sparc64
acd14a9e 650%attr(755,root,root) %{py_dyndir}/_dbm.so
9416f74d
AM
651%endif
652%attr(755,root,root) %{py_dyndir}/fcntl.so
acd14a9e 653%attr(755,root,root) %{py_dyndir}/_gdbm.so
9416f74d
AM
654%attr(755,root,root) %{py_dyndir}/grp.so
655%attr(755,root,root) %{py_dyndir}/itertools.so
9416f74d
AM
656%attr(755,root,root) %{py_dyndir}/math.so
657%attr(755,root,root) %{py_dyndir}/mmap.so
658%attr(755,root,root) %{py_dyndir}/nis.so
659%attr(755,root,root) %{py_dyndir}/operator.so
660%attr(755,root,root) %{py_dyndir}/ossaudiodev.so
661%attr(755,root,root) %{py_dyndir}/parser.so
662%attr(755,root,root) %{py_dyndir}/pyexpat.so
663%attr(755,root,root) %{py_dyndir}/readline.so
664%attr(755,root,root) %{py_dyndir}/resource.so
665%attr(755,root,root) %{py_dyndir}/select.so
9416f74d
AM
666%attr(755,root,root) %{py_dyndir}/syslog.so
667%attr(755,root,root) %{py_dyndir}/termios.so
668%attr(755,root,root) %{py_dyndir}/time.so
669%attr(755,root,root) %{py_dyndir}/spwd.so
670%attr(755,root,root) %{py_dyndir}/unicodedata.so
671%attr(755,root,root) %{py_dyndir}/zlib.so
672
673%dir %{py_scriptdir}/plat-*
674%{py_scriptdir}/plat-*/*.py[co]
675
9416f74d
AM
676%dir %{py_scriptdir}/ctypes
677%dir %{py_scriptdir}/ctypes/macholib
35ff21ac 678
9416f74d
AM
679%{py_scriptdir}/ctypes/*.py[co]
680%{py_scriptdir}/ctypes/macholib/*.py[co]
acd14a9e 681%doc %{py_scriptdir}/ctypes/macholib/README.ctypes
9416f74d
AM
682
683%dir %{py_scriptdir}/curses
684%{py_scriptdir}/curses/*.py[co]
685
acd14a9e
AF
686%dir %{py_scriptdir}/dbm
687%{py_scriptdir}/dbm/*.py[co]
688
9416f74d
AM
689%dir %{py_scriptdir}/distutils
690%dir %{py_scriptdir}/distutils/command
acd14a9e 691%doc %{py_scriptdir}/distutils/README
9416f74d
AM
692%{py_scriptdir}/distutils/*.py[co]
693%{py_scriptdir}/distutils/command/*.py[co]
acd14a9e 694%{py_scriptdir}/distutils/command/command_template
9416f74d
AM
695
696%dir %{py_scriptdir}/email
697%dir %{py_scriptdir}/email/mime
698%{py_scriptdir}/email/*.py[co]
699%{py_scriptdir}/email/mime/*.py[co]
700
acd14a9e
AF
701%dir %{py_scriptdir}/html
702%{py_scriptdir}/html/*.py[co]
703
704%dir %{py_scriptdir}/http
705%{py_scriptdir}/http/*.py[co]
706
fef40d51
AF
707%dir %{py_scriptdir}/importlib
708%{py_scriptdir}/importlib/*.py[co]
709
acd14a9e
AF
710%dir %{py_scriptdir}/json
711%{py_scriptdir}/json/*.py[co]
712
9416f74d
AM
713%dir %{py_scriptdir}/logging
714%{py_scriptdir}/logging/*.py[co]
715
acd14a9e
AF
716%dir %{py_scriptdir}/multiprocessing
717%{py_scriptdir}/multiprocessing/*.py[co]
718%dir %{py_scriptdir}/multiprocessing/dummy
719%{py_scriptdir}/multiprocessing/dummy/*.py[co]
720
721%dir %{py_scriptdir}/urllib
722%{py_scriptdir}/urllib/*.py[co]
723
9416f74d
AM
724%dir %{py_scriptdir}/wsgiref
725%{py_scriptdir}/wsgiref/*.py[co]
acd14a9e 726%{py_scriptdir}/wsgiref.egg-info
9416f74d
AM
727
728%dir %{py_scriptdir}/xml
729%dir %{py_scriptdir}/xml/dom
730%dir %{py_scriptdir}/xml/etree
731%dir %{py_scriptdir}/xml/parsers
732%dir %{py_scriptdir}/xml/sax
733%{py_scriptdir}/xml/*.py[co]
734%{py_scriptdir}/xml/dom/*.py[co]
735%{py_scriptdir}/xml/etree/*.py[co]
736%{py_scriptdir}/xml/parsers/*.py[co]
737%{py_scriptdir}/xml/sax/*.py[co]
738
acd14a9e
AF
739%dir %{py_scriptdir}/xmlrpc
740%{py_scriptdir}/xmlrpc/*.py[co]
741
9416f74d
AM
742%attr(755,root,root) %{py_dyndir}/_sqlite3.so
743%dir %{py_scriptdir}/sqlite3
744%{py_scriptdir}/sqlite3/*.py[co]
745
746%files libs
747%defattr(644,root,root,755)
acd14a9e 748%doc LICENSE
9416f74d
AM
749%attr(755,root,root) %{_libdir}/libpython*.so.*
750
751%dir %{py_dyndir}
752%dir %{py_scriptdir}
753%dir %{py_libdir}
754%dir %{py_sitescriptdir}
755%dir %{py_sitedir}
756
757# shared modules required by python library
758%attr(755,root,root) %{py_dyndir}/_struct.so
759
760# modules required by python library
b2f86a67
AF
761%{py_scriptdir}/_abcoll.py[co]
762%{py_scriptdir}/_weakrefset.py[co]
763%{py_scriptdir}/abc.py[co]
9416f74d 764%{py_scriptdir}/codecs.py[co]
acd14a9e 765%{py_scriptdir}/copyreg.py[co]
b2f86a67 766%{py_scriptdir}/genericpath.py[co]
9416f74d 767%{py_scriptdir}/locale.py[co]
b2f86a67 768%{py_scriptdir}/io.py[co]
9416f74d
AM
769%{py_scriptdir}/posixpath.py[co]
770%{py_scriptdir}/site.py[co]
771%{py_scriptdir}/stat.py[co]
772%{py_scriptdir}/os.py[co]
773# needed by the dynamic sys.lib patch
774%{py_scriptdir}/types.py[co]
775
776# encodings required by python library
777%dir %{py_scriptdir}/encodings
778%{py_scriptdir}/encodings/*.py[co]
779
2072c60e 780%files -n pydoc3
9416f74d 781%defattr(644,root,root,755)
19221b23 782%attr(755,root,root) %{_bindir}/pydoc3
9416f74d 783%{py_scriptdir}/pydoc.py[co]
fef40d51
AF
784%dir %{py_scriptdir}/pydoc_data
785%{py_scriptdir}/pydoc_data/*.py[co]
9416f74d 786
2072c60e 787%files -n idle3
9416f74d 788%defattr(644,root,root,755)
19221b23 789%attr(755,root,root) %{_bindir}/idle3
9416f74d
AM
790%dir %{py_scriptdir}/idlelib
791%dir %{py_scriptdir}/idlelib/Icons
792%{py_scriptdir}/idlelib/*.py[co]
acd14a9e
AF
793%doc %{py_scriptdir}/idlelib/*.txt
794%doc %{py_scriptdir}/idlelib/ChangeLog
9416f74d
AM
795%{py_scriptdir}/idlelib/Icons/*
796%{py_scriptdir}/idlelib/*.def
797
798%files devel
799%defattr(644,root,root,755)
800%doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
19221b23 801%attr(755,root,root) %{_bindir}/python*-config
9416f74d
AM
802%attr(755,root,root) %{_libdir}/lib*.so
803%dir %{py_incdir}
804%{py_incdir}/*.h
fef40d51 805%{_pkgconfigdir}/python*.pc
9416f74d
AM
806
807%dir %{py_libdir}/config
808%attr(755,root,root) %{py_libdir}/config/makesetup
809%attr(755,root,root) %{py_libdir}/config/install-sh
810%{py_libdir}/config/Makefile
811%{py_libdir}/config/Makefile.pre.in
812%{py_libdir}/config/Setup
813%{py_libdir}/config/Setup.config
814%{py_libdir}/config/Setup.local
815%{py_libdir}/config/config.c
816%{py_libdir}/config/config.c.in
817%{py_libdir}/config/python.o
818
819%files devel-src
820%defattr(644,root,root,755)
821%attr(-,root,root) %{py_scriptdir}/*.py
822%{py_scriptdir}/plat-*/*.py
9416f74d
AM
823%{py_scriptdir}/ctypes/*.py
824%{py_scriptdir}/ctypes/macholib/*.py
9416f74d 825%{py_scriptdir}/curses/*.py
acd14a9e 826%{py_scriptdir}/dbm/*.py
9416f74d
AM
827%{py_scriptdir}/distutils/*.py
828%{py_scriptdir}/distutils/command/*.py
829%{py_scriptdir}/email/*.py
830%{py_scriptdir}/email/mime/*.py
fef40d51 831%{py_scriptdir}/encodings/*.py
acd14a9e
AF
832%{py_scriptdir}/html/*.py
833%{py_scriptdir}/http/*.py
fef40d51
AF
834%{py_scriptdir}/idlelib/*.py
835%{py_scriptdir}/importlib/*.py
acd14a9e
AF
836%{py_scriptdir}/json/*.py
837%{py_scriptdir}/lib2to3/*.py
acd14a9e 838%{py_scriptdir}/lib2to3/pgen2/*.py
9416f74d 839%{py_scriptdir}/logging/*.py
acd14a9e
AF
840%{py_scriptdir}/multiprocessing/*.py
841%{py_scriptdir}/multiprocessing/dummy/*.py
fef40d51 842%{py_scriptdir}/pydoc_data/*.py
9416f74d 843%{py_scriptdir}/sqlite3/*.py
fef40d51 844%{py_scriptdir}/tkinter/*.py
acd14a9e 845%{py_scriptdir}/urllib/*.py
9416f74d
AM
846%{py_scriptdir}/wsgiref/*.py
847%{py_scriptdir}/xml/*.py
848%{py_scriptdir}/xml/dom/*.py
849%{py_scriptdir}/xml/etree/*.py
850%{py_scriptdir}/xml/parsers/*.py
851%{py_scriptdir}/xml/sax/*.py
acd14a9e 852%{py_scriptdir}/xmlrpc/*.py
9416f74d
AM
853
854%files devel-tools
855%defattr(644,root,root,755)
856%doc Lib/pdb.doc
24586eb0 857/etc/shrc.d/python*-devel*
9416f74d 858
24586eb0 859%attr(755,root,root) %{_bindir}/pygettext%{py_ver}
9416f74d 860
9416f74d
AM
861%{py_scriptdir}/pdb.py[co]
862%{py_scriptdir}/profile.py[co]
863%{py_scriptdir}/pstats.py[co]
864%{py_scriptdir}/timeit.py[co]
865
30b0ff7b 866%files 2to3
eb7b678c 867%attr(755,root,root) %{_bindir}/2to3-%{py_ver}
30b0ff7b
AF
868%dir %{py_scriptdir}/lib2to3
869%{py_scriptdir}/lib2to3/*.txt
870%{py_scriptdir}/lib2to3/*.pickle
871%{py_scriptdir}/lib2to3/*.py[co]
872%dir %{py_scriptdir}/lib2to3/fixes
be43ead0 873%{py_scriptdir}/lib2to3/fixes/*.py
30b0ff7b
AF
874%{py_scriptdir}/lib2to3/fixes/*.py[co]
875%dir %{py_scriptdir}/lib2to3/pgen2
876%{py_scriptdir}/lib2to3/pgen2/*.py[co]
877
9416f74d
AM
878%files static
879%defattr(644,root,root,755)
880%{_libdir}/lib*.a
881
882%files examples
883%defattr(644,root,root,755)
884%{_examplesdir}/%{name}-%{version}
885
9416f74d
AM
886%if %{with info}
887%files doc-info
888%defattr(644,root,root,755)
889%{_infodir}/*.info*
890%endif
891
892%if %{with tkinter}
893%files tkinter
894%defattr(644,root,root,755)
acd14a9e
AF
895%dir %{py_scriptdir}/tkinter
896%{py_scriptdir}/tkinter/*.py[co]
9416f74d
AM
897%attr(755,root,root) %{py_dyndir}/_tkinter.so
898%endif
This page took 0.196856 seconds and 4 git commands to generate.