]> git.pld-linux.org Git - packages/python3.git/blame - python3.spec
- up to 3.1.1 (tests are failing)
[packages/python3.git] / python3.spec
CommitLineData
19221b23
AG
1#
2# TODO:
3# - fix tests
4# - check unpackaged files
9416f74d
AM
5
6# Conditional build:
7%bcond_with info # info pages (requires emacs)
8%bcond_without tkinter # disables tkinter module building
9%bcond_without tests # disables Python testing
10%bcond_with verbose_tests # runs tests in verbose mode
9416f74d
AM
11#
12# tests which will not work on 64-bit platforms
13%define no64bit_tests test_audioop test_rgbimg test_imageop
14# tests which may fail because of builder environment limitations (no /proc or /dev/pts)
15%define nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
16# tests which fail because of some unknown/unresolved reason (this list should be empty)
f488a705 17%define broken_tests test_httpservers test_distutils test_cmd_line
9416f74d 18
2a27c05c 19%define beta %{nil}
9416f74d 20
19221b23 21%define py_ver 3.1
9416f74d
AM
22%define py_prefix %{_prefix}
23%define py_libdir %{py_prefix}/%{_lib}/python%{py_ver}
24%define py_incdir %{_includedir}/python%{py_ver}
25%define py_sitedir %{py_libdir}/site-packages
26%define py_dyndir %{py_libdir}/lib-dynload
27
28Summary: Very high level scripting language with X interface
29Summary(es.UTF-8): Lenguaje script de alto nivel con interfaz X
30Summary(fr.UTF-8): Langage de script de très haut niveau avec interface X
31Summary(pl.UTF-8): Python - język obiektowy wysokiego poziomu
32Summary(pt_BR.UTF-8): Linguagem de programação interpretada de alto nível
33Summary(ru.UTF-8): Язык программирования очень высокого уровня с X-интерфейсом
34Summary(tr.UTF-8): X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
35Summary(uk.UTF-8): Мова програмування дуже високого рівня з X-інтерфейсом
2072c60e 36Name: python3
1e9e2c3d
AM
37Version: %{py_ver}.1
38Release: 1
9416f74d
AM
39Epoch: 1
40License: PSF
41Group: Applications
3ba70ac2 42Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}%{beta}.tar.bz2
1e9e2c3d 43# Source0-md5: d1ddd9f16e3c6a51c7208f33518cd674
a20e3138
AG
44Patch0: %{name}-pythonpath.patch
45Patch1: %{name}-ac_fixes.patch
46Patch2: %{name}-lib64.patch
47Patch3: %{name}-noarch_to_datadir.patch
48Patch4: %{name}-cast-fix.patch
9416f74d
AM
49URL: http://www.python.org/
50BuildRequires: autoconf
51BuildRequires: bluez-libs-devel
52BuildRequires: bzip2-devel
53BuildRequires: db-devel >= 4
54%{?with_info:BuildRequires: emacs >= 21}
55BuildRequires: expat-devel >= 1:1.95.7
56BuildRequires: file
57BuildRequires: gdbm-devel >= 1.8.3
58BuildRequires: gmp-devel >= 4.0
3ba70ac2 59BuildRequires: libffi-devel
9416f74d
AM
60BuildRequires: libstdc++-devel
61BuildRequires: ncurses-ext-devel >= 5.2
9416f74d 62BuildRequires: openssl-devel >= 0.9.8
9416f74d
AM
63BuildRequires: readline-devel >= 5.0
64BuildRequires: rpm-pythonprov
65BuildRequires: sed >= 4.0
66BuildRequires: sqlite3-devel >= 3.3.5
67%{?with_info:BuildRequires: tetex-makeindex}
68%{?with_tkinter:BuildRequires: tix-devel >= 1:8.1.4-4}
69%{?with_tkinter:BuildRequires: tk-devel >= 8.4.3}
70BuildRequires: zlib-devel
71Requires: %{name}-libs = %{epoch}:%{version}-%{release}
9416f74d 72BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34dfde61 73
8d0b0882 74%define specflags_ppc -D__ppc__=1
34dfde61 75%define specflags_ppc64 -D__ppc64__=1
9416f74d
AM
76
77%if %{with verbose_tests}
78%define test_flags -v -l -x
79%else
f488a705 80%define test_flags -w -l -x
9416f74d
AM
81%endif
82
83%ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
84%define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
85%else
86%define test_list %{nobuilder_tests} %{broken_tests}
87%endif
88
89%ifarch sparc
90%define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
91%endif
92
93%description
94Python is an interpreted, interactive, object-oriented programming
95language. It incorporates modules, exceptions, dynamic typing, very
96high level dynamic data types, and classes. Python combines remarkable
97power with very clear syntax. It has interfaces to many system calls
98and libraries, as well as to various window systems, and is extensible
99in C or C++. It is also usable as an extension language for
100applications that need a programmable interface. Finally, Python is
101portable: it runs on many brands of UNIX, on the Mac, and on PCs under
102MS-DOS, Windows, Windows NT, and OS/2.
103
104This package contains the Python binary.
105
106%description -l de.UTF-8
107Python ist eine interpretierte, interaktive, objektorientierte
108Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
109Python enthält Module, Klassen, Exceptions, High-Level dynamische
110Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
111zu vielen Systemaufrufen und Libraries, sowie verschiedene
112Fenstersysteme (X11, Motif, Tk, Mac und MFC)
113
114Programmierer können neue built-in-Module für Python in C oder C++
115schreiben. Python kann auch als Erweiterungssprache für Applikationen
116benutzt werden, die ein programmierbares Interface brauchen. Dieses
117Paket enthält die meisten Standard-Python-Module, und Module zum
118Ansprechen von Tix (Tk-widget set) und RPM.
119
120%description -l es.UTF-8
121Python es un lenguaje de scripts interpretado orientado a objetos.
122Contiene soporte para carga dinámica de objetos, clases, módulos y
123excepciones.
124
125Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
126través de código C, tornando Python fácil de usar en ambientes
127particulares/personalizados. Este paquete Python incluye la mayoría de
128los módulos padrón Python, junto con módulos para crear interfaces
129para el conjunto de componentes Tix para Tk y RPM.
130
131%description -l fr.UTF-8
132Python est un langage de script interprété et orienté objet. Il gère
133le chargement dynamique des objets, les classes, les modules et les
134exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
135avec du code C est simple, ce qui rend Python facile à utiliser dans
136des configs personnalisées.
137
138Ce paquetage Python contient la plupart des modules Python standards,
139ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
140et RPM.
141
142%description -l pl.UTF-8
143Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
144językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
145typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
146sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
147wielu wywołań systemowych i bibliotek, w tym również do różnych
148bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
149poprzez odpowiednie moduły pisane w C lub C++. Python może być również
150użyty jako element aplikacji, którym potrzebny jest interpreter do
151skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
152odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
153OS/2.
154
155Ten pakiet zawiera binarkę Pythona.
156
157%description -l pt_BR.UTF-8
158Python é uma linguagem de scripts interpretada orientada a objetos.
159Contém suporte para carga dinâmica de objetos, classes, módulos e
160exceções. Adicionar interfaces para novos sistemas de biblioteca
161através de código C é simples, tornando Python fácil de usar em
162ambientes particulares/personalizados.
163
164Este pacote Python inclui a maioria do módulos padrão Python, junto
165com módulos para interfaceamento para o conjunto de componentes Tix
166para Tk e RPM.
167
168%description -l ru.UTF-8
169Python - это интерпретируемый, объектно-ориентированный язык
170программирования. Он поддерживает динамическую загрузку объектов,
171классы, модули и обработку исключительных ситуаций (exceptions).
172Простота добавления интерфейсов к новым системным библиотекам через
173код на языке C делает Python хорошим выбором для использования в
174специальных конфигурациях.
175
176%description -l tr.UTF-8
177Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
178sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
179destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
180paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
181arayüz birimlerini de içerir.
182
183%description -l uk.UTF-8
184Python - це інтерпретована, об'єктно-орієнтована мова програмування.
185Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
186виключних ситуацій (exceptions). Простота додавання інтерфейсів для
187нових системних бібліотек через код на мові C робить Python добрим
188вибором для використання в спеціальних конфігураціях.
189
190%package libs
191Summary: Python library
192Summary(pl.UTF-8): Biblioteka języka Python
193Group: Libraries/Python
194# broken detection in rpm/pythondeps.sh
195Provides: python(abi) = %{py_ver}
196# for compatibility with existing Ac packages
197Provides: python(bytecode) = %{py_ver}
2072c60e 198%{!?with_info:Obsoletes: python3-doc-info}
9416f74d
AM
199
200%description libs
201Python shared library and very essental modules for Python binary.
202
203%description libs -l pl.UTF-8
204Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
205dla Pythona.
206
207%package modules
208Summary: Python modules
209Summary(pl.UTF-8): Moduły języka Python
210Group: Libraries/Python
211Requires: %{name}-libs = %{epoch}:%{version}-%{release}
fef40d51 212Obsoletes: python3-modules-sqlite
9416f74d
AM
213
214%description modules
215Python officially distributed modules.
216
217%description modules -l pl.UTF-8
218Oficjalnie rozprowadzane moduły języka Python.
219
2072c60e 220%package -n pydoc3
9416f74d
AM
221Summary: Python interactive module documentation access support
222Summary(pl.UTF-8): Interaktywne korzystanie z dokumentacji modułów języka Python
223Group: Applications
224Requires: %{name}-modules = %{epoch}:%{version}-%{release}
225
2072c60e 226%description -n pydoc3
9416f74d
AM
227Python interactive module documentation access support.
228
2072c60e 229%description -n pydoc3 -l pl.UTF-8
9416f74d
AM
230Interaktywne korzystanie z dokumentacji modułów języka Python.
231
2072c60e 232%package -n idle3
9416f74d
AM
233Summary: IDE for Python language
234Summary(pl.UTF-8): IDE dla języka Python
235Group: Applications
236Requires: %{name}-tkinter = %{epoch}:%{version}-%{release}
237
2072c60e 238%description -n idle3
9416f74d
AM
239IDE for Python language.
240
2072c60e 241%description -n idle3 -l pl.UTF-8
9416f74d
AM
242IDE dla języka Python.
243
244%package devel
245Summary: Libraries and header files for building python code
246Summary(de.UTF-8): Libraries und Header-Dateien zum Erstellen von Python-Code
247Summary(es.UTF-8): Bibliotecas y archivos de inclusión para construir programas en python
248Summary(fr.UTF-8): Bibliothèques et en-têtes pour construire du code python
249Summary(pl.UTF-8): Pliki nagłówkowe i biblioteki Pythona
250Summary(pt_BR.UTF-8): Bibliotecas e arquivos de inclusão para o Python
251Summary(ru.UTF-8): Библиотеки и хедеры для построения кода на языке Python
252Summary(tr.UTF-8): Python ile geliştirme yapmak için gerekli dosyalar
253Summary(uk.UTF-8): Бібліотеки та хедери для програмування на мові Python
254Group: Development/Languages/Python
255Requires: %{name}-libs = %{epoch}:%{version}-%{release}
256
257%description devel
258The Python interpreter is relatively easy to extend with dynamically
259loaded extensions and to embed in other programs. This package
260contains the header files and libraries which are needed to do both of
261these tasks.
262
263%description devel -l de.UTF-8
264Der Python-Interpretierer ist relativ einfach anhand von dynamisch
265ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
266integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
267die für beide Aufgaben erforderlich sind.
268
269%description devel -l es.UTF-8
270El interpretador Python permite incluir con facilidad extensiones
271cargadas dinámicamente. Python es también fácil de ser empotrado en
272otros programas. Este paquete contiene los archivos de inclusión y
273bibliotecas necesarios para estas dos tareas.
274
275%description devel -l fr.UTF-8
276L'interpréteur Python est relativement facile à étendre avec des
277extensions chargées dynamiquement et à insérer dans d'autres
278programmes. Ce paquetage contient les en-têtes et les bibliothèques
279nécessaires à ces deux tâches.
280
281%description devel -l pl.UTF-8
282Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
283dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
284osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
285wszystko inne co potrzebne do tych celów.
286
287%description devel -l pt_BR.UTF-8
288O interpretador Python permite incluir com facilidade extensões
289carregadas dinamicamente. Python é também fácil de ser embutido em
290outros programas. Este pacote contém os arquivos de inclusão e
291bibliotecas necessários para estas duas tarefas.
292
293%description devel -l ru.UTF-8
294Интерпретатор Python относительно легко расширяется при помощи
295динамически загружаемых расширений и встраивается в другие программы.
296Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
297задач.
298
299%description devel -l tr.UTF-8
300Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
301dosyalarını ve kitaplıkları içerir.
302
303%description devel -l uk.UTF-8
304Інтерпретатор Python відносно легко розширюється за допомогою
305розширень з динамічною загрузкою та вбудовується в інші програми. Цей
306пакет містить хедери та бібліотеки, необхідні для обох цих задач.
307
308%package devel-src
309Summary: Python module sources
310Summary(pl.UTF-8): Pliki źródłowe modułów Pythona
311Group: Development/Languages/Python
312Requires: %{name}-modules = %{epoch}:%{version}-%{release}
313
314%description devel-src
315Python module sources.
316
317%description devel-src -l pl.UTF-8
318Pliki źródłowe modułów Pythona.
319
320%package devel-tools
321Summary: Python development tools
322Summary(pl.UTF-8): Narzędzia programistyczne języka Python
323Group: Development/Languages/Python
324Requires: %{name}-modules = %{epoch}:%{version}-%{release}
325
326%description devel-tools
327Python development tools such as profilers and debugger.
328
329%description devel-tools -l pl.UTF-8
330Narzędzia programistyczne języka Python takie jak profiler oraz
331debugger.
332
30b0ff7b
AF
333%package 2to3
334Summary: Automated Python 2 to 3 code translation
335Summary(pl.UTF-8): Automatyczne tłumaczenie kody Pythona 2 do 3
336Group: Development/Languages/Pythona
337
338%description 2to3
3392to3 is a Python program that reads Python 2.x source code and applies a series
340of fixers to transform it into valid Python 3.x code. The standard library
341contains a rich set of fixers that will handle almost all code. 2to3 supporting
342library lib2to3 is, however, a flexible and generic library, so it is possible
343to write your own fixers for 2to3. lib2to3 could also be adapted to custom
344applications in which Python code needs to be edited automatically.
345
9416f74d
AM
346%package static
347Summary: Static python library
348Summary(pl.UTF-8): Statyczna biblioteka Pythona
349Group: Development/Languages/Python
350Requires: %{name}-devel = %{epoch}:%{version}-%{release}
351
352%description static
353Static python library.
354
355%description static -l pl.UTF-8
356Statyczna biblioteka Pythona.
357
358%package doc
359Summary: Documentation on Python
360Summary(de.UTF-8): Dokumentation zu Python
361Summary(es.UTF-8): Documentación para Python
362Summary(fr.UTF-8): Documentation sur Python
363Summary(pl.UTF-8): Dokumentacja do Pythona
364Summary(pt_BR.UTF-8): Documentação para a linguagem de programação Python
365Summary(ru.UTF-8): Документация по языку Python
366Summary(tr.UTF-8): Python belgeleri
367Summary(uk.UTF-8): Документація по мові Python
368Group: Documentation
369
370%description doc
371This package contains documentation on the Python language and
372interpretor as a mix of plain ASCII files and LaTeX sources.
373
374%description doc -l de.UTF-8
375Dieses Paket enthält Dokumentationen zu Python (Sprache und
376Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
377
378%description doc -l es.UTF-8
379Documentación para Python. Contiene archivos en texto y PostScript.
380
381%description doc -l fr.UTF-8
382Ce paquetage contient la documentation sur le langage python et sur
383son interpréteur sous forme de fichiers ASCII et LaTeX.
384
385%description doc -l pl.UTF-8
386Oficjalna dokumentacja do Pythona. Zawiera przykładowe programy,
387narzędzia i dokumentację. Strony podręcznika man znajdują się w
388głównym pakiecie. Ten pakiet nie zawiera źródeł dokumentacji
389napisanych w LaTeXu, tylko gotowe do wykorzystania pliki postscriptowe
390i HTML.
391
392%description doc -l pt_BR.UTF-8
393O pacote python-doc contém documentação para a linguagem de
394programação e para o interpretador Python. Fornecida em arquivos texto
395e Postcript.
396
397%description doc -l ru.UTF-8
398Этот пакет содержит документацию по собственно языку Python и по
399исполняющему его интерпретатору в виде набора текстовых файлов и
400исходных текстов в формате LaTeX.
401
402%description doc -l tr.UTF-8
403Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyaları ve
404LaTeX kaynaklarının bir karışımı olan yorumlayıcıyı içerir.
405
406%description doc -l uk.UTF-8
407Цей пакет містить документацію по власне мові Python та по виконуючому
408її інтерпретатору у вигляді набора текстових файлів та вихідних
409текстів у форматі LaTeX.
410
411%package doc-info
412Summary: Documentation on Python in texinfo format
413Summary(pl.UTF-8): Dokumentacja do Pythona w formacie texinfo
414Group: Documentation
415
416%description doc-info
417Documentation on Python in texinfo format.
418
419%description doc-info -l pl.UTF-8
420Dokumentacja do Pythona w formacie texinfo.
421
422%package tkinter
423Summary: Standard Python interface to the Tk GUI toolkit
424Summary(de.UTF-8): Grafische Tk-Schnittstelle für Python
425Summary(es.UTF-8): Interfaz de GUI Tk para Python
426Summary(fr.UTF-8): Interface graphique Tk pour Python
427Summary(pl.UTF-8): Standardowy interfejs Pythona do biblioteki Tk
428Summary(pt_BR.UTF-8): Interface GUI Tk para Phyton
429Summary(tr.UTF-8): Python için grafik kullanıcı arayüzü
430Group: Libraries/Python
431Requires: %{name}-modules = %{epoch}:%{version}-%{release}
432Requires: tcl >= 8.4.3
433Requires: tix >= 1:8.1.4-4
434Requires: tk >= 8.4.3
435
436%description tkinter
437Standard Python interface to the Tk GUI toolkit.
438
439%description tkinter -l de.UTF-8
440Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
441vielen Konfigurations-Tools genutzt.
442
443%description tkinter -l es.UTF-8
444Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
445herramientas de configuración.
446
447%description tkinter -l fr.UTF-8
448Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
449beaucoup des outils de configuration.
450
451%description tkinter -l pl.UTF-8
452Standardowy interfejs Pythona do biblioteki Tk.
453
454%description tkinter -l pt_BR.UTF-8
455Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
456muitas ferramentas de configuração.
457
458%description tkinter -l ru.UTF-8
459Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
460
461%description tkinter -l tr.UTF-8
462Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
463kullanılan grafik bir arayüzdür.
464
465%description tkinter -l uk.UTF-8
466Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
467
468%package examples
469Summary: Example programs in Python
470Summary(pl.UTF-8): Przykładowe programy w Pythonie
471Group: Development/Languages/Python
472
473%description examples
474Example programs in Python.
475
476These are for Python 2.3.4, not %{version}.
477
478%description examples -l pl.UTF-8
479Przykładowe programy w Pythonie.
480
481Przykłady te są dla Pythona 2.3.4, nie %{version}.
482
483%prep
484%setup -q -n Python-%{version}%{beta}
a20e3138 485%patch0 -p1
30b0ff7b 486%patch1 -p1
a20e3138 487%patch2 -p1
9416f74d 488%patch3 -p1
acd14a9e 489%patch4 -p1
306c0f2d 490sed -i -e 's=@EXENAME@=%{_bindir}/python3=' Misc/python-config.in
9416f74d
AM
491
492%build
493sed -i -e 's#-ltermcap#-ltinfo#g' configure*
494%{__autoconf}
3ba70ac2 495CPPFLAGS="-I/usr/include/ncursesw"; export CPPFLAGS
9416f74d 496%configure \
3ba70ac2 497 --with-cxx-main="%{__cxx}" \
9416f74d
AM
498 --enable-shared \
499 --enable-ipv6 \
19221b23 500 --with-dbmliborder=gdbm:bdb \
3ba70ac2 501 --with-wide-unicode \
9416f74d
AM
502 --with-signal-module \
503 --with-tsc \
504 --with-threads \
505 --with-doc-strings \
9416f74d 506 --with-fpectl \
3ba70ac2 507 --with-system-ffi \
9416f74d
AM
508 LINKCC='$(PURIFY) $(CXX)' \
509 LDSHARED='$(CC) $(CFLAGS) -shared' \
510 BLDSHARED='$(CC) $(CFLAGS) -shared' \
511 LDFLAGS="%{rpmcflags} %{rpmldflags}"
512
513%{__make} \
514 OPT="%{rpmcflags}" 2>&1 | awk '
515BEGIN { fail = 0; logmsg = ""; }
516{
517 if ($0 ~ /\*\*\* WARNING:/) {
518 fail = 1;
519 logmsg = logmsg $0;
520 }
521 print $0;
522}
523END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
524
525LC_ALL=C
526export LC_ALL
527%if %{with tests}
528binlibdir=`echo build/lib.*`
529%{__make} test \
530 TESTOPTS="%{test_flags} %{test_list}" \
3ba70ac2 531 TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
9416f74d
AM
532%endif
533
534%install
535rm -rf $RPM_BUILD_ROOT
536install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
537 $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
538 $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
539 $RPM_BUILD_ROOT%{_infodir} \
540 $RPM_BUILD_ROOT/etc/shrc.d
541
542%{__make} install \
543 DESTDIR=$RPM_BUILD_ROOT
544
545%if %{with info}
546%{__make} -C Doc/info
547install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
548%endif
549
550install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
551
552mv $RPM_BUILD_ROOT{%{py_libdir}/config,%{_libdir}}/libpython%{py_ver}.a
553ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
9416f74d
AM
554ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{py_ver}.so
555
9416f74d
AM
556install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
557cp -a Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
558
559#
560# create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
561#
562
563# for python devel tools
564for script in timeit profile pdb pstats; do
24586eb0
AM
565 echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
566done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
9416f74d 567
24586eb0
AM
568echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
569 >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
9416f74d
AM
570
571sed 's/=/ /' \
24586eb0
AM
572 < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
573 > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
9416f74d
AM
574
575# for python modules
576for script in smtpd webbrowser; do
24586eb0
AM
577 echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
578done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
9416f74d
AM
579
580sed 's/=/ /' \
24586eb0
AM
581 < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
582 > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
9416f74d
AM
583
584# xgettext specific for Python code
585#
586# we will have two commands: pygettext.py (an alias) and pygettext;
587# this way there are no import (which is impossible now) conflicts and
588# pygettext.py is provided for compatibility
24586eb0
AM
589install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
590
9416f74d
AM
591# just to cut the noise, as they are not packaged (now)
592# first tests
593rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/test
594rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/bsddb/test
595rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
596rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
597rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/email/test
598rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
acd14a9e
AF
599rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/json/tests
600rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
fef40d51 601rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/importlib/test
9416f74d
AM
602
603# other files
604rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
acd14a9e
AF
605rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
606rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
607rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
30b0ff7b
AF
608rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
609rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
610rm -rf $RPM_BUILD_ROOT%{_bindir}/smtpd.py
acd14a9e
AF
611# already in %%doc
612rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/pdb.doc
613rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
9416f74d
AM
614
615%clean
616rm -rf $RPM_BUILD_ROOT
617
618%post libs -p /sbin/ldconfig
619%postun libs -p /sbin/ldconfig
620
a20bb9dc
ER
621%post doc-info -p /sbin/postshell
622-/usr/sbin/fix-info-dir -c %{_infodir}
9416f74d 623
a20bb9dc
ER
624%postun doc-info -p /sbin/postshell
625-/usr/sbin/fix-info-dir -c %{_infodir}
9416f74d
AM
626
627%files
628%defattr(644,root,root,755)
24586eb0 629%attr(755,root,root) %{_bindir}/python%{py_ver}
306c0f2d 630%attr(755,root,root) %{_bindir}/python3
19221b23 631%{_mandir}/man1/python*.1*
9416f74d
AM
632
633%files modules
634%defattr(644,root,root,755)
24586eb0 635/etc/shrc.d/python*-modules*
b2f86a67
AF
636%exclude %{py_scriptdir}/_abcoll.py[co]
637%exclude %{py_scriptdir}/_weakrefset.py[co]
638%exclude %{py_scriptdir}/abc.py[co]
9416f74d 639%exclude %{py_scriptdir}/codecs.py[co]
acd14a9e 640%exclude %{py_scriptdir}/copyreg.py[co]
b2f86a67
AF
641%exclude %{py_scriptdir}/genericpath.py[co]
642%exclude %{py_scriptdir}/io.py[co]
9416f74d
AM
643%exclude %{py_scriptdir}/locale.py[co]
644%exclude %{py_scriptdir}/posixpath.py[co]
645%exclude %{py_scriptdir}/pdb.py[co]
646%exclude %{py_scriptdir}/profile.py[co]
647%exclude %{py_scriptdir}/pstats.py[co]
648%exclude %{py_scriptdir}/pydoc.py[co]
649%exclude %{py_scriptdir}/site.py[co]
650%exclude %{py_scriptdir}/stat.py[co]
651%exclude %{py_scriptdir}/timeit.py[co]
652%exclude %{py_scriptdir}/os.py[co]
653%exclude %{py_scriptdir}/encodings/*.py[co]
654%exclude %{py_scriptdir}/types.py[co]
655
656%{py_scriptdir}/*.py[co]
657
658%{py_dyndir}/*.egg-info
659
660#
661# list .so modules to be sure that all of them are built
662#
663
929a5a93 664# modules below do not work on 64-bit architectures
9416f74d
AM
665# see Python README file for explanation
666%ifnarch alpha ia64 ppc64 sparc64 %{x8664}
667%attr(755,root,root) %{py_dyndir}/audioop.so
9416f74d
AM
668%endif
669
670%attr(755,root,root) %{py_dyndir}/array.so
35ff21ac
AM
671%attr(755,root,root) %{py_dyndir}/atexit.so
672%attr(755,root,root) %{py_dyndir}/audioop.so
9416f74d
AM
673%attr(755,root,root) %{py_dyndir}/binascii.so
674%attr(755,root,root) %{py_dyndir}/_bisect.so
9416f74d
AM
675%attr(755,root,root) %{py_dyndir}/bz2.so
676%attr(755,root,root) %{py_dyndir}/cmath.so
677%attr(755,root,root) %{py_dyndir}/_codecs_cn.so
678%attr(755,root,root) %{py_dyndir}/_codecs_hk.so
679%attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
680%attr(755,root,root) %{py_dyndir}/_codecs_jp.so
681%attr(755,root,root) %{py_dyndir}/_codecs_kr.so
682%attr(755,root,root) %{py_dyndir}/_codecs_tw.so
35ff21ac 683%attr(755,root,root) %{py_dyndir}/_collections.so
9416f74d 684%attr(755,root,root) %{py_dyndir}/crypt.so
9416f74d
AM
685%attr(755,root,root) %{py_dyndir}/_csv.so
686%attr(755,root,root) %{py_dyndir}/_ctypes*.so
687%attr(755,root,root) %{py_dyndir}/_curses_panel.so
688%attr(755,root,root) %{py_dyndir}/_curses.so
689%attr(755,root,root) %{py_dyndir}/datetime.so
690%attr(755,root,root) %{py_dyndir}/_elementtree.so
19221b23 691#%attr(755,root,root) %{py_dyndir}/_functools.so
9416f74d
AM
692%attr(755,root,root) %{py_dyndir}/_hashlib.so
693%attr(755,root,root) %{py_dyndir}/_heapq.so
acd14a9e 694%attr(755,root,root) %{py_dyndir}/_json.so
19221b23 695#%attr(755,root,root) %{py_dyndir}/_locale.so
9416f74d
AM
696%attr(755,root,root) %{py_dyndir}/_lsprof.so
697%attr(755,root,root) %{py_dyndir}/_multibytecodec.so
acd14a9e
AF
698%attr(755,root,root) %{py_dyndir}/_multiprocessing.so
699%attr(755,root,root) %{py_dyndir}/_pickle.so
9416f74d 700%attr(755,root,root) %{py_dyndir}/_random.so
9416f74d
AM
701%attr(755,root,root) %{py_dyndir}/_socket.so
702%attr(755,root,root) %{py_dyndir}/_ssl.so
703%attr(755,root,root) %{py_dyndir}/_testcapi.so
9416f74d 704%ifnarch sparc64
acd14a9e 705%attr(755,root,root) %{py_dyndir}/_dbm.so
9416f74d
AM
706%endif
707%attr(755,root,root) %{py_dyndir}/fcntl.so
acd14a9e 708%attr(755,root,root) %{py_dyndir}/_gdbm.so
9416f74d
AM
709%attr(755,root,root) %{py_dyndir}/grp.so
710%attr(755,root,root) %{py_dyndir}/itertools.so
9416f74d
AM
711%attr(755,root,root) %{py_dyndir}/math.so
712%attr(755,root,root) %{py_dyndir}/mmap.so
713%attr(755,root,root) %{py_dyndir}/nis.so
714%attr(755,root,root) %{py_dyndir}/operator.so
715%attr(755,root,root) %{py_dyndir}/ossaudiodev.so
716%attr(755,root,root) %{py_dyndir}/parser.so
717%attr(755,root,root) %{py_dyndir}/pyexpat.so
718%attr(755,root,root) %{py_dyndir}/readline.so
719%attr(755,root,root) %{py_dyndir}/resource.so
720%attr(755,root,root) %{py_dyndir}/select.so
9416f74d
AM
721%attr(755,root,root) %{py_dyndir}/syslog.so
722%attr(755,root,root) %{py_dyndir}/termios.so
723%attr(755,root,root) %{py_dyndir}/time.so
724%attr(755,root,root) %{py_dyndir}/spwd.so
725%attr(755,root,root) %{py_dyndir}/unicodedata.so
726%attr(755,root,root) %{py_dyndir}/zlib.so
727
728%dir %{py_scriptdir}/plat-*
729%{py_scriptdir}/plat-*/*.py[co]
730
9416f74d
AM
731%dir %{py_scriptdir}/ctypes
732%dir %{py_scriptdir}/ctypes/macholib
35ff21ac 733
9416f74d
AM
734%{py_scriptdir}/ctypes/*.py[co]
735%{py_scriptdir}/ctypes/macholib/*.py[co]
acd14a9e 736%doc %{py_scriptdir}/ctypes/macholib/README.ctypes
9416f74d
AM
737
738%dir %{py_scriptdir}/curses
739%{py_scriptdir}/curses/*.py[co]
740
acd14a9e
AF
741%dir %{py_scriptdir}/dbm
742%{py_scriptdir}/dbm/*.py[co]
743
9416f74d
AM
744%dir %{py_scriptdir}/distutils
745%dir %{py_scriptdir}/distutils/command
acd14a9e 746%doc %{py_scriptdir}/distutils/README
9416f74d
AM
747%{py_scriptdir}/distutils/*.py[co]
748%{py_scriptdir}/distutils/command/*.py[co]
acd14a9e 749%{py_scriptdir}/distutils/command/command_template
9416f74d
AM
750
751%dir %{py_scriptdir}/email
752%dir %{py_scriptdir}/email/mime
753%{py_scriptdir}/email/*.py[co]
754%{py_scriptdir}/email/mime/*.py[co]
755
acd14a9e
AF
756%dir %{py_scriptdir}/html
757%{py_scriptdir}/html/*.py[co]
758
759%dir %{py_scriptdir}/http
760%{py_scriptdir}/http/*.py[co]
761
fef40d51
AF
762%dir %{py_scriptdir}/importlib
763%{py_scriptdir}/importlib/*.py[co]
764
acd14a9e
AF
765%dir %{py_scriptdir}/json
766%{py_scriptdir}/json/*.py[co]
767
9416f74d
AM
768%dir %{py_scriptdir}/logging
769%{py_scriptdir}/logging/*.py[co]
770
acd14a9e
AF
771%dir %{py_scriptdir}/multiprocessing
772%{py_scriptdir}/multiprocessing/*.py[co]
773%dir %{py_scriptdir}/multiprocessing/dummy
774%{py_scriptdir}/multiprocessing/dummy/*.py[co]
775
776%dir %{py_scriptdir}/urllib
777%{py_scriptdir}/urllib/*.py[co]
778
9416f74d
AM
779%dir %{py_scriptdir}/wsgiref
780%{py_scriptdir}/wsgiref/*.py[co]
acd14a9e 781%{py_scriptdir}/wsgiref.egg-info
9416f74d
AM
782
783%dir %{py_scriptdir}/xml
784%dir %{py_scriptdir}/xml/dom
785%dir %{py_scriptdir}/xml/etree
786%dir %{py_scriptdir}/xml/parsers
787%dir %{py_scriptdir}/xml/sax
788%{py_scriptdir}/xml/*.py[co]
789%{py_scriptdir}/xml/dom/*.py[co]
790%{py_scriptdir}/xml/etree/*.py[co]
791%{py_scriptdir}/xml/parsers/*.py[co]
792%{py_scriptdir}/xml/sax/*.py[co]
793
acd14a9e
AF
794%dir %{py_scriptdir}/xmlrpc
795%{py_scriptdir}/xmlrpc/*.py[co]
796
9416f74d
AM
797%attr(755,root,root) %{py_dyndir}/_sqlite3.so
798%dir %{py_scriptdir}/sqlite3
799%{py_scriptdir}/sqlite3/*.py[co]
800
801%files libs
802%defattr(644,root,root,755)
acd14a9e 803%doc LICENSE
9416f74d
AM
804%attr(755,root,root) %{_libdir}/libpython*.so.*
805
806%dir %{py_dyndir}
807%dir %{py_scriptdir}
808%dir %{py_libdir}
809%dir %{py_sitescriptdir}
810%dir %{py_sitedir}
811
812# shared modules required by python library
813%attr(755,root,root) %{py_dyndir}/_struct.so
814
815# modules required by python library
b2f86a67
AF
816%{py_scriptdir}/_abcoll.py[co]
817%{py_scriptdir}/_weakrefset.py[co]
818%{py_scriptdir}/abc.py[co]
9416f74d 819%{py_scriptdir}/codecs.py[co]
acd14a9e 820%{py_scriptdir}/copyreg.py[co]
b2f86a67 821%{py_scriptdir}/genericpath.py[co]
9416f74d 822%{py_scriptdir}/locale.py[co]
b2f86a67 823%{py_scriptdir}/io.py[co]
9416f74d
AM
824%{py_scriptdir}/posixpath.py[co]
825%{py_scriptdir}/site.py[co]
826%{py_scriptdir}/stat.py[co]
827%{py_scriptdir}/os.py[co]
828# needed by the dynamic sys.lib patch
829%{py_scriptdir}/types.py[co]
830
831# encodings required by python library
832%dir %{py_scriptdir}/encodings
833%{py_scriptdir}/encodings/*.py[co]
834
2072c60e 835%files -n pydoc3
9416f74d 836%defattr(644,root,root,755)
19221b23 837%attr(755,root,root) %{_bindir}/pydoc3
9416f74d 838%{py_scriptdir}/pydoc.py[co]
fef40d51
AF
839%dir %{py_scriptdir}/pydoc_data
840%{py_scriptdir}/pydoc_data/*.py[co]
9416f74d 841
2072c60e 842%files -n idle3
9416f74d 843%defattr(644,root,root,755)
19221b23 844%attr(755,root,root) %{_bindir}/idle3
9416f74d
AM
845%dir %{py_scriptdir}/idlelib
846%dir %{py_scriptdir}/idlelib/Icons
847%{py_scriptdir}/idlelib/*.py[co]
acd14a9e
AF
848%doc %{py_scriptdir}/idlelib/*.txt
849%doc %{py_scriptdir}/idlelib/ChangeLog
9416f74d
AM
850%{py_scriptdir}/idlelib/Icons/*
851%{py_scriptdir}/idlelib/*.def
852
853%files devel
854%defattr(644,root,root,755)
855%doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
19221b23 856%attr(755,root,root) %{_bindir}/python*-config
9416f74d
AM
857%attr(755,root,root) %{_libdir}/lib*.so
858%dir %{py_incdir}
859%{py_incdir}/*.h
fef40d51 860%{_pkgconfigdir}/python*.pc
9416f74d
AM
861
862%dir %{py_libdir}/config
863%attr(755,root,root) %{py_libdir}/config/makesetup
864%attr(755,root,root) %{py_libdir}/config/install-sh
865%{py_libdir}/config/Makefile
866%{py_libdir}/config/Makefile.pre.in
867%{py_libdir}/config/Setup
868%{py_libdir}/config/Setup.config
869%{py_libdir}/config/Setup.local
870%{py_libdir}/config/config.c
871%{py_libdir}/config/config.c.in
872%{py_libdir}/config/python.o
873
874%files devel-src
875%defattr(644,root,root,755)
876%attr(-,root,root) %{py_scriptdir}/*.py
877%{py_scriptdir}/plat-*/*.py
9416f74d
AM
878%{py_scriptdir}/ctypes/*.py
879%{py_scriptdir}/ctypes/macholib/*.py
9416f74d 880%{py_scriptdir}/curses/*.py
acd14a9e 881%{py_scriptdir}/dbm/*.py
9416f74d
AM
882%{py_scriptdir}/distutils/*.py
883%{py_scriptdir}/distutils/command/*.py
884%{py_scriptdir}/email/*.py
885%{py_scriptdir}/email/mime/*.py
fef40d51 886%{py_scriptdir}/encodings/*.py
acd14a9e
AF
887%{py_scriptdir}/html/*.py
888%{py_scriptdir}/http/*.py
fef40d51
AF
889%{py_scriptdir}/idlelib/*.py
890%{py_scriptdir}/importlib/*.py
acd14a9e
AF
891%{py_scriptdir}/json/*.py
892%{py_scriptdir}/lib2to3/*.py
893%{py_scriptdir}/lib2to3/fixes/*.py
894%{py_scriptdir}/lib2to3/pgen2/*.py
9416f74d 895%{py_scriptdir}/logging/*.py
acd14a9e
AF
896%{py_scriptdir}/multiprocessing/*.py
897%{py_scriptdir}/multiprocessing/dummy/*.py
fef40d51 898%{py_scriptdir}/pydoc_data/*.py
9416f74d 899%{py_scriptdir}/sqlite3/*.py
fef40d51 900%{py_scriptdir}/tkinter/*.py
acd14a9e 901%{py_scriptdir}/urllib/*.py
9416f74d
AM
902%{py_scriptdir}/wsgiref/*.py
903%{py_scriptdir}/xml/*.py
904%{py_scriptdir}/xml/dom/*.py
905%{py_scriptdir}/xml/etree/*.py
906%{py_scriptdir}/xml/parsers/*.py
907%{py_scriptdir}/xml/sax/*.py
acd14a9e 908%{py_scriptdir}/xmlrpc/*.py
9416f74d
AM
909
910%files devel-tools
911%defattr(644,root,root,755)
912%doc Lib/pdb.doc
24586eb0 913/etc/shrc.d/python*-devel*
9416f74d 914
24586eb0 915%attr(755,root,root) %{_bindir}/pygettext%{py_ver}
9416f74d 916
9416f74d
AM
917%{py_scriptdir}/pdb.py[co]
918%{py_scriptdir}/profile.py[co]
919%{py_scriptdir}/pstats.py[co]
920%{py_scriptdir}/timeit.py[co]
921
30b0ff7b
AF
922%files 2to3
923%attr(755,root,root) %{_bindir}/2to3
924%dir %{py_scriptdir}/lib2to3
925%{py_scriptdir}/lib2to3/*.txt
926%{py_scriptdir}/lib2to3/*.pickle
927%{py_scriptdir}/lib2to3/*.py[co]
928%dir %{py_scriptdir}/lib2to3/fixes
929%{py_scriptdir}/lib2to3/fixes/*.py[co]
930%dir %{py_scriptdir}/lib2to3/pgen2
931%{py_scriptdir}/lib2to3/pgen2/*.py[co]
932
9416f74d
AM
933%files static
934%defattr(644,root,root,755)
935%{_libdir}/lib*.a
936
937%files examples
938%defattr(644,root,root,755)
939%{_examplesdir}/%{name}-%{version}
940
9416f74d
AM
941%if %{with info}
942%files doc-info
943%defattr(644,root,root,755)
944%{_infodir}/*.info*
945%endif
946
947%if %{with tkinter}
948%files tkinter
949%defattr(644,root,root,755)
acd14a9e
AF
950%dir %{py_scriptdir}/tkinter
951%{py_scriptdir}/tkinter/*.py[co]
9416f74d
AM
952%attr(755,root,root) %{py_dyndir}/_tkinter.so
953%endif
This page took 0.203065 seconds and 4 git commands to generate.