]> git.pld-linux.org Git - packages/python3.git/blame - python3.spec
- seems no longer needed for Python 3.2
[packages/python3.git] / python3.spec
CommitLineData
19221b23
AG
1#
2# TODO:
3# - fix tests
4# - check unpackaged files
9416f74d
AM
5
6# Conditional build:
7%bcond_with info # info pages (requires emacs)
8%bcond_without tkinter # disables tkinter module building
9%bcond_without tests # disables Python testing
10%bcond_with verbose_tests # runs tests in verbose mode
9416f74d
AM
11#
12# tests which will not work on 64-bit platforms
13%define no64bit_tests test_audioop test_rgbimg test_imageop
14# tests which may fail because of builder environment limitations (no /proc or /dev/pts)
15%define nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
16# tests which fail because of some unknown/unresolved reason (this list should be empty)
be43ead0 17%define broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib test_zlib
9416f74d 18
3da62d7c 19%define beta %{nil}
9416f74d 20
a0694bb8 21%define py_ver 3.2
9416f74d
AM
22%define py_prefix %{_prefix}
23%define py_libdir %{py_prefix}/%{_lib}/python%{py_ver}
24%define py_incdir %{_includedir}/python%{py_ver}
25%define py_sitedir %{py_libdir}/site-packages
26%define py_dyndir %{py_libdir}/lib-dynload
27
28Summary: Very high level scripting language with X interface
29Summary(es.UTF-8): Lenguaje script de alto nivel con interfaz X
30Summary(fr.UTF-8): Langage de script de très haut niveau avec interface X
31Summary(pl.UTF-8): Python - język obiektowy wysokiego poziomu
32Summary(pt_BR.UTF-8): Linguagem de programação interpretada de alto nível
33Summary(ru.UTF-8): Язык программирования очень высокого уровня с X-интерфейсом
34Summary(tr.UTF-8): X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
35Summary(uk.UTF-8): Мова програмування дуже високого рівня з X-інтерфейсом
2072c60e 36Name: python3
a0694bb8 37Version: %{py_ver}
4449431f 38#Release: 0.%{beta}.1
39Release: 0.1
9416f74d
AM
40Epoch: 1
41License: PSF
42Group: Applications
3ba70ac2 43Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}%{beta}.tar.bz2
3da62d7c 44# Source0-md5: 92e94b5b6652b96349d6362b8337811d
a20e3138
AG
45Patch0: %{name}-pythonpath.patch
46Patch1: %{name}-ac_fixes.patch
47Patch2: %{name}-lib64.patch
48Patch3: %{name}-noarch_to_datadir.patch
49Patch4: %{name}-cast-fix.patch
9416f74d
AM
50URL: http://www.python.org/
51BuildRequires: autoconf
52BuildRequires: bluez-libs-devel
53BuildRequires: bzip2-devel
54BuildRequires: db-devel >= 4
55%{?with_info:BuildRequires: emacs >= 21}
56BuildRequires: expat-devel >= 1:1.95.7
57BuildRequires: file
58BuildRequires: gdbm-devel >= 1.8.3
59BuildRequires: gmp-devel >= 4.0
3ba70ac2 60BuildRequires: libffi-devel
9416f74d
AM
61BuildRequires: libstdc++-devel
62BuildRequires: ncurses-ext-devel >= 5.2
9416f74d 63BuildRequires: openssl-devel >= 0.9.8
9416f74d
AM
64BuildRequires: readline-devel >= 5.0
65BuildRequires: rpm-pythonprov
66BuildRequires: sed >= 4.0
67BuildRequires: sqlite3-devel >= 3.3.5
68%{?with_info:BuildRequires: tetex-makeindex}
69%{?with_tkinter:BuildRequires: tix-devel >= 1:8.1.4-4}
70%{?with_tkinter:BuildRequires: tk-devel >= 8.4.3}
71BuildRequires: zlib-devel
72Requires: %{name}-libs = %{epoch}:%{version}-%{release}
9416f74d 73BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34dfde61 74
8d0b0882 75%define specflags_ppc -D__ppc__=1
34dfde61 76%define specflags_ppc64 -D__ppc64__=1
9416f74d
AM
77
78%if %{with verbose_tests}
79%define test_flags -v -l -x
80%else
f488a705 81%define test_flags -w -l -x
9416f74d
AM
82%endif
83
84%ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
85%define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
86%else
87%define test_list %{nobuilder_tests} %{broken_tests}
88%endif
89
90%ifarch sparc
91%define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
92%endif
93
94%description
95Python is an interpreted, interactive, object-oriented programming
96language. It incorporates modules, exceptions, dynamic typing, very
97high level dynamic data types, and classes. Python combines remarkable
98power with very clear syntax. It has interfaces to many system calls
99and libraries, as well as to various window systems, and is extensible
100in C or C++. It is also usable as an extension language for
101applications that need a programmable interface. Finally, Python is
102portable: it runs on many brands of UNIX, on the Mac, and on PCs under
103MS-DOS, Windows, Windows NT, and OS/2.
104
105This package contains the Python binary.
106
107%description -l de.UTF-8
108Python ist eine interpretierte, interaktive, objektorientierte
109Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
110Python enthält Module, Klassen, Exceptions, High-Level dynamische
111Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
112zu vielen Systemaufrufen und Libraries, sowie verschiedene
113Fenstersysteme (X11, Motif, Tk, Mac und MFC)
114
115Programmierer können neue built-in-Module für Python in C oder C++
116schreiben. Python kann auch als Erweiterungssprache für Applikationen
117benutzt werden, die ein programmierbares Interface brauchen. Dieses
118Paket enthält die meisten Standard-Python-Module, und Module zum
119Ansprechen von Tix (Tk-widget set) und RPM.
120
121%description -l es.UTF-8
122Python es un lenguaje de scripts interpretado orientado a objetos.
123Contiene soporte para carga dinámica de objetos, clases, módulos y
124excepciones.
125
126Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
127través de código C, tornando Python fácil de usar en ambientes
128particulares/personalizados. Este paquete Python incluye la mayoría de
129los módulos padrón Python, junto con módulos para crear interfaces
130para el conjunto de componentes Tix para Tk y RPM.
131
132%description -l fr.UTF-8
133Python est un langage de script interprété et orienté objet. Il gère
134le chargement dynamique des objets, les classes, les modules et les
135exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
136avec du code C est simple, ce qui rend Python facile à utiliser dans
137des configs personnalisées.
138
139Ce paquetage Python contient la plupart des modules Python standards,
140ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
141et RPM.
142
143%description -l pl.UTF-8
144Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
145językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
146typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
147sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
148wielu wywołań systemowych i bibliotek, w tym również do różnych
149bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
150poprzez odpowiednie moduły pisane w C lub C++. Python może być również
151użyty jako element aplikacji, którym potrzebny jest interpreter do
152skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
153odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
154OS/2.
155
156Ten pakiet zawiera binarkę Pythona.
157
158%description -l pt_BR.UTF-8
159Python é uma linguagem de scripts interpretada orientada a objetos.
160Contém suporte para carga dinâmica de objetos, classes, módulos e
161exceções. Adicionar interfaces para novos sistemas de biblioteca
162através de código C é simples, tornando Python fácil de usar em
163ambientes particulares/personalizados.
164
165Este pacote Python inclui a maioria do módulos padrão Python, junto
166com módulos para interfaceamento para o conjunto de componentes Tix
167para Tk e RPM.
168
169%description -l ru.UTF-8
170Python - это интерпретируемый, объектно-ориентированный язык
171программирования. Он поддерживает динамическую загрузку объектов,
172классы, модули и обработку исключительных ситуаций (exceptions).
173Простота добавления интерфейсов к новым системным библиотекам через
174код на языке C делает Python хорошим выбором для использования в
175специальных конфигурациях.
176
177%description -l tr.UTF-8
178Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
179sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
180destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
181paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
182arayüz birimlerini de içerir.
183
184%description -l uk.UTF-8
185Python - це інтерпретована, об'єктно-орієнтована мова програмування.
186Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
187виключних ситуацій (exceptions). Простота додавання інтерфейсів для
188нових системних бібліотек через код на мові C робить Python добрим
189вибором для використання в спеціальних конфігураціях.
190
191%package libs
192Summary: Python library
193Summary(pl.UTF-8): Biblioteka języka Python
194Group: Libraries/Python
195# broken detection in rpm/pythondeps.sh
196Provides: python(abi) = %{py_ver}
197# for compatibility with existing Ac packages
198Provides: python(bytecode) = %{py_ver}
2072c60e 199%{!?with_info:Obsoletes: python3-doc-info}
9416f74d
AM
200
201%description libs
202Python shared library and very essental modules for Python binary.
203
204%description libs -l pl.UTF-8
205Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
206dla Pythona.
207
208%package modules
209Summary: Python modules
210Summary(pl.UTF-8): Moduły języka Python
211Group: Libraries/Python
212Requires: %{name}-libs = %{epoch}:%{version}-%{release}
fef40d51 213Obsoletes: python3-modules-sqlite
9416f74d
AM
214
215%description modules
216Python officially distributed modules.
217
218%description modules -l pl.UTF-8
219Oficjalnie rozprowadzane moduły języka Python.
220
2072c60e 221%package -n pydoc3
9416f74d
AM
222Summary: Python interactive module documentation access support
223Summary(pl.UTF-8): Interaktywne korzystanie z dokumentacji modułów języka Python
224Group: Applications
225Requires: %{name}-modules = %{epoch}:%{version}-%{release}
226
2072c60e 227%description -n pydoc3
9416f74d
AM
228Python interactive module documentation access support.
229
2072c60e 230%description -n pydoc3 -l pl.UTF-8
9416f74d
AM
231Interaktywne korzystanie z dokumentacji modułów języka Python.
232
2072c60e 233%package -n idle3
9416f74d
AM
234Summary: IDE for Python language
235Summary(pl.UTF-8): IDE dla języka Python
236Group: Applications
237Requires: %{name}-tkinter = %{epoch}:%{version}-%{release}
238
2072c60e 239%description -n idle3
9416f74d
AM
240IDE for Python language.
241
2072c60e 242%description -n idle3 -l pl.UTF-8
9416f74d
AM
243IDE dla języka Python.
244
245%package devel
246Summary: Libraries and header files for building python code
247Summary(de.UTF-8): Libraries und Header-Dateien zum Erstellen von Python-Code
248Summary(es.UTF-8): Bibliotecas y archivos de inclusión para construir programas en python
249Summary(fr.UTF-8): Bibliothèques et en-têtes pour construire du code python
250Summary(pl.UTF-8): Pliki nagłówkowe i biblioteki Pythona
251Summary(pt_BR.UTF-8): Bibliotecas e arquivos de inclusão para o Python
252Summary(ru.UTF-8): Библиотеки и хедеры для построения кода на языке Python
253Summary(tr.UTF-8): Python ile geliştirme yapmak için gerekli dosyalar
254Summary(uk.UTF-8): Бібліотеки та хедери для програмування на мові Python
255Group: Development/Languages/Python
256Requires: %{name}-libs = %{epoch}:%{version}-%{release}
257
258%description devel
259The Python interpreter is relatively easy to extend with dynamically
260loaded extensions and to embed in other programs. This package
261contains the header files and libraries which are needed to do both of
262these tasks.
263
264%description devel -l de.UTF-8
265Der Python-Interpretierer ist relativ einfach anhand von dynamisch
266ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
267integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
268die für beide Aufgaben erforderlich sind.
269
270%description devel -l es.UTF-8
271El interpretador Python permite incluir con facilidad extensiones
272cargadas dinámicamente. Python es también fácil de ser empotrado en
273otros programas. Este paquete contiene los archivos de inclusión y
274bibliotecas necesarios para estas dos tareas.
275
276%description devel -l fr.UTF-8
277L'interpréteur Python est relativement facile à étendre avec des
278extensions chargées dynamiquement et à insérer dans d'autres
279programmes. Ce paquetage contient les en-têtes et les bibliothèques
280nécessaires à ces deux tâches.
281
282%description devel -l pl.UTF-8
283Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
284dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
285osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
286wszystko inne co potrzebne do tych celów.
287
288%description devel -l pt_BR.UTF-8
289O interpretador Python permite incluir com facilidade extensões
290carregadas dinamicamente. Python é também fácil de ser embutido em
291outros programas. Este pacote contém os arquivos de inclusão e
292bibliotecas necessários para estas duas tarefas.
293
294%description devel -l ru.UTF-8
295Интерпретатор Python относительно легко расширяется при помощи
296динамически загружаемых расширений и встраивается в другие программы.
297Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
298задач.
299
300%description devel -l tr.UTF-8
301Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
302dosyalarını ve kitaplıkları içerir.
303
304%description devel -l uk.UTF-8
305Інтерпретатор Python відносно легко розширюється за допомогою
306розширень з динамічною загрузкою та вбудовується в інші програми. Цей
307пакет містить хедери та бібліотеки, необхідні для обох цих задач.
308
309%package devel-src
310Summary: Python module sources
311Summary(pl.UTF-8): Pliki źródłowe modułów Pythona
312Group: Development/Languages/Python
313Requires: %{name}-modules = %{epoch}:%{version}-%{release}
314
315%description devel-src
316Python module sources.
317
318%description devel-src -l pl.UTF-8
319Pliki źródłowe modułów Pythona.
320
321%package devel-tools
322Summary: Python development tools
323Summary(pl.UTF-8): Narzędzia programistyczne języka Python
324Group: Development/Languages/Python
325Requires: %{name}-modules = %{epoch}:%{version}-%{release}
326
327%description devel-tools
328Python development tools such as profilers and debugger.
329
330%description devel-tools -l pl.UTF-8
331Narzędzia programistyczne języka Python takie jak profiler oraz
332debugger.
333
30b0ff7b
AF
334%package 2to3
335Summary: Automated Python 2 to 3 code translation
336Summary(pl.UTF-8): Automatyczne tłumaczenie kody Pythona 2 do 3
337Group: Development/Languages/Pythona
338
339%description 2to3
3402to3 is a Python program that reads Python 2.x source code and applies a series
341of fixers to transform it into valid Python 3.x code. The standard library
342contains a rich set of fixers that will handle almost all code. 2to3 supporting
343library lib2to3 is, however, a flexible and generic library, so it is possible
344to write your own fixers for 2to3. lib2to3 could also be adapted to custom
345applications in which Python code needs to be edited automatically.
346
9416f74d
AM
347%package static
348Summary: Static python library
349Summary(pl.UTF-8): Statyczna biblioteka Pythona
350Group: Development/Languages/Python
351Requires: %{name}-devel = %{epoch}:%{version}-%{release}
352
353%description static
354Static python library.
355
356%description static -l pl.UTF-8
357Statyczna biblioteka Pythona.
358
9416f74d
AM
359%package doc-info
360Summary: Documentation on Python in texinfo format
361Summary(pl.UTF-8): Dokumentacja do Pythona w formacie texinfo
362Group: Documentation
363
364%description doc-info
365Documentation on Python in texinfo format.
366
367%description doc-info -l pl.UTF-8
368Dokumentacja do Pythona w formacie texinfo.
369
370%package tkinter
371Summary: Standard Python interface to the Tk GUI toolkit
372Summary(de.UTF-8): Grafische Tk-Schnittstelle für Python
373Summary(es.UTF-8): Interfaz de GUI Tk para Python
374Summary(fr.UTF-8): Interface graphique Tk pour Python
375Summary(pl.UTF-8): Standardowy interfejs Pythona do biblioteki Tk
376Summary(pt_BR.UTF-8): Interface GUI Tk para Phyton
377Summary(tr.UTF-8): Python için grafik kullanıcı arayüzü
378Group: Libraries/Python
379Requires: %{name}-modules = %{epoch}:%{version}-%{release}
380Requires: tcl >= 8.4.3
381Requires: tix >= 1:8.1.4-4
382Requires: tk >= 8.4.3
383
384%description tkinter
385Standard Python interface to the Tk GUI toolkit.
386
387%description tkinter -l de.UTF-8
388Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
389vielen Konfigurations-Tools genutzt.
390
391%description tkinter -l es.UTF-8
392Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
393herramientas de configuración.
394
395%description tkinter -l fr.UTF-8
396Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
397beaucoup des outils de configuration.
398
399%description tkinter -l pl.UTF-8
400Standardowy interfejs Pythona do biblioteki Tk.
401
402%description tkinter -l pt_BR.UTF-8
403Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
404muitas ferramentas de configuração.
405
406%description tkinter -l ru.UTF-8
407Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
408
409%description tkinter -l tr.UTF-8
410Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
411kullanılan grafik bir arayüzdür.
412
413%description tkinter -l uk.UTF-8
414Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
415
416%package examples
417Summary: Example programs in Python
418Summary(pl.UTF-8): Przykładowe programy w Pythonie
419Group: Development/Languages/Python
420
421%description examples
422Example programs in Python.
423
424These are for Python 2.3.4, not %{version}.
425
426%description examples -l pl.UTF-8
427Przykładowe programy w Pythonie.
428
429Przykłady te są dla Pythona 2.3.4, nie %{version}.
430
431%prep
432%setup -q -n Python-%{version}%{beta}
a20e3138 433%patch0 -p1
30b0ff7b 434%patch1 -p1
a0694bb8 435#%patch2 -p1
436#%patch3 -p1
437#%patch4 -p1
9416f74d
AM
438
439%build
440sed -i -e 's#-ltermcap#-ltinfo#g' configure*
441%{__autoconf}
31552fa6 442CPPFLAGS="-I/usr/include/ncursesw %{rpmcppflags}"; export CPPFLAGS
9416f74d 443%configure \
3ba70ac2 444 --with-cxx-main="%{__cxx}" \
9416f74d
AM
445 --enable-shared \
446 --enable-ipv6 \
19221b23 447 --with-dbmliborder=gdbm:bdb \
3ba70ac2 448 --with-wide-unicode \
9416f74d
AM
449 --with-signal-module \
450 --with-tsc \
451 --with-threads \
452 --with-doc-strings \
9416f74d 453 --with-fpectl \
3ba70ac2 454 --with-system-ffi \
23f5417d 455 --with-computed-gotos \
9416f74d
AM
456 LINKCC='$(PURIFY) $(CXX)' \
457 LDSHARED='$(CC) $(CFLAGS) -shared' \
458 BLDSHARED='$(CC) $(CFLAGS) -shared' \
459 LDFLAGS="%{rpmcflags} %{rpmldflags}"
460
461%{__make} \
23f5417d 462 OPT="%{rpmcflags} -fno-caller-saves" 2>&1 | awk '
9416f74d
AM
463BEGIN { fail = 0; logmsg = ""; }
464{
465 if ($0 ~ /\*\*\* WARNING:/) {
466 fail = 1;
467 logmsg = logmsg $0;
468 }
469 print $0;
470}
471END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
472
473LC_ALL=C
474export LC_ALL
475%if %{with tests}
476binlibdir=`echo build/lib.*`
477%{__make} test \
478 TESTOPTS="%{test_flags} %{test_list}" \
3ba70ac2 479 TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
9416f74d
AM
480%endif
481
482%install
483rm -rf $RPM_BUILD_ROOT
484install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
485 $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
486 $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
487 $RPM_BUILD_ROOT%{_infodir} \
488 $RPM_BUILD_ROOT/etc/shrc.d
489
490%{__make} install \
491 DESTDIR=$RPM_BUILD_ROOT
492
493%if %{with info}
494%{__make} -C Doc/info
495install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
496%endif
497
9416f74d 498install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
4449431f 499cp -a Tools $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
9416f74d
AM
500
501#
502# create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
503#
504
505# for python devel tools
506for script in timeit profile pdb pstats; do
24586eb0
AM
507 echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
508done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
9416f74d 509
24586eb0
AM
510echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
511 >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
9416f74d
AM
512
513sed 's/=/ /' \
24586eb0
AM
514 < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
515 > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
9416f74d
AM
516
517# for python modules
518for script in smtpd webbrowser; do
24586eb0
AM
519 echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
520done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
9416f74d
AM
521
522sed 's/=/ /' \
24586eb0
AM
523 < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
524 > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
9416f74d
AM
525
526# xgettext specific for Python code
527#
528# we will have two commands: pygettext.py (an alias) and pygettext;
529# this way there are no import (which is impossible now) conflicts and
530# pygettext.py is provided for compatibility
24586eb0
AM
531install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
532
9416f74d
AM
533# just to cut the noise, as they are not packaged (now)
534# first tests
535rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/test
536rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/bsddb/test
537rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
538rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
539rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/email/test
540rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
acd14a9e
AF
541rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/json/tests
542rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
fef40d51 543rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/importlib/test
eb7b678c 544rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/tkinter/test
9416f74d
AM
545
546# other files
547rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
acd14a9e
AF
548rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
549rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
550rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
30b0ff7b
AF
551rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
552rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
553rm -rf $RPM_BUILD_ROOT%{_bindir}/smtpd.py
acd14a9e
AF
554# already in %%doc
555rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/pdb.doc
556rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
9416f74d
AM
557
558%clean
559rm -rf $RPM_BUILD_ROOT
560
561%post libs -p /sbin/ldconfig
562%postun libs -p /sbin/ldconfig
563
a20bb9dc
ER
564%post doc-info -p /sbin/postshell
565-/usr/sbin/fix-info-dir -c %{_infodir}
9416f74d 566
a20bb9dc
ER
567%postun doc-info -p /sbin/postshell
568-/usr/sbin/fix-info-dir -c %{_infodir}
9416f74d
AM
569
570%files
571%defattr(644,root,root,755)
24586eb0 572%attr(755,root,root) %{_bindir}/python%{py_ver}
306c0f2d 573%attr(755,root,root) %{_bindir}/python3
19221b23 574%{_mandir}/man1/python*.1*
9416f74d
AM
575
576%files modules
577%defattr(644,root,root,755)
24586eb0 578/etc/shrc.d/python*-modules*
b2f86a67
AF
579%exclude %{py_scriptdir}/_abcoll.py[co]
580%exclude %{py_scriptdir}/_weakrefset.py[co]
581%exclude %{py_scriptdir}/abc.py[co]
9416f74d 582%exclude %{py_scriptdir}/codecs.py[co]
acd14a9e 583%exclude %{py_scriptdir}/copyreg.py[co]
b2f86a67
AF
584%exclude %{py_scriptdir}/genericpath.py[co]
585%exclude %{py_scriptdir}/io.py[co]
9416f74d
AM
586%exclude %{py_scriptdir}/locale.py[co]
587%exclude %{py_scriptdir}/posixpath.py[co]
588%exclude %{py_scriptdir}/pdb.py[co]
589%exclude %{py_scriptdir}/profile.py[co]
590%exclude %{py_scriptdir}/pstats.py[co]
591%exclude %{py_scriptdir}/pydoc.py[co]
592%exclude %{py_scriptdir}/site.py[co]
593%exclude %{py_scriptdir}/stat.py[co]
594%exclude %{py_scriptdir}/timeit.py[co]
595%exclude %{py_scriptdir}/os.py[co]
596%exclude %{py_scriptdir}/encodings/*.py[co]
597%exclude %{py_scriptdir}/types.py[co]
598
599%{py_scriptdir}/*.py[co]
600
601%{py_dyndir}/*.egg-info
602
603#
604# list .so modules to be sure that all of them are built
605#
606
929a5a93 607# modules below do not work on 64-bit architectures
9416f74d
AM
608# see Python README file for explanation
609%ifnarch alpha ia64 ppc64 sparc64 %{x8664}
610%attr(755,root,root) %{py_dyndir}/audioop.so
9416f74d
AM
611%endif
612
613%attr(755,root,root) %{py_dyndir}/array.so
35ff21ac
AM
614%attr(755,root,root) %{py_dyndir}/atexit.so
615%attr(755,root,root) %{py_dyndir}/audioop.so
9416f74d
AM
616%attr(755,root,root) %{py_dyndir}/binascii.so
617%attr(755,root,root) %{py_dyndir}/_bisect.so
9416f74d
AM
618%attr(755,root,root) %{py_dyndir}/bz2.so
619%attr(755,root,root) %{py_dyndir}/cmath.so
620%attr(755,root,root) %{py_dyndir}/_codecs_cn.so
621%attr(755,root,root) %{py_dyndir}/_codecs_hk.so
622%attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
623%attr(755,root,root) %{py_dyndir}/_codecs_jp.so
624%attr(755,root,root) %{py_dyndir}/_codecs_kr.so
625%attr(755,root,root) %{py_dyndir}/_codecs_tw.so
35ff21ac 626%attr(755,root,root) %{py_dyndir}/_collections.so
9416f74d 627%attr(755,root,root) %{py_dyndir}/crypt.so
9416f74d
AM
628%attr(755,root,root) %{py_dyndir}/_csv.so
629%attr(755,root,root) %{py_dyndir}/_ctypes*.so
630%attr(755,root,root) %{py_dyndir}/_curses_panel.so
631%attr(755,root,root) %{py_dyndir}/_curses.so
632%attr(755,root,root) %{py_dyndir}/datetime.so
633%attr(755,root,root) %{py_dyndir}/_elementtree.so
19221b23 634#%attr(755,root,root) %{py_dyndir}/_functools.so
9416f74d
AM
635%attr(755,root,root) %{py_dyndir}/_hashlib.so
636%attr(755,root,root) %{py_dyndir}/_heapq.so
acd14a9e 637%attr(755,root,root) %{py_dyndir}/_json.so
19221b23 638#%attr(755,root,root) %{py_dyndir}/_locale.so
9416f74d
AM
639%attr(755,root,root) %{py_dyndir}/_lsprof.so
640%attr(755,root,root) %{py_dyndir}/_multibytecodec.so
acd14a9e
AF
641%attr(755,root,root) %{py_dyndir}/_multiprocessing.so
642%attr(755,root,root) %{py_dyndir}/_pickle.so
9416f74d 643%attr(755,root,root) %{py_dyndir}/_random.so
9416f74d
AM
644%attr(755,root,root) %{py_dyndir}/_socket.so
645%attr(755,root,root) %{py_dyndir}/_ssl.so
646%attr(755,root,root) %{py_dyndir}/_testcapi.so
9416f74d 647%ifnarch sparc64
acd14a9e 648%attr(755,root,root) %{py_dyndir}/_dbm.so
9416f74d
AM
649%endif
650%attr(755,root,root) %{py_dyndir}/fcntl.so
acd14a9e 651%attr(755,root,root) %{py_dyndir}/_gdbm.so
9416f74d
AM
652%attr(755,root,root) %{py_dyndir}/grp.so
653%attr(755,root,root) %{py_dyndir}/itertools.so
9416f74d
AM
654%attr(755,root,root) %{py_dyndir}/math.so
655%attr(755,root,root) %{py_dyndir}/mmap.so
656%attr(755,root,root) %{py_dyndir}/nis.so
657%attr(755,root,root) %{py_dyndir}/operator.so
658%attr(755,root,root) %{py_dyndir}/ossaudiodev.so
659%attr(755,root,root) %{py_dyndir}/parser.so
660%attr(755,root,root) %{py_dyndir}/pyexpat.so
661%attr(755,root,root) %{py_dyndir}/readline.so
662%attr(755,root,root) %{py_dyndir}/resource.so
663%attr(755,root,root) %{py_dyndir}/select.so
9416f74d
AM
664%attr(755,root,root) %{py_dyndir}/syslog.so
665%attr(755,root,root) %{py_dyndir}/termios.so
666%attr(755,root,root) %{py_dyndir}/time.so
667%attr(755,root,root) %{py_dyndir}/spwd.so
668%attr(755,root,root) %{py_dyndir}/unicodedata.so
669%attr(755,root,root) %{py_dyndir}/zlib.so
670
671%dir %{py_scriptdir}/plat-*
672%{py_scriptdir}/plat-*/*.py[co]
673
9416f74d
AM
674%dir %{py_scriptdir}/ctypes
675%dir %{py_scriptdir}/ctypes/macholib
35ff21ac 676
9416f74d
AM
677%{py_scriptdir}/ctypes/*.py[co]
678%{py_scriptdir}/ctypes/macholib/*.py[co]
acd14a9e 679%doc %{py_scriptdir}/ctypes/macholib/README.ctypes
9416f74d
AM
680
681%dir %{py_scriptdir}/curses
682%{py_scriptdir}/curses/*.py[co]
683
acd14a9e
AF
684%dir %{py_scriptdir}/dbm
685%{py_scriptdir}/dbm/*.py[co]
686
9416f74d
AM
687%dir %{py_scriptdir}/distutils
688%dir %{py_scriptdir}/distutils/command
acd14a9e 689%doc %{py_scriptdir}/distutils/README
9416f74d
AM
690%{py_scriptdir}/distutils/*.py[co]
691%{py_scriptdir}/distutils/command/*.py[co]
acd14a9e 692%{py_scriptdir}/distutils/command/command_template
9416f74d
AM
693
694%dir %{py_scriptdir}/email
695%dir %{py_scriptdir}/email/mime
696%{py_scriptdir}/email/*.py[co]
697%{py_scriptdir}/email/mime/*.py[co]
698
acd14a9e
AF
699%dir %{py_scriptdir}/html
700%{py_scriptdir}/html/*.py[co]
701
702%dir %{py_scriptdir}/http
703%{py_scriptdir}/http/*.py[co]
704
fef40d51
AF
705%dir %{py_scriptdir}/importlib
706%{py_scriptdir}/importlib/*.py[co]
707
acd14a9e
AF
708%dir %{py_scriptdir}/json
709%{py_scriptdir}/json/*.py[co]
710
9416f74d
AM
711%dir %{py_scriptdir}/logging
712%{py_scriptdir}/logging/*.py[co]
713
acd14a9e
AF
714%dir %{py_scriptdir}/multiprocessing
715%{py_scriptdir}/multiprocessing/*.py[co]
716%dir %{py_scriptdir}/multiprocessing/dummy
717%{py_scriptdir}/multiprocessing/dummy/*.py[co]
718
719%dir %{py_scriptdir}/urllib
720%{py_scriptdir}/urllib/*.py[co]
721
9416f74d
AM
722%dir %{py_scriptdir}/wsgiref
723%{py_scriptdir}/wsgiref/*.py[co]
acd14a9e 724%{py_scriptdir}/wsgiref.egg-info
9416f74d
AM
725
726%dir %{py_scriptdir}/xml
727%dir %{py_scriptdir}/xml/dom
728%dir %{py_scriptdir}/xml/etree
729%dir %{py_scriptdir}/xml/parsers
730%dir %{py_scriptdir}/xml/sax
731%{py_scriptdir}/xml/*.py[co]
732%{py_scriptdir}/xml/dom/*.py[co]
733%{py_scriptdir}/xml/etree/*.py[co]
734%{py_scriptdir}/xml/parsers/*.py[co]
735%{py_scriptdir}/xml/sax/*.py[co]
736
acd14a9e
AF
737%dir %{py_scriptdir}/xmlrpc
738%{py_scriptdir}/xmlrpc/*.py[co]
739
9416f74d
AM
740%attr(755,root,root) %{py_dyndir}/_sqlite3.so
741%dir %{py_scriptdir}/sqlite3
742%{py_scriptdir}/sqlite3/*.py[co]
743
744%files libs
745%defattr(644,root,root,755)
acd14a9e 746%doc LICENSE
9416f74d
AM
747%attr(755,root,root) %{_libdir}/libpython*.so.*
748
749%dir %{py_dyndir}
750%dir %{py_scriptdir}
751%dir %{py_libdir}
752%dir %{py_sitescriptdir}
753%dir %{py_sitedir}
754
755# shared modules required by python library
756%attr(755,root,root) %{py_dyndir}/_struct.so
757
758# modules required by python library
b2f86a67
AF
759%{py_scriptdir}/_abcoll.py[co]
760%{py_scriptdir}/_weakrefset.py[co]
761%{py_scriptdir}/abc.py[co]
9416f74d 762%{py_scriptdir}/codecs.py[co]
acd14a9e 763%{py_scriptdir}/copyreg.py[co]
b2f86a67 764%{py_scriptdir}/genericpath.py[co]
9416f74d 765%{py_scriptdir}/locale.py[co]
b2f86a67 766%{py_scriptdir}/io.py[co]
9416f74d
AM
767%{py_scriptdir}/posixpath.py[co]
768%{py_scriptdir}/site.py[co]
769%{py_scriptdir}/stat.py[co]
770%{py_scriptdir}/os.py[co]
771# needed by the dynamic sys.lib patch
772%{py_scriptdir}/types.py[co]
773
774# encodings required by python library
775%dir %{py_scriptdir}/encodings
776%{py_scriptdir}/encodings/*.py[co]
777
2072c60e 778%files -n pydoc3
9416f74d 779%defattr(644,root,root,755)
19221b23 780%attr(755,root,root) %{_bindir}/pydoc3
9416f74d 781%{py_scriptdir}/pydoc.py[co]
fef40d51
AF
782%dir %{py_scriptdir}/pydoc_data
783%{py_scriptdir}/pydoc_data/*.py[co]
9416f74d 784
2072c60e 785%files -n idle3
9416f74d 786%defattr(644,root,root,755)
19221b23 787%attr(755,root,root) %{_bindir}/idle3
9416f74d
AM
788%dir %{py_scriptdir}/idlelib
789%dir %{py_scriptdir}/idlelib/Icons
790%{py_scriptdir}/idlelib/*.py[co]
acd14a9e
AF
791%doc %{py_scriptdir}/idlelib/*.txt
792%doc %{py_scriptdir}/idlelib/ChangeLog
9416f74d
AM
793%{py_scriptdir}/idlelib/Icons/*
794%{py_scriptdir}/idlelib/*.def
795
796%files devel
797%defattr(644,root,root,755)
798%doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
19221b23 799%attr(755,root,root) %{_bindir}/python*-config
9416f74d
AM
800%attr(755,root,root) %{_libdir}/lib*.so
801%dir %{py_incdir}
802%{py_incdir}/*.h
fef40d51 803%{_pkgconfigdir}/python*.pc
9416f74d
AM
804
805%dir %{py_libdir}/config
806%attr(755,root,root) %{py_libdir}/config/makesetup
807%attr(755,root,root) %{py_libdir}/config/install-sh
808%{py_libdir}/config/Makefile
809%{py_libdir}/config/Makefile.pre.in
810%{py_libdir}/config/Setup
811%{py_libdir}/config/Setup.config
812%{py_libdir}/config/Setup.local
813%{py_libdir}/config/config.c
814%{py_libdir}/config/config.c.in
815%{py_libdir}/config/python.o
816
817%files devel-src
818%defattr(644,root,root,755)
819%attr(-,root,root) %{py_scriptdir}/*.py
820%{py_scriptdir}/plat-*/*.py
9416f74d
AM
821%{py_scriptdir}/ctypes/*.py
822%{py_scriptdir}/ctypes/macholib/*.py
9416f74d 823%{py_scriptdir}/curses/*.py
acd14a9e 824%{py_scriptdir}/dbm/*.py
9416f74d
AM
825%{py_scriptdir}/distutils/*.py
826%{py_scriptdir}/distutils/command/*.py
827%{py_scriptdir}/email/*.py
828%{py_scriptdir}/email/mime/*.py
fef40d51 829%{py_scriptdir}/encodings/*.py
acd14a9e
AF
830%{py_scriptdir}/html/*.py
831%{py_scriptdir}/http/*.py
fef40d51
AF
832%{py_scriptdir}/idlelib/*.py
833%{py_scriptdir}/importlib/*.py
acd14a9e
AF
834%{py_scriptdir}/json/*.py
835%{py_scriptdir}/lib2to3/*.py
acd14a9e 836%{py_scriptdir}/lib2to3/pgen2/*.py
9416f74d 837%{py_scriptdir}/logging/*.py
acd14a9e
AF
838%{py_scriptdir}/multiprocessing/*.py
839%{py_scriptdir}/multiprocessing/dummy/*.py
fef40d51 840%{py_scriptdir}/pydoc_data/*.py
9416f74d 841%{py_scriptdir}/sqlite3/*.py
fef40d51 842%{py_scriptdir}/tkinter/*.py
acd14a9e 843%{py_scriptdir}/urllib/*.py
9416f74d
AM
844%{py_scriptdir}/wsgiref/*.py
845%{py_scriptdir}/xml/*.py
846%{py_scriptdir}/xml/dom/*.py
847%{py_scriptdir}/xml/etree/*.py
848%{py_scriptdir}/xml/parsers/*.py
849%{py_scriptdir}/xml/sax/*.py
acd14a9e 850%{py_scriptdir}/xmlrpc/*.py
9416f74d
AM
851
852%files devel-tools
853%defattr(644,root,root,755)
854%doc Lib/pdb.doc
24586eb0 855/etc/shrc.d/python*-devel*
9416f74d 856
24586eb0 857%attr(755,root,root) %{_bindir}/pygettext%{py_ver}
9416f74d 858
9416f74d
AM
859%{py_scriptdir}/pdb.py[co]
860%{py_scriptdir}/profile.py[co]
861%{py_scriptdir}/pstats.py[co]
862%{py_scriptdir}/timeit.py[co]
863
30b0ff7b 864%files 2to3
eb7b678c 865%attr(755,root,root) %{_bindir}/2to3-%{py_ver}
30b0ff7b
AF
866%dir %{py_scriptdir}/lib2to3
867%{py_scriptdir}/lib2to3/*.txt
868%{py_scriptdir}/lib2to3/*.pickle
869%{py_scriptdir}/lib2to3/*.py[co]
870%dir %{py_scriptdir}/lib2to3/fixes
be43ead0 871%{py_scriptdir}/lib2to3/fixes/*.py
30b0ff7b
AF
872%{py_scriptdir}/lib2to3/fixes/*.py[co]
873%dir %{py_scriptdir}/lib2to3/pgen2
874%{py_scriptdir}/lib2to3/pgen2/*.py[co]
875
9416f74d
AM
876%files static
877%defattr(644,root,root,755)
878%{_libdir}/lib*.a
879
880%files examples
881%defattr(644,root,root,755)
882%{_examplesdir}/%{name}-%{version}
883
9416f74d
AM
884%if %{with info}
885%files doc-info
886%defattr(644,root,root,755)
887%{_infodir}/*.info*
888%endif
889
890%if %{with tkinter}
891%files tkinter
892%defattr(644,root,root,755)
acd14a9e
AF
893%dir %{py_scriptdir}/tkinter
894%{py_scriptdir}/tkinter/*.py[co]
9416f74d
AM
895%attr(755,root,root) %{py_dyndir}/_tkinter.so
896%endif
This page took 0.184252 seconds and 4 git commands to generate.