]> git.pld-linux.org Git - packages/python3.git/blame - python3.spec
- updated noarch_to_datadir patch to install config to arch-dependent dir and libpyth...
[packages/python3.git] / python3.spec
CommitLineData
19221b23
AG
1#
2# TODO:
c7fdbe10
JB
3# - decide what to do with __pycache__:
4# 1) package *.py sources in main and use __pycache__ dirs (and package them)
5# 2) don't package __pycache__, manually invoke py_compileall everywhere (i.e. stick to python2-way)
19221b23
AG
6# - fix tests
7# - check unpackaged files
9416f74d
AM
8
9# Conditional build:
10%bcond_with info # info pages (requires emacs)
11%bcond_without tkinter # disables tkinter module building
12%bcond_without tests # disables Python testing
13%bcond_with verbose_tests # runs tests in verbose mode
9416f74d
AM
14#
15# tests which will not work on 64-bit platforms
16%define no64bit_tests test_audioop test_rgbimg test_imageop
17# tests which may fail because of builder environment limitations (no /proc or /dev/pts)
18%define nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
19# tests which fail because of some unknown/unresolved reason (this list should be empty)
be43ead0 20%define broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib test_zlib
9416f74d 21
a0694bb8 22%define py_ver 3.2
c7fdbe10 23%define py_abi %{py_ver}mu
9416f74d
AM
24%define py_prefix %{_prefix}
25%define py_libdir %{py_prefix}/%{_lib}/python%{py_ver}
c7fdbe10 26%define py_incdir %{_includedir}/python%{py_abi}
9416f74d
AM
27%define py_sitedir %{py_libdir}/site-packages
28%define py_dyndir %{py_libdir}/lib-dynload
29
30Summary: Very high level scripting language with X interface
31Summary(es.UTF-8): Lenguaje script de alto nivel con interfaz X
32Summary(fr.UTF-8): Langage de script de très haut niveau avec interface X
33Summary(pl.UTF-8): Python - język obiektowy wysokiego poziomu
34Summary(pt_BR.UTF-8): Linguagem de programação interpretada de alto nível
35Summary(ru.UTF-8): Язык программирования очень высокого уровня с X-интерфейсом
36Summary(tr.UTF-8): X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
37Summary(uk.UTF-8): Мова програмування дуже високого рівня з X-інтерфейсом
2072c60e 38Name: python3
a0694bb8 39Version: %{py_ver}
4449431f 40Release: 0.1
9416f74d
AM
41Epoch: 1
42License: PSF
43Group: Applications
0cf503a8 44Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
efe92a87 45# Source0-md5: 563c0b4b8c8596e332cc076c4f013971
a20e3138
AG
46Patch0: %{name}-pythonpath.patch
47Patch1: %{name}-ac_fixes.patch
48Patch2: %{name}-lib64.patch
49Patch3: %{name}-noarch_to_datadir.patch
9416f74d
AM
50URL: http://www.python.org/
51BuildRequires: autoconf
52BuildRequires: bluez-libs-devel
53BuildRequires: bzip2-devel
54BuildRequires: db-devel >= 4
55%{?with_info:BuildRequires: emacs >= 21}
56BuildRequires: expat-devel >= 1:1.95.7
57BuildRequires: file
58BuildRequires: gdbm-devel >= 1.8.3
59BuildRequires: gmp-devel >= 4.0
3ba70ac2 60BuildRequires: libffi-devel
9416f74d
AM
61BuildRequires: libstdc++-devel
62BuildRequires: ncurses-ext-devel >= 5.2
9416f74d 63BuildRequires: openssl-devel >= 0.9.8
9416f74d
AM
64BuildRequires: readline-devel >= 5.0
65BuildRequires: rpm-pythonprov
66BuildRequires: sed >= 4.0
67BuildRequires: sqlite3-devel >= 3.3.5
68%{?with_info:BuildRequires: tetex-makeindex}
69%{?with_tkinter:BuildRequires: tix-devel >= 1:8.1.4-4}
70%{?with_tkinter:BuildRequires: tk-devel >= 8.4.3}
71BuildRequires: zlib-devel
72Requires: %{name}-libs = %{epoch}:%{version}-%{release}
9416f74d 73BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34dfde61 74
8d0b0882 75%define specflags_ppc -D__ppc__=1
34dfde61 76%define specflags_ppc64 -D__ppc64__=1
9416f74d
AM
77
78%if %{with verbose_tests}
79%define test_flags -v -l -x
80%else
f488a705 81%define test_flags -w -l -x
9416f74d
AM
82%endif
83
84%ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
85%define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
86%else
87%define test_list %{nobuilder_tests} %{broken_tests}
88%endif
89
90%ifarch sparc
91%define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
92%endif
93
94%description
95Python is an interpreted, interactive, object-oriented programming
96language. It incorporates modules, exceptions, dynamic typing, very
97high level dynamic data types, and classes. Python combines remarkable
98power with very clear syntax. It has interfaces to many system calls
99and libraries, as well as to various window systems, and is extensible
100in C or C++. It is also usable as an extension language for
101applications that need a programmable interface. Finally, Python is
102portable: it runs on many brands of UNIX, on the Mac, and on PCs under
103MS-DOS, Windows, Windows NT, and OS/2.
104
105This package contains the Python binary.
106
107%description -l de.UTF-8
108Python ist eine interpretierte, interaktive, objektorientierte
109Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
110Python enthält Module, Klassen, Exceptions, High-Level dynamische
111Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
112zu vielen Systemaufrufen und Libraries, sowie verschiedene
113Fenstersysteme (X11, Motif, Tk, Mac und MFC)
114
115Programmierer können neue built-in-Module für Python in C oder C++
116schreiben. Python kann auch als Erweiterungssprache für Applikationen
117benutzt werden, die ein programmierbares Interface brauchen. Dieses
118Paket enthält die meisten Standard-Python-Module, und Module zum
119Ansprechen von Tix (Tk-widget set) und RPM.
120
121%description -l es.UTF-8
122Python es un lenguaje de scripts interpretado orientado a objetos.
123Contiene soporte para carga dinámica de objetos, clases, módulos y
124excepciones.
125
126Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
127través de código C, tornando Python fácil de usar en ambientes
128particulares/personalizados. Este paquete Python incluye la mayoría de
129los módulos padrón Python, junto con módulos para crear interfaces
130para el conjunto de componentes Tix para Tk y RPM.
131
132%description -l fr.UTF-8
133Python est un langage de script interprété et orienté objet. Il gère
134le chargement dynamique des objets, les classes, les modules et les
135exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
136avec du code C est simple, ce qui rend Python facile à utiliser dans
137des configs personnalisées.
138
139Ce paquetage Python contient la plupart des modules Python standards,
140ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
141et RPM.
142
143%description -l pl.UTF-8
144Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
145językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
146typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
147sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
148wielu wywołań systemowych i bibliotek, w tym również do różnych
149bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
150poprzez odpowiednie moduły pisane w C lub C++. Python może być również
151użyty jako element aplikacji, którym potrzebny jest interpreter do
152skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
153odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
154OS/2.
155
156Ten pakiet zawiera binarkę Pythona.
157
158%description -l pt_BR.UTF-8
159Python é uma linguagem de scripts interpretada orientada a objetos.
160Contém suporte para carga dinâmica de objetos, classes, módulos e
161exceções. Adicionar interfaces para novos sistemas de biblioteca
162através de código C é simples, tornando Python fácil de usar em
163ambientes particulares/personalizados.
164
165Este pacote Python inclui a maioria do módulos padrão Python, junto
166com módulos para interfaceamento para o conjunto de componentes Tix
167para Tk e RPM.
168
169%description -l ru.UTF-8
170Python - это интерпретируемый, объектно-ориентированный язык
171программирования. Он поддерживает динамическую загрузку объектов,
172классы, модули и обработку исключительных ситуаций (exceptions).
173Простота добавления интерфейсов к новым системным библиотекам через
174код на языке C делает Python хорошим выбором для использования в
175специальных конфигурациях.
176
177%description -l tr.UTF-8
178Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
179sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
180destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
181paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
182arayüz birimlerini de içerir.
183
184%description -l uk.UTF-8
185Python - це інтерпретована, об'єктно-орієнтована мова програмування.
186Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
187виключних ситуацій (exceptions). Простота додавання інтерфейсів для
188нових системних бібліотек через код на мові C робить Python добрим
189вибором для використання в спеціальних конфігураціях.
190
191%package libs
192Summary: Python library
193Summary(pl.UTF-8): Biblioteka języka Python
194Group: Libraries/Python
195# broken detection in rpm/pythondeps.sh
196Provides: python(abi) = %{py_ver}
197# for compatibility with existing Ac packages
198Provides: python(bytecode) = %{py_ver}
2072c60e 199%{!?with_info:Obsoletes: python3-doc-info}
9416f74d
AM
200
201%description libs
202Python shared library and very essental modules for Python binary.
203
204%description libs -l pl.UTF-8
205Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
206dla Pythona.
207
208%package modules
209Summary: Python modules
210Summary(pl.UTF-8): Moduły języka Python
211Group: Libraries/Python
212Requires: %{name}-libs = %{epoch}:%{version}-%{release}
fef40d51 213Obsoletes: python3-modules-sqlite
9416f74d
AM
214
215%description modules
216Python officially distributed modules.
217
218%description modules -l pl.UTF-8
219Oficjalnie rozprowadzane moduły języka Python.
220
2072c60e 221%package -n pydoc3
9416f74d
AM
222Summary: Python interactive module documentation access support
223Summary(pl.UTF-8): Interaktywne korzystanie z dokumentacji modułów języka Python
224Group: Applications
225Requires: %{name}-modules = %{epoch}:%{version}-%{release}
226
2072c60e 227%description -n pydoc3
9416f74d
AM
228Python interactive module documentation access support.
229
2072c60e 230%description -n pydoc3 -l pl.UTF-8
9416f74d
AM
231Interaktywne korzystanie z dokumentacji modułów języka Python.
232
2072c60e 233%package -n idle3
9416f74d
AM
234Summary: IDE for Python language
235Summary(pl.UTF-8): IDE dla języka Python
236Group: Applications
237Requires: %{name}-tkinter = %{epoch}:%{version}-%{release}
238
2072c60e 239%description -n idle3
9416f74d
AM
240IDE for Python language.
241
2072c60e 242%description -n idle3 -l pl.UTF-8
9416f74d
AM
243IDE dla języka Python.
244
245%package devel
246Summary: Libraries and header files for building python code
247Summary(de.UTF-8): Libraries und Header-Dateien zum Erstellen von Python-Code
248Summary(es.UTF-8): Bibliotecas y archivos de inclusión para construir programas en python
249Summary(fr.UTF-8): Bibliothèques et en-têtes pour construire du code python
250Summary(pl.UTF-8): Pliki nagłówkowe i biblioteki Pythona
251Summary(pt_BR.UTF-8): Bibliotecas e arquivos de inclusão para o Python
252Summary(ru.UTF-8): Библиотеки и хедеры для построения кода на языке Python
253Summary(tr.UTF-8): Python ile geliştirme yapmak için gerekli dosyalar
254Summary(uk.UTF-8): Бібліотеки та хедери для програмування на мові Python
255Group: Development/Languages/Python
256Requires: %{name}-libs = %{epoch}:%{version}-%{release}
257
258%description devel
259The Python interpreter is relatively easy to extend with dynamically
260loaded extensions and to embed in other programs. This package
261contains the header files and libraries which are needed to do both of
262these tasks.
263
264%description devel -l de.UTF-8
265Der Python-Interpretierer ist relativ einfach anhand von dynamisch
266ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
267integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
268die für beide Aufgaben erforderlich sind.
269
270%description devel -l es.UTF-8
271El interpretador Python permite incluir con facilidad extensiones
272cargadas dinámicamente. Python es también fácil de ser empotrado en
273otros programas. Este paquete contiene los archivos de inclusión y
274bibliotecas necesarios para estas dos tareas.
275
276%description devel -l fr.UTF-8
277L'interpréteur Python est relativement facile à étendre avec des
278extensions chargées dynamiquement et à insérer dans d'autres
279programmes. Ce paquetage contient les en-têtes et les bibliothèques
280nécessaires à ces deux tâches.
281
282%description devel -l pl.UTF-8
283Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
284dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
285osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
286wszystko inne co potrzebne do tych celów.
287
288%description devel -l pt_BR.UTF-8
289O interpretador Python permite incluir com facilidade extensões
290carregadas dinamicamente. Python é também fácil de ser embutido em
291outros programas. Este pacote contém os arquivos de inclusão e
292bibliotecas necessários para estas duas tarefas.
293
294%description devel -l ru.UTF-8
295Интерпретатор Python относительно легко расширяется при помощи
296динамически загружаемых расширений и встраивается в другие программы.
297Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
298задач.
299
300%description devel -l tr.UTF-8
301Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
302dosyalarını ve kitaplıkları içerir.
303
304%description devel -l uk.UTF-8
305Інтерпретатор Python відносно легко розширюється за допомогою
306розширень з динамічною загрузкою та вбудовується в інші програми. Цей
307пакет містить хедери та бібліотеки, необхідні для обох цих задач.
308
309%package devel-src
310Summary: Python module sources
311Summary(pl.UTF-8): Pliki źródłowe modułów Pythona
312Group: Development/Languages/Python
313Requires: %{name}-modules = %{epoch}:%{version}-%{release}
314
315%description devel-src
316Python module sources.
317
318%description devel-src -l pl.UTF-8
319Pliki źródłowe modułów Pythona.
320
321%package devel-tools
322Summary: Python development tools
323Summary(pl.UTF-8): Narzędzia programistyczne języka Python
324Group: Development/Languages/Python
325Requires: %{name}-modules = %{epoch}:%{version}-%{release}
326
327%description devel-tools
328Python development tools such as profilers and debugger.
329
330%description devel-tools -l pl.UTF-8
331Narzędzia programistyczne języka Python takie jak profiler oraz
332debugger.
333
30b0ff7b
AF
334%package 2to3
335Summary: Automated Python 2 to 3 code translation
0cf503a8 336Summary(pl.UTF-8): Automatyczne tłumaczenie kodu Pythona 2 do 3
30b0ff7b
AF
337Group: Development/Languages/Pythona
338
339%description 2to3
0cf503a8
JB
3402to3 is a Python program that reads Python 2.x source code and applies
341a series of fixers to transform it into valid Python 3.x code. The
342standard library contains a rich set of fixers that will handle almost
343all code. 2to3 supporting library lib2to3 is, however, a flexible and
344generic library, so it is possible to write your own fixers for 2to3.
345lib2to3 could also be adapted to custom applications in which Python
346code needs to be edited automatically.
347
348%description 2to3 -l pl.UTF-8
3492to3 to program w Pythonie czytający od źródłowy w Pythonie 2.x i
350aplikujący serię poprawek przekształcających go w poprawny kod w
351Pythonie 3.x. Biblioteka standardowa zawiera duży zbiór poprawek
352obsługujących większość kodu. Biblioteka wspierająca 2to3 (lib2to3)
353jest jednak elastyczną i ogólną biblioteką, więc można pisać własne
354poprawki dla 2to3. lib2to3 można także zaadaptować na potrzeby
355własnych zastosowań, w których kod w Pythonie musi być modyfikowany
356automatycznie.
30b0ff7b 357
9416f74d
AM
358%package static
359Summary: Static python library
360Summary(pl.UTF-8): Statyczna biblioteka Pythona
361Group: Development/Languages/Python
362Requires: %{name}-devel = %{epoch}:%{version}-%{release}
363
364%description static
365Static python library.
366
367%description static -l pl.UTF-8
368Statyczna biblioteka Pythona.
369
9416f74d
AM
370%package doc-info
371Summary: Documentation on Python in texinfo format
372Summary(pl.UTF-8): Dokumentacja do Pythona w formacie texinfo
373Group: Documentation
374
375%description doc-info
376Documentation on Python in texinfo format.
377
378%description doc-info -l pl.UTF-8
379Dokumentacja do Pythona w formacie texinfo.
380
381%package tkinter
382Summary: Standard Python interface to the Tk GUI toolkit
383Summary(de.UTF-8): Grafische Tk-Schnittstelle für Python
384Summary(es.UTF-8): Interfaz de GUI Tk para Python
385Summary(fr.UTF-8): Interface graphique Tk pour Python
386Summary(pl.UTF-8): Standardowy interfejs Pythona do biblioteki Tk
387Summary(pt_BR.UTF-8): Interface GUI Tk para Phyton
388Summary(tr.UTF-8): Python için grafik kullanıcı arayüzü
389Group: Libraries/Python
390Requires: %{name}-modules = %{epoch}:%{version}-%{release}
391Requires: tcl >= 8.4.3
392Requires: tix >= 1:8.1.4-4
393Requires: tk >= 8.4.3
394
395%description tkinter
396Standard Python interface to the Tk GUI toolkit.
397
398%description tkinter -l de.UTF-8
399Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
400vielen Konfigurations-Tools genutzt.
401
402%description tkinter -l es.UTF-8
403Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
404herramientas de configuración.
405
406%description tkinter -l fr.UTF-8
407Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
408beaucoup des outils de configuration.
409
410%description tkinter -l pl.UTF-8
411Standardowy interfejs Pythona do biblioteki Tk.
412
413%description tkinter -l pt_BR.UTF-8
414Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
415muitas ferramentas de configuração.
416
417%description tkinter -l ru.UTF-8
418Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
419
420%description tkinter -l tr.UTF-8
421Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
422kullanılan grafik bir arayüzdür.
423
424%description tkinter -l uk.UTF-8
425Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
426
427%package examples
428Summary: Example programs in Python
429Summary(pl.UTF-8): Przykładowe programy w Pythonie
430Group: Development/Languages/Python
431
432%description examples
433Example programs in Python.
434
435These are for Python 2.3.4, not %{version}.
436
437%description examples -l pl.UTF-8
438Przykładowe programy w Pythonie.
439
440Przykłady te są dla Pythona 2.3.4, nie %{version}.
441
442%prep
0cf503a8 443%setup -q -n Python-%{version}
a20e3138 444%patch0 -p1
30b0ff7b 445%patch1 -p1
e3852288
JB
446%patch2 -p1
447%patch3 -p1
9416f74d
AM
448
449%build
9416f74d 450%{__autoconf}
31552fa6 451CPPFLAGS="-I/usr/include/ncursesw %{rpmcppflags}"; export CPPFLAGS
9416f74d 452%configure \
3ba70ac2 453 --with-cxx-main="%{__cxx}" \
9416f74d
AM
454 --enable-shared \
455 --enable-ipv6 \
19221b23 456 --with-dbmliborder=gdbm:bdb \
3ba70ac2 457 --with-wide-unicode \
9416f74d
AM
458 --with-signal-module \
459 --with-tsc \
460 --with-threads \
461 --with-doc-strings \
9416f74d 462 --with-fpectl \
3ba70ac2 463 --with-system-ffi \
23f5417d 464 --with-computed-gotos \
9416f74d
AM
465 LINKCC='$(PURIFY) $(CXX)' \
466 LDSHARED='$(CC) $(CFLAGS) -shared' \
467 BLDSHARED='$(CC) $(CFLAGS) -shared' \
468 LDFLAGS="%{rpmcflags} %{rpmldflags}"
469
470%{__make} \
23f5417d 471 OPT="%{rpmcflags} -fno-caller-saves" 2>&1 | awk '
9416f74d
AM
472BEGIN { fail = 0; logmsg = ""; }
473{
474 if ($0 ~ /\*\*\* WARNING:/) {
475 fail = 1;
476 logmsg = logmsg $0;
477 }
478 print $0;
479}
480END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
481
482LC_ALL=C
483export LC_ALL
484%if %{with tests}
485binlibdir=`echo build/lib.*`
486%{__make} test \
487 TESTOPTS="%{test_flags} %{test_list}" \
3ba70ac2 488 TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
9416f74d
AM
489%endif
490
491%install
492rm -rf $RPM_BUILD_ROOT
493install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
494 $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
495 $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
496 $RPM_BUILD_ROOT%{_infodir} \
497 $RPM_BUILD_ROOT/etc/shrc.d
498
499%{__make} install \
500 DESTDIR=$RPM_BUILD_ROOT
501
502%if %{with info}
503%{__make} -C Doc/info
504install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
505%endif
506
9416f74d 507install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
4449431f 508cp -a Tools $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
9416f74d
AM
509
510#
511# create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
512#
513
514# for python devel tools
515for script in timeit profile pdb pstats; do
24586eb0
AM
516 echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
517done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
9416f74d 518
24586eb0
AM
519echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
520 >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
9416f74d
AM
521
522sed 's/=/ /' \
24586eb0
AM
523 < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
524 > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
9416f74d
AM
525
526# for python modules
527for script in smtpd webbrowser; do
24586eb0
AM
528 echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
529done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
9416f74d
AM
530
531sed 's/=/ /' \
24586eb0
AM
532 < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
533 > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
9416f74d
AM
534
535# xgettext specific for Python code
536#
537# we will have two commands: pygettext.py (an alias) and pygettext;
538# this way there are no import (which is impossible now) conflicts and
539# pygettext.py is provided for compatibility
24586eb0
AM
540install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
541
9416f74d
AM
542# just to cut the noise, as they are not packaged (now)
543# first tests
e3852288
JB
544%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/test
545%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
546%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
547%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/email/test
548%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/importlib/test
549%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
550%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
551%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/tkinter/test
9416f74d
AM
552
553# other files
e3852288
JB
554%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
555%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
556%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
557%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
558%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
559%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
acd14a9e 560# already in %%doc
e3852288 561%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
9416f74d
AM
562
563%clean
564rm -rf $RPM_BUILD_ROOT
565
566%post libs -p /sbin/ldconfig
567%postun libs -p /sbin/ldconfig
568
e3852288 569%post doc-info -p /sbin/postshell
a20bb9dc 570-/usr/sbin/fix-info-dir -c %{_infodir}
9416f74d 571
e3852288 572%postun doc-info -p /sbin/postshell
a20bb9dc 573-/usr/sbin/fix-info-dir -c %{_infodir}
9416f74d
AM
574
575%files
576%defattr(644,root,root,755)
24586eb0 577%attr(755,root,root) %{_bindir}/python%{py_ver}
c7fdbe10 578%attr(755,root,root) %{_bindir}/python%{py_abi}
306c0f2d 579%attr(755,root,root) %{_bindir}/python3
c7fdbe10
JB
580%{_mandir}/man1/python%{py_ver}.1*
581
582%files libs
583%defattr(644,root,root,755)
584%doc LICENSE
585%attr(755,root,root) %{_libdir}/libpython%{py_abi}.so.*.*
586
587%dir %{py_libdir}
588%dir %{py_dyndir}
589%dir %{py_sitedir}
590%dir %{py_scriptdir}
591%dir %{py_sitescriptdir}
592
593# shared modules required by python library
594%attr(755,root,root) %{py_dyndir}/_struct.cpython-*.so
595
596# modules required by python library
597%{py_scriptdir}/_abcoll.py[co]
598%{py_scriptdir}/_weakrefset.py[co]
599%{py_scriptdir}/abc.py[co]
600%{py_scriptdir}/codecs.py[co]
601%{py_scriptdir}/copyreg.py[co]
602%{py_scriptdir}/genericpath.py[co]
603%{py_scriptdir}/locale.py[co]
604%{py_scriptdir}/io.py[co]
605%{py_scriptdir}/posixpath.py[co]
606%{py_scriptdir}/site.py[co]
607%{py_scriptdir}/stat.py[co]
608%{py_scriptdir}/os.py[co]
609# needed by the dynamic sys.lib patch
610%{py_scriptdir}/types.py[co]
611
612# encodings required by python library
613%dir %{py_scriptdir}/encodings
614%{py_scriptdir}/encodings/*.py[co]
9416f74d
AM
615
616%files modules
617%defattr(644,root,root,755)
24586eb0 618/etc/shrc.d/python*-modules*
b2f86a67
AF
619%exclude %{py_scriptdir}/_abcoll.py[co]
620%exclude %{py_scriptdir}/_weakrefset.py[co]
621%exclude %{py_scriptdir}/abc.py[co]
9416f74d 622%exclude %{py_scriptdir}/codecs.py[co]
acd14a9e 623%exclude %{py_scriptdir}/copyreg.py[co]
b2f86a67
AF
624%exclude %{py_scriptdir}/genericpath.py[co]
625%exclude %{py_scriptdir}/io.py[co]
9416f74d
AM
626%exclude %{py_scriptdir}/locale.py[co]
627%exclude %{py_scriptdir}/posixpath.py[co]
628%exclude %{py_scriptdir}/pdb.py[co]
629%exclude %{py_scriptdir}/profile.py[co]
630%exclude %{py_scriptdir}/pstats.py[co]
631%exclude %{py_scriptdir}/pydoc.py[co]
632%exclude %{py_scriptdir}/site.py[co]
633%exclude %{py_scriptdir}/stat.py[co]
634%exclude %{py_scriptdir}/timeit.py[co]
635%exclude %{py_scriptdir}/os.py[co]
636%exclude %{py_scriptdir}/encodings/*.py[co]
637%exclude %{py_scriptdir}/types.py[co]
638
639%{py_scriptdir}/*.py[co]
640
c7fdbe10 641%{py_dyndir}/Python-%{py_ver}-py*.egg-info
9416f74d
AM
642
643#
644# list .so modules to be sure that all of them are built
645#
646
929a5a93 647# modules below do not work on 64-bit architectures
9416f74d
AM
648# see Python README file for explanation
649%ifnarch alpha ia64 ppc64 sparc64 %{x8664}
c7fdbe10 650%attr(755,root,root) %{py_dyndir}/audioop.cpython-*.so
9416f74d
AM
651%endif
652
c7fdbe10
JB
653%attr(755,root,root) %{py_dyndir}/_bisect.cpython-*.so
654%attr(755,root,root) %{py_dyndir}/_codecs_cn.cpython-*.so
655%attr(755,root,root) %{py_dyndir}/_codecs_hk.cpython-*.so
656%attr(755,root,root) %{py_dyndir}/_codecs_iso2022.cpython-*.so
657%attr(755,root,root) %{py_dyndir}/_codecs_jp.cpython-*.so
658%attr(755,root,root) %{py_dyndir}/_codecs_kr.cpython-*.so
659%attr(755,root,root) %{py_dyndir}/_codecs_tw.cpython-*.so
660%attr(755,root,root) %{py_dyndir}/_csv.cpython-*.so
661%attr(755,root,root) %{py_dyndir}/_ctypes*.cpython-*.so
662%attr(755,root,root) %{py_dyndir}/_curses_panel.cpython-*.so
663%attr(755,root,root) %{py_dyndir}/_curses.cpython-*.so
664%attr(755,root,root) %{py_dyndir}/_datetime.cpython-*.so
9416f74d 665%ifnarch sparc64
c7fdbe10 666%attr(755,root,root) %{py_dyndir}/_dbm.cpython-*.so
9416f74d 667%endif
c7fdbe10
JB
668%attr(755,root,root) %{py_dyndir}/_elementtree.cpython-*.so
669%attr(755,root,root) %{py_dyndir}/_gdbm.cpython-*.so
670%attr(755,root,root) %{py_dyndir}/_hashlib.cpython-*.so
671%attr(755,root,root) %{py_dyndir}/_heapq.cpython-*.so
672%attr(755,root,root) %{py_dyndir}/_json.cpython-*.so
673%attr(755,root,root) %{py_dyndir}/_lsprof.cpython-*.so
674%attr(755,root,root) %{py_dyndir}/_multibytecodec.cpython-*.so
675%attr(755,root,root) %{py_dyndir}/_multiprocessing.cpython-*.so
676%attr(755,root,root) %{py_dyndir}/_pickle.cpython-*.so
677%attr(755,root,root) %{py_dyndir}/_random.cpython-*.so
678%attr(755,root,root) %{py_dyndir}/_socket.cpython-*.so
679%attr(755,root,root) %{py_dyndir}/_ssl.cpython-*.so
680%attr(755,root,root) %{py_dyndir}/_testcapi.cpython-*.so
681%attr(755,root,root) %{py_dyndir}/array.cpython-*.so
682%attr(755,root,root) %{py_dyndir}/atexit.cpython-*.so
683%attr(755,root,root) %{py_dyndir}/binascii.cpython-*.so
684%attr(755,root,root) %{py_dyndir}/bz2.cpython-*.so
685%attr(755,root,root) %{py_dyndir}/cmath.cpython-*.so
686%attr(755,root,root) %{py_dyndir}/crypt.cpython-*.so
687%attr(755,root,root) %{py_dyndir}/fcntl.cpython-*.so
688%attr(755,root,root) %{py_dyndir}/grp.cpython-*.so
689%attr(755,root,root) %{py_dyndir}/math.cpython-*.so
690%attr(755,root,root) %{py_dyndir}/mmap.cpython-*.so
691%attr(755,root,root) %{py_dyndir}/nis.cpython-*.so
692%attr(755,root,root) %{py_dyndir}/ossaudiodev.cpython-*.so
693%attr(755,root,root) %{py_dyndir}/parser.cpython-*.so
694%attr(755,root,root) %{py_dyndir}/pyexpat.cpython-*.so
695%attr(755,root,root) %{py_dyndir}/readline.cpython-*.so
696%attr(755,root,root) %{py_dyndir}/resource.cpython-*.so
697%attr(755,root,root) %{py_dyndir}/select.cpython-*.so
698%attr(755,root,root) %{py_dyndir}/syslog.cpython-*.so
699%attr(755,root,root) %{py_dyndir}/termios.cpython-*.so
700%attr(755,root,root) %{py_dyndir}/time.cpython-*.so
701%attr(755,root,root) %{py_dyndir}/spwd.cpython-*.so
702%attr(755,root,root) %{py_dyndir}/unicodedata.cpython-*.so
703%attr(755,root,root) %{py_dyndir}/zlib.cpython-*.so
9416f74d
AM
704
705%dir %{py_scriptdir}/plat-*
706%{py_scriptdir}/plat-*/*.py[co]
707
9416f74d
AM
708%dir %{py_scriptdir}/ctypes
709%dir %{py_scriptdir}/ctypes/macholib
35ff21ac 710
9416f74d
AM
711%{py_scriptdir}/ctypes/*.py[co]
712%{py_scriptdir}/ctypes/macholib/*.py[co]
acd14a9e 713%doc %{py_scriptdir}/ctypes/macholib/README.ctypes
9416f74d
AM
714
715%dir %{py_scriptdir}/curses
716%{py_scriptdir}/curses/*.py[co]
717
acd14a9e
AF
718%dir %{py_scriptdir}/dbm
719%{py_scriptdir}/dbm/*.py[co]
720
9416f74d
AM
721%dir %{py_scriptdir}/distutils
722%dir %{py_scriptdir}/distutils/command
acd14a9e 723%doc %{py_scriptdir}/distutils/README
9416f74d
AM
724%{py_scriptdir}/distutils/*.py[co]
725%{py_scriptdir}/distutils/command/*.py[co]
acd14a9e 726%{py_scriptdir}/distutils/command/command_template
9416f74d
AM
727
728%dir %{py_scriptdir}/email
729%dir %{py_scriptdir}/email/mime
730%{py_scriptdir}/email/*.py[co]
731%{py_scriptdir}/email/mime/*.py[co]
732
acd14a9e
AF
733%dir %{py_scriptdir}/html
734%{py_scriptdir}/html/*.py[co]
735
736%dir %{py_scriptdir}/http
737%{py_scriptdir}/http/*.py[co]
738
fef40d51
AF
739%dir %{py_scriptdir}/importlib
740%{py_scriptdir}/importlib/*.py[co]
741
acd14a9e
AF
742%dir %{py_scriptdir}/json
743%{py_scriptdir}/json/*.py[co]
744
9416f74d
AM
745%dir %{py_scriptdir}/logging
746%{py_scriptdir}/logging/*.py[co]
747
acd14a9e
AF
748%dir %{py_scriptdir}/multiprocessing
749%{py_scriptdir}/multiprocessing/*.py[co]
750%dir %{py_scriptdir}/multiprocessing/dummy
751%{py_scriptdir}/multiprocessing/dummy/*.py[co]
752
753%dir %{py_scriptdir}/urllib
754%{py_scriptdir}/urllib/*.py[co]
755
9416f74d
AM
756%dir %{py_scriptdir}/wsgiref
757%{py_scriptdir}/wsgiref/*.py[co]
acd14a9e 758%{py_scriptdir}/wsgiref.egg-info
9416f74d
AM
759
760%dir %{py_scriptdir}/xml
761%dir %{py_scriptdir}/xml/dom
762%dir %{py_scriptdir}/xml/etree
763%dir %{py_scriptdir}/xml/parsers
764%dir %{py_scriptdir}/xml/sax
765%{py_scriptdir}/xml/*.py[co]
766%{py_scriptdir}/xml/dom/*.py[co]
767%{py_scriptdir}/xml/etree/*.py[co]
768%{py_scriptdir}/xml/parsers/*.py[co]
769%{py_scriptdir}/xml/sax/*.py[co]
770
acd14a9e
AF
771%dir %{py_scriptdir}/xmlrpc
772%{py_scriptdir}/xmlrpc/*.py[co]
773
c7fdbe10 774%attr(755,root,root) %{py_dyndir}/_sqlite3.cpython-*.so
9416f74d
AM
775%dir %{py_scriptdir}/sqlite3
776%{py_scriptdir}/sqlite3/*.py[co]
777
2072c60e 778%files -n pydoc3
9416f74d 779%defattr(644,root,root,755)
19221b23 780%attr(755,root,root) %{_bindir}/pydoc3
9416f74d 781%{py_scriptdir}/pydoc.py[co]
fef40d51
AF
782%dir %{py_scriptdir}/pydoc_data
783%{py_scriptdir}/pydoc_data/*.py[co]
9416f74d 784
2072c60e 785%files -n idle3
9416f74d 786%defattr(644,root,root,755)
19221b23 787%attr(755,root,root) %{_bindir}/idle3
9416f74d
AM
788%dir %{py_scriptdir}/idlelib
789%dir %{py_scriptdir}/idlelib/Icons
790%{py_scriptdir}/idlelib/*.py[co]
acd14a9e
AF
791%doc %{py_scriptdir}/idlelib/*.txt
792%doc %{py_scriptdir}/idlelib/ChangeLog
9416f74d
AM
793%{py_scriptdir}/idlelib/Icons/*
794%{py_scriptdir}/idlelib/*.def
795
796%files devel
797%defattr(644,root,root,755)
798%doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
c7fdbe10
JB
799%attr(755,root,root) %{_bindir}/python%{py_ver}-config
800%attr(755,root,root) %{_bindir}/python%{py_abi}-config
801%attr(755,root,root) %{_bindir}/python3-config
802%attr(755,root,root) %{_libdir}/libpython%{py_abi}.so
803%attr(755,root,root) %{_libdir}/libpython3.so
9416f74d
AM
804%dir %{py_incdir}
805%{py_incdir}/*.h
c7fdbe10
JB
806%{_pkgconfigdir}/python-%{py_ver}.pc
807%{_pkgconfigdir}/python-%{py_abi}.pc
808%{_pkgconfigdir}/python3.pc
809
810%dir %{py_libdir}/config-%{py_abi}
811%attr(755,root,root) %{py_libdir}/config-%{py_abi}/makesetup
812%attr(755,root,root) %{py_libdir}/config-%{py_abi}/install-sh
813%{py_libdir}/config-%{py_abi}/Makefile
814%{py_libdir}/config-%{py_abi}/Setup
815%{py_libdir}/config-%{py_abi}/Setup.config
816%{py_libdir}/config-%{py_abi}/Setup.local
817%{py_libdir}/config-%{py_abi}/config.c
818%{py_libdir}/config-%{py_abi}/config.c.in
819%{py_libdir}/config-%{py_abi}/python.o
9416f74d
AM
820
821%files devel-src
822%defattr(644,root,root,755)
823%attr(-,root,root) %{py_scriptdir}/*.py
824%{py_scriptdir}/plat-*/*.py
9416f74d
AM
825%{py_scriptdir}/ctypes/*.py
826%{py_scriptdir}/ctypes/macholib/*.py
9416f74d 827%{py_scriptdir}/curses/*.py
acd14a9e 828%{py_scriptdir}/dbm/*.py
9416f74d
AM
829%{py_scriptdir}/distutils/*.py
830%{py_scriptdir}/distutils/command/*.py
831%{py_scriptdir}/email/*.py
832%{py_scriptdir}/email/mime/*.py
fef40d51 833%{py_scriptdir}/encodings/*.py
acd14a9e
AF
834%{py_scriptdir}/html/*.py
835%{py_scriptdir}/http/*.py
fef40d51
AF
836%{py_scriptdir}/idlelib/*.py
837%{py_scriptdir}/importlib/*.py
acd14a9e
AF
838%{py_scriptdir}/json/*.py
839%{py_scriptdir}/lib2to3/*.py
acd14a9e 840%{py_scriptdir}/lib2to3/pgen2/*.py
9416f74d 841%{py_scriptdir}/logging/*.py
acd14a9e
AF
842%{py_scriptdir}/multiprocessing/*.py
843%{py_scriptdir}/multiprocessing/dummy/*.py
fef40d51 844%{py_scriptdir}/pydoc_data/*.py
9416f74d 845%{py_scriptdir}/sqlite3/*.py
fef40d51 846%{py_scriptdir}/tkinter/*.py
acd14a9e 847%{py_scriptdir}/urllib/*.py
9416f74d
AM
848%{py_scriptdir}/wsgiref/*.py
849%{py_scriptdir}/xml/*.py
850%{py_scriptdir}/xml/dom/*.py
851%{py_scriptdir}/xml/etree/*.py
852%{py_scriptdir}/xml/parsers/*.py
853%{py_scriptdir}/xml/sax/*.py
acd14a9e 854%{py_scriptdir}/xmlrpc/*.py
9416f74d
AM
855
856%files devel-tools
857%defattr(644,root,root,755)
24586eb0 858/etc/shrc.d/python*-devel*
9416f74d 859
24586eb0 860%attr(755,root,root) %{_bindir}/pygettext%{py_ver}
9416f74d 861
9416f74d
AM
862%{py_scriptdir}/pdb.py[co]
863%{py_scriptdir}/profile.py[co]
864%{py_scriptdir}/pstats.py[co]
865%{py_scriptdir}/timeit.py[co]
866
30b0ff7b 867%files 2to3
eb7b678c 868%attr(755,root,root) %{_bindir}/2to3-%{py_ver}
30b0ff7b
AF
869%dir %{py_scriptdir}/lib2to3
870%{py_scriptdir}/lib2to3/*.txt
871%{py_scriptdir}/lib2to3/*.pickle
872%{py_scriptdir}/lib2to3/*.py[co]
873%dir %{py_scriptdir}/lib2to3/fixes
be43ead0 874%{py_scriptdir}/lib2to3/fixes/*.py
30b0ff7b
AF
875%{py_scriptdir}/lib2to3/fixes/*.py[co]
876%dir %{py_scriptdir}/lib2to3/pgen2
877%{py_scriptdir}/lib2to3/pgen2/*.py[co]
878
9416f74d
AM
879%files static
880%defattr(644,root,root,755)
6eede82b 881%{_libdir}/libpython%{py_abi}.a
9416f74d
AM
882
883%files examples
884%defattr(644,root,root,755)
885%{_examplesdir}/%{name}-%{version}
886
9416f74d
AM
887%if %{with info}
888%files doc-info
889%defattr(644,root,root,755)
890%{_infodir}/*.info*
891%endif
892
893%if %{with tkinter}
894%files tkinter
895%defattr(644,root,root,755)
acd14a9e
AF
896%dir %{py_scriptdir}/tkinter
897%{py_scriptdir}/tkinter/*.py[co]
c7fdbe10 898%attr(755,root,root) %{py_dyndir}/_tkinter.cpython-*.so
9416f74d 899%endif
This page took 0.198075 seconds and 4 git commands to generate.