]> git.pld-linux.org Git - packages/opera.git/blame - opera.spec
- up to 10.60-0.6372
[packages/opera.git] / opera.spec
CommitLineData
a79ddb02
AM
1# BRANCHES:
2# - HEAD - stable version
3# - DEVEL - development version
0de1d20d 4# - WEEKLY - weekly development version (sometimes it's on DEVEL)
0de1d20d 5%bcond_without distributable # distributable or not
e789f1d0 6
978003e4
AM
7%define subver 6372
8%define subverdir 26449_10.60-6372
b400423e 9%define rel 1
40d43d2d 10Summary: World fastest web browser
0580138e 11Summary(pl.UTF-8): Najszybsza przeglądarka WWW na świecie
40d43d2d 12Name: opera
948f1843 13Version: 10.60
b400423e 14Release: 0.%{subver}.%{rel}
94132831 15Epoch: 2
ae712f51 16License: Distributable
40d43d2d 17Group: X11/Applications/Networking
948f1843 18Source0: http://snapshot.opera.com/unix/%{subverdir}/%{name}-%{version}-%{subver}.i386.linux.tar.bz2
978003e4 19# Source0-md5: efccbff4196d7c13d53ea1aa7351b44f
0de1d20d 20%{!?with_distributable:NoSource: 0}
948f1843 21Source1: http://snapshot.opera.com/unix/%{subverdir}/%{name}-%{version}-%{subver}.x86_64.linux.tar.bz2
978003e4 22# Source1-md5: 6528c279f94af1e5337ad7b256a25608
52e96c7d 23%{!?with_distributable:NoSource: 1}
35677f25 24Patch0: %{name}-wrapper.patch
b400423e 25Patch1: %{name}-desktop.patch
00895999 26Patch2: %{name}-pluginpath.patch
8cb331c2 27URL: http://www.opera.com/
f6dbdb8e 28BuildRequires: rpmbuild(macros) >= 1.356
6eebcb83 29BuildRequires: sed >= 4.0
00895999 30Requires(post,postun): desktop-file-utils
dc0906c4
ER
31Requires(post,postun): gtk+2
32Requires(post,postun): hicolor-icon-theme
b400423e 33Requires(post,postun): shared-mime-info
f6dbdb8e 34Requires: browser-plugins >= 2.0
2f4fa75a 35Requires: freetype >= 2
92d2fb78 36Suggests: gstreamer-theora
cf17d6f2 37Suggests: gstreamer-vorbis
3b8cc5d5 38Provides: wwwbrowser
37147bb6 39Obsoletes: opera-i18n
52e96c7d 40ExclusiveArch: %{ix86} %{x8664}
8cb331c2 41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
1e3271ab 42
cf17d6f2
ER
43%define _enable_debug_packages 0
44
45%define _plugindir %{_libdir}/opera/plugins
b400423e 46%define _operadocdir %{_docdir}/%{name}-%{version}
8cb331c2 47
48%description
49Opera is world fastest web browser. It supports most of nowaday
52e96c7d 50extensions of HTML. And it is quite stable.
8cb331c2 51
14283174
JR
52%description -l pl.UTF-8
53Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
52e96c7d 54dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna.
37147bb6
AM
55
56%package plugin32
57Summary: Opera 32-bit plugins support
58Summary(pl.UTF-8): Obsługa 32-bitowych wtyczek Opery
59Group: X11/Applications/Networking
60Requires: %{name} = %{epoch}:%{version}-%{release}
61
62%description plugin32
63Opera 32-bit plugins support.
64
65%description plugin32 -l pl.UTF-8
66Obsługa 32-bitowych wtyczek Opery.
58d714bb 67
8cb331c2 68%prep
643785f9 69%ifarch %{ix86}
b400423e 70%setup -q -T -b0 -n %{name}-%{version}-%{subver}.i386.linux
b966c84f 71%endif
0de1d20d 72%ifarch %{x8664}
b400423e 73%setup -q -T -b1 -n %{name}-%{version}-%{subver}.x86_64.linux
af2f4f47 74
c8f7ea63 75%endif
b400423e
ER
76sed -i -e '
77 s,@@{PREFIX},%{_prefix},g
78 s,@@{SUFFIX},,
79 s,@@{_SUFFIX},,
00895999
ER
80' share/{applications/*.desktop,mime/packages/*.xml}
81
82sed -i -e 's,kfmclient exec,xdg-open,' share/opera/defaults/filehandler.ini
b400423e
ER
83
84%patch0 -p1
85%patch1 -p1
af2f4f47
ER
86
87# remove lib32/lib64 paths so patch2 can apply (i386 build contained lib64 as well, oh well)
88%{__sed} -i -e '/lib32\|lib64/d;$d' share/opera/defaults/pluginpath.ini
00895999 89%patch2 -p1
8cb331c2 90
b400423e 91mv lib/opera/plugins/README README.plugins
00895999 92mv share/opera/defaults/license.txt .
b400423e
ER
93mv share/doc/opera/* .
94
95# nobody wants scalable huge icons
96rm -rf share/icons/hicolor/scalable
97
98# opera packaging tools we don't need runtime
99mv share/opera/package .
0de1d20d 100
8cb331c2 101%install
102rm -rf $RPM_BUILD_ROOT
52e96c7d 103install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_datadir},%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
8cb331c2 104
f6dbdb8e
ER
105%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
106# opera does not use for .xpt files
107*.xpt
6ab3a1e1
ER
108
109# use mplayerplug-in-opera instead
110mplayerplug-in*
f6dbdb8e
ER
111EOF
112
b400423e
ER
113install -p opera* $RPM_BUILD_ROOT%{_bindir}
114cp -a lib/opera $RPM_BUILD_ROOT%{_libdir}
115cp -a share/* $RPM_BUILD_ROOT%{_datadir}
116#cp -a etc/*.ini $RPM_BUILD_ROOT%{_sysconfdir}
a8029af7 117
b400423e 118sed -i -e 's#/usr/lib/opera#%{_libdir}/opera#g' $RPM_BUILD_ROOT%{_bindir}/opera
cf9bda24 119
8cb331c2 120%clean
121rm -rf $RPM_BUILD_ROOT
122
f6dbdb8e 123%post
b400423e 124%update_mime_database
dc0906c4 125%update_icon_cache hicolor
00895999 126%update_desktop_database_post
f6dbdb8e
ER
127%update_browser_plugins
128
129%postun
b400423e 130%update_mime_database
dc0906c4 131%update_icon_cache hicolor
00895999 132%update_desktop_database_postun
f6dbdb8e
ER
133if [ "$1" = 0 ]; then
134 %update_browser_plugins
135fi
136
8cb331c2 137%files
138%defattr(644,root,root,755)
c2ef0548 139%doc LICENSE
b400423e 140#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
f6dbdb8e
ER
141
142# browser plugins v2
0de1d20d 143%{_browserpluginsconfdir}/browsers.d/%{name}.*
144%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
f6dbdb8e 145
b400423e
ER
146%attr(755,root,root) %{_bindir}/opera
147%attr(755,root,root) %{_bindir}/opera-widget-manager
1e3271ab 148%dir %{_libdir}/opera
0f1c894e
AM
149%ifarch %{x8664}
150%exclude %{_libdir}/opera/*-ia32-*
151%endif
52e96c7d
AM
152%attr(755,root,root) %{_libdir}/opera/*.so
153%attr(755,root,root) %{_libdir}/opera/opera*
1e3271ab 154%dir %{_plugindir}
cc40c56b
AM
155%dir %{_libdir}/opera/gstreamer
156%dir %{_libdir}/opera/gstreamer/plugins
157%attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperamatroska.so
158%attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperavp8.so
a5b49fac
KK
159%dir %{_datadir}/opera
160%{_datadir}/opera/*.*
0de1d20d 161%{_datadir}/opera/defaults
162%{_datadir}/opera/extra
a5b49fac 163%{_datadir}/opera/skin
10b9f892 164#%{_datadir}/opera/scripts
a5b49fac 165%{_datadir}/opera/styles
0de1d20d 166%{_datadir}/opera/ui
e702c05e 167%{_datadir}/opera/unite
f8b4ca83 168%dir %{_datadir}/opera/locale
169%{_datadir}/opera/locale/en
10b9f892
AM
170%lang(be) %{_datadir}/opera/locale/be
171%lang(bg) %{_datadir}/opera/locale/bg
172%lang(cs) %{_datadir}/opera/locale/cs
173%lang(da) %{_datadir}/opera/locale/da
174%lang(de) %{_datadir}/opera/locale/de
175%lang(el) %{_datadir}/opera/locale/el
176%lang(en_GB) %{_datadir}/opera/locale/en-GB
177%lang(es_ES) %{_datadir}/opera/locale/es-ES
178%lang(es_LA) %{_datadir}/opera/locale/es-LA
179%lang(et) %{_datadir}/opera/locale/et
180%lang(fi) %{_datadir}/opera/locale/fi
181%lang(fr) %{_datadir}/opera/locale/fr
182%lang(fr_CA) %{_datadir}/opera/locale/fr-CA
183%lang(fy) %{_datadir}/opera/locale/fy
184%lang(hi) %{_datadir}/opera/locale/hi
185%lang(hr) %{_datadir}/opera/locale/hr
186%lang(hu) %{_datadir}/opera/locale/hu
187%lang(id) %{_datadir}/opera/locale/id
188%lang(it) %{_datadir}/opera/locale/it
189%lang(ja) %{_datadir}/opera/locale/ja
190%lang(ka) %{_datadir}/opera/locale/ka
191%lang(ko) %{_datadir}/opera/locale/ko
192%lang(lt) %{_datadir}/opera/locale/lt
193%lang(mk) %{_datadir}/opera/locale/mk
194%lang(nb) %{_datadir}/opera/locale/nb
195%lang(nl) %{_datadir}/opera/locale/nl
196%lang(nn) %{_datadir}/opera/locale/nn
197%lang(pl) %{_datadir}/opera/locale/pl
198%lang(pt) %{_datadir}/opera/locale/pt
199%lang(pt_BR) %{_datadir}/opera/locale/pt-BR
200%lang(ro) %{_datadir}/opera/locale/ro
201%lang(ru) %{_datadir}/opera/locale/ru
202%lang(sk) %{_datadir}/opera/locale/sk
203%lang(sr) %{_datadir}/opera/locale/sr
204%lang(sv) %{_datadir}/opera/locale/sv
205%lang(ta) %{_datadir}/opera/locale/ta
206%lang(te) %{_datadir}/opera/locale/te
207%lang(tr) %{_datadir}/opera/locale/tr
208%lang(uk) %{_datadir}/opera/locale/uk
b400423e 209%lang(vi) %{_datadir}/opera/locale/vi
37147bb6 210%lang(zh_CN) %{_datadir}/opera/locale/zh-cn
0de1d20d 211%lang(zh_HK) %{_datadir}/opera/locale/zh-hk
37147bb6 212%lang(zh_TW) %{_datadir}/opera/locale/zh-tw
b400423e 213%{_datadir}/mime/packages/opera-widget.xml
948f1843 214%{_datadir}/mime/packages/opera-unite-application.xml
7b1a5f81 215%{_desktopdir}/*.desktop
1e3271ab 216%{_mandir}/man1/opera.1*
b400423e
ER
217%{_mandir}/man1/opera-widget-manager.1*
218#%{_pixmapsdir}/opera.xpm
219%{_iconsdir}/hicolor/*/*/*.png
671735f8 220
0f1c894e
AM
221%ifarch %{x8664}
222%files plugin32
223%defattr(644,root,root,755)
224%attr(755,root,root) %{_libdir}/opera/*-ia32-*
225%endif
This page took 0.187245 seconds and 4 git commands to generate.