]> git.pld-linux.org Git - packages/gdb.git/blame - gdb.spec
- added readline8.2 patch from git (fixes build with readline 8.2.x)
[packages/gdb.git] / gdb.spec
CommitLineData
d7dc9553 1# NOTE: -lib package is used by fpc.spec
7566401a
ER
2
3# TODO
0e7ddf04 4# - debuginfod (BR: elfutils-debuginfod-devel >= 0.179)
124c2194 5# - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
a59c1d89 6# - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
854ea054 7# - reenable guile after https://sourceware.org/bugzilla/show_bug.cgi?id=21104 is fixed
e1daef87 8#
7566401a 9# Conditional build:
854ea054 10%bcond_with guile # Guile embedded scripting
2725d199 11%bcond_without python # build without python support
7566401a 12
5ff7d7dd 13Summary: A GNU source-level debugger for C, C++ and Fortran
0ec45698
ER
14Summary(de.UTF-8): Symbolischer Debugger für C und andere Sprachen
15Summary(es.UTF-8): Depurador de programas C y otras lenguajes
16Summary(fr.UTF-8): Débugger symbolique pour C et d'autres langages
17Summary(pl.UTF-8): Symboliczny odpluskwiacz dla C i innych języków
18Summary(pt_BR.UTF-8): Depurador de programas C e outras linguagens
19Summary(ru.UTF-8): Символический отладчик для C и других языков
20Summary(tr.UTF-8): C ve diğer diller için sembolik hata ayıklayıcı
21Summary(uk.UTF-8): Символьний відладчик для С та інших мов
22Summary(zh_CN.UTF-8): [开发]C和其他语言的调试器
23Summary(zh_TW.UTF-8): [.-A開發]C和.$)B其.-A他語.$)B言的調試器
0241102e 24Name: gdb
0e7ddf04
JB
25Version: 12.1
26Release: 1
d7c2fd3d 27License: GPL v3+
0241102e 28Group: Development/Debuggers
3b576511 29Source0: https://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
0e7ddf04 30# Source0-md5: 759a1b8d2b4d403367dd0e14fa04643d
31a43e77 31Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
feb56b14 32# Source1-md5: 2e8a48939ae282c12bbacdd54e398247
41611023 33Source3: %{name}-gstack.man
b90874d2
JR
34Patch100: gdb-6.6-buildid-locate.patch
35Patch101: gdb-6.6-buildid-locate-solib-missing-ids.patch
36Patch102: gdb-6.6-buildid-locate-rpm.patch
b90874d2 37Patch104: gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
321e94d6 38Patch105: gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
140f8057 39Patch106: gdb-6.6-buildid-locate-rpm-scl.patch
321e94d6 40Patch110: gdb-6.3-gstack-20050411.patch
a59c1d89
ER
41Patch1000: %{name}-readline.patch
42Patch1001: %{name}-info.patch
43Patch1002: %{name}-passflags.patch
8124607e 44Patch1003: %{name}-readline8.2.patch
a59c1d89 45Patch1005: %{name}-pretty-print-by-default.patch
84034fed 46Patch1006: buildid-locate-rpm-pld.patch
3a97e68e 47URL: http://www.gnu.org/software/gdb/
a7de96f0 48BuildRequires: autoconf >= 2.69
830462ab 49BuildRequires: automake
124c2194 50BuildRequires: babeltrace-devel >= 1.1.0
0e7ddf04 51BuildRequires: bison
b3dcfe9b 52BuildRequires: expat-devel
140f8057 53BuildRequires: flex >= 2.6.4
124c2194 54BuildRequires: gettext-tools >= 0.12.1
5458b868 55BuildRequires: gmp-devel
830e7ce9
JB
56%if %{with guile}
57BuildRequires: guile-devel >= 2.0
2a89498c 58BuildRequires: guile-devel < 3.2
830e7ce9 59%endif
b28748e1
AM
60%ifarch %{ix86} %{x8664}
61BuildRequires: libipt-devel
62%endif
5458b868 63BuildRequires: libmpc-devel
04bf7c80 64BuildRequires: libselinux-devel
124c2194 65BuildRequires: libstdc++-devel >= 6:4.8
0e7ddf04 66BuildRequires: libtool >= 2:2
124c2194 67BuildRequires: make >= 3.81
169fe030 68BuildRequires: mpfr-devel
4e6d01d3 69BuildRequires: ncurses-devel >= 5.2
b3dcfe9b 70BuildRequires: pkgconfig
bdc5760f 71BuildRequires: readline-devel
0e7ddf04 72BuildRequires: rpm-devel >= 4.6
fc1b3e2b 73BuildRequires: rpmbuild(macros) >= 1.219
830e7ce9 74BuildRequires: source-highlight-devel >= 3.0
169fe030 75BuildRequires: tar >= 1:1.22
3a97e68e 76BuildRequires: texinfo >= 4.4
830e7ce9 77BuildRequires: xxHash-devel
169fe030 78BuildRequires: xz
124c2194 79BuildRequires: xz-devel
ab050a48 80BuildRequires: zlib-devel
fc1b3e2b 81%if %{with python}
0e7ddf04 82BuildRequires: python3-devel >= 1:3.2
fc1b3e2b 83BuildRequires: rpm-pythonprov
5458b868 84Obsoletes: python-gdb < 7.3
da016e1e 85# for traceback module
0e7ddf04 86Requires: python3-modules >= 1:3.2
fc1b3e2b 87%endif
3d4c8009 88%{?with_guile:Requires: guile >= 2.0.12}
b4655cd1 89BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6aa96a1b 90
174fe25c
JP
91%define autoconf_ver %(rpm -q --qf='%%{VERSION}' autoconf)
92
6aa96a1b 93%description
92563ae4 94Gdb is a full featured, command driven debugger. Gdb allows you to
95trace the execution of programs and examine their internal state at
96any time. Gdb works for C and C++ compiled with the GNU C compiler
97gcc.
6aa96a1b 98
f01e46e5
JR
99%description -l de.UTF-8
100dem Sie die Ausführung von Programmen verfolgen und jederzeit den
101inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
92563ae4 102kompiliertes C++.
6aa96a1b 103
f01e46e5
JR
104%description -l es.UTF-8
105Este es un debugger orientado a comandos repleto de características.
106Te permite rastrear la ejecución de programas y examinar su estado
c15663f7 107interno a cualquier momento. Funciona para C y C++ compilado con el
108compilador GNU C.
109
f01e46e5
JR
110%description -l fr.UTF-8
111Débugger complet, piloté par commandes. Permet de tracer l'exécution
112des programmes et d'examiner à tout moment leur état interne.
113Fonctionne avec les binaires C et C++ compilés avec le compilateur C
92563ae4 114de GNU, gcc.
6aa96a1b 115
f01e46e5
JR
116%description -l pl.UTF-8
117Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
118śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
119umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
92563ae4 120przy pomocy kompilatora GNU (gcc).
6aa96a1b 121
f01e46e5
JR
122%description -l pt_BR.UTF-8
123Este é um debugger orientado a comandos repleto de características.
124Ele permite à você rastrear a execução de programas e examinar o seu
c15663f7 125estado interno a qualquer momento. Ele funciona para para C e C++
126compilado com o compilador GNU C.
127
f01e46e5
JR
128%description -l ru.UTF-8
129Это полноценный отладчик, управляемый командами. Он позволяет
130трассировать исполнение программ и изучать их внутреннее состояние в
131любой момент времени. Работает с программами на C и C++,
132скомпилированными GNU компилятором C (gcc, egcs, pgcc).
11d14365 133
f01e46e5
JR
134%description -l tr.UTF-8
135Bir komut arayüzü üzerinden programcıya programını adım adım izleme
136(trace) ve herhangi bir anda programın durumunu inceleme olanağı
92563ae4 137verir.
6aa96a1b 138
f01e46e5
JR
139%description -l uk.UTF-8
140Це повноцінний відладчик, що керується командами. Він дозволяє
141трасувати виконання програм та вивчати їх внутрішній стан в довільний
142момент часу. Працює з програмами на C та C++, зкомпільованими
143компіляторами GNU C (gcc, egcs, pgcc).
11d14365 144
7566401a
ER
145%package gdbserver
146Summary: A standalone server for GDB (the GNU source-level debugger)
138e5ce3 147Summary(pl.UTF-8): Samodzielny serwer GDB (debuggera GNU)
7566401a
ER
148Group: Development/Debuggers
149
150%description gdbserver
151GDB, the GNU debugger, allows you to debug programs written in C, C++,
152Java, and other languages, by executing them in a controlled fashion
153and printing their data.
154
155This package provides a program that allows you to run GDB on a
156different machine than the one which is running the program being
157debugged.
158
138e5ce3 159%description gdbserver -l pl.UTF-8
6ed6bacf
AM
160GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
161innych językach programowania poprzez wykonywanie ich w sposób
138e5ce3
JB
162kontrolowany oraz wypisywanie ich danych.
163
164Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
165maszynie niż ta, na której działa śledzony program.
166
f02a934e 167%package lib
4e0c2e1e 168Summary: GDB in the form of a static library
0ec45698 169Summary(pl.UTF-8): GDB w postaci biblioteki statycznej
f02a934e 170Group: Development/Debuggers
786e369a 171# libraries that needs to be linked to fulfill libgdb.a symbol requirements
a8252687
JB
172Requires: binutils-devel >= 2.17.50
173Requires: expat-devel
174Requires: libselinux-devel
175Requires: libsepol-devel
176Requires: ncurses-devel
3a039e54 177Requires: python3-devel
a8252687
JB
178Requires: readline-devel
179Requires: xz-devel
180Requires: zlib-devel
f02a934e
JR
181
182%description lib
183GDB in the form of a static library.
184
f01e46e5 185%description lib -l pl.UTF-8
4e0c2e1e
JB
186GDB w postaci biblioteki statycznej.
187
6aa96a1b 188%prep
b90874d2 189%setup -q
049ba25c 190
049ba25c 191# Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
f281b164
JB
192%{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
193%{__rm} gdb/m2-exp.c gdb/p-exp.c
049ba25c 194
b90874d2
JR
195%patch100 -p1
196%patch101 -p1
197%patch102 -p1
b90874d2 198%patch104 -p1
969912f7 199%patch105 -p1
140f8057 200%patch106 -p1
321e94d6 201%patch110 -p1
ed003b1c 202
a59c1d89
ER
203%patch1000 -p1
204%patch1001 -p1
205%patch1002 -p1
8124607e 206%patch1003 -p1
a59c1d89 207%patch1005 -p1
84034fed 208%patch1006 -p1
9164351f 209
41611023
ER
210# Change the version that gets printed at GDB startup, so it is PLD Linux specific.
211cat > gdb/version.in << EOF
765d4ce9 212%{version}-%{release} (PLD Linux)
41611023
ER
213EOF
214
0e7ddf04 215%{__sed} -i -e '1s,/usr/bin/python$,%{__python},' \
e28f2cc1 216 contrib/dg-extract-results.py \
0e7ddf04
JB
217
218%{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' \
e28f2cc1 219 gdb/contrib/test_pubnames_and_indexes.py \
e28f2cc1
AM
220 gdb/testsuite/print-ts.py
221
0e7ddf04
JB
222%{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' \
223 gdb/testsuite/analyze-racy-logs.py \
e28f2cc1
AM
224 gdb/copyright.py
225
0e7ddf04 226%{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' \
e28f2cc1 227 gdb/contrib/cc-with-tweaks.sh \
e28f2cc1
AM
228 gdb/gcore.in \
229 src-release.sh
754d4c0c 230
174fe25c
JP
231sed -i -e 's/\[2\.69\]/[%{autoconf_ver}]/' config/override.m4
232
6aa96a1b 233%build
7f5ea247 234# omit hand-written gdb/testsuite aclocal.m4
174fe25c 235for dir in gdb gdbserver ; do
7f5ea247
JB
236 olddir=$(pwd)
237 cd $dir
238 %{__rm} aclocal.m4
239 %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
240 cd $olddir
241done
754d4c0c 242for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
0cd7a575
AM
243 dir=$(dirname "$dir")
244 olddir=$(pwd)
245 cd $dir
0cd7a575 246 %{__autoconf}
754d4c0c 247 grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
0cd7a575
AM
248 cd $olddir
249done
3661d025 250cp -f /usr/share/automake/config.* .
e28f2cc1 251install -d build && cd build
3a97e68e 252# don't --enable-shared here, there would be libs version mismatch with binutils
e28f2cc1 253../%configure \
fdffb271 254 --disable-gdbtk \
ebd49a3e 255 --disable-shared \
449770db 256 --disable-silent-rules \
fdffb271 257 --enable-gdbcli \
b257c914 258 --enable-gdbmi \
259 --enable-multi-ice \
ebd49a3e 260 --enable-netrom \
fdffb271 261 --enable-nls \
5f8bd10e 262 --enable-tui \
fdffb271 263 --with-cpu=%{_target_cpu} \
449770db
JB
264 --with-gdb-datadir=%{_datadir}/gdb \
265 --with-guile%{!?with_guile:=no} \
ac43b5eb 266%ifnarch alpha
3a97e68e 267 --with-mmalloc \
ac43b5eb 268%endif
449770db 269%if %{with python}
3a039e54
JP
270 --with-python="%{__python3}" \
271 --with-pythondir=%{py3_sitescriptdir} \
449770db
JB
272%else
273 --without-python \
274%endif
275 --with-separate-debug-dir=/usr/lib/debug \
276 --with-system-readline \
3a97e68e
JB
277 --without-included-gettext \
278 --without-included-regex \
279 --without-x
ebd49a3e 280
449770db
JB
281# V=1 because only some subdirs honour --enable-silent-rules
282%{__make} \
283 V=1
284
a59c1d89 285%{__make} -j1 info
6aa96a1b 286
f412e1b4 287# gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
449770db
JB
288%{__make} -C gdb libgdb.a \
289 V=1
f412e1b4 290
6aa96a1b 291%install
292rm -rf $RPM_BUILD_ROOT
5ff7d7dd 293install -d $RPM_BUILD_ROOT%{_infodir}
6aa96a1b 294
e28f2cc1 295%{__make} -C build -j1 install install-info \
049ba25c 296 DESTDIR=$RPM_BUILD_ROOT
e611e157 297
e28f2cc1 298cp -a build/gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
124c2194
JB
299
300# gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
a59c1d89
ER
301# window is created too.
302echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
303ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
304
8d9a5f3e 305bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
124c2194 306%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
7566401a
ER
307
308rm -f $RPM_BUILD_ROOT%{_infodir}/dir
7566401a
ER
309
310%if %{with python}
311# Temporarily now:
432e4f9b 312for LIB in lib lib64 libx32; do
7566401a
ER
313 LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
314 install -d $LIBPATH
7566401a 315done
fc1b3e2b 316
3a039e54
JP
317%py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}
318%py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}
7566401a 319%endif
8d9a5f3e 320
41611023
ER
321cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
322
e28f2cc1 323cp -p build/libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
70189bec 324
7566401a 325# Remove the files that are part of a gdb build but that are owned and provided by other packages.
d7dc9553
JB
326# These are part of binutils:
327%{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
0e7ddf04 328%{__rm} $RPM_BUILD_ROOT%{_infodir}/{bfd,ctf-spec}.info*
2a89498c
JB
329%{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,ctf,ctf-api,diagnostics,dis-asm,symcat,plugin-api}.h
330%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,ctf,ctf-nobfd,opcodes}.la
331%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,ctf,ctf-nobfd,opcodes}.a
f02a934e 332
b0a9ea6d
JB
333%clean
334rm -rf $RPM_BUILD_ROOT
6aa96a1b 335
138e5ce3 336%post -p /sbin/postshell
1f7f0d47 337-/usr/sbin/fix-info-dir -c %{_infodir}
6aa96a1b 338
138e5ce3 339%postun -p /sbin/postshell
1f7f0d47 340-/usr/sbin/fix-info-dir -c %{_infodir}
6aa96a1b 341
6aa96a1b 342%files
0241102e 343%defattr(644,root,root,755)
0e7ddf04 344%doc gdb/{NEWS,PROBLEMS,README}
7566401a
ER
345%attr(755,root,root) %{_bindir}/gdb
346%attr(755,root,root) %{_bindir}/gdbtui
969912f7
JR
347%attr(755,root,root) %{_bindir}/gdb-add-index
348%attr(755,root,root) %{_bindir}/gstack
321e94d6 349%attr(755,root,root) %{_bindir}/gcore
7566401a 350%dir %{_datadir}/gdb
a6c8042b
PS
351%dir %{_datadir}/gdb/auto-load
352%dir %{_datadir}/gdb/auto-load%{_prefix}
353%dir %{_datadir}/gdb/auto-load%{_prefix}/lib
432e4f9b 354%ifarch %{x8664} x32
a6c8042b 355%dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
432e4f9b 356%dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
a6c8042b 357%endif
174fe25c
JP
358%ifarch aarch64
359%dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
360%endif
4ed7a5ee 361%{?with_guile:%{_datadir}/gdb/guile}
7566401a 362%{_datadir}/gdb/syscalls
3e0eff1e 363%{_datadir}/gdb/system-gdbinit
6ed6bacf 364%{_datadir}/gdb/python
7566401a
ER
365%{_mandir}/man1/gdb.1*
366%{_mandir}/man1/gdbtui.1*
f727df28 367%{_mandir}/man1/gdb-add-index.1*
41611023 368%{_mandir}/man1/gstack.1*
321e94d6 369%{_mandir}/man1/gcore.1*
3e0eff1e 370%{_mandir}/man5/gdbinit.5*
8d9a5f3e 371%lang(es) %{_mandir}/es/man1/*
372%lang(fr) %{_mandir}/fr/man1/*
373%lang(hu) %{_mandir}/hu/man1/*
374%lang(ja) %{_mandir}/ja/man1/*
375%lang(pl) %{_mandir}/pl/man1/*
7566401a
ER
376%{_infodir}/annotate.info*
377%{_infodir}/gdb.info*
7566401a
ER
378%{_infodir}/stabs.info*
379
138e5ce3
JB
380%files gdbserver
381%defattr(644,root,root,755)
382%attr(755,root,root) %{_bindir}/gdbserver
383%{_mandir}/man1/gdbserver.1*
19bd73a6 384%ifnarch %{arm}
138e5ce3 385%attr(755,root,root) %{_libdir}/libinproctrace.so
19bd73a6 386%endif
138e5ce3 387
f02a934e
JR
388%files lib
389%defattr(644,root,root,755)
70189bec 390%{_libdir}/libdecnumber.a
f02a934e 391%{_libdir}/libgdb.a
d7dc9553 392%{_includedir}/gdb
This page took 1.593528 seconds and 4 git commands to generate.