]> git.pld-linux.org Git - packages/gdb.git/blame - gdb.spec
updated source url to https
[packages/gdb.git] / gdb.spec
CommitLineData
d7dc9553 1# NOTE: -lib package is used by fpc.spec
7566401a
ER
2
3# TODO
124c2194 4# - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
a59c1d89 5# - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
854ea054 6# - reenable guile after https://sourceware.org/bugzilla/show_bug.cgi?id=21104 is fixed
e1daef87 7#
7566401a 8# Conditional build:
854ea054 9%bcond_with guile # Guile embedded scripting
2725d199 10%bcond_without python # build without python support
7566401a 11
5ff7d7dd 12Summary: A GNU source-level debugger for C, C++ and Fortran
0ec45698
ER
13Summary(de.UTF-8): Symbolischer Debugger für C und andere Sprachen
14Summary(es.UTF-8): Depurador de programas C y otras lenguajes
15Summary(fr.UTF-8): Débugger symbolique pour C et d'autres langages
16Summary(pl.UTF-8): Symboliczny odpluskwiacz dla C i innych języków
17Summary(pt_BR.UTF-8): Depurador de programas C e outras linguagens
18Summary(ru.UTF-8): Символический отладчик для C и других языков
19Summary(tr.UTF-8): C ve diğer diller için sembolik hata ayıklayıcı
20Summary(uk.UTF-8): Символьний відладчик для С та інших мов
21Summary(zh_CN.UTF-8): [开发]C和其他语言的调试器
22Summary(zh_TW.UTF-8): [.-A開發]C和.$)B其.-A他語.$)B言的調試器
0241102e 23Name: gdb
e28f2cc1 24Version: 9.1
830e7ce9 25Release: 2
d7c2fd3d 26License: GPL v3+
0241102e 27Group: Development/Debuggers
3b576511 28Source0: https://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
e28f2cc1 29# Source0-md5: f7e9f6236c425097d9e5f18a6ac40655
31a43e77 30Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
feb56b14 31# Source1-md5: 2e8a48939ae282c12bbacdd54e398247
41611023 32Source3: %{name}-gstack.man
b90874d2
JR
33Patch100: gdb-6.6-buildid-locate.patch
34Patch101: gdb-6.6-buildid-locate-solib-missing-ids.patch
35Patch102: gdb-6.6-buildid-locate-rpm.patch
36Patch103: gdb-6.6-buildid-locate-core-as-arg.patch
37Patch104: gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
321e94d6 38Patch105: gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
140f8057 39Patch106: gdb-6.6-buildid-locate-rpm-scl.patch
321e94d6 40Patch110: gdb-6.3-gstack-20050411.patch
ed003b1c 41
aa964043 42Patch112: gdb-archer-vla-tests.patch
140f8057
JR
43Patch113: gdb-vla-intel-fortran-strides.patch
44Patch114: gdb-vla-intel-stringbt-fix.patch
45Patch115: gdb-vla-intel-fortran-vla-strings.patch
46Patch116: gdb-vla-intel-tests.patch
a59c1d89
ER
47Patch1000: %{name}-readline.patch
48Patch1001: %{name}-info.patch
49Patch1002: %{name}-passflags.patch
50Patch1005: %{name}-pretty-print-by-default.patch
84034fed 51Patch1006: buildid-locate-rpm-pld.patch
3a97e68e 52URL: http://www.gnu.org/software/gdb/
a7de96f0 53BuildRequires: autoconf >= 2.69
830462ab 54BuildRequires: automake
435950f1 55BuildRequires: bison
124c2194 56BuildRequires: babeltrace-devel >= 1.1.0
b3dcfe9b 57BuildRequires: expat-devel
140f8057 58BuildRequires: flex >= 2.6.4
124c2194 59BuildRequires: gettext-tools >= 0.12.1
830e7ce9
JB
60%if %{with guile}
61BuildRequires: guile-devel >= 2.0
62BuildRequires: guile-devel < 2.2
63%endif
b28748e1
AM
64%ifarch %{ix86} %{x8664}
65BuildRequires: libipt-devel
66%endif
04bf7c80 67BuildRequires: libselinux-devel
124c2194 68BuildRequires: libstdc++-devel >= 6:4.8
72a26adc 69BuildRequires: libtool
124c2194 70BuildRequires: make >= 3.81
169fe030 71BuildRequires: mpfr-devel
4e6d01d3 72BuildRequires: ncurses-devel >= 5.2
b3dcfe9b 73BuildRequires: pkgconfig
bdc5760f 74BuildRequires: readline-devel
fc1b3e2b 75BuildRequires: rpmbuild(macros) >= 1.219
830e7ce9 76BuildRequires: source-highlight-devel >= 3.0
169fe030 77BuildRequires: tar >= 1:1.22
3a97e68e 78BuildRequires: texinfo >= 4.4
830e7ce9 79BuildRequires: xxHash-devel
169fe030 80BuildRequires: xz
124c2194 81BuildRequires: xz-devel
ab050a48 82BuildRequires: zlib-devel
fc1b3e2b 83%if %{with python}
3a039e54 84BuildRequires: python3-devel
fc1b3e2b 85BuildRequires: rpm-pythonprov
6ed6bacf 86Obsoletes: python-gdb
da016e1e 87# for traceback module
3a039e54 88Requires: python3-modules
fc1b3e2b 89%endif
3d4c8009 90%{?with_guile:Requires: guile >= 2.0.12}
b4655cd1 91BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6aa96a1b 92
93%description
92563ae4 94Gdb is a full featured, command driven debugger. Gdb allows you to
95trace the execution of programs and examine their internal state at
96any time. Gdb works for C and C++ compiled with the GNU C compiler
97gcc.
6aa96a1b 98
f01e46e5
JR
99%description -l de.UTF-8
100dem Sie die Ausführung von Programmen verfolgen und jederzeit den
101inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
92563ae4 102kompiliertes C++.
6aa96a1b 103
f01e46e5
JR
104%description -l es.UTF-8
105Este es un debugger orientado a comandos repleto de características.
106Te permite rastrear la ejecución de programas y examinar su estado
c15663f7 107interno a cualquier momento. Funciona para C y C++ compilado con el
108compilador GNU C.
109
f01e46e5
JR
110%description -l fr.UTF-8
111Débugger complet, piloté par commandes. Permet de tracer l'exécution
112des programmes et d'examiner à tout moment leur état interne.
113Fonctionne avec les binaires C et C++ compilés avec le compilateur C
92563ae4 114de GNU, gcc.
6aa96a1b 115
f01e46e5
JR
116%description -l pl.UTF-8
117Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
118śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
119umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
92563ae4 120przy pomocy kompilatora GNU (gcc).
6aa96a1b 121
f01e46e5
JR
122%description -l pt_BR.UTF-8
123Este é um debugger orientado a comandos repleto de características.
124Ele permite à você rastrear a execução de programas e examinar o seu
c15663f7 125estado interno a qualquer momento. Ele funciona para para C e C++
126compilado com o compilador GNU C.
127
f01e46e5
JR
128%description -l ru.UTF-8
129Это полноценный отладчик, управляемый командами. Он позволяет
130трассировать исполнение программ и изучать их внутреннее состояние в
131любой момент времени. Работает с программами на C и C++,
132скомпилированными GNU компилятором C (gcc, egcs, pgcc).
11d14365 133
f01e46e5
JR
134%description -l tr.UTF-8
135Bir komut arayüzü üzerinden programcıya programını adım adım izleme
136(trace) ve herhangi bir anda programın durumunu inceleme olanağı
92563ae4 137verir.
6aa96a1b 138
f01e46e5
JR
139%description -l uk.UTF-8
140Це повноцінний відладчик, що керується командами. Він дозволяє
141трасувати виконання програм та вивчати їх внутрішній стан в довільний
142момент часу. Працює з програмами на C та C++, зкомпільованими
143компіляторами GNU C (gcc, egcs, pgcc).
11d14365 144
7566401a
ER
145%package gdbserver
146Summary: A standalone server for GDB (the GNU source-level debugger)
138e5ce3 147Summary(pl.UTF-8): Samodzielny serwer GDB (debuggera GNU)
7566401a
ER
148Group: Development/Debuggers
149
150%description gdbserver
151GDB, the GNU debugger, allows you to debug programs written in C, C++,
152Java, and other languages, by executing them in a controlled fashion
153and printing their data.
154
155This package provides a program that allows you to run GDB on a
156different machine than the one which is running the program being
157debugged.
158
138e5ce3 159%description gdbserver -l pl.UTF-8
6ed6bacf
AM
160GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
161innych językach programowania poprzez wykonywanie ich w sposób
138e5ce3
JB
162kontrolowany oraz wypisywanie ich danych.
163
164Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
165maszynie niż ta, na której działa śledzony program.
166
f02a934e 167%package lib
4e0c2e1e 168Summary: GDB in the form of a static library
0ec45698 169Summary(pl.UTF-8): GDB w postaci biblioteki statycznej
f02a934e 170Group: Development/Debuggers
786e369a 171# libraries that needs to be linked to fulfill libgdb.a symbol requirements
a8252687
JB
172Requires: binutils-devel >= 2.17.50
173Requires: expat-devel
174Requires: libselinux-devel
175Requires: libsepol-devel
176Requires: ncurses-devel
3a039e54 177Requires: python3-devel
a8252687
JB
178Requires: readline-devel
179Requires: xz-devel
180Requires: zlib-devel
f02a934e
JR
181
182%description lib
183GDB in the form of a static library.
184
f01e46e5 185%description lib -l pl.UTF-8
4e0c2e1e
JB
186GDB w postaci biblioteki statycznej.
187
6aa96a1b 188%prep
b90874d2 189%setup -q
049ba25c 190
049ba25c 191# Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
f281b164
JB
192%{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
193%{__rm} gdb/m2-exp.c gdb/p-exp.c
049ba25c 194
b90874d2
JR
195%patch100 -p1
196%patch101 -p1
197%patch102 -p1
198%patch103 -p1
199%patch104 -p1
969912f7 200%patch105 -p1
140f8057 201%patch106 -p1
321e94d6 202%patch110 -p1
ed003b1c 203
aa964043
KK
204%patch112 -p1
205%patch113 -p1
206%patch114 -p1
207%patch115 -p1
b1b25d28 208%patch116 -p1
b90874d2 209
a59c1d89
ER
210%patch1000 -p1
211%patch1001 -p1
212%patch1002 -p1
213%patch1005 -p1
84034fed 214%patch1006 -p1
9164351f 215
41611023
ER
216# Change the version that gets printed at GDB startup, so it is PLD Linux specific.
217cat > gdb/version.in << EOF
765d4ce9 218%{version}-%{release} (PLD Linux)
41611023
ER
219EOF
220
3a039e54 221sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python3}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python3}\1,' \
e28f2cc1
AM
222 contrib/dg-extract-results.py \
223 gdb/contrib/test_pubnames_and_indexes.py \
224 gdb/testsuite/analyze-racy-logs.py \
225 gdb/testsuite/print-ts.py
226
227sed -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
228 gdb/copyright.py
229
230sed -E -i -e '1s,#!\s*/usr/bin/env\s+(.*),#!%{__bindir}\1,' \
231 gdb/contrib/cc-with-tweaks.sh \
232 gdb/gcore \
233 gdb/gcore.in \
234 src-release.sh
754d4c0c 235
6aa96a1b 236%build
7f5ea247
JB
237# omit hand-written gdb/testsuite aclocal.m4
238for dir in gdb gdb/gdbserver ; do
239 olddir=$(pwd)
240 cd $dir
241 %{__rm} aclocal.m4
242 %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
243 cd $olddir
244done
754d4c0c 245for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
0cd7a575
AM
246 dir=$(dirname "$dir")
247 olddir=$(pwd)
248 cd $dir
0cd7a575 249 %{__autoconf}
754d4c0c 250 grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
0cd7a575
AM
251 cd $olddir
252done
3661d025 253cp -f /usr/share/automake/config.* .
e28f2cc1 254install -d build && cd build
3a97e68e 255# don't --enable-shared here, there would be libs version mismatch with binutils
e28f2cc1 256../%configure \
fdffb271 257 --disable-gdbtk \
ebd49a3e 258 --disable-shared \
449770db 259 --disable-silent-rules \
fdffb271 260 --enable-gdbcli \
b257c914 261 --enable-gdbmi \
262 --enable-multi-ice \
ebd49a3e 263 --enable-netrom \
fdffb271 264 --enable-nls \
5f8bd10e 265 --enable-tui \
fdffb271 266 --with-cpu=%{_target_cpu} \
449770db
JB
267 --with-gdb-datadir=%{_datadir}/gdb \
268 --with-guile%{!?with_guile:=no} \
ac43b5eb 269%ifnarch alpha
3a97e68e 270 --with-mmalloc \
ac43b5eb 271%endif
449770db 272%if %{with python}
3a039e54
JP
273 --with-python="%{__python3}" \
274 --with-pythondir=%{py3_sitescriptdir} \
449770db
JB
275%else
276 --without-python \
277%endif
278 --with-separate-debug-dir=/usr/lib/debug \
279 --with-system-readline \
3a97e68e
JB
280 --without-included-gettext \
281 --without-included-regex \
282 --without-x
ebd49a3e 283
449770db
JB
284# V=1 because only some subdirs honour --enable-silent-rules
285%{__make} \
286 V=1
287
a59c1d89 288%{__make} -j1 info
6aa96a1b 289
f412e1b4 290# gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
449770db
JB
291%{__make} -C gdb libgdb.a \
292 V=1
f412e1b4 293
6aa96a1b 294%install
295rm -rf $RPM_BUILD_ROOT
5ff7d7dd 296install -d $RPM_BUILD_ROOT%{_infodir}
6aa96a1b 297
e28f2cc1 298%{__make} -C build -j1 install install-info \
049ba25c 299 DESTDIR=$RPM_BUILD_ROOT
e611e157 300
e28f2cc1 301cp -a build/gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
124c2194
JB
302
303# gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
a59c1d89
ER
304# window is created too.
305echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
306ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
307
8d9a5f3e 308bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
124c2194 309%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
7566401a
ER
310
311rm -f $RPM_BUILD_ROOT%{_infodir}/dir
7566401a
ER
312
313%if %{with python}
314# Temporarily now:
432e4f9b 315for LIB in lib lib64 libx32; do
7566401a
ER
316 LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
317 install -d $LIBPATH
7566401a 318done
fc1b3e2b 319
3a039e54
JP
320%py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}
321%py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}
7566401a 322%endif
8d9a5f3e 323
41611023
ER
324cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
325
e28f2cc1 326cp -p build/libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
70189bec 327
7566401a 328# Remove the files that are part of a gdb build but that are owned and provided by other packages.
d7dc9553
JB
329# These are part of binutils:
330%{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
b1b25d28 331%{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
e28f2cc1 332%{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfd_stdint,bfdlink,diagnostics,dis-asm,symcat,plugin-api}.h
d7dc9553 333%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
321e94d6 334%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
f02a934e 335
b0a9ea6d
JB
336%clean
337rm -rf $RPM_BUILD_ROOT
6aa96a1b 338
138e5ce3 339%post -p /sbin/postshell
1f7f0d47 340-/usr/sbin/fix-info-dir -c %{_infodir}
6aa96a1b 341
138e5ce3 342%postun -p /sbin/postshell
1f7f0d47 343-/usr/sbin/fix-info-dir -c %{_infodir}
6aa96a1b 344
6aa96a1b 345%files
0241102e 346%defattr(644,root,root,755)
f0842f54 347%doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
7566401a
ER
348%attr(755,root,root) %{_bindir}/gdb
349%attr(755,root,root) %{_bindir}/gdbtui
969912f7
JR
350%attr(755,root,root) %{_bindir}/gdb-add-index
351%attr(755,root,root) %{_bindir}/gstack
321e94d6 352%attr(755,root,root) %{_bindir}/gcore
7566401a 353%dir %{_datadir}/gdb
a6c8042b
PS
354%dir %{_datadir}/gdb/auto-load
355%dir %{_datadir}/gdb/auto-load%{_prefix}
356%dir %{_datadir}/gdb/auto-load%{_prefix}/lib
432e4f9b 357%ifarch %{x8664} x32
a6c8042b 358%dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
432e4f9b 359%dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
a6c8042b 360%endif
4ed7a5ee 361%{?with_guile:%{_datadir}/gdb/guile}
7566401a 362%{_datadir}/gdb/syscalls
3e0eff1e 363%{_datadir}/gdb/system-gdbinit
6ed6bacf 364%{_datadir}/gdb/python
7566401a
ER
365%{_mandir}/man1/gdb.1*
366%{_mandir}/man1/gdbtui.1*
f727df28 367%{_mandir}/man1/gdb-add-index.1*
41611023 368%{_mandir}/man1/gstack.1*
321e94d6 369%{_mandir}/man1/gcore.1*
3e0eff1e 370%{_mandir}/man5/gdbinit.5*
8d9a5f3e 371%lang(es) %{_mandir}/es/man1/*
372%lang(fr) %{_mandir}/fr/man1/*
373%lang(hu) %{_mandir}/hu/man1/*
374%lang(ja) %{_mandir}/ja/man1/*
375%lang(pl) %{_mandir}/pl/man1/*
7566401a
ER
376%{_infodir}/annotate.info*
377%{_infodir}/gdb.info*
7566401a
ER
378%{_infodir}/stabs.info*
379
138e5ce3
JB
380%files gdbserver
381%defattr(644,root,root,755)
382%attr(755,root,root) %{_bindir}/gdbserver
383%{_mandir}/man1/gdbserver.1*
19bd73a6 384%ifnarch %{arm}
138e5ce3 385%attr(755,root,root) %{_libdir}/libinproctrace.so
19bd73a6 386%endif
138e5ce3 387
f02a934e
JR
388%files lib
389%defattr(644,root,root,755)
70189bec 390%{_libdir}/libdecnumber.a
f02a934e 391%{_libdir}/libgdb.a
d7dc9553 392%{_includedir}/gdb
This page took 0.117938 seconds and 4 git commands to generate.