]> git.pld-linux.org Git - packages/gdb.git/blame - gdb.spec
- teach gdb about little-endian IBM long double (required for binutils 2.24.51.0.1)
[packages/gdb.git] / gdb.spec
CommitLineData
7566401a
ER
1# NOTE
2# - Do not remove -lib package, it is required by FPC
3
4# TODO
a59c1d89 5# - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
e1daef87 6#
7566401a 7# Conditional build:
2725d199 8%bcond_without python # build without python support
7566401a 9
5ff7d7dd 10Summary: A GNU source-level debugger for C, C++ and Fortran
0ec45698
ER
11Summary(de.UTF-8): Symbolischer Debugger für C und andere Sprachen
12Summary(es.UTF-8): Depurador de programas C y otras lenguajes
13Summary(fr.UTF-8): Débugger symbolique pour C et d'autres langages
14Summary(pl.UTF-8): Symboliczny odpluskwiacz dla C i innych języków
15Summary(pt_BR.UTF-8): Depurador de programas C e outras linguagens
16Summary(ru.UTF-8): Символический отладчик для C и других языков
17Summary(tr.UTF-8): C ve diğer diller için sembolik hata ayıklayıcı
18Summary(uk.UTF-8): Символьний відладчик для С та інших мов
19Summary(zh_CN.UTF-8): [开发]C和其他语言的调试器
20Summary(zh_TW.UTF-8): [.-A開發]C和.$)B其.-A他語.$)B言的調試器
a7de96f0 21%define snap 20120926
0241102e 22Name: gdb
1dce4dc1 23Version: 7.6.1
99d067e5 24Release: 2
d7c2fd3d 25License: GPL v3+
0241102e 26Group: Development/Debuggers
b90874d2 27Source0: http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.bz2
1dce4dc1 28# Source0-md5: fbc4dab4181e6e9937075b43a4ce2732
31a43e77 29Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
feb56b14 30# Source1-md5: 2e8a48939ae282c12bbacdd54e398247
41611023 31Source3: %{name}-gstack.man
b90874d2
JR
32Patch100: gdb-6.6-buildid-locate.patch
33Patch101: gdb-6.6-buildid-locate-solib-missing-ids.patch
34Patch102: gdb-6.6-buildid-locate-rpm.patch
35Patch103: gdb-6.6-buildid-locate-core-as-arg.patch
36Patch104: gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
969912f7
JR
37Patch105: gdb-6.3-gstack-20050411.patch
38Patch106: gdb-gdb-add-index-script.patch
99d067e5 39Patch107: floatformat_ibm_long_double.patch
a59c1d89
ER
40Patch1000: %{name}-readline.patch
41Patch1001: %{name}-info.patch
42Patch1002: %{name}-passflags.patch
43Patch1005: %{name}-pretty-print-by-default.patch
84034fed 44Patch1006: buildid-locate-rpm-pld.patch
3a97e68e 45URL: http://www.gnu.org/software/gdb/
a7de96f0 46BuildRequires: autoconf >= 2.69
830462ab 47BuildRequires: automake
435950f1 48BuildRequires: bison
b3dcfe9b 49BuildRequires: expat-devel
435950f1 50BuildRequires: flex
8588b8ec 51BuildRequires: gettext-devel
04bf7c80 52BuildRequires: libselinux-devel
72a26adc 53BuildRequires: libtool
6ed6bacf 54BuildRequires: libunwind-devel >= 0.97
4e6d01d3 55BuildRequires: ncurses-devel >= 5.2
b3dcfe9b 56BuildRequires: pkgconfig
bdc5760f 57BuildRequires: readline-devel
fc1b3e2b 58BuildRequires: rpmbuild(macros) >= 1.219
3a97e68e 59BuildRequires: texinfo >= 4.4
ab050a48 60BuildRequires: zlib-devel
fc1b3e2b
ER
61%if %{with python}
62BuildRequires: python-devel
63BuildRequires: rpm-pythonprov
6ed6bacf 64Obsoletes: python-gdb
da016e1e
ER
65# for traceback module
66Requires: python-modules
fc1b3e2b 67%endif
6ed6bacf 68Requires: libunwind >= 0.97
b4655cd1 69BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6aa96a1b 70
71%description
92563ae4 72Gdb is a full featured, command driven debugger. Gdb allows you to
73trace the execution of programs and examine their internal state at
74any time. Gdb works for C and C++ compiled with the GNU C compiler
75gcc.
6aa96a1b 76
f01e46e5
JR
77%description -l de.UTF-8
78dem Sie die Ausführung von Programmen verfolgen und jederzeit den
79inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
92563ae4 80kompiliertes C++.
6aa96a1b 81
f01e46e5
JR
82%description -l es.UTF-8
83Este es un debugger orientado a comandos repleto de características.
84Te permite rastrear la ejecución de programas y examinar su estado
c15663f7 85interno a cualquier momento. Funciona para C y C++ compilado con el
86compilador GNU C.
87
f01e46e5
JR
88%description -l fr.UTF-8
89Débugger complet, piloté par commandes. Permet de tracer l'exécution
90des programmes et d'examiner à tout moment leur état interne.
91Fonctionne avec les binaires C et C++ compilés avec le compilateur C
92563ae4 92de GNU, gcc.
6aa96a1b 93
f01e46e5
JR
94%description -l pl.UTF-8
95Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
96śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
97umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
92563ae4 98przy pomocy kompilatora GNU (gcc).
6aa96a1b 99
f01e46e5
JR
100%description -l pt_BR.UTF-8
101Este é um debugger orientado a comandos repleto de características.
102Ele permite à você rastrear a execução de programas e examinar o seu
c15663f7 103estado interno a qualquer momento. Ele funciona para para C e C++
104compilado com o compilador GNU C.
105
f01e46e5
JR
106%description -l ru.UTF-8
107Это полноценный отладчик, управляемый командами. Он позволяет
108трассировать исполнение программ и изучать их внутреннее состояние в
109любой момент времени. Работает с программами на C и C++,
110скомпилированными GNU компилятором C (gcc, egcs, pgcc).
11d14365 111
f01e46e5
JR
112%description -l tr.UTF-8
113Bir komut arayüzü üzerinden programcıya programını adım adım izleme
114(trace) ve herhangi bir anda programın durumunu inceleme olanağı
92563ae4 115verir.
6aa96a1b 116
f01e46e5
JR
117%description -l uk.UTF-8
118Це повноцінний відладчик, що керується командами. Він дозволяє
119трасувати виконання програм та вивчати їх внутрішній стан в довільний
120момент часу. Працює з програмами на C та C++, зкомпільованими
121компіляторами GNU C (gcc, egcs, pgcc).
11d14365 122
7566401a
ER
123%package gdbserver
124Summary: A standalone server for GDB (the GNU source-level debugger)
138e5ce3 125Summary(pl.UTF-8): Samodzielny serwer GDB (debuggera GNU)
7566401a
ER
126Group: Development/Debuggers
127
128%description gdbserver
129GDB, the GNU debugger, allows you to debug programs written in C, C++,
130Java, and other languages, by executing them in a controlled fashion
131and printing their data.
132
133This package provides a program that allows you to run GDB on a
134different machine than the one which is running the program being
135debugged.
136
138e5ce3 137%description gdbserver -l pl.UTF-8
6ed6bacf
AM
138GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
139innych językach programowania poprzez wykonywanie ich w sposób
138e5ce3
JB
140kontrolowany oraz wypisywanie ich danych.
141
142Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
143maszynie niż ta, na której działa śledzony program.
144
f02a934e 145%package lib
4e0c2e1e 146Summary: GDB in the form of a static library
0ec45698 147Summary(pl.UTF-8): GDB w postaci biblioteki statycznej
f02a934e 148Group: Development/Debuggers
786e369a 149# libraries that needs to be linked to fulfill libgdb.a symbol requirements
a8252687
JB
150Requires: binutils-devel >= 2.17.50
151Requires: expat-devel
152Requires: libselinux-devel
153Requires: libsepol-devel
154Requires: ncurses-devel
155Requires: python-devel
156Requires: readline-devel
157Requires: xz-devel
158Requires: zlib-devel
f02a934e
JR
159
160%description lib
161GDB in the form of a static library.
162
f01e46e5 163%description lib -l pl.UTF-8
4e0c2e1e
JB
164GDB w postaci biblioteki statycznej.
165
6aa96a1b 166%prep
b90874d2 167%setup -q
049ba25c 168
049ba25c
AM
169# Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
170rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
171rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
172
b90874d2
JR
173%patch100 -p1
174%patch101 -p1
175%patch102 -p1
176%patch103 -p1
177%patch104 -p1
969912f7
JR
178%patch105 -p1
179%patch106 -p1
99d067e5 180%patch107 -p1
b90874d2 181
a59c1d89
ER
182%patch1000 -p1
183%patch1001 -p1
184%patch1002 -p1
185%patch1005 -p1
84034fed 186%patch1006 -p1
9164351f 187
41611023
ER
188# Change the version that gets printed at GDB startup, so it is PLD Linux specific.
189cat > gdb/version.in << EOF
765d4ce9 190%{version}-%{release} (PLD Linux)
41611023
ER
191EOF
192
a7de96f0 193sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
754d4c0c 194
6aa96a1b 195%build
7f5ea247
JB
196# omit hand-written gdb/testsuite aclocal.m4
197for dir in gdb gdb/gdbserver ; do
198 olddir=$(pwd)
199 cd $dir
200 %{__rm} aclocal.m4
201 %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
202 cd $olddir
203done
754d4c0c 204for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
0cd7a575
AM
205 dir=$(dirname "$dir")
206 olddir=$(pwd)
207 cd $dir
0cd7a575 208 %{__autoconf}
754d4c0c 209 grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
0cd7a575
AM
210 cd $olddir
211done
3661d025 212cp -f /usr/share/automake/config.* .
3a97e68e 213# don't --enable-shared here, there would be libs version mismatch with binutils
62be29ad 214%configure \
049ba25c
AM
215 --with-gdb-datadir=%{_datadir}/gdb \
216 --with-separate-debug-dir=/usr/lib/debug \
7566401a 217%if %{with python}
6ed6bacf 218 --with-python=yes \
7566401a
ER
219 --with-pythondir=%{py_sitescriptdir} \
220%else
221 --without-python \
222%endif
fdffb271 223 --disable-gdbtk \
ebd49a3e 224 --disable-shared \
fdffb271 225 --enable-gdbcli \
b257c914 226 --enable-gdbmi \
227 --enable-multi-ice \
ebd49a3e 228 --enable-netrom \
fdffb271 229 --enable-nls \
5f8bd10e 230 --enable-tui \
72a62b37 231 --with-system-readline \
fdffb271 232 --with-cpu=%{_target_cpu} \
ac43b5eb 233%ifnarch alpha
3a97e68e 234 --with-mmalloc \
ac43b5eb 235%endif
3a97e68e
JB
236 --without-included-gettext \
237 --without-included-regex \
238 --without-x
ebd49a3e 239
81e12145 240%{__make}
a59c1d89 241%{__make} -j1 info
6aa96a1b 242
f412e1b4 243# gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
81e12145 244%{__make} -C gdb libgdb.a
f412e1b4 245
6aa96a1b 246%install
247rm -rf $RPM_BUILD_ROOT
5ff7d7dd 248install -d $RPM_BUILD_ROOT%{_infodir}
6aa96a1b 249
bf594b18 250%{__make} -j1 install install-info \
049ba25c 251 DESTDIR=$RPM_BUILD_ROOT
e611e157 252
a59c1d89
ER
253# gdbtui seems all identical to gdb except when invoked as gdbtio, ncurses
254# window is created too.
255echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
256ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
257
8d9a5f3e 258bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
7566401a
ER
259cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
260
261rm -f $RPM_BUILD_ROOT%{_infodir}/dir
262rm -f $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
263
264%if %{with python}
265# Temporarily now:
266for LIB in lib lib64; do
267 LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
268 install -d $LIBPATH
7566401a 269done
fc1b3e2b
ER
270
271%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
272%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
273%py_postclean
7566401a 274%endif
8d9a5f3e 275
41611023
ER
276cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
277
70189bec
JR
278install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
279
7566401a
ER
280# Remove the files that are part of a gdb build but that are owned and provided by other packages.
281# These are part of binutils
a7de96f0 282rm -rf $RPM_BUILD_ROOT%{_localedir}
7566401a
ER
283rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
284rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
285rm -f $RPM_BUILD_ROOT%{_infodir}/mmalloc*
286rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
287rm -rf $RPM_BUILD_ROOT%{_includedir}
288rm -rf $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,opcodes*,iberty*,mmalloc*}
f02a934e 289
b0a9ea6d
JB
290%clean
291rm -rf $RPM_BUILD_ROOT
6aa96a1b 292
138e5ce3 293%post -p /sbin/postshell
1f7f0d47 294-/usr/sbin/fix-info-dir -c %{_infodir}
6aa96a1b 295
138e5ce3 296%postun -p /sbin/postshell
1f7f0d47 297-/usr/sbin/fix-info-dir -c %{_infodir}
6aa96a1b 298
6aa96a1b 299%files
0241102e 300%defattr(644,root,root,755)
f0842f54 301%doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
7566401a
ER
302%attr(755,root,root) %{_bindir}/gdb
303%attr(755,root,root) %{_bindir}/gdbtui
969912f7
JR
304%attr(755,root,root) %{_bindir}/gdb-add-index
305%attr(755,root,root) %{_bindir}/gstack
7566401a 306%dir %{_datadir}/gdb
a6c8042b
PS
307%dir %{_datadir}/gdb/auto-load
308%dir %{_datadir}/gdb/auto-load%{_prefix}
309%dir %{_datadir}/gdb/auto-load%{_prefix}/lib
310%ifarch %{x8664}
311%dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
312%endif
7566401a 313%{_datadir}/gdb/syscalls
6ed6bacf 314%{_datadir}/gdb/python
7566401a
ER
315%{_mandir}/man1/gdb.1*
316%{_mandir}/man1/gdbtui.1*
41611023 317%{_mandir}/man1/gstack.1*
8d9a5f3e 318%lang(es) %{_mandir}/es/man1/*
319%lang(fr) %{_mandir}/fr/man1/*
320%lang(hu) %{_mandir}/hu/man1/*
321%lang(ja) %{_mandir}/ja/man1/*
322%lang(pl) %{_mandir}/pl/man1/*
7566401a
ER
323%{_infodir}/annotate.info*
324%{_infodir}/gdb.info*
325%{_infodir}/gdbint.info*
326%{_infodir}/stabs.info*
327
138e5ce3
JB
328%files gdbserver
329%defattr(644,root,root,755)
330%attr(755,root,root) %{_bindir}/gdbserver
331%{_mandir}/man1/gdbserver.1*
332%attr(755,root,root) %{_libdir}/libinproctrace.so
333
f02a934e
JR
334%files lib
335%defattr(644,root,root,755)
70189bec 336%{_libdir}/libdecnumber.a
f02a934e 337%{_libdir}/libgdb.a
This page took 0.402476 seconds and 4 git commands to generate.