]> git.pld-linux.org Git - packages/gdb.git/blame - gdb.spec
up to 11.1
[packages/gdb.git] / gdb.spec
CommitLineData
d7dc9553 1# NOTE: -lib package is used by fpc.spec
7566401a
ER
2
3# TODO
124c2194 4# - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
a59c1d89 5# - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
854ea054 6# - reenable guile after https://sourceware.org/bugzilla/show_bug.cgi?id=21104 is fixed
e1daef87 7#
7566401a 8# Conditional build:
854ea054 9%bcond_with guile # Guile embedded scripting
2725d199 10%bcond_without python # build without python support
7566401a 11
5ff7d7dd 12Summary: A GNU source-level debugger for C, C++ and Fortran
0ec45698
ER
13Summary(de.UTF-8): Symbolischer Debugger für C und andere Sprachen
14Summary(es.UTF-8): Depurador de programas C y otras lenguajes
15Summary(fr.UTF-8): Débugger symbolique pour C et d'autres langages
16Summary(pl.UTF-8): Symboliczny odpluskwiacz dla C i innych języków
17Summary(pt_BR.UTF-8): Depurador de programas C e outras linguagens
18Summary(ru.UTF-8): Символический отладчик для C и других языков
19Summary(tr.UTF-8): C ve diğer diller için sembolik hata ayıklayıcı
20Summary(uk.UTF-8): Символьний відладчик для С та інших мов
21Summary(zh_CN.UTF-8): [开发]C和其他语言的调试器
22Summary(zh_TW.UTF-8): [.-A開發]C和.$)B其.-A他語.$)B言的調試器
0241102e 23Name: gdb
1d2a824d 24Version: 11.1
174fe25c 25Release: 1
d7c2fd3d 26License: GPL v3+
0241102e 27Group: Development/Debuggers
3b576511 28Source0: https://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
1d2a824d 29# Source0-md5: 257cb0f67927f79acf636d8c01e19990
31a43e77 30Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
feb56b14 31# Source1-md5: 2e8a48939ae282c12bbacdd54e398247
41611023 32Source3: %{name}-gstack.man
1d2a824d 33Patch0: glibc2.34.patch
b90874d2
JR
34Patch100: gdb-6.6-buildid-locate.patch
35Patch101: gdb-6.6-buildid-locate-solib-missing-ids.patch
36Patch102: gdb-6.6-buildid-locate-rpm.patch
b90874d2 37Patch104: gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
321e94d6 38Patch105: gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
140f8057 39Patch106: gdb-6.6-buildid-locate-rpm-scl.patch
321e94d6 40Patch110: gdb-6.3-gstack-20050411.patch
ed003b1c 41
140f8057 42Patch114: gdb-vla-intel-stringbt-fix.patch
174fe25c 43Patch115: gdb-vla-intel-tests.patch
a59c1d89
ER
44Patch1000: %{name}-readline.patch
45Patch1001: %{name}-info.patch
46Patch1002: %{name}-passflags.patch
47Patch1005: %{name}-pretty-print-by-default.patch
84034fed 48Patch1006: buildid-locate-rpm-pld.patch
3a97e68e 49URL: http://www.gnu.org/software/gdb/
a7de96f0 50BuildRequires: autoconf >= 2.69
830462ab 51BuildRequires: automake
435950f1 52BuildRequires: bison
124c2194 53BuildRequires: babeltrace-devel >= 1.1.0
b3dcfe9b 54BuildRequires: expat-devel
140f8057 55BuildRequires: flex >= 2.6.4
124c2194 56BuildRequires: gettext-tools >= 0.12.1
830e7ce9
JB
57%if %{with guile}
58BuildRequires: guile-devel >= 2.0
59BuildRequires: guile-devel < 2.2
60%endif
b28748e1
AM
61%ifarch %{ix86} %{x8664}
62BuildRequires: libipt-devel
63%endif
04bf7c80 64BuildRequires: libselinux-devel
124c2194 65BuildRequires: libstdc++-devel >= 6:4.8
72a26adc 66BuildRequires: libtool
124c2194 67BuildRequires: make >= 3.81
169fe030 68BuildRequires: mpfr-devel
4e6d01d3 69BuildRequires: ncurses-devel >= 5.2
b3dcfe9b 70BuildRequires: pkgconfig
bdc5760f 71BuildRequires: readline-devel
fc1b3e2b 72BuildRequires: rpmbuild(macros) >= 1.219
830e7ce9 73BuildRequires: source-highlight-devel >= 3.0
169fe030 74BuildRequires: tar >= 1:1.22
3a97e68e 75BuildRequires: texinfo >= 4.4
830e7ce9 76BuildRequires: xxHash-devel
169fe030 77BuildRequires: xz
124c2194 78BuildRequires: xz-devel
ab050a48 79BuildRequires: zlib-devel
fc1b3e2b 80%if %{with python}
3a039e54 81BuildRequires: python3-devel
fc1b3e2b 82BuildRequires: rpm-pythonprov
6ed6bacf 83Obsoletes: python-gdb
da016e1e 84# for traceback module
3a039e54 85Requires: python3-modules
fc1b3e2b 86%endif
3d4c8009 87%{?with_guile:Requires: guile >= 2.0.12}
b4655cd1 88BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6aa96a1b 89
174fe25c
JP
90%define autoconf_ver %(rpm -q --qf='%%{VERSION}' autoconf)
91
6aa96a1b 92%description
92563ae4 93Gdb is a full featured, command driven debugger. Gdb allows you to
94trace the execution of programs and examine their internal state at
95any time. Gdb works for C and C++ compiled with the GNU C compiler
96gcc.
6aa96a1b 97
f01e46e5
JR
98%description -l de.UTF-8
99dem Sie die Ausführung von Programmen verfolgen und jederzeit den
100inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
92563ae4 101kompiliertes C++.
6aa96a1b 102
f01e46e5
JR
103%description -l es.UTF-8
104Este es un debugger orientado a comandos repleto de características.
105Te permite rastrear la ejecución de programas y examinar su estado
c15663f7 106interno a cualquier momento. Funciona para C y C++ compilado con el
107compilador GNU C.
108
f01e46e5
JR
109%description -l fr.UTF-8
110Débugger complet, piloté par commandes. Permet de tracer l'exécution
111des programmes et d'examiner à tout moment leur état interne.
112Fonctionne avec les binaires C et C++ compilés avec le compilateur C
92563ae4 113de GNU, gcc.
6aa96a1b 114
f01e46e5
JR
115%description -l pl.UTF-8
116Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
117śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
118umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
92563ae4 119przy pomocy kompilatora GNU (gcc).
6aa96a1b 120
f01e46e5
JR
121%description -l pt_BR.UTF-8
122Este é um debugger orientado a comandos repleto de características.
123Ele permite à você rastrear a execução de programas e examinar o seu
c15663f7 124estado interno a qualquer momento. Ele funciona para para C e C++
125compilado com o compilador GNU C.
126
f01e46e5
JR
127%description -l ru.UTF-8
128Это полноценный отладчик, управляемый командами. Он позволяет
129трассировать исполнение программ и изучать их внутреннее состояние в
130любой момент времени. Работает с программами на C и C++,
131скомпилированными GNU компилятором C (gcc, egcs, pgcc).
11d14365 132
f01e46e5
JR
133%description -l tr.UTF-8
134Bir komut arayüzü üzerinden programcıya programını adım adım izleme
135(trace) ve herhangi bir anda programın durumunu inceleme olanağı
92563ae4 136verir.
6aa96a1b 137
f01e46e5
JR
138%description -l uk.UTF-8
139Це повноцінний відладчик, що керується командами. Він дозволяє
140трасувати виконання програм та вивчати їх внутрішній стан в довільний
141момент часу. Працює з програмами на C та C++, зкомпільованими
142компіляторами GNU C (gcc, egcs, pgcc).
11d14365 143
7566401a
ER
144%package gdbserver
145Summary: A standalone server for GDB (the GNU source-level debugger)
138e5ce3 146Summary(pl.UTF-8): Samodzielny serwer GDB (debuggera GNU)
7566401a
ER
147Group: Development/Debuggers
148
149%description gdbserver
150GDB, the GNU debugger, allows you to debug programs written in C, C++,
151Java, and other languages, by executing them in a controlled fashion
152and printing their data.
153
154This package provides a program that allows you to run GDB on a
155different machine than the one which is running the program being
156debugged.
157
138e5ce3 158%description gdbserver -l pl.UTF-8
6ed6bacf
AM
159GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
160innych językach programowania poprzez wykonywanie ich w sposób
138e5ce3
JB
161kontrolowany oraz wypisywanie ich danych.
162
163Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
164maszynie niż ta, na której działa śledzony program.
165
f02a934e 166%package lib
4e0c2e1e 167Summary: GDB in the form of a static library
0ec45698 168Summary(pl.UTF-8): GDB w postaci biblioteki statycznej
f02a934e 169Group: Development/Debuggers
786e369a 170# libraries that needs to be linked to fulfill libgdb.a symbol requirements
a8252687
JB
171Requires: binutils-devel >= 2.17.50
172Requires: expat-devel
173Requires: libselinux-devel
174Requires: libsepol-devel
175Requires: ncurses-devel
3a039e54 176Requires: python3-devel
a8252687
JB
177Requires: readline-devel
178Requires: xz-devel
179Requires: zlib-devel
f02a934e
JR
180
181%description lib
182GDB in the form of a static library.
183
f01e46e5 184%description lib -l pl.UTF-8
4e0c2e1e
JB
185GDB w postaci biblioteki statycznej.
186
6aa96a1b 187%prep
b90874d2 188%setup -q
049ba25c 189
049ba25c 190# Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
f281b164
JB
191%{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
192%{__rm} gdb/m2-exp.c gdb/p-exp.c
049ba25c 193
1d2a824d 194%patch0 -p1
b90874d2
JR
195%patch100 -p1
196%patch101 -p1
197%patch102 -p1
b90874d2 198%patch104 -p1
969912f7 199%patch105 -p1
140f8057 200%patch106 -p1
321e94d6 201%patch110 -p1
ed003b1c 202
aa964043
KK
203%patch114 -p1
204%patch115 -p1
b90874d2 205
a59c1d89
ER
206%patch1000 -p1
207%patch1001 -p1
208%patch1002 -p1
209%patch1005 -p1
84034fed 210%patch1006 -p1
9164351f 211
41611023
ER
212# Change the version that gets printed at GDB startup, so it is PLD Linux specific.
213cat > gdb/version.in << EOF
765d4ce9 214%{version}-%{release} (PLD Linux)
41611023
ER
215EOF
216
3a039e54 217sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python3}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python3}\1,' \
e28f2cc1
AM
218 contrib/dg-extract-results.py \
219 gdb/contrib/test_pubnames_and_indexes.py \
220 gdb/testsuite/analyze-racy-logs.py \
221 gdb/testsuite/print-ts.py
222
223sed -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
224 gdb/copyright.py
225
226sed -E -i -e '1s,#!\s*/usr/bin/env\s+(.*),#!%{__bindir}\1,' \
227 gdb/contrib/cc-with-tweaks.sh \
228 gdb/gcore \
229 gdb/gcore.in \
230 src-release.sh
754d4c0c 231
174fe25c
JP
232sed -i -e 's/\[2\.69\]/[%{autoconf_ver}]/' config/override.m4
233
6aa96a1b 234%build
7f5ea247 235# omit hand-written gdb/testsuite aclocal.m4
174fe25c 236for dir in gdb gdbserver ; do
7f5ea247
JB
237 olddir=$(pwd)
238 cd $dir
239 %{__rm} aclocal.m4
240 %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
241 cd $olddir
242done
754d4c0c 243for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
0cd7a575
AM
244 dir=$(dirname "$dir")
245 olddir=$(pwd)
246 cd $dir
0cd7a575 247 %{__autoconf}
754d4c0c 248 grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
0cd7a575
AM
249 cd $olddir
250done
3661d025 251cp -f /usr/share/automake/config.* .
e28f2cc1 252install -d build && cd build
3a97e68e 253# don't --enable-shared here, there would be libs version mismatch with binutils
e28f2cc1 254../%configure \
fdffb271 255 --disable-gdbtk \
ebd49a3e 256 --disable-shared \
449770db 257 --disable-silent-rules \
fdffb271 258 --enable-gdbcli \
b257c914 259 --enable-gdbmi \
260 --enable-multi-ice \
ebd49a3e 261 --enable-netrom \
fdffb271 262 --enable-nls \
5f8bd10e 263 --enable-tui \
fdffb271 264 --with-cpu=%{_target_cpu} \
449770db
JB
265 --with-gdb-datadir=%{_datadir}/gdb \
266 --with-guile%{!?with_guile:=no} \
ac43b5eb 267%ifnarch alpha
3a97e68e 268 --with-mmalloc \
ac43b5eb 269%endif
449770db 270%if %{with python}
3a039e54
JP
271 --with-python="%{__python3}" \
272 --with-pythondir=%{py3_sitescriptdir} \
449770db
JB
273%else
274 --without-python \
275%endif
276 --with-separate-debug-dir=/usr/lib/debug \
277 --with-system-readline \
3a97e68e
JB
278 --without-included-gettext \
279 --without-included-regex \
280 --without-x
ebd49a3e 281
449770db
JB
282# V=1 because only some subdirs honour --enable-silent-rules
283%{__make} \
284 V=1
285
a59c1d89 286%{__make} -j1 info
6aa96a1b 287
f412e1b4 288# gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
449770db
JB
289%{__make} -C gdb libgdb.a \
290 V=1
f412e1b4 291
6aa96a1b 292%install
293rm -rf $RPM_BUILD_ROOT
5ff7d7dd 294install -d $RPM_BUILD_ROOT%{_infodir}
6aa96a1b 295
e28f2cc1 296%{__make} -C build -j1 install install-info \
049ba25c 297 DESTDIR=$RPM_BUILD_ROOT
e611e157 298
e28f2cc1 299cp -a build/gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
124c2194
JB
300
301# gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
a59c1d89
ER
302# window is created too.
303echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
304ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
305
8d9a5f3e 306bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
124c2194 307%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
7566401a
ER
308
309rm -f $RPM_BUILD_ROOT%{_infodir}/dir
7566401a
ER
310
311%if %{with python}
312# Temporarily now:
432e4f9b 313for LIB in lib lib64 libx32; do
7566401a
ER
314 LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
315 install -d $LIBPATH
7566401a 316done
fc1b3e2b 317
3a039e54
JP
318%py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}
319%py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}
7566401a 320%endif
8d9a5f3e 321
41611023
ER
322cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
323
e28f2cc1 324cp -p build/libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
70189bec 325
7566401a 326# Remove the files that are part of a gdb build but that are owned and provided by other packages.
d7dc9553
JB
327# These are part of binutils:
328%{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
b1b25d28 329%{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
1d2a824d 330%{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,diagnostics,dis-asm,symcat,plugin-api}.h
d7dc9553 331%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
321e94d6 332%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
f02a934e 333
b0a9ea6d
JB
334%clean
335rm -rf $RPM_BUILD_ROOT
6aa96a1b 336
138e5ce3 337%post -p /sbin/postshell
1f7f0d47 338-/usr/sbin/fix-info-dir -c %{_infodir}
6aa96a1b 339
138e5ce3 340%postun -p /sbin/postshell
1f7f0d47 341-/usr/sbin/fix-info-dir -c %{_infodir}
6aa96a1b 342
6aa96a1b 343%files
0241102e 344%defattr(644,root,root,755)
f0842f54 345%doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
7566401a
ER
346%attr(755,root,root) %{_bindir}/gdb
347%attr(755,root,root) %{_bindir}/gdbtui
969912f7
JR
348%attr(755,root,root) %{_bindir}/gdb-add-index
349%attr(755,root,root) %{_bindir}/gstack
321e94d6 350%attr(755,root,root) %{_bindir}/gcore
7566401a 351%dir %{_datadir}/gdb
a6c8042b
PS
352%dir %{_datadir}/gdb/auto-load
353%dir %{_datadir}/gdb/auto-load%{_prefix}
354%dir %{_datadir}/gdb/auto-load%{_prefix}/lib
432e4f9b 355%ifarch %{x8664} x32
a6c8042b 356%dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
432e4f9b 357%dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
a6c8042b 358%endif
174fe25c
JP
359%ifarch aarch64
360%dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
361%endif
4ed7a5ee 362%{?with_guile:%{_datadir}/gdb/guile}
7566401a 363%{_datadir}/gdb/syscalls
3e0eff1e 364%{_datadir}/gdb/system-gdbinit
6ed6bacf 365%{_datadir}/gdb/python
7566401a
ER
366%{_mandir}/man1/gdb.1*
367%{_mandir}/man1/gdbtui.1*
f727df28 368%{_mandir}/man1/gdb-add-index.1*
41611023 369%{_mandir}/man1/gstack.1*
321e94d6 370%{_mandir}/man1/gcore.1*
3e0eff1e 371%{_mandir}/man5/gdbinit.5*
8d9a5f3e 372%lang(es) %{_mandir}/es/man1/*
373%lang(fr) %{_mandir}/fr/man1/*
374%lang(hu) %{_mandir}/hu/man1/*
375%lang(ja) %{_mandir}/ja/man1/*
376%lang(pl) %{_mandir}/pl/man1/*
7566401a
ER
377%{_infodir}/annotate.info*
378%{_infodir}/gdb.info*
7566401a
ER
379%{_infodir}/stabs.info*
380
138e5ce3
JB
381%files gdbserver
382%defattr(644,root,root,755)
383%attr(755,root,root) %{_bindir}/gdbserver
384%{_mandir}/man1/gdbserver.1*
19bd73a6 385%ifnarch %{arm}
138e5ce3 386%attr(755,root,root) %{_libdir}/libinproctrace.so
19bd73a6 387%endif
138e5ce3 388
f02a934e
JR
389%files lib
390%defattr(644,root,root,755)
70189bec 391%{_libdir}/libdecnumber.a
f02a934e 392%{_libdir}/libgdb.a
d7dc9553 393%{_includedir}/gdb
This page took 0.134846 seconds and 4 git commands to generate.