]> git.pld-linux.org Git - packages/gdb.git/commitdiff
- added readline8.2 patch from git (fixes build with readline 8.2.x)
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 7 Oct 2022 14:02:57 +0000 (16:02 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 7 Oct 2022 14:02:57 +0000 (16:02 +0200)
gdb-readline8.2.patch [new file with mode: 0644]
gdb.spec

diff --git a/gdb-readline8.2.patch b/gdb-readline8.2.patch
new file mode 100644 (file)
index 0000000..ce1cd55
--- /dev/null
@@ -0,0 +1,36 @@
+From 1add37b567a7dee39d99f37b37802034c3fce9c4 Mon Sep 17 00:00:00 2001
+From: Andreas Schwab <schwab@linux-m68k.org>
+Date: Sun, 20 Mar 2022 14:01:54 +0100
+Subject: [PATCH] Add support for readline 8.2
+
+In readline 8.2 the type of rl_completer_word_break_characters changed to
+include const.
+---
+ gdb/completer.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/gdb/completer.c b/gdb/completer.c
+index d3900ae2014..a51c16ac7f8 100644
+--- a/gdb/completer.c
++++ b/gdb/completer.c
+@@ -36,7 +36,7 @@
+    calling a hook instead so we eliminate the CLI dependency.  */
+ #include "gdbcmd.h"
+-/* Needed for rl_completer_word_break_characters() and for
++/* Needed for rl_completer_word_break_characters and for
+    rl_filename_completion_function.  */
+ #include "readline/readline.h"
+@@ -2011,7 +2011,7 @@ gdb_completion_word_break_characters_throw ()
+       rl_basic_quote_characters = NULL;
+     }
+-  return rl_completer_word_break_characters;
++  return (char *) rl_completer_word_break_characters;
+ }
+ char *
+-- 
+2.31.1
+
index ae7118757104ce9b111bc656ef23026824533e5e..14b10a8034f46c951249b09e0ff36a5e251856a6 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -41,6 +41,7 @@ Patch110:     gdb-6.3-gstack-20050411.patch
 Patch1000:     %{name}-readline.patch
 Patch1001:     %{name}-info.patch
 Patch1002:     %{name}-passflags.patch
+Patch1003:     %{name}-readline8.2.patch
 Patch1005:     %{name}-pretty-print-by-default.patch
 Patch1006:     buildid-locate-rpm-pld.patch
 URL:           http://www.gnu.org/software/gdb/
@@ -202,6 +203,7 @@ GDB w postaci biblioteki statycznej.
 %patch1000 -p1
 %patch1001 -p1
 %patch1002 -p1
+%patch1003 -p1
 %patch1005 -p1
 %patch1006 -p1
 
This page took 0.66473 seconds and 4 git commands to generate.