]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- fix install progs
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
2b3b2117 1# Conditional build:
e756f355 2%bcond_with amr # build 3GPP Adaptive Multi Rate (AMR) speech codec
294c9b1e
JB
3%bcond_without autoreqdep # don't care about package name deps generated by rpm
4%bcond_without imlib2 # don't build imlib2 vhook module
874f67c9 5#
2305d791
ER
6%define _snap 2006-12-04
7%define snap %(echo %{_snap} | tr -d -)
09d9551a 8%define _rel 0.4
76243dbd
JB
9Summary: Realtime audio/video encoder and streaming server
10Summary(pl): Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
9fc4ad22 11Name: ffmpeg
c32b589f 12Version: 0.4.9
839e806f 13Release: 3.%{snap}.%{_rel}
9cf4d8a4 14# LGPL or GPL, chosen at configure time (GPL version is more featured)
fc8de229 15# (postprocessing, a52, xvid, x264, dts, faad)
f68a4dcc 16License: GPL with LGPL parts
fde29260 17Group: Applications/Multimedia
d7493de8 18#Source0: http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
f50f7d7c 19#Source0: ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
2305d791
ER
20#Source0: %{name}-%{snap}.tar.bz2
21Source0: http://ffmpeg.mplayerhq.hu/%{name}-export-snapshot.tar.bz2
22# Source0-md5: 5be2e4d1e326bb7809205a3401204621
fde29260
ER
23Source1: ffserver.init
24Source2: ffserver.sysconfig
38cf6de3 25Source3: ffserver.conf
d7493de8
JB
26Patch0: %{name}-libtool.patch
27Patch1: %{name}-libdir.patch
7a286645 28Patch2: %{name}-gcc4.patch
fc8de229 29Patch3: %{name}-system-amr.patch
2305d791 30Patch4: %{name}-x264-symbol.patch
892bb830 31Patch5: %{name}-kill-mabi_altivec.patch
d2fa6a1d 32URL: http://ffmpeg.mplayerhq.hu/
2a60eebe 33BuildRequires: SDL-devel
fc8de229
JB
34%if %{with amr}
35BuildRequires: amrnb-devel
36BuildRequires: amrwb-devel >= 5.3.0
37%endif
e380e18a 38BuildRequires: faac-devel
b959c224 39BuildRequires: faad2-devel
2a60eebe 40BuildRequires: freetype-devel
4bee03f0
JB
41%ifarch ppc
42# require version with altivec support fixed
43BuildRequires: gcc >= 5:3.3.2-3
44%endif
8a764e4b 45%{?with_imlib2:BuildRequires: imlib2-devel >= 1.1.0-2}
e380e18a 46BuildRequires: lame-libs-devel
b959c224 47BuildRequires: libdts-devel
f3692243 48BuildRequires: libgsm-devel
d7493de8 49BuildRequires: libtheora-devel
4814ac84 50BuildRequires: libtool >= 2:1.4d-3
e380e18a 51BuildRequires: libvorbis-devel
42dd6e0f 52BuildRequires: libx264-devel >= 0.1.2-1.20061024_2245.1
e1fe03f7 53%ifarch %{ix86}
54%ifnarch i386 i486
76243dbd
JB
55BuildRequires: nasm
56%endif
e1fe03f7 57%endif
1463656a 58BuildRequires: perl-tools-pod
593d3a64 59BuildRequires: rpmbuild(macros) >= 1.268
1463656a 60BuildRequires: tetex
9cf4d8a4 61BuildRequires: texinfo
872de59d 62%{?with_amr:BuildRequires: unzip}
46f2a56b 63BuildRequires: xvid-devel >= 1:1.1.0
33a1c0f3 64BuildRequires: zlib-devel
57ebb8ad 65%{?with_autoreqdep:BuildConflicts: libpostproc}
54ec280e 66Requires: %{name}-libs = %{version}-%{release}
839e806f 67Requires: xvid >= 1:1.1.0
af49d6ab 68Obsoletes: libpostproc
539b540f 69BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 70
2a60eebe
JB
71%define _noautoreqdep libGL.so.1 libGLU.so.1
72
c01d7857
PS
73%define specflags -fno-strict-aliasing
74
75# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
76%define specflags_ia32 -fomit-frame-pointer
77# -mmmx is needed to enable <mmintrin.h> code.
78%define specflags_i586 -mmmx
79%define specflags_i686 -mmmx
80
9fc4ad22
AM
81%description
82ffmpeg is a hyper fast realtime audio/video encoder and streaming
83server. It can grab from a standard Video4Linux video source and
84convert it into several file formats based on DCT/motion compensation
85encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
fda3e16d 86compatible stream.
9fc4ad22
AM
87
88%description -l pl
fda3e16d 89ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
90