]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- -lX11 for ffplay (direct XOpen/CloseDisplay usage).
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
8152d6a2 1#
294c9b1e 2# TODO: update for lzo 2.x (currently only lzo 1.x is supported)
3f3f0ec8 3# - make (ffmpeg code inside) mplayer play .3gp mobile phone movies
f68a4dcc 4# (ffplay and vlc plays them fine
8152d6a2 5#
2b3b2117 6# Conditional build:
3534e1ea 7%bcond_without amr # don't build 3GPP Adaptive Multi Rate (AMR) speech codec
294c9b1e
JB
8%bcond_without autoreqdep # don't care about package name deps generated by rpm
9%bcond_without imlib2 # don't build imlib2 vhook module
10%bcond_with lzo # build with LZO support
874f67c9 11#
76243dbd
JB
12Summary: Realtime audio/video encoder and streaming server
13Summary(pl): Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
9fc4ad22 14Name: ffmpeg
c32b589f 15Version: 0.4.9
3534e1ea 16%define snap 20060129
95e03dfb 17%define _rel 10
839e806f 18Release: 3.%{snap}.%{_rel}
9cf4d8a4 19# LGPL or GPL, chosen at configure time (GPL version is more featured)
f68a4dcc 20#
21# (BTW. what are the 'more' features mentioned above?)
22#
23# Some parts of the code *is* LGPL (for example libavformat amr.c) so
24# it is possible to include /and distribute/ external 3GPP AMR codecs
25# (some kind of public domain with patent restrictions) to the
26# GPL-licensed stuff /and keep GPL license/.
27%if %{with amr}
28License: GPL with LGPL/Public Domain parts
29%else
30License: GPL with LGPL parts
31%endif
fde29260 32Group: Applications/Multimedia
d7493de8 33#Source0: http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
f50f7d7c
JB
34#Source0: ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
35Source0: %{name}-%{snap}.tar.bz2
36# Source0-md5: d8ea09431d6c0c91bfd35e0ca74a67e1
fde29260
ER
37Source1: ffserver.init
38Source2: ffserver.sysconfig
38cf6de3 39Source3: ffserver.conf
b524cd99 40%if %{with amr}
41# AMR WB FLOAT
42#Source4: http://www.3gpp.org/ftp/Specs/latest/Rel-6/26_series/26204-600.zip
b524cd99 43Source4: http://www.3gpp.org/ftp/Specs/latest/Rel-5/26_series/26204-530.zip
44# Source4-md5: 988060bdb18b5d64b8bd82c3507d2420
b524cd99 45# AMR NB FLOAT
46#Source6: http://www.3gpp.org/ftp/Specs/latest/Rel-6/26_series/26104-610.zip
47Source6: http://www.3gpp.org/ftp/Specs/latest/Rel-5/26_series/26104-540.zip
48# Source6-md5: 4dcbeb2bc28bf86e7131fe4cae3e0dec
49%endif
50
d7493de8
JB
51Patch0: %{name}-libtool.patch
52Patch1: %{name}-libdir.patch
7a286645 53Patch2: %{name}-gcc4.patch
bb062d35 54URL: http://ffmpeg.sourceforge.net/
2a60eebe 55BuildRequires: SDL-devel
e380e18a 56BuildRequires: faac-devel
b959c224 57BuildRequires: faad2-devel
2a60eebe 58BuildRequires: freetype-devel
4bee03f0
JB
59%ifarch ppc
60# require version with altivec support fixed
61BuildRequires: gcc >= 5:3.3.2-3
62%endif
8a764e4b 63%{?with_imlib2:BuildRequires: imlib2-devel >= 1.1.0-2}
e380e18a 64BuildRequires: lame-libs-devel
b959c224 65BuildRequires: libdts-devel
f3692243 66BuildRequires: libgsm-devel
d7493de8 67BuildRequires: libtheora-devel
4814ac84 68BuildRequires: libtool >= 2:1.4d-3
e380e18a 69BuildRequires: libvorbis-devel
8b2a8e66 70BuildRequires: libx264-devel >= 0.1.2-1.20060430_2245.1
294c9b1e 71%{?with_lzo:BuildRequires: lzo-devel < 2.0}
e1fe03f7 72%ifarch %{ix86}
73%ifnarch i386 i486
76243dbd
JB
74BuildRequires: nasm
75%endif
e1fe03f7 76%endif
1463656a 77BuildRequires: perl-tools-pod
593d3a64 78BuildRequires: rpmbuild(macros) >= 1.268
1463656a 79BuildRequires: tetex
9cf4d8a4 80BuildRequires: texinfo
872de59d 81%{?with_amr:BuildRequires: unzip}
46f2a56b 82BuildRequires: xvid-devel >= 1:1.1.0
33a1c0f3 83BuildRequires: zlib-devel
57ebb8ad 84%{?with_autoreqdep:BuildConflicts: libpostproc}
54ec280e 85Requires: %{name}-libs = %{version}-%{release}
839e806f 86Requires: xvid >= 1:1.1.0
af49d6ab 87Obsoletes: libpostproc
539b540f 88BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 89
2a60eebe
JB
90%define _noautoreqdep libGL.so.1 libGLU.so.1
91
c01d7857
PS
92%define specflags -fno-strict-aliasing
93
94# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
95%define specflags_ia32 -fomit-frame-pointer
96# -mmmx is needed to enable <mmintrin.h> code.
97%define specflags_i586 -mmmx
98%define specflags_i686 -mmmx
99
9fc4ad22
AM
100%description
101ffmpeg is a hyper fast realtime audio/video encoder and streaming
102server. It can grab from a standard Video4Linux video source and
103convert it into several file formats based on DCT/motion compensation
104encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
fda3e16d 105compatible stream.
9fc4ad22
AM
106
107%description -l pl
fda3e16d 108ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
109