]> git.pld-linux.org Git - packages/commoncpp2.git/blame - commoncpp2.spec
- fix building with gcc 11, rebuild with openssl 3.0.0, rel 6
[packages/commoncpp2.git] / commoncpp2.spec
CommitLineData
e5703f90
KK
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
8dc0ec17 4%bcond_with gnutls # use GnuTLS instead of OpenSSL [needs update: recent gnutls no longer uses libgcrypt]
e5703f90 5#
3ef9580c 6Summary: A GNU package for creating portable C++ programs
8c8acc7d 7Summary(pl.UTF-8): Pakiet GNU do tworzenia przenośnych programów w C++
3ef9580c 8Name: commoncpp2
8fc0cf85 9Version: 1.8.1
0f7d9105 10Release: 6
c45a90a3 11License: GPL v2+ with runtime exception
3ef9580c 12Group: Libraries
9cfec48b 13Source0: http://ftp.gnu.org/gnu/commoncpp/%{name}-%{version}.tar.gz
8fc0cf85
JB
14# Source0-md5: 4804b184e609154ba2bc0aa9f61dc6ef
15Patch0: %{name}-netfilter.patch
16Patch1: %{name}-include.patch
17Patch2: %{name}-link.patch
18Patch3: %{name}-info.patch
4c3fdf6b 19Patch4: openssl.patch
7c7445ba 20URL: http://www.gnu.org/software/commoncpp/
8fc0cf85 21BuildRequires: autoconf >= 2.50
7c7445ba 22BuildRequires: automake
3ef9580c 23BuildRequires: doxygen
8dc0ec17 24%{?with_gnutls:BuildRequires: gnutls-devel}
3ef9580c 25BuildRequires: libstdc++-devel
8fc0cf85 26BuildRequires: libtool >= 2:1.5
3ef9580c 27BuildRequires: libxml2-devel
8dc0ec17 28%{!?with_gnutls:BuildRequires: openssl-devel}
8fc0cf85 29BuildRequires: texinfo
3ef9580c 30BuildRequires: zlib-devel
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34This is the second major release of GNU Common C++. GNU Common C++ "2"
35is a GNU package which offers portable "abstraction" of system
36services such as threads, networks, and sockets. GNU Common C++ "2"
37also offers individual frameworks generally useful to developing
38portable C++ applications including a object persistance engine, math
39libraries, threading, sockets, etc. GNU Common C++ "2" is small, and
40highly portable. GNU Common C++ "2" will support most Unix operating
1abd0668 41systems as well as Win32, in addition to GNU/Linux.
3ef9580c 42
06c607b2
JR
43%description -l pl.UTF-8
44Drugie główne wydanie GNU Common C++. GNU Common C++ oferuje przenośne
45abstrakcje usług systemowych takich jak wątki, sieci i gniazda.
46Oferuje także poszczególne szkielety użyteczne do rozwijania
47przenośnych aplikacji C++ zawierające silnik trwałych obiektów,
48biblioteki matematyczne, wątków, gniazd itd. GNU Common C++ jest mały
49i przenośny. Oprócz GNU/Linuksa obsługuje także większość uniksowych
50systemów operacyjnych oraz Win32.
17bc0025 51
3ef9580c 52%package devel
53Summary: Header files for commoncpp2 library
8c8acc7d 54Summary(pl.UTF-8): Pliki nagłówkowe biblioteki commoncpp2
3ef9580c 55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
8dc0ec17 57%{?with_gnutls:Requires: gnutls-devel}
3ef9580c 58Requires: libstdc++-devel
59Requires: libxml2-devel
8dc0ec17 60%{!?with_gnutls:Requires: openssl-devel}
3ef9580c 61Requires: zlib-devel
62
63%description devel
64Header files for commoncpp2 library.
65
06c607b2
JR
66%description devel -l pl.UTF-8
67Pliki nagłówkowe biblioteki commoncpp2.
3ef9580c 68
69%package static
70Summary: Static commoncpp2 library
8c8acc7d 71Summary(pl.UTF-8): Statyczna biblioteka commoncpp2
3ef9580c 72Group: Development/Libraries
73Requires: %{name}-devel = %{version}-%{release}
74
75%description static
76Static commoncpp2 library.
77
06c607b2 78%description static -l pl.UTF-8
3ef9580c 79Statyczna biblioteka commoncpp2.
80
81%prep
82%setup -q
7a5c4ef4 83%patch0 -p1
54a4a4fa 84%patch1 -p1
8fc0cf85
JB
85%patch2 -p1
86%patch3 -p1
4c3fdf6b 87%patch4 -p1
3ef9580c 88
89%build
e131c2a8 90%{__libtoolize}
4a331386 91%{__aclocal} -I m4
4a331386 92%{__autoconf}
e131c2a8 93%{__autoheader}
94%{__automake}
0f7d9105 95export CXXFLAGS="%{rpmcxxflags} -std=c++11 -fpermissive"
4a331386 96%configure \
e5703f90 97 %{!?with_static_libs:--disable-static} \
8dc0ec17
JB
98 %{?with_gnutls:--with-gnutls} \
99 %{!?with_gnutls:--with-openssl}
8fc0cf85
JB
100
101# ensure netfilter is detected
8dc0ec17 102grep -q 'HAVE_NAT_NETFILTER 1' config.h || exit 1
8fc0cf85 103
54a4a4fa 104%{__make} -j1
3ef9580c 105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109%{__make} install \
110 DESTDIR=$RPM_BUILD_ROOT
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post -p /sbin/ldconfig
116%postun -p /sbin/ldconfig
117
8fc0cf85 118%post devel -p /sbin/postshell
2485d124 119-/usr/sbin/fix-info-dir -c %{_infodir}
3ef9580c 120
8fc0cf85 121%postun devel -p /sbin/postshell
2485d124 122-/usr/sbin/fix-info-dir -c %{_infodir}
3ef9580c 123
124%files
125%defattr(644,root,root,755)
8fc0cf85
JB
126%doc AUTHORS COPYING.addendum ChangeLog NEWS README SUPPORT THANKS TODO
127%attr(755,root,root) %{_libdir}/libccext2-1.8.so.*.*.*
128%ghost %{_libdir}/libccext2-1.8.so.0
129%attr(755,root,root) %{_libdir}/libccgnu2-1.8.so.*.*.*
130%ghost %{_libdir}/libccgnu2-1.8.so.0
3ef9580c 131
132%files devel
133%defattr(644,root,root,755)
8fc0cf85
JB
134%doc doc/html/*.{css,html,js,png}
135%attr(755,root,root) %{_bindir}/ccgnu2-config
136%attr(755,root,root) %{_libdir}/libccext2.so
137%attr(755,root,root) %{_libdir}/libccgnu2.so
138%{_libdir}/libccext2.la
139%{_libdir}/libccgnu2.la
8bab2ee7 140%{_includedir}/cc++
8fc0cf85
JB
141%{_aclocaldir}/ost_check2.m4
142%{_pkgconfigdir}/libccext2.pc
143%{_pkgconfigdir}/libccgnu2.pc
144%{_infodir}/commoncpp2.info*
3ef9580c 145
e5703f90 146%if %{with static_libs}
3ef9580c 147%files static
148%defattr(644,root,root,755)
8fc0cf85
JB
149%{_libdir}/libccext2.a
150%{_libdir}/libccgnu2.a
e5703f90 151%endif
This page took 0.083591 seconds and 4 git commands to generate.