]> git.pld-linux.org Git - packages/commoncpp2.git/blob - commoncpp2.spec
- fix building with gcc 11, rebuild with openssl 3.0.0, rel 6
[packages/commoncpp2.git] / commoncpp2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_with     gnutls          # use GnuTLS instead of OpenSSL [needs update: recent gnutls no longer uses libgcrypt]
5 #
6 Summary:        A GNU package for creating portable C++ programs
7 Summary(pl.UTF-8):      Pakiet GNU do tworzenia przenośnych programów w C++
8 Name:           commoncpp2
9 Version:        1.8.1
10 Release:        1
11 License:        GPL v2+ with runtime exception
12 Group:          Libraries
13 Source0:        http://ftp.gnu.org/gnu/commoncpp/%{name}-%{version}.tar.gz
14 # Source0-md5:  4804b184e609154ba2bc0aa9f61dc6ef
15 Patch0:         %{name}-netfilter.patch
16 Patch1:         %{name}-include.patch
17 Patch2:         %{name}-link.patch
18 Patch3:         %{name}-info.patch
19 URL:            http://www.gnu.org/software/commoncpp/
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  doxygen
23 %{?with_gnutls:BuildRequires:   gnutls-devel}
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool >= 2:1.5
26 BuildRequires:  libxml2-devel
27 %{!?with_gnutls:BuildRequires:  openssl-devel}
28 BuildRequires:  texinfo
29 BuildRequires:  zlib-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This is the second major release of GNU Common C++. GNU Common C++ "2"
34 is a GNU package which offers portable "abstraction" of system
35 services such as threads, networks, and sockets. GNU Common C++ "2"
36 also offers individual frameworks generally useful to developing
37 portable C++ applications including a object persistance engine, math
38 libraries, threading, sockets, etc. GNU Common C++ "2" is small, and
39 highly portable. GNU Common C++ "2" will support most Unix operating
40 systems as well as Win32, in addition to GNU/Linux.
41
42 %description -l pl.UTF-8
43 Drugie główne wydanie GNU Common C++. GNU Common C++ oferuje przenośne
44 abstrakcje usług systemowych takich jak wątki, sieci i gniazda.
45 Oferuje także poszczególne szkielety użyteczne do rozwijania
46 przenośnych aplikacji C++ zawierające silnik trwałych obiektów,
47 biblioteki matematyczne, wątków, gniazd itd. GNU Common C++ jest mały
48 i przenośny. Oprócz GNU/Linuksa obsługuje także większość uniksowych
49 systemów operacyjnych oraz Win32.
50
51 %package devel
52 Summary:        Header files for commoncpp2 library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki commoncpp2
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 %{?with_gnutls:Requires:        gnutls-devel}
57 Requires:       libstdc++-devel
58 Requires:       libxml2-devel
59 %{!?with_gnutls:Requires:       openssl-devel}
60 Requires:       zlib-devel
61
62 %description devel
63 Header files for commoncpp2 library.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki commoncpp2.
67
68 %package static
69 Summary:        Static commoncpp2 library
70 Summary(pl.UTF-8):      Statyczna biblioteka commoncpp2
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static commoncpp2 library.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka commoncpp2.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85 %patch3 -p1
86
87 %build
88 %{__libtoolize}
89 %{__aclocal} -I m4
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 %configure \
94         %{!?with_static_libs:--disable-static} \
95         %{?with_gnutls:--with-gnutls} \
96         %{!?with_gnutls:--with-openssl}
97
98 # ensure netfilter is detected
99 grep -q 'HAVE_NAT_NETFILTER 1' config.h || exit 1
100
101 %{__make} -j1
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %post   devel -p /sbin/postshell
116 -/usr/sbin/fix-info-dir -c %{_infodir}
117
118 %postun devel -p /sbin/postshell
119 -/usr/sbin/fix-info-dir -c %{_infodir}
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS COPYING.addendum ChangeLog NEWS README SUPPORT THANKS TODO
124 %attr(755,root,root) %{_libdir}/libccext2-1.8.so.*.*.*
125 %ghost %{_libdir}/libccext2-1.8.so.0
126 %attr(755,root,root) %{_libdir}/libccgnu2-1.8.so.*.*.*
127 %ghost %{_libdir}/libccgnu2-1.8.so.0
128
129 %files devel
130 %defattr(644,root,root,755)
131 %doc doc/html/*.{css,html,js,png}
132 %attr(755,root,root) %{_bindir}/ccgnu2-config
133 %attr(755,root,root) %{_libdir}/libccext2.so
134 %attr(755,root,root) %{_libdir}/libccgnu2.so
135 %{_libdir}/libccext2.la
136 %{_libdir}/libccgnu2.la
137 %{_includedir}/cc++
138 %{_aclocaldir}/ost_check2.m4
139 %{_pkgconfigdir}/libccext2.pc
140 %{_pkgconfigdir}/libccgnu2.pc
141 %{_infodir}/commoncpp2.info*
142
143 %if %{with static_libs}
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libccext2.a
147 %{_libdir}/libccgnu2.a
148 %endif
This page took 0.03541 seconds and 3 git commands to generate.