]> git.pld-linux.org Git - packages/commoncpp2.git/blame - commoncpp2.spec
- updated to 1.8.1
[packages/commoncpp2.git] / commoncpp2.spec
CommitLineData
e5703f90
KK
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4#
3ef9580c 5Summary: A GNU package for creating portable C++ programs
8c8acc7d 6Summary(pl.UTF-8): Pakiet GNU do tworzenia przenośnych programów w C++
3ef9580c 7Name: commoncpp2
8fc0cf85
JB
8Version: 1.8.1
9Release: 1
10License: GPL v2+ with linking exception
3ef9580c 11Group: Libraries
9cfec48b 12Source0: http://ftp.gnu.org/gnu/commoncpp/%{name}-%{version}.tar.gz
8fc0cf85
JB
13# Source0-md5: 4804b184e609154ba2bc0aa9f61dc6ef
14Patch0: %{name}-netfilter.patch
15Patch1: %{name}-include.patch
16Patch2: %{name}-link.patch
17Patch3: %{name}-info.patch
7c7445ba 18URL: http://www.gnu.org/software/commoncpp/
8fc0cf85 19BuildRequires: autoconf >= 2.50
7c7445ba 20BuildRequires: automake
3ef9580c 21BuildRequires: doxygen
22BuildRequires: libstdc++-devel
8fc0cf85 23BuildRequires: libtool >= 2:1.5
3ef9580c 24BuildRequires: libxml2-devel
4a331386 25BuildRequires: openssl-devel
8fc0cf85 26BuildRequires: texinfo
3ef9580c 27BuildRequires: zlib-devel
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31This is the second major release of GNU Common C++. GNU Common C++ "2"
32is a GNU package which offers portable "abstraction" of system
33services such as threads, networks, and sockets. GNU Common C++ "2"
34also offers individual frameworks generally useful to developing
35portable C++ applications including a object persistance engine, math
36libraries, threading, sockets, etc. GNU Common C++ "2" is small, and
37highly portable. GNU Common C++ "2" will support most Unix operating
1abd0668 38systems as well as Win32, in addition to GNU/Linux.
3ef9580c 39
06c607b2
JR
40%description -l pl.UTF-8
41Drugie główne wydanie GNU Common C++. GNU Common C++ oferuje przenośne
42abstrakcje usług systemowych takich jak wątki, sieci i gniazda.
43Oferuje także poszczególne szkielety użyteczne do rozwijania
44przenośnych aplikacji C++ zawierające silnik trwałych obiektów,
45biblioteki matematyczne, wątków, gniazd itd. GNU Common C++ jest mały
46i przenośny. Oprócz GNU/Linuksa obsługuje także większość uniksowych
47systemów operacyjnych oraz Win32.
17bc0025 48
3ef9580c 49%package devel
50Summary: Header files for commoncpp2 library
8c8acc7d 51Summary(pl.UTF-8): Pliki nagłówkowe biblioteki commoncpp2
3ef9580c 52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54Requires: libstdc++-devel
55Requires: libxml2-devel
e5703f90 56Requires: openssl-devel
3ef9580c 57Requires: zlib-devel
58
59%description devel
60Header files for commoncpp2 library.
61
06c607b2
JR
62%description devel -l pl.UTF-8
63Pliki nagłówkowe biblioteki commoncpp2.
3ef9580c 64
65%package static
66Summary: Static commoncpp2 library
8c8acc7d 67Summary(pl.UTF-8): Statyczna biblioteka commoncpp2
3ef9580c 68Group: Development/Libraries
69Requires: %{name}-devel = %{version}-%{release}
70
71%description static
72Static commoncpp2 library.
73
06c607b2 74%description static -l pl.UTF-8
3ef9580c 75Statyczna biblioteka commoncpp2.
76
77%prep
78%setup -q
7a5c4ef4 79%patch0 -p1
54a4a4fa 80%patch1 -p1
8fc0cf85
JB
81%patch2 -p1
82%patch3 -p1
3ef9580c 83
84%build
e131c2a8 85%{__libtoolize}
4a331386 86%{__aclocal} -I m4
4a331386 87%{__autoconf}
e131c2a8 88%{__autoheader}
89%{__automake}
4a331386 90%configure \
e5703f90 91 %{!?with_static_libs:--disable-static} \
4a331386 92 --with-openssl
8fc0cf85
JB
93
94# ensure netfilter is detected
95grep 'HAVE_NAT_NETFILTER 1' config.h || exit 1
96
54a4a4fa 97%{__make} -j1
3ef9580c 98
99%install
100rm -rf $RPM_BUILD_ROOT
101
102%{__make} install \
103 DESTDIR=$RPM_BUILD_ROOT
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post -p /sbin/ldconfig
109%postun -p /sbin/ldconfig
110
8fc0cf85 111%post devel -p /sbin/postshell
2485d124 112-/usr/sbin/fix-info-dir -c %{_infodir}
3ef9580c 113
8fc0cf85 114%postun devel -p /sbin/postshell
2485d124 115-/usr/sbin/fix-info-dir -c %{_infodir}
3ef9580c 116
117%files
118%defattr(644,root,root,755)
8fc0cf85
JB
119%doc AUTHORS COPYING.addendum ChangeLog NEWS README SUPPORT THANKS TODO
120%attr(755,root,root) %{_libdir}/libccext2-1.8.so.*.*.*
121%ghost %{_libdir}/libccext2-1.8.so.0
122%attr(755,root,root) %{_libdir}/libccgnu2-1.8.so.*.*.*
123%ghost %{_libdir}/libccgnu2-1.8.so.0
3ef9580c 124
125%files devel
126%defattr(644,root,root,755)
8fc0cf85
JB
127%doc doc/html/*.{css,html,js,png}
128%attr(755,root,root) %{_bindir}/ccgnu2-config
129%attr(755,root,root) %{_libdir}/libccext2.so
130%attr(755,root,root) %{_libdir}/libccgnu2.so
131%{_libdir}/libccext2.la
132%{_libdir}/libccgnu2.la
8bab2ee7 133%{_includedir}/cc++
8fc0cf85
JB
134%{_aclocaldir}/ost_check2.m4
135%{_pkgconfigdir}/libccext2.pc
136%{_pkgconfigdir}/libccgnu2.pc
137%{_infodir}/commoncpp2.info*
3ef9580c 138
e5703f90 139%if %{with static_libs}
3ef9580c 140%files static
141%defattr(644,root,root,755)
8fc0cf85
JB
142%{_libdir}/libccext2.a
143%{_libdir}/libccgnu2.a
e5703f90 144%endif
This page took 0.106099 seconds and 4 git commands to generate.