]> git.pld-linux.org Git - packages/commoncpp2.git/commitdiff
- updated to 1.8.1
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 2 Jan 2012 19:36:02 +0000 (19:36 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- removed obsolete lt,gcc4 patches
- added netfilter patch, ensure that NAT is detected after running configure
- added include patch (missing <sys/stat.h> for mkfifo())
- added link patch instead of bogus skip_post_check_so
- added info patch (to unify direntry)

Changed files:
    commoncpp2-gcc4.patch -> 1.2
    commoncpp2-include.patch -> 1.1
    commoncpp2-info.patch -> 1.1
    commoncpp2-link.patch -> 1.1
    commoncpp2-lt.patch -> 1.5
    commoncpp2-netfilter.patch -> 1.1
    commoncpp2.spec -> 1.30

commoncpp2-gcc4.patch [deleted file]
commoncpp2-include.patch [new file with mode: 0644]
commoncpp2-info.patch [new file with mode: 0644]
commoncpp2-link.patch [new file with mode: 0644]
commoncpp2-lt.patch [deleted file]
commoncpp2-netfilter.patch [new file with mode: 0644]
commoncpp2.spec

diff --git a/commoncpp2-gcc4.patch b/commoncpp2-gcc4.patch
deleted file mode 100644 (file)
index fb491c2..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- commoncpp2-1.7.1/src/cidr.cpp.orig 2009-10-23 23:38:56.094302646 +0200
-+++ commoncpp2-1.7.1/src/cidr.cpp      2009-10-23 23:41:40.582997710 +0200
-@@ -202,7 +202,7 @@
- #if defined(_MSC_VER) && _MSC_VER >= 1500
-       ep = (char *)strchr(cp, '/');
- #else
--      ep = strchr(cp, '/');
-+      ep = (char *)strchr(cp, '/');
- #endif
-       if(ep)
-@@ -332,7 +332,7 @@
-       memset(&netmask, 0, sizeof(netmask));
-       bitset((bit_t *)&netmask, getMask(cp));
-       setString(cbuf, sizeof(cbuf), cp);
--      ep = strchr(cp, '/');
-+      ep = (char *)strchr(cp, '/');
-       if(ep)
-               *ep = 0;
diff --git a/commoncpp2-include.patch b/commoncpp2-include.patch
new file mode 100644 (file)
index 0000000..6db9cd5
--- /dev/null
@@ -0,0 +1,10 @@
+--- commoncpp2-1.8.1/src/applog.cpp.orig       2010-11-01 00:11:55.000000000 +0100
++++ commoncpp2-1.8.1/src/applog.cpp    2012-01-02 19:32:59.313140341 +0100
+@@ -45,6 +45,7 @@
+ #include <cstdlib>
+ #include <stdarg.h>
+ #include <errno.h>
++#include <sys/stat.h>
+ // TODO sc: test if has to move up now that it is into commoncpp
+ // NOTE: the order of inclusion is important do not move following include line
diff --git a/commoncpp2-info.patch b/commoncpp2-info.patch
new file mode 100644 (file)
index 0000000..e781b2d
--- /dev/null
@@ -0,0 +1,14 @@
+--- commoncpp2-1.8.1/doc/commoncpp2.texi.orig  2010-10-31 17:29:17.000000000 +0100
++++ commoncpp2-1.8.1/doc/commoncpp2.texi       2012-01-02 20:11:27.536550962 +0100
+@@ -12,9 +12,9 @@
+ @set VERSION 1.0
+ @set UPDATED September 2002
+-@dircategory Development
++@dircategory Libraries:
+ @direntry
+-* GNU Common C++ 2: (commoncpp2).     GNU Common C++ 2 Framework Documentation.
++* GNU Common C++ 2: (commoncpp2).     GNU Common C++ 2 Framework Documentation
+ @end direntry
+ @c -----------------------------------------------------------------------
diff --git a/commoncpp2-link.patch b/commoncpp2-link.patch
new file mode 100644 (file)
index 0000000..53f8c8a
--- /dev/null
@@ -0,0 +1,11 @@
+--- commoncpp2-1.8.1/m4/ost_ssl.m4.orig        2010-10-31 23:01:26.000000000 +0100
++++ commoncpp2-1.8.1/m4/ost_ssl.m4     2012-01-02 20:05:34.673205812 +0100
+@@ -41,7 +41,7 @@
+ #       ])
+ #   ],[
+         AC_CHECK_HEADER(openssl/ssl.h,[
+-            SSL_LIBS="-lssl"
++            SSL_LIBS="-lssl -lcrypto"
+             ost_cv_ssl=true
+             AC_DEFINE(CCXX_OPENSSL, [1], [define openssl])
+             AC_DEFINE(CCXX_SSL, [OPENSSL], [defines ssl])
diff --git a/commoncpp2-lt.patch b/commoncpp2-lt.patch
deleted file mode 100644 (file)
index 20c7ab8..0000000
+++ /dev/null
@@ -1,218 +0,0 @@
-diff -urN commoncpp2-1.6.3.org/commoncpp2.list.in commoncpp2-1.6.3/commoncpp2.list.in
---- commoncpp2-1.6.3.org/commoncpp2.list.in    2008-06-23 15:02:12.000000000 +0200
-+++ commoncpp2-1.6.3/commoncpp2.list.in        2008-08-23 12:56:15.597826382 +0200
-@@ -39,11 +39,11 @@
- l 0644 root root ${libdir}/libccgnu2.dylib-@VERSION@.@LT_SUBVER@.dylib libccgnu2-@VERSION@.dylib
- l 0644 root root ${libdir}/libccext2.dylib-@VERSION@.@LT_SUBVER@.dylib libccext2-@VERSION@.dylib 
- %system freebsd
--f 0644 root root ${libdir} ./src/.libs/libccgnu2-@LT_RELEASE@.so.*
--f 0644 root root ${libdir} ./src/.libs/libccext2-@LT_RELEASE@.so.*
-+f 0644 root root ${libdir} ./src/.libs/libccgnu2-@TW_LT_RELEASE@.so.*
-+f 0644 root root ${libdir} ./src/.libs/libccext2-@TW_LT_RELEASE@.so.*
- %system linux solaris
--f 0644 root root ${libdir} ./src/.libs/libccgnu2-@LT_RELEASE@.so.*.*.*
--f 0644 root root ${libdir} ./src/.libs/libccext2-@LT_RELEASE@.so.*.*.*
-+f 0644 root root ${libdir} ./src/.libs/libccgnu2-@TW_LT_RELEASE@.so.*.*.*
-+f 0644 root root ${libdir} ./src/.libs/libccext2-@TW_LT_RELEASE@.so.*.*.*
- %system linux freebsd
- %postinstall /sbin/ldconfig
- %postremove /sbin/ldconfig
-diff -urN commoncpp2-1.6.3.org/configure.ac commoncpp2-1.6.3/configure.ac
---- commoncpp2-1.6.3.org/configure.ac  2008-08-20 19:53:45.000000000 +0200
-+++ commoncpp2-1.6.3/configure.ac      2008-08-23 12:56:15.624076944 +0200
-@@ -11,8 +11,8 @@
- AC_INIT(src/thread.cpp)
- VERSION="1.7.3"
--LT_RELEASE="1.7"
--LT_VERSION="0:3"
-+TW_LT_RELEASE="1.7"
-+TW_LT_VERSION="0:3"
- dnl this is a C++ library after all..
- AC_LANG(C++)
-@@ -195,7 +195,7 @@
- OST_PROG_COMMON
- OST_PROG_LIBVER
--OST_PROG_LIBRARY(CCXX,[$LT_VERSION])
-+OST_PROG_LIBRARY(CCXX,[$TW_LT_VERSION])
- OST_AUTOMAKE_MODE
- OST_MAINTAINER_MODE
- OST_WINVER
-@@ -302,7 +302,7 @@
-       fi
- fi
- KDOC_DIR="\$(top_srcdir)/doc"
--AC_SUBST(LT_RELEASE)
-+AC_SUBST(TW_LT_RELEASE)
- AC_SUBST(KDOC_DIR)
- AC_SUBST(CCXX_DIR)
- AC_SUBST(incprefix)
-@@ -400,8 +400,8 @@
- AM_CONDITIONAL(GETOPT_LONG, [test ! -z "$LIBGETOPTOBJS"])
--LIB_VERSION=`echo $LT_RELEASE | sed -e 's/[\.]/_/'` 
--LIB_MAJOR=`echo $LT_VERSION | sed -e 's/[:].*$//'`
-+LIB_VERSION=`echo $TW_LT_RELEASE | sed -e 's/[\.]/_/'` 
-+LIB_MAJOR=`echo $TW_LT_VERSION | sed -e 's/[:].*$//'`
- AC_SUBST(LIB_VERSION)
- AC_SUBST(LIB_MAJOR)
-@@ -423,7 +423,7 @@
- #
- # Visual Studio
- #
--DLLVERSION=`echo "$LT_RELEASE" | sed -e 's/\.//'g`
-+DLLVERSION=`echo "$TW_LT_RELEASE" | sed -e 's/\.//'g`
- #
- # Visual Studio 2008
- #
-diff -urN commoncpp2-1.6.3.org/demo/Makefile.in commoncpp2-1.6.3/demo/Makefile.in
---- commoncpp2-1.6.3.org/demo/Makefile.in      2008-08-20 20:02:57.000000000 +0200
-+++ commoncpp2-1.6.3/demo/Makefile.in  2008-08-23 12:56:17.804493110 +0200
-@@ -227,7 +227,7 @@
- LT_CCXX_VERSION = @LT_CCXX_VERSION@
- LT_MAJOR = @LT_MAJOR@
- LT_MINOR = @LT_MINOR@
--LT_RELEASE = @LT_RELEASE@
-+TW_LT_RELEASE = @TW_LT_RELEASE@
- LT_SUBVER = @LT_SUBVER@
- MAINT = @MAINT@
- MAKEINFO = @MAKEINFO@
-diff -urN commoncpp2-1.6.3.org/doc/Makefile.in commoncpp2-1.6.3/doc/Makefile.in
---- commoncpp2-1.6.3.org/doc/Makefile.in       2008-08-20 20:02:57.000000000 +0200
-+++ commoncpp2-1.6.3/doc/Makefile.in   2008-08-23 12:56:17.847826306 +0200
-@@ -143,7 +143,7 @@
- LT_CCXX_VERSION = @LT_CCXX_VERSION@
- LT_MAJOR = @LT_MAJOR@
- LT_MINOR = @LT_MINOR@
--LT_RELEASE = @LT_RELEASE@
-+TW_LT_RELEASE = @TW_LT_RELEASE@
- LT_SUBVER = @LT_SUBVER@
- MAINT = @MAINT@
- MAKEINFO = @MAKEINFO@
-diff -urN commoncpp2-1.6.3.org/inc/Makefile.in commoncpp2-1.6.3/inc/Makefile.in
---- commoncpp2-1.6.3.org/inc/Makefile.in       2008-08-20 20:02:57.000000000 +0200
-+++ commoncpp2-1.6.3/inc/Makefile.in   2008-08-23 12:56:17.850743908 +0200
-@@ -134,7 +134,7 @@
- LT_CCXX_VERSION = @LT_CCXX_VERSION@
- LT_MAJOR = @LT_MAJOR@
- LT_MINOR = @LT_MINOR@
--LT_RELEASE = @LT_RELEASE@
-+TW_LT_RELEASE = @TW_LT_RELEASE@
- LT_SUBVER = @LT_SUBVER@
- MAINT = @MAINT@
- MAKEINFO = @MAKEINFO@
-diff -urN commoncpp2-1.6.3.org/m4/Makefile.in commoncpp2-1.6.3/m4/Makefile.in
---- commoncpp2-1.6.3.org/m4/Makefile.in        2008-08-20 20:02:57.000000000 +0200
-+++ commoncpp2-1.6.3/m4/Makefile.in    2008-08-23 12:56:17.850743908 +0200
-@@ -121,7 +121,7 @@
- LT_CCXX_VERSION = @LT_CCXX_VERSION@
- LT_MAJOR = @LT_MAJOR@
- LT_MINOR = @LT_MINOR@
--LT_RELEASE = @LT_RELEASE@
-+TW_LT_RELEASE = @TW_LT_RELEASE@
- LT_SUBVER = @LT_SUBVER@
- MAINT = @MAINT@
- MAKEINFO = @MAKEINFO@
-diff -urN commoncpp2-1.6.3.org/m4/ost_prog.m4 commoncpp2-1.6.3/m4/ost_prog.m4
---- commoncpp2-1.6.3.org/m4/ost_prog.m4        2008-06-23 15:02:07.000000000 +0200
-+++ commoncpp2-1.6.3/m4/ost_prog.m4    2008-08-23 12:56:17.857826188 +0200
-@@ -45,10 +45,10 @@
- ])
- AC_DEFUN([OST_PROG_LIBVER],[
--      LT_MAJOR="`echo $LT_VERSION | sed s/:.*$//`"
--      LT_MINOR="`echo $LT_VERSION | sed s/.*://`"
-+      LT_MAJOR="`echo $TW_LT_VERSION | sed s/:.*$//`"
-+      LT_MINOR="`echo $TW_LT_VERSION | sed s/.*://`"
-       LT_SUBVER="$LT_MAJOR.$LT_MINOR"
--      AC_SUBST(LT_RELEASE)
-+      AC_SUBST(TW_LT_RELEASE)
-       AC_SUBST(LT_SUBVER)
-       AC_SUBST(LT_MAJOR)
-       AC_SUBST(LT_MINOR)
-diff -urN commoncpp2-1.6.3.org/Makefile.in commoncpp2-1.6.3/Makefile.in
---- commoncpp2-1.6.3.org/Makefile.in   2008-08-20 20:02:58.000000000 +0200
-+++ commoncpp2-1.6.3/Makefile.in       2008-08-23 12:56:15.627410065 +0200
-@@ -151,7 +151,7 @@
- LT_CCXX_VERSION = @LT_CCXX_VERSION@
- LT_MAJOR = @LT_MAJOR@
- LT_MINOR = @LT_MINOR@
--LT_RELEASE = @LT_RELEASE@
-+TW_LT_RELEASE = @TW_LT_RELEASE@
- LT_SUBVER = @LT_SUBVER@
- MAINT = @MAINT@
- MAKEINFO = @MAKEINFO@
-diff -urN commoncpp2-1.6.3.org/src/Makefile.am commoncpp2-1.6.3/src/Makefile.am
---- commoncpp2-1.6.3.org/src/Makefile.am       2008-08-20 20:02:18.000000000 +0200
-+++ commoncpp2-1.6.3/src/Makefile.am   2008-08-23 12:56:17.914076506 +0200
-@@ -11,12 +11,12 @@
- MAINTAINERCLEANFILES = Makefile.in Makefile
- EXTRA_DIST=ccgnu2-config.in ccgnu2-config ost_check2.m4 \
-       getopt.h getopt.c getopt1.c *.pc *.pc.in
--LT_VERSION=@LT_CCXX_VERSION@
-+TW_LT_VERSION=@LT_CCXX_VERSION@
- AM_CXXFLAGS = -I../src -DCCXX_EXPORT_LIBRARY $(THREAD_FLAGS) \
-         $(COMMON_FLAGS) -I$(CCXX_DIR) $(DEBUG_FLAGS)
- AM_CFLAGS = $(THREAD_FLAGS)
- INCLUDES = -I$(top_srcdir)/inc 
--RELEASE = $(LT_VERSION) -release $(LT_RELEASE)
-+RELEASE = $(TW_LT_VERSION) -release $(TW_LT_RELEASE)
- if EXTRAS
- pkgconfig_DATA = libccgnu2.pc libccext2.pc
-diff -urN commoncpp2-1.6.3.org/src/Makefile.in commoncpp2-1.6.3/src/Makefile.in
---- commoncpp2-1.6.3.org/src/Makefile.in       2008-08-20 20:02:57.000000000 +0200
-+++ commoncpp2-1.6.3/src/Makefile.in   2008-08-23 12:56:17.917826194 +0200
-@@ -206,7 +206,7 @@
- LT_CCXX_VERSION = @LT_CCXX_VERSION@
- LT_MAJOR = @LT_MAJOR@
- LT_MINOR = @LT_MINOR@
--LT_RELEASE = @LT_RELEASE@
-+TW_LT_RELEASE = @TW_LT_RELEASE@
- LT_SUBVER = @LT_SUBVER@
- MAINT = @MAINT@
- MAKEINFO = @MAKEINFO@
-@@ -302,13 +302,13 @@
- EXTRA_DIST = ccgnu2-config.in ccgnu2-config ost_check2.m4 \
-       getopt.h getopt.c getopt1.c *.pc *.pc.in
--LT_VERSION = @LT_CCXX_VERSION@
-+TW_LT_VERSION = @LT_CCXX_VERSION@
- AM_CXXFLAGS = -I../src -DCCXX_EXPORT_LIBRARY $(THREAD_FLAGS) \
-         $(COMMON_FLAGS) -I$(CCXX_DIR) $(DEBUG_FLAGS)
- AM_CFLAGS = $(THREAD_FLAGS)
- INCLUDES = -I$(top_srcdir)/inc 
--RELEASE = $(LT_VERSION) -release $(LT_RELEASE)
-+RELEASE = $(TW_LT_VERSION) -release $(TW_LT_RELEASE)
- @EXTRAS_FALSE@pkgconfig_DATA = libccgnu2.pc
- @EXTRAS_TRUE@pkgconfig_DATA = libccgnu2.pc libccext2.pc
- @EXTRAS_FALSE@lib_LTLIBRARIES = libccgnu2.la
-diff -urN commoncpp2-1.6.3.org/tests/Makefile.in commoncpp2-1.6.3/tests/Makefile.in
---- commoncpp2-1.6.3.org/tests/Makefile.in     2008-08-20 20:02:57.000000000 +0200
-+++ commoncpp2-1.6.3/tests/Makefile.in 2008-08-23 12:56:17.997409883 +0200
-@@ -213,7 +213,7 @@
- LT_CCXX_VERSION = @LT_CCXX_VERSION@
- LT_MAJOR = @LT_MAJOR@
- LT_MINOR = @LT_MINOR@
--LT_RELEASE = @LT_RELEASE@
-+TW_LT_RELEASE = @TW_LT_RELEASE@
- LT_SUBVER = @LT_SUBVER@
- MAINT = @MAINT@
- MAKEINFO = @MAKEINFO@
-diff -urN commoncpp2-1.6.3.org/w32/Makefile.in commoncpp2-1.6.3/w32/Makefile.in
---- commoncpp2-1.6.3.org/w32/Makefile.in       2008-08-20 20:02:57.000000000 +0200
-+++ commoncpp2-1.6.3/w32/Makefile.in   2008-08-23 12:56:18.034492835 +0200
-@@ -120,7 +120,7 @@
- LT_CCXX_VERSION = @LT_CCXX_VERSION@
- LT_MAJOR = @LT_MAJOR@
- LT_MINOR = @LT_MINOR@
--LT_RELEASE = @LT_RELEASE@
-+TW_LT_RELEASE = @TW_LT_RELEASE@
- LT_SUBVER = @LT_SUBVER@
- MAINT = @MAINT@
- MAKEINFO = @MAKEINFO@
diff --git a/commoncpp2-netfilter.patch b/commoncpp2-netfilter.patch
new file mode 100644 (file)
index 0000000..ac0a2e1
--- /dev/null
@@ -0,0 +1,15 @@
+--- commoncpp2-1.8.1/m4/ost_socket.m4.orig     2010-10-31 23:01:12.000000000 +0100
++++ commoncpp2-1.8.1/m4/ost_socket.m4  2012-01-02 19:23:26.549787830 +0100
+@@ -93,7 +93,11 @@
+                 AC_CHECK_HEADERS([linux/netfilter_ipv4.h linux/netfilter_ipv6.h],,,
+                     [#ifdef HAVE_LIMITS_H
+                     #include <limits.h>
+-                    #endif])
++                    #endif
++                    #include <stddef.h>
++                    #include <sys/socket.h>
++                    #include <linux/in.h>
++                    #include <linux/in6.h>])
+                 if test "$ac_cv_header_linux_netfilter_ipv4_h" = "yes" &&
+                    [ test "$ac_cv_header_linux_netfilter_ipv6_h" = "yes" &&
+                      test "$ost_cv_ipv6" = "yes" ||
index 437672d7c3189f803882f5654a4f16c3ed432efe..5316cc1199e5ba239bf0a1c28ff0b51db73d1f20 100644 (file)
@@ -5,27 +5,28 @@
 Summary:       A GNU package for creating portable C++ programs
 Summary(pl.UTF-8):     Pakiet GNU do tworzenia przenośnych programów w C++
 Name:          commoncpp2
-Version:       1.7.3
-Release:       4
-License:       GPL
+Version:       1.8.1
+Release:       1
+License:       GPL v2+ with linking exception
 Group:         Libraries
 Source0:       http://ftp.gnu.org/gnu/commoncpp/%{name}-%{version}.tar.gz
-# Source0-md5: ca741179a728d264eb276ae471ebaf70
-Patch0:                %{name}-lt.patch
-Patch1:                %{name}-gcc4.patch
+# Source0-md5: 4804b184e609154ba2bc0aa9f61dc6ef
+Patch0:                %{name}-netfilter.patch
+Patch1:                %{name}-include.patch
+Patch2:                %{name}-link.patch
+Patch3:                %{name}-info.patch
 URL:           http://www.gnu.org/software/commoncpp/
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: doxygen
 BuildRequires: libstdc++-devel
-BuildRequires: libtool
+BuildRequires: libtool >= 2:1.5
 BuildRequires: libxml2-devel
 BuildRequires: openssl-devel
+BuildRequires: texinfo
 BuildRequires: zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                skip_post_check_so      libccgnu2-.*\.so\..* libccext2-.*\.so\..*
-
 %description
 This is the second major release of GNU Common C++. GNU Common C++ "2"
 is a GNU package which offers portable "abstraction" of system
@@ -77,6 +78,8 @@ Statyczna biblioteka commoncpp2.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %build
 %{__libtoolize}
@@ -87,6 +90,10 @@ Statyczna biblioteka commoncpp2.
 %configure \
        %{!?with_static_libs:--disable-static} \
        --with-openssl
+
+# ensure netfilter is detected
+grep 'HAVE_NAT_NETFILTER 1' config.h || exit 1
+
 %{__make} -j1
 
 %install
@@ -101,32 +108,37 @@ rm -rf $RPM_BUILD_ROOT
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-%post devel    -p      /sbin/postshell
+%post  devel -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun devel  -p      /sbin/postshell
+%postun        devel -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS COPYING.addendum NEWS README TODO ChangeLog
-%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
-%ghost %{_libdir}/libccext2-1.7.so.0
-%ghost %{_libdir}/libccgnu2-1.7.so.0
+%doc AUTHORS COPYING.addendum ChangeLog NEWS README SUPPORT THANKS TODO
+%attr(755,root,root) %{_libdir}/libccext2-1.8.so.*.*.*
+%ghost %{_libdir}/libccext2-1.8.so.0
+%attr(755,root,root) %{_libdir}/libccgnu2-1.8.so.*.*.*
+%ghost %{_libdir}/libccgnu2-1.8.so.0
 
 %files devel
 %defattr(644,root,root,755)
-%doc doc/html/*.html doc/html/*.*g*
-%attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
+%doc doc/html/*.{css,html,js,png}
+%attr(755,root,root) %{_bindir}/ccgnu2-config
+%attr(755,root,root) %{_libdir}/libccext2.so
+%attr(755,root,root) %{_libdir}/libccgnu2.so
+%{_libdir}/libccext2.la
+%{_libdir}/libccgnu2.la
 %{_includedir}/cc++
-%{_aclocaldir}/*.m4
-%{_pkgconfigdir}/*.pc
-%{_infodir}/*.info*
+%{_aclocaldir}/ost_check2.m4
+%{_pkgconfigdir}/libccext2.pc
+%{_pkgconfigdir}/libccgnu2.pc
+%{_infodir}/commoncpp2.info*
 
 %if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libccext2.a
+%{_libdir}/libccgnu2.a
 %endif
This page took 0.129537 seconds and 4 git commands to generate.