]> git.pld-linux.org Git - packages/commoncpp2.git/blame - commoncpp2.spec
- fix for "invalid conversion from ‘const char*’ to ‘char*’"
[packages/commoncpp2.git] / commoncpp2.spec
CommitLineData
e5703f90
KK
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4#
3ef9580c 5Summary: A GNU package for creating portable C++ programs
8c8acc7d 6Summary(pl.UTF-8): Pakiet GNU do tworzenia przenośnych programów w C++
3ef9580c 7Name: commoncpp2
5188bc31
SS
8Version: 1.7.3
9Release: 0.1
3ef9580c 10License: GPL
11Group: Libraries
9cfec48b 12Source0: http://ftp.gnu.org/gnu/commoncpp/%{name}-%{version}.tar.gz
5188bc31 13# Source0-md5: ca741179a728d264eb276ae471ebaf70
7a5c4ef4 14Patch0: %{name}-lt.patch
7c7445ba 15URL: http://www.gnu.org/software/commoncpp/
4a331386 16BuildRequires: autoconf
7c7445ba 17BuildRequires: automake
3ef9580c 18BuildRequires: doxygen
19BuildRequires: libstdc++-devel
e131c2a8 20BuildRequires: libtool
3ef9580c 21BuildRequires: libxml2-devel
4a331386 22BuildRequires: openssl-devel
3ef9580c 23BuildRequires: zlib-devel
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27This is the second major release of GNU Common C++. GNU Common C++ "2"
28is a GNU package which offers portable "abstraction" of system
29services such as threads, networks, and sockets. GNU Common C++ "2"
30also offers individual frameworks generally useful to developing
31portable C++ applications including a object persistance engine, math
32libraries, threading, sockets, etc. GNU Common C++ "2" is small, and
33highly portable. GNU Common C++ "2" will support most Unix operating
1abd0668 34systems as well as Win32, in addition to GNU/Linux.
3ef9580c 35
06c607b2
JR
36%description -l pl.UTF-8
37Drugie główne wydanie GNU Common C++. GNU Common C++ oferuje przenośne
38abstrakcje usług systemowych takich jak wątki, sieci i gniazda.
39Oferuje także poszczególne szkielety użyteczne do rozwijania
40przenośnych aplikacji C++ zawierające silnik trwałych obiektów,
41biblioteki matematyczne, wątków, gniazd itd. GNU Common C++ jest mały
42i przenośny. Oprócz GNU/Linuksa obsługuje także większość uniksowych
43systemów operacyjnych oraz Win32.
17bc0025 44
3ef9580c 45%package devel
46Summary: Header files for commoncpp2 library
8c8acc7d 47Summary(pl.UTF-8): Pliki nagłówkowe biblioteki commoncpp2
3ef9580c 48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50Requires: libstdc++-devel
51Requires: libxml2-devel
e5703f90 52Requires: openssl-devel
3ef9580c 53Requires: zlib-devel
54
55%description devel
56Header files for commoncpp2 library.
57
06c607b2
JR
58%description devel -l pl.UTF-8
59Pliki nagłówkowe biblioteki commoncpp2.
3ef9580c 60
61%package static
62Summary: Static commoncpp2 library
8c8acc7d 63Summary(pl.UTF-8): Statyczna biblioteka commoncpp2
3ef9580c 64Group: Development/Libraries
65Requires: %{name}-devel = %{version}-%{release}
66
67%description static
68Static commoncpp2 library.
69
06c607b2 70%description static -l pl.UTF-8
3ef9580c 71Statyczna biblioteka commoncpp2.
72
73%prep
74%setup -q
7a5c4ef4 75%patch0 -p1
3ef9580c 76
77%build
e131c2a8 78%{__libtoolize}
4a331386 79%{__aclocal} -I m4
4a331386 80%{__autoconf}
e131c2a8 81%{__autoheader}
82%{__automake}
4a331386 83%configure \
e5703f90 84 %{!?with_static_libs:--disable-static} \
4a331386 85 --with-openssl
3ef9580c 86%{__make}
87
88%install
89rm -rf $RPM_BUILD_ROOT
90
91%{__make} install \
92 DESTDIR=$RPM_BUILD_ROOT
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%post -p /sbin/ldconfig
98%postun -p /sbin/ldconfig
99
2485d124
ER
100%post devel -p /sbin/postshell
101-/usr/sbin/fix-info-dir -c %{_infodir}
3ef9580c 102
2485d124
ER
103%postun devel -p /sbin/postshell
104-/usr/sbin/fix-info-dir -c %{_infodir}
3ef9580c 105
106%files
107%defattr(644,root,root,755)
108%doc AUTHORS COPYING.addendum NEWS README TODO ChangeLog
109%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
f5becfa2
AM
110%ghost %{_libdir}/libccext2-1.7.so.0
111%ghost %{_libdir}/libccgnu2-1.7.so.0
3ef9580c 112
113%files devel
114%defattr(644,root,root,755)
115%doc doc/html/*.html doc/html/*.*g*
116%attr(755,root,root) %{_bindir}/*
117%attr(755,root,root) %{_libdir}/lib*.so
118%{_libdir}/lib*.la
8bab2ee7 119%{_includedir}/cc++
3ef9580c 120%{_aclocaldir}/*.m4
121%{_pkgconfigdir}/*.pc
1abd0668 122%{_infodir}/*.info*
3ef9580c 123
e5703f90 124%if %{with static_libs}
3ef9580c 125%files static
126%defattr(644,root,root,755)
127%{_libdir}/lib*.a
e5703f90 128%endif
This page took 0.054132 seconds and 4 git commands to generate.