]> git.pld-linux.org Git - packages/commoncpp2.git/blame - commoncpp2.spec
- added required skip_post_check_so
[packages/commoncpp2.git] / commoncpp2.spec
CommitLineData
e5703f90
KK
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4#
3ef9580c 5Summary: A GNU package for creating portable C++ programs
8c8acc7d 6Summary(pl.UTF-8): Pakiet GNU do tworzenia przenośnych programów w C++
3ef9580c 7Name: commoncpp2
5188bc31 8Version: 1.7.3
984e9b7a 9Release: 4
3ef9580c 10License: GPL
11Group: Libraries
9cfec48b 12Source0: http://ftp.gnu.org/gnu/commoncpp/%{name}-%{version}.tar.gz
5188bc31 13# Source0-md5: ca741179a728d264eb276ae471ebaf70
7a5c4ef4 14Patch0: %{name}-lt.patch
54a4a4fa 15Patch1: %{name}-gcc4.patch
7c7445ba 16URL: http://www.gnu.org/software/commoncpp/
4a331386 17BuildRequires: autoconf
7c7445ba 18BuildRequires: automake
3ef9580c 19BuildRequires: doxygen
20BuildRequires: libstdc++-devel
e131c2a8 21BuildRequires: libtool
3ef9580c 22BuildRequires: libxml2-devel
4a331386 23BuildRequires: openssl-devel
3ef9580c 24BuildRequires: zlib-devel
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
984e9b7a 27%define skip_post_check_so libccgnu2-.*\.so\..* libccext2-.*\.so\..*
28
3ef9580c 29%description
30This is the second major release of GNU Common C++. GNU Common C++ "2"
31is a GNU package which offers portable "abstraction" of system
32services such as threads, networks, and sockets. GNU Common C++ "2"
33also offers individual frameworks generally useful to developing
34portable C++ applications including a object persistance engine, math
35libraries, threading, sockets, etc. GNU Common C++ "2" is small, and
36highly portable. GNU Common C++ "2" will support most Unix operating
1abd0668 37systems as well as Win32, in addition to GNU/Linux.
3ef9580c 38
06c607b2
JR
39%description -l pl.UTF-8
40Drugie główne wydanie GNU Common C++. GNU Common C++ oferuje przenośne
41abstrakcje usług systemowych takich jak wątki, sieci i gniazda.
42Oferuje także poszczególne szkielety użyteczne do rozwijania
43przenośnych aplikacji C++ zawierające silnik trwałych obiektów,
44biblioteki matematyczne, wątków, gniazd itd. GNU Common C++ jest mały
45i przenośny. Oprócz GNU/Linuksa obsługuje także większość uniksowych
46systemów operacyjnych oraz Win32.
17bc0025 47
3ef9580c 48%package devel
49Summary: Header files for commoncpp2 library
8c8acc7d 50Summary(pl.UTF-8): Pliki nagłówkowe biblioteki commoncpp2
3ef9580c 51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53Requires: libstdc++-devel
54Requires: libxml2-devel
e5703f90 55Requires: openssl-devel
3ef9580c 56Requires: zlib-devel
57
58%description devel
59Header files for commoncpp2 library.
60
06c607b2
JR
61%description devel -l pl.UTF-8
62Pliki nagłówkowe biblioteki commoncpp2.
3ef9580c 63
64%package static
65Summary: Static commoncpp2 library
8c8acc7d 66Summary(pl.UTF-8): Statyczna biblioteka commoncpp2
3ef9580c 67Group: Development/Libraries
68Requires: %{name}-devel = %{version}-%{release}
69
70%description static
71Static commoncpp2 library.
72
06c607b2 73%description static -l pl.UTF-8
3ef9580c 74Statyczna biblioteka commoncpp2.
75
76%prep
77%setup -q
7a5c4ef4 78%patch0 -p1
54a4a4fa 79%patch1 -p1
3ef9580c 80
81%build
e131c2a8 82%{__libtoolize}
4a331386 83%{__aclocal} -I m4
4a331386 84%{__autoconf}
e131c2a8 85%{__autoheader}
86%{__automake}
4a331386 87%configure \
e5703f90 88 %{!?with_static_libs:--disable-static} \
4a331386 89 --with-openssl
54a4a4fa 90%{__make} -j1
3ef9580c 91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95%{__make} install \
96 DESTDIR=$RPM_BUILD_ROOT
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%post -p /sbin/ldconfig
102%postun -p /sbin/ldconfig
103
2485d124
ER
104%post devel -p /sbin/postshell
105-/usr/sbin/fix-info-dir -c %{_infodir}
3ef9580c 106
2485d124
ER
107%postun devel -p /sbin/postshell
108-/usr/sbin/fix-info-dir -c %{_infodir}
3ef9580c 109
110%files
111%defattr(644,root,root,755)
112%doc AUTHORS COPYING.addendum NEWS README TODO ChangeLog
113%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
f5becfa2
AM
114%ghost %{_libdir}/libccext2-1.7.so.0
115%ghost %{_libdir}/libccgnu2-1.7.so.0
3ef9580c 116
117%files devel
118%defattr(644,root,root,755)
119%doc doc/html/*.html doc/html/*.*g*
120%attr(755,root,root) %{_bindir}/*
121%attr(755,root,root) %{_libdir}/lib*.so
122%{_libdir}/lib*.la
8bab2ee7 123%{_includedir}/cc++
3ef9580c 124%{_aclocaldir}/*.m4
125%{_pkgconfigdir}/*.pc
1abd0668 126%{_infodir}/*.info*
3ef9580c 127
e5703f90 128%if %{with static_libs}
3ef9580c 129%files static
130%defattr(644,root,root,755)
131%{_libdir}/lib*.a
e5703f90 132%endif
This page took 0.046255 seconds and 4 git commands to generate.