]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- fix for: -D option can't use value with equals sign
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
b563f9dc
JB
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
77f8acdd 10
efafbc62 11Summary: Cross-platform, open-source make system
ac3ea35a 12Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 13Name: cmake
0fd568ba 14Version: 2.8.3
6d0542bf 15Release: 2
efafbc62 16License: BSD
72a696fa 17Group: Development/Building
28f0bd6c 18Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
0fd568ba 19# Source0-md5: a76a44b93acf5e3badda9de111385921
6342daf8 20Patch0: %{name}-lib64.patch
44af9955 21Patch1: %{name}-tinfo.patch
6d0542bf 22Patch2: %{name}-parse.patch
a315a797 23URL: http://www.cmake.org/
33042d59 24%{?with_gui:BuildRequires: QtGui-devel}
fef12180 25BuildRequires: libarchive-devel
ece9e155
KK
26BuildRequires: libstdc++-devel
27BuildRequires: ncurses-devel
33042d59
KK
28%{?with_gui:BuildRequires: qt4-build}
29%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 30BuildRequires: rpmbuild(macros) >= 1.167
ab02ad6a 31%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
efafbc62 32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
33
34%description
efafbc62
AG
35CMake is used to control the software compilation process using simple
36platform and compiler independent configuration files. CMake generates
37native makefiles and workspaces that can be used in the compiler
38environment of your choice. CMake is quite sophisticated: it is
39possible to support complex environments requiring system
40configuration, pre-processor generation, code generation, and template
41instantiation.
3fcbc09a 42
520c9eb8
JR
43%description -l pl.UTF-8
44CMake służy do sterowania procesem kompilacji oprogramowania przy
ca760f29 45użyciu prostych plików konfiguracyjnych niezależnych od platformy i
46kompilatora. CMake generuje natywne pliki makefile i workspace,
485d9a7a 47których można używać w wybranym środowisku kompilatora. CMake jest
59787775 48dość wyrafinowany: może obsłużyć złożone środowiska wymagające
ca760f29 49konfiguracji systemu, generowanie preprocesora, generowanie kodu i
50dziedziczenie szablonów.
33042d59
KK
51
52%package gui
b563f9dc
JB
53Summary: Qt GUI for CMake
54Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
55Group: Development/Tools
56Requires: %{name} = %{version}-%{release}
57
b563f9dc
JB
58%description gui
59This package contains the Qt based GUI for CMake.
60
61%description gui -l pl.UTF-8
62Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
63CMake.
72a696fa 64
3fcbc09a 65%prep
923851a2 66%setup -q
286b1479 67%if "%{_lib}" == "lib64"
6342daf8 68%patch0 -p1
286b1479 69%endif
44af9955 70%patch1 -p0
6d0542bf 71%patch2 -p1
3fcbc09a 72
ece9e155 73cat > "init.cmake" <<EOF
286b1479 74SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
ece9e155
KK
75EOF
76
3fcbc09a 77%build
ece9e155
KK
78export CC="%{__cc}"
79export CXX="%{__cxx}"
80export CFLAGS="%{rpmcflags}"
81export CXXFLAGS="%{rpmcxxflags}"
ccca321d 82export LDFLAGS="%{rpmldflags}"
923851a2
AG
83./bootstrap \
84 --prefix=%{_prefix} \
85 --mandir=/share/man \
86 --datadir=/share/cmake \
ece9e155 87 --init=init.cmake \
c342f103 88 %{!?with_bootstrap:--system-libs} \
33042d59 89 %{?with_gui:--qt-gui} \
08bb5e07 90 --qt-qmake=/usr/bin/qmake-qt4 \
923851a2
AG
91 --verbose
92
28f0bd6c 93%{__make} VERBOSE=1
3fcbc09a
AG
94
95%install
efafbc62 96rm -rf $RPM_BUILD_ROOT
9ecf094d 97install -d $RPM_BUILD_ROOT%{_libdir}/cmake
72a696fa
JB
98%{__make} install \
99 DESTDIR=$RPM_BUILD_ROOT
100
77f8acdd 101rm -r $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%files
efafbc62 107%defattr(644,root,root,755)
51ed65c6 108%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
109%attr(755,root,root) %{_bindir}/ccmake
110%attr(755,root,root) %{_bindir}/cmake
08b6790a 111%attr(755,root,root) %{_bindir}/cpack
72a696fa 112%attr(755,root,root) %{_bindir}/ctest
08bb5e07
JB
113%{_mandir}/man1/ccmake.1*
114%{_mandir}/man1/cmake.1*
115%{_mandir}/man1/cmakecommands.1*
116%{_mandir}/man1/cmakecompat.1*
117%{_mandir}/man1/cmakemodules.1*
118%{_mandir}/man1/cmakepolicies.1*
119%{_mandir}/man1/cmakeprops.1*
120%{_mandir}/man1/cmakevars.1*
121%{_mandir}/man1/cpack.1*
122%{_mandir}/man1/ctest.1*
923851a2 123%{_datadir}/cmake
1941b22e 124%dir %{_libdir}/cmake
33042d59 125
1a3a9dcd 126%if %{with gui}
33042d59
KK
127%files gui
128%defattr(644,root,root,755)
129%attr(755,root,root) %{_bindir}/cmake-gui
130%{_datadir}/mime/packages/cmakecache.xml
131%{_desktopdir}/CMake.desktop
ca760f29 132%{_pixmapsdir}/CMakeSetup32.png
08bb5e07 133%{_mandir}/man1/cmake-gui.1*
1a3a9dcd 134%endif
This page took 0.047083 seconds and 4 git commands to generate.