]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- recognize python 2.7 in FIND_PACKAGE(PythonLibs); rel 2
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
b563f9dc
JB
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
77f8acdd 10
efafbc62 11Summary: Cross-platform, open-source make system
ac3ea35a 12Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 13Name: cmake
44af9955 14Version: 2.8.2
77f8acdd 15Release: 2
efafbc62 16License: BSD
72a696fa 17Group: Development/Building
28f0bd6c 18Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
44af9955 19# Source0-md5: 8c967d5264657a798f22ee23976ff0d9
6342daf8 20Patch0: %{name}-lib64.patch
44af9955 21Patch1: %{name}-tinfo.patch
77f8acdd 22Patch2: python-2.7.patch
a315a797 23URL: http://www.cmake.org/
33042d59 24%{?with_gui:BuildRequires: QtGui-devel}
ece9e155
KK
25BuildRequires: libstdc++-devel
26BuildRequires: ncurses-devel
33042d59
KK
27%{?with_gui:BuildRequires: qt4-build}
28%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 29BuildRequires: rpmbuild(macros) >= 1.167
ab02ad6a 30%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
efafbc62 31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
32
33%description
efafbc62
AG
34CMake is used to control the software compilation process using simple
35platform and compiler independent configuration files. CMake generates
36native makefiles and workspaces that can be used in the compiler
37environment of your choice. CMake is quite sophisticated: it is
38possible to support complex environments requiring system
39configuration, pre-processor generation, code generation, and template
40instantiation.
3fcbc09a 41
520c9eb8
JR
42%description -l pl.UTF-8
43CMake służy do sterowania procesem kompilacji oprogramowania przy
ca760f29 44użyciu prostych plików konfiguracyjnych niezależnych od platformy i
45kompilatora. CMake generuje natywne pliki makefile i workspace,
485d9a7a 46których można używać w wybranym środowisku kompilatora. CMake jest
59787775 47dość wyrafinowany: może obsłużyć złożone środowiska wymagające
ca760f29 48konfiguracji systemu, generowanie preprocesora, generowanie kodu i
49dziedziczenie szablonów.
33042d59
KK
50
51%package gui
b563f9dc
JB
52Summary: Qt GUI for CMake
53Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
54Group: Development/Tools
55Requires: %{name} = %{version}-%{release}
56
b563f9dc
JB
57%description gui
58This package contains the Qt based GUI for CMake.
59
60%description gui -l pl.UTF-8
61Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
62CMake.
72a696fa 63
3fcbc09a 64%prep
923851a2 65%setup -q
286b1479 66%if "%{_lib}" == "lib64"
6342daf8 67%patch0 -p1
286b1479 68%endif
44af9955 69%patch1 -p0
77f8acdd 70%patch2 -p1
3fcbc09a 71
ece9e155 72cat > "init.cmake" <<EOF
286b1479 73SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
ece9e155
KK
74EOF
75
3fcbc09a 76%build
ece9e155
KK
77export CC="%{__cc}"
78export CXX="%{__cxx}"
79export CFLAGS="%{rpmcflags}"
80export CXXFLAGS="%{rpmcxxflags}"
ccca321d 81export LDFLAGS="%{rpmldflags}"
923851a2
AG
82./bootstrap \
83 --prefix=%{_prefix} \
84 --mandir=/share/man \
85 --datadir=/share/cmake \
ece9e155 86 --init=init.cmake \
c342f103 87 %{!?with_bootstrap:--system-libs} \
33042d59 88 %{?with_gui:--qt-gui} \
923851a2
AG
89 --verbose
90
28f0bd6c 91%{__make} VERBOSE=1
3fcbc09a
AG
92
93%install
efafbc62 94rm -rf $RPM_BUILD_ROOT
9ecf094d 95install -d $RPM_BUILD_ROOT%{_libdir}/cmake
72a696fa
JB
96%{__make} install \
97 DESTDIR=$RPM_BUILD_ROOT
98
77f8acdd 99rm -r $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%files
efafbc62 105%defattr(644,root,root,755)
51ed65c6 106%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
107%attr(755,root,root) %{_bindir}/ccmake
108%attr(755,root,root) %{_bindir}/cmake
08b6790a 109%attr(755,root,root) %{_bindir}/cpack
72a696fa
JB
110%attr(755,root,root) %{_bindir}/ctest
111%{_mandir}/man1/*.1*
923851a2 112%{_datadir}/cmake
1941b22e 113%dir %{_libdir}/cmake
33042d59 114
1a3a9dcd 115%if %{with gui}
33042d59
KK
116%files gui
117%defattr(644,root,root,755)
118%attr(755,root,root) %{_bindir}/cmake-gui
119%{_datadir}/mime/packages/cmakecache.xml
120%{_desktopdir}/CMake.desktop
ca760f29 121%{_pixmapsdir}/CMakeSetup32.png
1a3a9dcd 122%endif
This page took 0.046358 seconds and 4 git commands to generate.