]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
- icu rebuild
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
f684992e 5%bcond_with dev # with dev optimizations (skip clean source)
ba685303 6%bcond_without gconf # with GConf
75f96a39 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 9%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 10%bcond_without libjpegturbo # use libjpeg-turbo features
3aa67e11 11%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
db3fa756 12%bcond_without ninja # use Ninja instead of make to build
ba685303 13%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
14%bcond_without sandboxing # with sandboxing
15%bcond_with selinux # with SELinux (need policy first)
16%bcond_with shared_libs # with shared libs
17%bcond_with sse2 # use SSE2 instructions
ba685303 18%bcond_without system_flac # system flac
a323900c 19%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 20%bcond_without system_harfbuzz # system harfbuzz
cb6dde87 21%bcond_without system_icu # system icu
ba685303 22%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
23%bcond_without system_libexif # system libexif
24%bcond_without system_libmtp # system libmtp
3934d767 25%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
88171dca 26%bcond_without system_libwebp # system libwebp
4884fc99 27%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 28%bcond_with system_mesa # system Mesa
126ea630 29%bcond_without system_minizip # system minizip
62950103 30%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
e7b1e97c
ER
31# protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
32%bcond_with system_protobuf # system protobuf
543e99ac 33%bcond_without system_re2 # system re2
7e634b46 34%bcond_without system_snappy # system snappy
ba685303 35%bcond_without system_speex # system speex
a8f4f3ac 36%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 37%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 38%bcond_with system_v8 # system v8
f047b07c 39%bcond_with system_libvpx # system libvpx
ba685303 40%bcond_without system_yasm # system yasm
1c00315b 41%bcond_without system_zlib # system zlib
14c8ce0e 42%bcond_with tcmalloc # use tcmalloc
7e136323 43%bcond_without verbose # verbose build (V=1)
0c480b89 44
b3fc6cb2
ER
45%ifarch %{ix86}
46# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
47%undefine with_system_mesa
5e3c5baa
ER
48
49# unable build with debuginfo on 32bit build systems
313715ac
ER
50# /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
51%undefine with_debuginfo
52%endif
53
54%ifarch %{x8664}
55# x86_64 systems fail with debugedit crashing
56# /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
5e3c5baa 57%undefine with_debuginfo
b3fc6cb2
ER
58%endif
59
6d92f81c 60# TODO
b363f856 61# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 62# - use_system_skia
a3140cd1 63# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 64# - use_system_stlport (android specific)
7b8f219a 65# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 66
e53ecfb5 67# NOTES:
4fe038cb
ER
68# - mute BEEP mixer if you do not want to hear horrible system bell when
69# pressing home/end in url bar or more ^F search results on page.
7c638678 70# - space considerations:
0bb93ab2 71# - unpacked sources: ~490MiB
c1ecd31f 72# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 73# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 74# - to look for new tarball, use update-source.sh script
f1b276d4 75
7324ed5c 76%define branch 43.0.2357
34dd729e 77%define basever 65
80615441 78%define patchver 81
a3140cd1 79%define gyp_rev 1014
11ad81c4 80Summary: A WebKit powered web browser
05f72ae2 81Name: chromium-browser
f73369da
ER
82%if "%{?patchver}" != ""
83Version: %{branch}.%{patchver}
84%else
85Version: %{branch}.%{basever}
86%endif
d6f2061f 87Release: 2
5bb99ef4 88License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 89Group: X11/Applications/Networking
34dd729e
ER
90Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
91# Source0-md5: 4aa590c1965817cfb693df7f8404e0b6
3c73e180
ER
92%if "%{?patchver}" != ""
93Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
80615441 94# Patch0-md5: 9b379619238dbcbad2bed28442e4d371
3c73e180 95%endif
37ceaf05 96Source1: %{name}.default
8b53130d
ER
97Source2: %{name}.sh
98Source3: %{name}.desktop
56c6e811
ER
99Source5: find-lang.sh
100Source6: update-source.sh
101Source7: clean-source.sh
836b1cac 102Source8: get-source.sh
0562b864 103Source9: master_preferences.json
a198be7c 104# https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
706f2712 105Patch2: enable-video-decode-accel.patch
5aa5df39 106Patch7: dlopen_sonamed_gl.patch
4765ddf1 107Patch8: chromium_useragent.patch.in
1347c76c
AM
108# https://bugs.gentoo.org/show_bug.cgi?id=393471
109# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 110Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
111Patch15: nacl-build-irt.patch
112Patch16: nacl-linkingfix.patch
9516ca97 113Patch18: nacl-no-untar.patch
6897926c 114Patch24: nacl-verbose.patch
c5b396f3
ER
115Patch25: gnome3-volume-control.patch
116Patch26: master-prefs-path.patch
25d4e23c 117Patch28: system-mesa.patch
9cce36cb 118Patch31: system-jinja.patch
708e64c2 119Patch32: remove_bundled_libraries-stale.patch
d7fca4aa 120Patch35: etc-dir.patch
6e3c39b4 121Patch36: angle.patch
a20f29ed 122Patch37: %{name}-build.patch
a198be7c 123Patch38: vaapi_include.patch
221355ea 124Patch39: libsecret.patch
12687dbd 125Patch40: system-libvpx.patch
750b48f7 126URL: http://www.chromium.org/Home
ae3fe89f 127%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3 128%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
3a3b7da9 129BuildRequires: Mesa-libGLES-devel >= 9.1
7b8f219a 130%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 131%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
132BuildRequires: alsa-lib-devel
133BuildRequires: atk-devel
134BuildRequires: bison
11ad81c4 135BuildRequires: bzip2-devel
5997e180
ER
136%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
137%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
138%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 139%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 140%{?with_cups:BuildRequires: cups-devel}
92965b0e 141BuildRequires: elfutils-devel
77f32fa3 142BuildRequires: expat-devel
7d0dbc8d 143%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 144%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 145BuildRequires: fontconfig-devel
f1b276d4 146BuildRequires: glib2-devel
05f72ae2 147BuildRequires: gperf
71d49434 148%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 149BuildRequires: gtest-devel
8b53130d 150BuildRequires: gtk+2-devel
01b4dc8e 151%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 152%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 153%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 154BuildRequires: hicolor-icon-theme
ed514974 155%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 156%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 157BuildRequires: libevent-devel
8456d676 158%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 159%{?with_keyring:BuildRequires: libgnome-keyring-devel}
cb6dde87 160%{?with_system_icu:BuildRequires: libicu-devel >= 4.6}
39c71b4c 161%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 162%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 163%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 164BuildRequires: libpng-devel
221355ea 165BuildRequires: libsecret-devel
e266589e 166%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 167BuildRequires: libstdc++-devel
ba685303 168%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
5f786a22 169%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.4.0}
88171dca 170%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
f1b276d4 171BuildRequires: libxml2-devel
11ad81c4 172BuildRequires: libxslt-devel
535cb410 173BuildRequires: man-db
62950103 174%{?with_system_minizip:BuildRequires: minizip-devel}
f8597c6e 175%{?with_ninja:BuildRequires: ninja >= 1.3.0}
05f72ae2 176BuildRequires: nspr-devel
f1b276d4 177BuildRequires: nss-devel >= 1:3.12.3
8456d676 178%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 179BuildRequires: pam-devel
f1b276d4 180BuildRequires: pango-devel
ef121064 181BuildRequires: pciutils-devel
3a3b7da9 182BuildRequires: perl-JSON
48b341f5 183BuildRequires: perl-modules
184BuildRequires: pkgconfig
75a27c2e 185%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 186%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 187BuildRequires: python
e2f921c3 188BuildRequires: python-BeautifulSoup
46cdefee 189#BuildRequires: python-gyp >= 1-%{gyp_rev}
9cce36cb 190BuildRequires: python-jinja2 >= 2.7
48b341f5 191BuildRequires: python-modules
e0a7fe40 192BuildRequires: python-ply >= 3.4
543e99ac 193%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 194BuildRequires: rpm >= 4.4.9-56
f1b276d4 195BuildRequires: rpmbuild(macros) >= 1.453
f099161f 196%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 197BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 198%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 199%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 200%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
0cad051b 201BuildRequires: tar >= 1:1.22
0a424ee2 202BuildRequires: udev-devel
7d1152d4 203BuildRequires: usbutils
2303ed45 204BuildRequires: util-linux
c14cd342 205%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 206BuildRequires: which
f1b276d4 207BuildRequires: xorg-lib-libXScrnSaver-devel
3a3b7da9 208BuildRequires: xorg-lib-libXtst-devel
836b1cac 209BuildRequires: xz
a3140cd1 210%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 211%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 212Requires: browser-plugins >= 2.0
0cad051b 213Requires: desktop-file-utils
8f5f6775 214%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
215# crashes if no fontconfig font present
216Requires: fonts-Type1-urw
0eb19b0b 217Requires: hicolor-icon-theme
56403697 218Requires: libevent >= 2.0.21
c1edaafa 219%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
5f786a22 220%{?with_system_libvpx:Requires: libvpx >= 1.4.0}
b809ab60 221Requires: lsb-release
b2c4ae39 222%{?with_system_re2:Requires: re2 >= 20130115-2}
4b2f9b57 223%{?with_system_protobuf:Requires: protobuf-libs >= 2.5.0-2}
3700ba38 224Requires: shared-mime-info
f7b16691 225%{?with_system_sqlite:Requires: sqlite3(icu)}
4dc49133 226Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 227Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 228Provides: wwwbrowser
c3582150 229Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 230Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 231ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 232BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 233
319f81f7
ER
234# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
235# Note: these are for PLD Linux use ONLY.
236# For your own distribution, please get your own set of keys.
237%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
238%define google_default_client_id 724288223830.apps.googleusercontent.com
239%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
240
7ebeabb6 241%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 242
e7fa0817
ER
243# Usage: gyp_with BCOND_NAME [OPTION_NAME]
244%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 245
a323900c
ER
246%ifarch %{ix86}
247%define target_arch ia32
248%endif
249%ifarch %{x8664}
250%define target_arch x64
251%endif
252
f8597c6e
ER
253%define buildtype %{?debug:Debug}%{!?debug:Release}
254%define builddir out/%{buildtype}
255
6b113615
ER
256%if %{without debuginfo}
257%define _enable_debug_packages 0
258%endif
259
11ad81c4 260%description
80838854
ER
261Chromium is an open-source browser project that aims to build a safer,
262faster, and more stable way for all Internet users to experience the
263web.
264
265Chromium serves as a base for Google Chrome, which is Chromium
266rebranded (name and logo) with very few additions such as usage
267tracking and an auto-updater system.
268
f1b276d4
ER
269%package l10n
270Summary: chromium-browser language packages
271Group: I18n
272Requires: %{name} = %{version}-%{release}
8da7b90b
ER
273%if "%{_rpmversion}" >= "5"
274BuildArch: noarch
275%endif
f1b276d4
ER
276
277%description l10n
278Chromium is an open-source browser project that aims to build a safer,
279faster, and more stable way for all Internet users to experience the
280web.
281
282This package contains language packages for 50 languages:
283
e7fa0817
ER
284ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
285he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
286pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
287zh-TW
f1b276d4
ER
288
289%prep
3c73e180
ER
290%setup -qc
291%if "%{?patchver}" != ""
77bd7e0a 292cd chromium*-%{branch}.%{basever}
3c73e180
ER
293%patch0 -p1
294cd ..
295%endif
77bd7e0a 296mv chromium*-%{branch}.%{basever}/* .
589d90ea 297
05f72ae2
ER
298# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
299# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 300. ./chrome/VERSION
e00e4177
ER
301chrome=$MAJOR.$MINOR.$BUILD.$PATCH
302test "$chrome" = %{version}
a3140cd1 303
75f96a39 304gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 305test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 306
4765ddf1
ER
307# add chromium and pld to useragent
308%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
309sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
310 -e 's/@BUILD_DIST_NAME@/PLD/g' \
311 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 312 < %{PATCH8} | %{__patch} -p1
4765ddf1 313
8da7b90b 314%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
315ln -s %{SOURCE7} .
316
810e0294 317#%patch2 -p1 CHECK
7879021e 318%patch7 -p1
75f96a39 319%patch15 -p2
f4a8da6a 320%{!?with_libjpegturbo:%patch11 -p0}
5997e180 321%patch16 -p1
41d6a4b1 322%patch28 -p1
a323900c 323%patch25 -p1
3aa67e11 324%{?with_nacl:%patch18 -p1}
ffb05754 325%patch24 -p1
75f96a39 326%patch26 -p2
cb6dde87 327%patch31 -p0
708e64c2 328%patch32 -p1
d7fca4aa 329%patch35 -p1
6e3c39b4 330%patch36 -p1
a20f29ed 331%patch37 -p1
810e0294 332#%patch38 -p1 CHECK
deef15b4 333%patch39 -p1
12687dbd 334%patch40 -p0
e9abb380 335
f684992e
ER
336%{?with_dev:exit 0}
337
75a27c2e
ER
338sh -x clean-source.sh \
339 %{!?with_nacl:nacl=0} \
bbdce24d
ER
340 %{!?with_system_libvpx:libvpx=0} \
341 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 342 %{!?with_system_mesa:mesa=0} \
75a27c2e 343 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 344 %{!?with_system_re2:re2=0} \
7e634b46 345 %{!?with_system_snappy:snappy=0} \
5048b37a 346 %{!?with_system_sqlite:sqlite=0} \
75a27c2e 347 %{!?with_system_v8:v8=0} \
0767a7a0 348 %{!?with_system_libwebp:libwebp=0} \
75a27c2e 349 %{!?with_system_zlib:zlib=0} \
f177fdad 350 %{!?with_system_ffmpeg:ffmpeg=0} \
75a27c2e 351 %{nil}
fded59be 352
e266589e 353%build
5997e180 354%if %{with nacl}
108c5f7c 355rm -rf native_client/toolchain/linux_x86_newlib
fded59be 356if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 357# Make symlinks for NaCL
108c5f7c 358install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 359
108c5f7c
ER
360cd native_client/toolchain/linux_x86_newlib
361ln -s x86_64-nacl/bin bin
362cd x86_64-nacl/bin
2e4113fd 363__cc='%{__cc}'
f64e73f6 364if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
365 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
366 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
367 %{__sed} -i -e '1i#!/bin/sh' gcc g++
368 chmod +x gcc g++
369else
370 ln -s %{_bindir}/x86_64-nacl-gcc gcc
371 ln -s %{_bindir}/x86_64-nacl-g++ g++
372fi
108c5f7c
ER
373ln -s gcc x86_64-nacl-gcc
374ln -s g++ x86_64-nacl-g++
375ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
376ln -s %{_bindir}/x86_64-nacl-ar ar
377ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 378ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 379ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 380ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 381ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 382ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
383ln -s %{_prefix}/x86_64-nacl/lib ../lib
384ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
385ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
386cd ../../../../..
fded59be 387fi
5997e180
ER
388%endif
389
a323900c 390%if %{without system_ffmpeg}
f8597c6e
ER
391if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
392 # Re-configure bundled ffmpeg
393 cd third_party/ffmpeg
50d701c6
ER
394 chromium/scripts/build_ffmpeg.py linux %{target_arch} \
395 --branding Chromium
f8597c6e 396 chromium/scripts/copy_config.sh
6e3c39b4 397 chromium/scripts/generate_gyp.py
f8597c6e
ER
398 cd -
399fi
0c480b89 400%endif
a323900c 401
6e3c39b4
ER
402third_party/libaddressinput/chromium/tools/update-strings.py
403
a323900c
ER
404flags="
405 -Dtarget_arch=%{target_arch} \
406 -Dpython_arch=%{target_arch} \
12687dbd 407 -Dproprietary_codecs=1 \
6e3c39b4 408 -Dffmpeg_branding=Chromium \
b91ce587 409 -Dsystem_libdir=%{_lib} \
a323900c 410 -Dpython_ver=%{py_ver} \
7b454a31
AM
411%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
412 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4 413%endif
f047b07c 414 %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
c980b122 415 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 416 %{?with_shared_libs:-Dlibrary=shared_library} \
b6942fc6 417 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
77bd7e0a 418 -Dinclude_tests__=0 \
c0808220 419%if %{with nacl}
038f76b9 420 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
421 -Ddisable_glibc_untar=1 \
422 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
423 -Ddisable_glibc=1 \
424 -Ddisable_pnacl=1 \
425 -Dbuild_pnacl_newlib=0 \
c0808220 426%else
8fb1dc98 427 -Ddisable_pnacl_untar=1 \
c0808220
ER
428 -Ddisable_nacl=1 \
429%endif
a3140cd1
ER
430 %{!?with_sse2:-Ddisable_sse2=1} \
431 %{?with_selinux:-Dselinux=1} \
7d1152d4 432 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 433 -Dlinux_link_libpci=1 \
7879021e 434 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
14c8ce0e 435 -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
71d49434 436 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
2983aa41
ER
437 -Dclang=0 \
438 -Dhost_clang=0 \
14c8ce0e
ER
439 -Dlinux_use_bundled_binutils=0 \
440 -Dlinux_use_bundled_gold=0 \
05998197 441 -Dlinux_use_gold_flags=0 \
71581184 442 -Dlogging_like_official_build=1 \
319f81f7
ER
443 -Dgoogle_api_key=%{google_api_key} \
444 -Dgoogle_default_client_id=%{google_default_client_id} \
445 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 446 %{gyp_with cups} \
8dda6bbc 447 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 448 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
449 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
450 %{gyp_with pulseaudio} \
41d6a4b1 451 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 452 %{gyp_with system_flac} \
01b4dc8e 453 %{gyp_with system_harfbuzz} \
cb6dde87 454 %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
2d65d095 455 %{gyp_with system_jsoncpp} \
62950103
ER
456 %{gyp_with system_libexif} \
457 %{gyp_with system_libmtp} \
9bd2659c 458 %{gyp_with system_libsrtp} \
581aec44 459 %{gyp_with system_libusb} \
88171dca 460 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
ba685303 461 %{gyp_with system_libwebp} \
4884fc99 462 %{gyp_with system_libxnvctrl} \
7b8f219a 463 %{gyp_with system_mesa} \
126ea630 464 %{gyp_with system_minizip} \
62950103 465 %{gyp_with system_opus} \
75a27c2e 466 %{gyp_with system_protobuf} \
bbdce24d 467 %{gyp_with system_re2} \
7e634b46 468 %{gyp_with system_snappy} \
e7fa0817 469 %{gyp_with system_speex} \
914ee37c 470 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
471 %{gyp_with system_v8} \
472 %{gyp_with system_yasm} \
473 %{gyp_with system_zlib} \
0c480b89 474 -Duse_system_bzip2=1 \
62950103 475 -Duse_system_expat=1 \
f1b276d4 476 -Duse_system_libevent=1 \
0c480b89 477 -Duse_system_libjpeg=1 \
f1b276d4
ER
478 -Duse_system_libpng=1 \
479 -Duse_system_libxml=1 \
480 -Duse_system_libxslt=1 \
b363f856 481 -Duse_system_nspr=1 \
7f40f3f4 482 -Duse_system_xdg_utils=1 \
7879021e
ER
483"
484
485build/linux/unbundle/replace_gyp_files.py $flags
486
f8597c6e
ER
487%if %{with ninja}
488chkfile=%{builddir}/build.ninja
489%else
490chkfile=Makefile
491%endif
492test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
493test -e $chkfile || \
7879021e
ER
494 CC="%{__cc}" \
495 CXX="%{__cxx}" \
496 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
497 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
498 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
499 CC_host="%{__cc}" \
500 CXX_host="%{__cxx}" \
501 LD_host="%{__cxx}" \
502%{__python} build/gyp_chromium \
f8597c6e 503 --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
7879021e
ER
504 --depth=. \
505 build/all.gyp \
506 $flags
11ad81c4 507
f8597c6e
ER
508%if %{with ninja}
509ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
510%else
b4d75247 511# need {CC/CXX/LDFLAGS}.host overrides for v8 build
f8597c6e
ER
512%{__make} -r \
513 BUILDTYPE=%{buildtype} \
f1b276d4 514 %{?with_verbose:V=1} \
f1b276d4
ER
515 CC.host="%{__cc}" \
516 CXX.host="%{__cxx}" \
b4d75247 517 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
f8597c6e
ER
518%endif
519 chrome %{?with_sandboxing:chrome_sandbox} \
520 %{nil}
11ad81c4 521
f8597c6e 522cd %{builddir}
535cb410
ER
523MANWIDTH=80 man ./chrome.1 > man.out
524%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
525
11ad81c4
AM
526%install
527rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
528install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
529 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
3b9998d5
ER
530 $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
531 $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
e266589e 532
f8597c6e 533cd %{builddir}
37ceaf05 534cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 535install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
536%{__sed} -i -e '
537 s,@libdir@,%{_libdir}/%{name},
538
539 /@OPTIONS@/ {
540 r options.txt
541 d
542 }
543' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b 544cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
fa8317a0 545cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
8da7b90b
ER
546ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
547ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 548cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 549install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
d1a83042 550install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
fcc48c19 551%if %{without system_ffmpeg}
f1b276d4 552install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 553%endif
e7fa0817 554cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 555cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 556
8da7b90b 557%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 558
164020eb
ER
559%if %{with nacl}
560# Install Native Client files on platforms that support it.
561install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
562install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
563%ifarch %{x8664}
564install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
565%endif
566%ifarch %{ix86}
567install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
568%endif
569%endif
570
0c480b89
ER
571cd -
572
75f96a39 573for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
574 size=${icon##*/product_logo_}
575 size=${size%.png}
576
577 # this will skip non-numeric (22_mono_invert, 22_mono)
578 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
579 test -d "$dir" || continue
580
581 install -d $RPM_BUILD_ROOT$dir
582 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
583done
7f40f3f4 584
13840bc2
AM
585%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
586# http://code.google.com/p/chromium/issues/detail?id=24507
587gecko-mediaplayer*.so
588EOF
11ad81c4 589
589d90ea
ER
590# find locales
591%find_lang %{name}.lang
e7fa0817 592# always package en-US
f1b276d4 593%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 594
11ad81c4
AM
595%clean
596rm -rf $RPM_BUILD_ROOT
597
8da7b90b
ER
598%pretrans
599for d in locales resources; do
600 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
601 install -d %{_datadir}/%{name}
602 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
603 fi
604done
605exit 0
606
f1b276d4 607%post
0eb19b0b 608%update_icon_cache hicolor
b7a6e4ee 609%update_desktop_database
f1b276d4
ER
610%update_browser_plugins
611
612%postun
613if [ "$1" = 0 ]; then
0eb19b0b 614 %update_icon_cache hicolor
f1b276d4
ER
615 %update_browser_plugins
616fi
617
1d2b9616 618%files
11ad81c4 619%defattr(644,root,root,755)
75f96a39 620%doc AUTHORS LICENSE
f1b276d4
ER
621%{_browserpluginsconfdir}/browsers.d/%{name}.*
622%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
623%dir %{_sysconfdir}/%{name}
624%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 625%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
3b9998d5
ER
626%dir %{_sysconfdir}/%{name}/native-messaging-hosts
627%dir %{_sysconfdir}/%{name}/policies
628%dir %{_sysconfdir}/%{name}/policies/managed
f1b276d4
ER
629%attr(755,root,root) %{_bindir}/%{name}
630%{_mandir}/man1/%{name}.1*
11ad81c4 631%{_desktopdir}/*.desktop
0eb19b0b 632%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 633%dir %{_libdir}/%{name}
e9abb380 634%{_libdir}/%{name}/chrome*.pak
c14cd342 635%{_libdir}/%{name}/content_resources.pak
f047b07c 636%{_libdir}/%{name}/keyboard_resources.pak
97fac491 637%{_libdir}/%{name}/resources.pak
fa8317a0
ER
638%{_libdir}/%{name}/natives_blob.bin
639%{_libdir}/%{name}/snapshot_blob.bin
8da7b90b
ER
640%{_libdir}/%{name}/locales
641%{_libdir}/%{name}/resources
642
643%dir %{_datadir}/%{name}
644%dir %{_datadir}/%{name}/locales
645%{_datadir}/%{name}/locales/en-US.pak
646%dir %{_datadir}/%{name}/resources
647%{_datadir}/%{name}/resources/inspector
648
f1b276d4
ER
649%dir %{_libdir}/%{name}/plugins
650%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 651# These unique permissions are intentional and necessary for the sandboxing
d1a83042 652%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
f1b276d4
ER
653
654# ffmpeg libs
fcc48c19 655%if %{without system_ffmpeg}
f1b276d4 656%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 657%endif
f1b276d4 658
164020eb
ER
659%if %{with nacl}
660%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
661%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
662%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
663%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
664%endif
665
f1b276d4
ER
666%files l10n -f %{name}.lang
667%defattr(644,root,root,755)
This page took 0.230779 seconds and 4 git commands to generate.