]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
- icu rebuild
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_with     dev                     # with dev optimizations (skip clean source)
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
10 %bcond_without  libjpegturbo    # use libjpeg-turbo features
11 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
12 %bcond_without  ninja                   # use Ninja instead of make to build
13 %bcond_without  pulseaudio              # with pulseaudio
14 %bcond_without  sandboxing              # with sandboxing
15 %bcond_with             selinux                 # with SELinux (need policy first)
16 %bcond_with             shared_libs             # with shared libs
17 %bcond_with             sse2                    # use SSE2 instructions
18 %bcond_without  system_flac             # system flac
19 %bcond_with     system_ffmpeg   # system ffmpeg instead of ffmpegsumo
20 %bcond_without  system_harfbuzz # system harfbuzz
21 %bcond_without  system_icu      # system icu
22 %bcond_without  system_jsoncpp  # system jsoncpp
23 %bcond_without  system_libexif  # system libexif
24 %bcond_without  system_libmtp   # system libmtp
25 %bcond_with     system_libusb   # system libusb-1, disabled: http://crbug.com/266149
26 %bcond_without  system_libwebp  # system libwebp
27 %bcond_without  system_libxnvctrl       # system libxnvctrl
28 %bcond_with     system_mesa             # system Mesa
29 %bcond_without  system_minizip  # system minizip
30 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
31 # protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
32 %bcond_with     system_protobuf # system protobuf
33 %bcond_without  system_re2              # system re2
34 %bcond_without  system_snappy   # system snappy
35 %bcond_without  system_speex    # system speex
36 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
37 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
38 %bcond_with             system_v8               # system v8
39 %bcond_with     system_libvpx   # system libvpx
40 %bcond_without  system_yasm             # system yasm
41 %bcond_without  system_zlib             # system zlib
42 %bcond_with     tcmalloc                # use tcmalloc
43 %bcond_without  verbose                 # verbose build (V=1)
44
45 %ifarch %{ix86}
46 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
47 %undefine       with_system_mesa
48
49 # unable build with debuginfo on 32bit build systems
50 # /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
51 %undefine       with_debuginfo
52 %endif
53
54 %ifarch %{x8664}
55 # x86_64 systems fail with debugedit crashing
56 # /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
57 %undefine       with_debuginfo
58 %endif
59
60 # TODO
61 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
62 # - use_system_skia
63 # - use_system_ssl (use_openssl: http://crbug.com/62803)
64 # - use_system_stlport (android specific)
65 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
66
67 # NOTES:
68 # - mute BEEP mixer if you do not want to hear horrible system bell when
69 #   pressing home/end in url bar or more ^F search results on page.
70 # - space considerations:
71 #   - unpacked sources: ~490MiB
72 #   - built code: ~1.4GiB (x86_64/i686)
73 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
74 # - to look for new tarball, use update-source.sh script
75
76 %define         branch          43.0.2357
77 %define         basever         65
78 %define         patchver        81
79 %define         gyp_rev 1014
80 Summary:        A WebKit powered web browser
81 Name:           chromium-browser
82 %if "%{?patchver}" != ""
83 Version:        %{branch}.%{patchver}
84 %else
85 Version:        %{branch}.%{basever}
86 %endif
87 Release:        2
88 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
89 Group:          X11/Applications/Networking
90 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
91 # Source0-md5:  4aa590c1965817cfb693df7f8404e0b6
92 %if "%{?patchver}" != ""
93 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
94 # Patch0-md5:   9b379619238dbcbad2bed28442e4d371
95 %endif
96 Source1:        %{name}.default
97 Source2:        %{name}.sh
98 Source3:        %{name}.desktop
99 Source5:        find-lang.sh
100 Source6:        update-source.sh
101 Source7:        clean-source.sh
102 Source8:        get-source.sh
103 Source9:        master_preferences.json
104 # https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
105 Patch2:         enable-video-decode-accel.patch
106 Patch7:         dlopen_sonamed_gl.patch
107 Patch8:         chromium_useragent.patch.in
108 # https://bugs.gentoo.org/show_bug.cgi?id=393471
109 # libjpeg-turbo >= 1.1.90 supports that feature
110 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
111 Patch15:        nacl-build-irt.patch
112 Patch16:        nacl-linkingfix.patch
113 Patch18:        nacl-no-untar.patch
114 Patch24:        nacl-verbose.patch
115 Patch25:        gnome3-volume-control.patch
116 Patch26:        master-prefs-path.patch
117 Patch28:        system-mesa.patch
118 Patch31:        system-jinja.patch
119 Patch32:        remove_bundled_libraries-stale.patch
120 Patch35:        etc-dir.patch
121 Patch36:        angle.patch
122 Patch37:        %{name}-build.patch
123 Patch38:        vaapi_include.patch
124 Patch39:        libsecret.patch
125 Patch40:        system-libvpx.patch
126 URL:            http://www.chromium.org/Home
127 %{?with_gconf:BuildRequires:    GConf2-devel}
128 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
129 BuildRequires:  Mesa-libGLES-devel >= 9.1
130 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
131 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
132 BuildRequires:  alsa-lib-devel
133 BuildRequires:  atk-devel
134 BuildRequires:  bison
135 BuildRequires:  bzip2-devel
136 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
137 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
138 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
139 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
140 %{?with_cups:BuildRequires:     cups-devel}
141 BuildRequires:  elfutils-devel
142 BuildRequires:  expat-devel
143 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
144 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
145 BuildRequires:  fontconfig-devel
146 BuildRequires:  glib2-devel
147 BuildRequires:  gperf
148 %{?with_gps:BuildRequires:      gpsd-devel}
149 BuildRequires:  gtest-devel
150 BuildRequires:  gtk+2-devel
151 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
152 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
153 %{?with_kerberos:BuildRequires: heimdal-devel}
154 BuildRequires:  hicolor-icon-theme
155 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
156 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
157 BuildRequires:  libevent-devel
158 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
159 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
160 %{?with_system_icu:BuildRequires:       libicu-devel >= 4.6}
161 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
162 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
163 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
164 BuildRequires:  libpng-devel
165 BuildRequires:  libsecret-devel
166 %{?with_selinux:BuildRequires:  libselinux-devel}
167 BuildRequires:  libstdc++-devel
168 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
169 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 1.4.0}
170 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.4.0}
171 BuildRequires:  libxml2-devel
172 BuildRequires:  libxslt-devel
173 BuildRequires:  man-db
174 %{?with_system_minizip:BuildRequires:   minizip-devel}
175 %{?with_ninja:BuildRequires:    ninja >= 1.3.0}
176 BuildRequires:  nspr-devel
177 BuildRequires:  nss-devel >= 1:3.12.3
178 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
179 BuildRequires:  pam-devel
180 BuildRequires:  pango-devel
181 BuildRequires:  pciutils-devel
182 BuildRequires:  perl-JSON
183 BuildRequires:  perl-modules
184 BuildRequires:  pkgconfig
185 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
186 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
187 BuildRequires:  python
188 BuildRequires:  python-BeautifulSoup
189 #BuildRequires: python-gyp >= 1-%{gyp_rev}
190 BuildRequires:  python-jinja2 >= 2.7
191 BuildRequires:  python-modules
192 BuildRequires:  python-ply >= 3.4
193 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
194 BuildRequires:  rpm >= 4.4.9-56
195 BuildRequires:  rpmbuild(macros) >= 1.453
196 %{?with_system_snappy:BuildRequires:    snappy-devel}
197 BuildRequires:  speech-dispatcher-devel >= 0.8
198 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
199 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
200 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
201 BuildRequires:  tar >= 1:1.22
202 BuildRequires:  udev-devel
203 BuildRequires:  usbutils
204 BuildRequires:  util-linux
205 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
206 BuildRequires:  which
207 BuildRequires:  xorg-lib-libXScrnSaver-devel
208 BuildRequires:  xorg-lib-libXtst-devel
209 BuildRequires:  xz
210 %{?with_system_yasm:BuildRequires:      yasm}
211 %{?with_system_zlib:BuildRequires:      zlib-devel}
212 Requires:       browser-plugins >= 2.0
213 Requires:       desktop-file-utils
214 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
215 # crashes if no fontconfig font present
216 Requires:       fonts-Type1-urw
217 Requires:       hicolor-icon-theme
218 Requires:       libevent >= 2.0.21
219 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
220 %{?with_system_libvpx:Requires: libvpx >= 1.4.0}
221 Requires:       lsb-release
222 %{?with_system_re2:Requires:    re2 >= 20130115-2}
223 %{?with_system_protobuf:Requires:       protobuf-libs >= 2.5.0-2}
224 Requires:       shared-mime-info
225 %{?with_system_sqlite:Requires: sqlite3(icu)}
226 Requires:       xdg-utils >= 1.0.2-4
227 Requires:       xorg-lib-libX11 >= 1.4.99.1
228 Provides:       wwwbrowser
229 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
230 Obsoletes:      chromium-browser-inspector < 15.0.863.0
231 ExclusiveArch:  %{ix86} %{x8664} arm
232 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
233
234 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
235 # Note: these are for PLD Linux use ONLY.
236 # For your own distribution, please get your own set of keys.
237 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
238 %define         google_default_client_id 724288223830.apps.googleusercontent.com
239 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
240
241 %define         find_lang       sh find-lang.sh %{buildroot}
242
243 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
244 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
245
246 %ifarch %{ix86}
247 %define         target_arch ia32
248 %endif
249 %ifarch %{x8664}
250 %define         target_arch x64
251 %endif
252
253 %define         buildtype       %{?debug:Debug}%{!?debug:Release}
254 %define         builddir        out/%{buildtype}
255
256 %if %{without debuginfo}
257 %define         _enable_debug_packages  0
258 %endif
259
260 %description
261 Chromium is an open-source browser project that aims to build a safer,
262 faster, and more stable way for all Internet users to experience the
263 web.
264
265 Chromium serves as a base for Google Chrome, which is Chromium
266 rebranded (name and logo) with very few additions such as usage
267 tracking and an auto-updater system.
268
269 %package l10n
270 Summary:        chromium-browser language packages
271 Group:          I18n
272 Requires:       %{name} = %{version}-%{release}
273 %if "%{_rpmversion}" >= "5"
274 BuildArch:      noarch
275 %endif
276
277 %description l10n
278 Chromium is an open-source browser project that aims to build a safer,
279 faster, and more stable way for all Internet users to experience the
280 web.
281
282 This package contains language packages for 50 languages:
283
284 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
285 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
286 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
287 zh-TW
288
289 %prep
290 %setup -qc
291 %if "%{?patchver}" != ""
292 cd chromium*-%{branch}.%{basever}
293 %patch0 -p1
294 cd ..
295 %endif
296 mv chromium*-%{branch}.%{basever}/* .
297
298 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
299 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
300 . ./chrome/VERSION
301 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
302 test "$chrome" = %{version}
303
304 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
305 test "$gyp_rev" = %{gyp_rev} || :
306
307 # add chromium and pld to useragent
308 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
309 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
310         -e 's/@BUILD_DIST_NAME@/PLD/g' \
311         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
312         < %{PATCH8} | %{__patch} -p1
313
314 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
315 ln -s %{SOURCE7} .
316
317 #%patch2 -p1 CHECK
318 %patch7 -p1
319 %patch15 -p2
320 %{!?with_libjpegturbo:%patch11 -p0}
321 %patch16 -p1
322 %patch28 -p1
323 %patch25 -p1
324 %{?with_nacl:%patch18 -p1}
325 %patch24 -p1
326 %patch26 -p2
327 %patch31 -p0
328 %patch32 -p1
329 %patch35 -p1
330 %patch36 -p1
331 %patch37 -p1
332 #%patch38 -p1 CHECK
333 %patch39 -p1
334 %patch40 -p0
335
336 %{?with_dev:exit 0}
337
338 sh -x clean-source.sh \
339         %{!?with_nacl:nacl=0} \
340         %{!?with_system_libvpx:libvpx=0} \
341         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
342         %{!?with_system_mesa:mesa=0} \
343         %{!?with_system_protobuf:protobuf=0} \
344         %{!?with_system_re2:re2=0} \
345         %{!?with_system_snappy:snappy=0} \
346         %{!?with_system_sqlite:sqlite=0} \
347         %{!?with_system_v8:v8=0} \
348         %{!?with_system_libwebp:libwebp=0} \
349         %{!?with_system_zlib:zlib=0} \
350         %{!?with_system_ffmpeg:ffmpeg=0} \
351         %{nil}
352
353 %build
354 %if %{with nacl}
355 rm -rf native_client/toolchain/linux_x86_newlib
356 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
357 # Make symlinks for NaCL
358 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
359
360 cd native_client/toolchain/linux_x86_newlib
361 ln -s x86_64-nacl/bin bin
362 cd x86_64-nacl/bin
363 __cc='%{__cc}'
364 if [ "${__cc#ccache}" != "$__cc" ]; then
365         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
366         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
367         %{__sed} -i -e '1i#!/bin/sh' gcc g++
368         chmod +x gcc g++
369 else
370         ln -s %{_bindir}/x86_64-nacl-gcc gcc
371         ln -s %{_bindir}/x86_64-nacl-g++ g++
372 fi
373 ln -s gcc x86_64-nacl-gcc
374 ln -s g++ x86_64-nacl-g++
375 ln -s %{_bindir}/x86_64-nacl-ar .
376 ln -s %{_bindir}/x86_64-nacl-ar ar
377 ln -s %{_bindir}/x86_64-nacl-as as
378 ln -s %{_bindir}/x86_64-nacl-ranlib .
379 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
380 ln -s %{_bindir}/x86_64-nacl-strip .
381 ln -s %{_bindir}/x86_64-nacl-strip strip
382 ln -s %{_bindir}/x86_64-nacl-objcopy .
383 ln -s %{_prefix}/x86_64-nacl/lib ../lib
384 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
385 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
386 cd ../../../../..
387 fi
388 %endif
389
390 %if %{without system_ffmpeg}
391 if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
392         # Re-configure bundled ffmpeg
393         cd third_party/ffmpeg
394         chromium/scripts/build_ffmpeg.py linux %{target_arch} \
395                 --branding Chromium
396         chromium/scripts/copy_config.sh
397         chromium/scripts/generate_gyp.py
398         cd -
399 fi
400 %endif
401
402 third_party/libaddressinput/chromium/tools/update-strings.py
403
404 flags="
405         -Dtarget_arch=%{target_arch} \
406         -Dpython_arch=%{target_arch} \
407         -Dproprietary_codecs=1 \
408         -Dffmpeg_branding=Chromium \
409         -Dsystem_libdir=%{_lib} \
410         -Dpython_ver=%{py_ver} \
411 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
412         -Dno_strict_aliasing=1 -Dgcc_version=44 \
413 %endif
414         %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
415         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
416         %{?with_shared_libs:-Dlibrary=shared_library} \
417         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
418         -Dinclude_tests__=0 \
419 %if %{with nacl}
420         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
421         -Ddisable_glibc_untar=1 \
422         -Ddisable_newlib_untar=1 \
423         -Ddisable_glibc=1 \
424         -Ddisable_pnacl=1 \
425         -Dbuild_pnacl_newlib=0 \
426 %else
427         -Ddisable_pnacl_untar=1 \
428         -Ddisable_nacl=1 \
429 %endif
430         %{!?with_sse2:-Ddisable_sse2=1} \
431         %{?with_selinux:-Dselinux=1} \
432         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
433         -Dlinux_link_libpci=1 \
434         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
435         -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
436         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
437         -Dclang=0 \
438         -Dhost_clang=0 \
439         -Dlinux_use_bundled_binutils=0 \
440         -Dlinux_use_bundled_gold=0 \
441         -Dlinux_use_gold_flags=0 \
442         -Dlogging_like_official_build=1 \
443         -Dgoogle_api_key=%{google_api_key} \
444         -Dgoogle_default_client_id=%{google_default_client_id} \
445         -Dgoogle_default_client_secret=%{google_default_client_secret} \
446         %{gyp_with cups} \
447         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
448         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
449         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
450         %{gyp_with pulseaudio} \
451         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
452         %{gyp_with system_flac} \
453         %{gyp_with system_harfbuzz} \
454         %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
455         %{gyp_with system_jsoncpp} \
456         %{gyp_with system_libexif} \
457         %{gyp_with system_libmtp} \
458         %{gyp_with system_libsrtp} \
459         %{gyp_with system_libusb} \
460         %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
461         %{gyp_with system_libwebp} \
462         %{gyp_with system_libxnvctrl} \
463         %{gyp_with system_mesa} \
464         %{gyp_with system_minizip} \
465         %{gyp_with system_opus} \
466         %{gyp_with system_protobuf} \
467         %{gyp_with system_re2} \
468         %{gyp_with system_snappy} \
469         %{gyp_with system_speex} \
470         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
471         %{gyp_with system_v8} \
472         %{gyp_with system_yasm} \
473         %{gyp_with system_zlib} \
474         -Duse_system_bzip2=1 \
475         -Duse_system_expat=1 \
476         -Duse_system_libevent=1 \
477         -Duse_system_libjpeg=1 \
478         -Duse_system_libpng=1 \
479         -Duse_system_libxml=1 \
480         -Duse_system_libxslt=1 \
481         -Duse_system_nspr=1 \
482         -Duse_system_xdg_utils=1 \
483 "
484
485 build/linux/unbundle/replace_gyp_files.py $flags
486
487 %if %{with ninja}
488 chkfile=%{builddir}/build.ninja
489 %else
490 chkfile=Makefile
491 %endif
492 test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
493 test -e $chkfile || \
494         CC="%{__cc}" \
495         CXX="%{__cxx}" \
496         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
497         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
498         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
499         CC_host="%{__cc}" \
500         CXX_host="%{__cxx}" \
501         LD_host="%{__cxx}" \
502 %{__python} build/gyp_chromium \
503         --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
504         --depth=. \
505         build/all.gyp \
506         $flags
507
508 %if %{with ninja}
509 ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
510 %else
511 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
512 %{__make} -r \
513         BUILDTYPE=%{buildtype} \
514         %{?with_verbose:V=1} \
515         CC.host="%{__cc}" \
516         CXX.host="%{__cxx}" \
517         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
518 %endif
519         chrome %{?with_sandboxing:chrome_sandbox} \
520         %{nil}
521
522 cd %{builddir}
523 MANWIDTH=80 man ./chrome.1 > man.out
524 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
525
526 %install
527 rm -rf $RPM_BUILD_ROOT
528 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
529         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
530         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
531         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
532
533 cd %{builddir}
534 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
535 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
536 %{__sed} -i -e '
537         s,@libdir@,%{_libdir}/%{name},
538
539         /@OPTIONS@/ {
540                 r options.txt
541                 d
542         }
543 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
544 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
545 cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
546 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
547 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
548 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
549 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
550 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
551 %if %{without system_ffmpeg}
552 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
553 %endif
554 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
555 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
556
557 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
558
559 %if %{with nacl}
560 # Install Native Client files on platforms that support it.
561 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
562 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
563 %ifarch %{x8664}
564 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
565 %endif
566 %ifarch %{ix86}
567 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
568 %endif
569 %endif
570
571 cd -
572
573 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
574         size=${icon##*/product_logo_}
575         size=${size%.png}
576
577         # this will skip non-numeric (22_mono_invert, 22_mono)
578         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
579         test -d "$dir" || continue
580
581         install -d $RPM_BUILD_ROOT$dir
582         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
583 done
584
585 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
586 # http://code.google.com/p/chromium/issues/detail?id=24507
587 gecko-mediaplayer*.so
588 EOF
589
590 # find locales
591 %find_lang %{name}.lang
592 # always package en-US
593 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
594
595 %clean
596 rm -rf $RPM_BUILD_ROOT
597
598 %pretrans
599 for d in locales resources; do
600         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
601                 install -d %{_datadir}/%{name}
602                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
603         fi
604 done
605 exit 0
606
607 %post
608 %update_icon_cache hicolor
609 %update_desktop_database
610 %update_browser_plugins
611
612 %postun
613 if [ "$1" = 0 ]; then
614         %update_icon_cache hicolor
615         %update_browser_plugins
616 fi
617
618 %files
619 %defattr(644,root,root,755)
620 %doc AUTHORS LICENSE
621 %{_browserpluginsconfdir}/browsers.d/%{name}.*
622 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
623 %dir %{_sysconfdir}/%{name}
624 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
625 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
626 %dir %{_sysconfdir}/%{name}/native-messaging-hosts
627 %dir %{_sysconfdir}/%{name}/policies
628 %dir %{_sysconfdir}/%{name}/policies/managed
629 %attr(755,root,root) %{_bindir}/%{name}
630 %{_mandir}/man1/%{name}.1*
631 %{_desktopdir}/*.desktop
632 %{_iconsdir}/hicolor/*/apps/%{name}.png
633 %dir %{_libdir}/%{name}
634 %{_libdir}/%{name}/chrome*.pak
635 %{_libdir}/%{name}/content_resources.pak
636 %{_libdir}/%{name}/keyboard_resources.pak
637 %{_libdir}/%{name}/resources.pak
638 %{_libdir}/%{name}/natives_blob.bin
639 %{_libdir}/%{name}/snapshot_blob.bin
640 %{_libdir}/%{name}/locales
641 %{_libdir}/%{name}/resources
642
643 %dir %{_datadir}/%{name}
644 %dir %{_datadir}/%{name}/locales
645 %{_datadir}/%{name}/locales/en-US.pak
646 %dir %{_datadir}/%{name}/resources
647 %{_datadir}/%{name}/resources/inspector
648
649 %dir %{_libdir}/%{name}/plugins
650 %attr(755,root,root) %{_libdir}/%{name}/%{name}
651 # These unique permissions are intentional and necessary for the sandboxing
652 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
653
654 # ffmpeg libs
655 %if %{without system_ffmpeg}
656 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
657 %endif
658
659 %if %{with nacl}
660 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
661 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
662 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
663 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
664 %endif
665
666 %files l10n -f %{name}.lang
667 %defattr(644,root,root,755)
This page took 0.071245 seconds and 3 git commands to generate.