]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
- release 2 (by relup.sh)
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
75f96a39 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 8%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
3aa67e11 10%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
ba685303 11%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
ba685303 16%bcond_without system_flac # system flac
4e881737 17%bcond_without system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 18%bcond_without system_harfbuzz # system harfbuzz
ba685303 19%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
20%bcond_without system_libexif # system libexif
21%bcond_without system_libmtp # system libmtp
3934d767 22%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
ba685303 23%bcond_without system_libwebp # system libwebp
4884fc99 24%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 25%bcond_with system_mesa # system Mesa
126ea630 26%bcond_without system_minizip # system minizip
62950103 27%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 28%bcond_without system_protobuf # system protobuf
543e99ac 29%bcond_without system_re2 # system re2
7e634b46 30%bcond_without system_snappy # system snappy
ba685303 31%bcond_without system_speex # system speex
a8f4f3ac 32%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 33%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 34%bcond_with system_v8 # system v8
4b411ffe 35%bcond_without system_libvpx # system libvpx
ba685303 36%bcond_without system_yasm # system yasm
1c00315b 37%bcond_without system_zlib # system zlib
d2781a31 38%bcond_without tcmalloc # use tcmalloc
7e136323 39%bcond_without verbose # verbose build (V=1)
0c480b89 40
b3fc6cb2
ER
41%ifarch %{ix86}
42# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
43%undefine with_system_mesa
44%endif
45
6d92f81c 46# TODO
b363f856 47# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 48# - use_system_skia
a3140cd1 49# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 50# - use_system_stlport (android specific)
7b8f219a 51# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 52
e53ecfb5 53# NOTES:
4fe038cb
ER
54# - mute BEEP mixer if you do not want to hear horrible system bell when
55# pressing home/end in url bar or more ^F search results on page.
7c638678 56# - space considerations:
0bb93ab2 57# - unpacked sources: ~490MiB
c1ecd31f 58# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 59# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 60# - to look for new tarball, use update-source.sh script
f1b276d4 61
fb336f24
ER
62%define branch 30.0.1599
63%define basever 66
058354e4 64%define patchver 114
a3140cd1 65%define gyp_rev 1014
11ad81c4 66Summary: A WebKit powered web browser
05f72ae2 67Name: chromium-browser
f73369da
ER
68%if "%{?patchver}" != ""
69Version: %{branch}.%{patchver}
70%else
71Version: %{branch}.%{basever}
72%endif
6d5298ac 73Release: 2
5bb99ef4 74License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 75Group: X11/Applications/Networking
dd9e51df
ER
76Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
77# Source0-md5: 065e908d4b4a7ca44026a8234b336cf1
3c73e180
ER
78%if "%{?patchver}" != ""
79Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
058354e4 80# Patch0-md5: ccc99af9e31d866c174d824eeed5aab2
3c73e180 81%endif
37ceaf05 82Source1: %{name}.default
8b53130d
ER
83Source2: %{name}.sh
84Source3: %{name}.desktop
56c6e811
ER
85Source5: find-lang.sh
86Source6: update-source.sh
87Source7: clean-source.sh
836b1cac 88Source8: get-source.sh
0562b864 89Source9: master_preferences.json
48b341f5 90Patch1: plugin-searchdirs.patch
72cb20c1 91Patch4: path-libpdf.patch
5aa5df39 92Patch7: dlopen_sonamed_gl.patch
4765ddf1 93Patch8: chromium_useragent.patch.in
8456d676 94Patch10: system-libxnvctrl.patch
1347c76c
AM
95# https://bugs.gentoo.org/show_bug.cgi?id=393471
96# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 97Patch11: chromium-revert-jpeg-swizzle-r2.patch
108c5f7c 98Patch12: system-ffmpeg.patch
5997e180
ER
99Patch15: nacl-build-irt.patch
100Patch16: nacl-linkingfix.patch
9516ca97 101Patch18: nacl-no-untar.patch
6897926c 102Patch24: nacl-verbose.patch
c5b396f3
ER
103Patch25: gnome3-volume-control.patch
104Patch26: master-prefs-path.patch
25d4e23c 105Patch28: system-mesa.patch
fb336f24 106Patch29: system-icu.patch
e0a7fe40 107Patch30: system-ply.patch
750b48f7 108URL: http://www.chromium.org/Home
ae3fe89f 109%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3 110%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
3a3b7da9 111BuildRequires: Mesa-libGLES-devel >= 9.1
7b8f219a 112%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 113%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
114BuildRequires: alsa-lib-devel
115BuildRequires: atk-devel
116BuildRequires: bison
11ad81c4 117BuildRequires: bzip2-devel
5997e180
ER
118%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
119%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
120%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 121%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 122%{?with_cups:BuildRequires: cups-devel}
92965b0e 123BuildRequires: elfutils-devel
77f32fa3 124BuildRequires: expat-devel
7d0dbc8d 125%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 126%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 127BuildRequires: fontconfig-devel
f1b276d4 128BuildRequires: glib2-devel
05f72ae2 129BuildRequires: gperf
71d49434 130%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 131BuildRequires: gtest-devel
8b53130d 132BuildRequires: gtk+2-devel
01b4dc8e 133%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 134%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 135%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 136BuildRequires: hicolor-icon-theme
ed514974 137%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 138%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 139BuildRequires: libevent-devel
8456d676 140%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 141%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 142BuildRequires: libicu-devel >= 4.6
39c71b4c 143%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 144%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 145%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 146BuildRequires: libpng-devel
e266589e 147%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 148BuildRequires: libstdc++-devel
ba685303 149%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 150%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 151%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 152BuildRequires: libxml2-devel
11ad81c4 153BuildRequires: libxslt-devel
535cb410 154BuildRequires: man-db
62950103 155%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 156BuildRequires: nspr-devel
f1b276d4 157BuildRequires: nss-devel >= 1:3.12.3
8456d676 158%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 159BuildRequires: pam-devel
f1b276d4 160BuildRequires: pango-devel
ef121064 161BuildRequires: pciutils-devel
3a3b7da9 162BuildRequires: perl-JSON
48b341f5 163BuildRequires: perl-modules
164BuildRequires: pkgconfig
75a27c2e 165%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 166%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 167BuildRequires: python
46cdefee 168#BuildRequires: python-gyp >= 1-%{gyp_rev}
93af9bb1 169BuildRequires: python-jinja2
48b341f5 170BuildRequires: python-modules
e0a7fe40 171BuildRequires: python-ply >= 3.4
543e99ac 172%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 173BuildRequires: rpm >= 4.4.9-56
f1b276d4 174BuildRequires: rpmbuild(macros) >= 1.453
f099161f 175%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 176BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 177%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 178%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 179%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
0cad051b 180BuildRequires: tar >= 1:1.22
0a424ee2 181BuildRequires: udev-devel
7d1152d4 182BuildRequires: usbutils
2303ed45 183BuildRequires: util-linux
c14cd342 184%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 185BuildRequires: which
f1b276d4 186BuildRequires: xorg-lib-libXScrnSaver-devel
3a3b7da9 187BuildRequires: xorg-lib-libXtst-devel
836b1cac 188BuildRequires: xz
a3140cd1 189%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 190%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 191Requires: browser-plugins >= 2.0
0cad051b 192Requires: desktop-file-utils
8f5f6775 193%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
194# crashes if no fontconfig font present
195Requires: fonts-Type1-urw
0eb19b0b 196Requires: hicolor-icon-theme
56403697 197Requires: libevent >= 2.0.21
c1edaafa 198%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 199%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
b809ab60 200Requires: lsb-release
b2c4ae39 201%{?with_system_re2:Requires: re2 >= 20130115-2}
3700ba38 202Requires: shared-mime-info
f7b16691 203%{?with_system_sqlite:Requires: sqlite3(icu)}
4dc49133 204Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 205Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 206Provides: wwwbrowser
c3582150 207Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 208Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 209ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 210BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 211
319f81f7
ER
212# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
213# Note: these are for PLD Linux use ONLY.
214# For your own distribution, please get your own set of keys.
215%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
216%define google_default_client_id 724288223830.apps.googleusercontent.com
217%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
218
7ebeabb6 219%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 220
e7fa0817
ER
221# Usage: gyp_with BCOND_NAME [OPTION_NAME]
222%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 223
6b113615
ER
224%if %{without debuginfo}
225%define _enable_debug_packages 0
226%endif
227
11ad81c4 228%description
80838854
ER
229Chromium is an open-source browser project that aims to build a safer,
230faster, and more stable way for all Internet users to experience the
231web.
232
233Chromium serves as a base for Google Chrome, which is Chromium
234rebranded (name and logo) with very few additions such as usage
235tracking and an auto-updater system.
236
f1b276d4
ER
237%package l10n
238Summary: chromium-browser language packages
239Group: I18n
240Requires: %{name} = %{version}-%{release}
8da7b90b
ER
241%if "%{_rpmversion}" >= "5"
242BuildArch: noarch
243%endif
f1b276d4
ER
244
245%description l10n
246Chromium is an open-source browser project that aims to build a safer,
247faster, and more stable way for all Internet users to experience the
248web.
249
250This package contains language packages for 50 languages:
251
e7fa0817
ER
252ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
253he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
254pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
255zh-TW
f1b276d4
ER
256
257%prep
3c73e180
ER
258%setup -qc
259%if "%{?patchver}" != ""
260cd %{name}-%{branch}.%{basever}
261%patch0 -p1
262cd ..
263%endif
75f96a39 264mv %{name}-%{branch}.%{basever}/* .
589d90ea 265
05f72ae2
ER
266# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
267# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 268. ./chrome/VERSION
e00e4177
ER
269chrome=$MAJOR.$MINOR.$BUILD.$PATCH
270test "$chrome" = %{version}
a3140cd1 271
75f96a39 272gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 273test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 274
e00e4177
ER
275. ./v8.sh
276v8=$MAJOR_VERSION.$MINOR_VERSION.$BUILD_NUMBER.$PATCH_LEVEL
33b04c7d 277
4765ddf1
ER
278# add chromium and pld to useragent
279%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
280sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
281 -e 's/@BUILD_DIST_NAME@/PLD/g' \
282 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 283 < %{PATCH8} | %{__patch} -p1
4765ddf1 284
8da7b90b 285%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
286ln -s %{SOURCE7} .
287
fb336f24 288%patch1 -p1
75f96a39 289%patch4 -p3
7879021e
ER
290%patch7 -p1
291%patch10 -p1
75f96a39 292%patch15 -p2
f4a8da6a 293%{!?with_libjpegturbo:%patch11 -p0}
108c5f7c 294%patch12 -p1
5997e180 295%patch16 -p1
41d6a4b1 296%patch28 -p1
75f96a39 297%patch25 -p2
3aa67e11 298%{?with_nacl:%patch18 -p1}
75f96a39
ER
299%patch24 -p2
300%patch26 -p2
fb336f24 301%patch29 -p0
e0a7fe40 302%patch30 -p0
e9abb380 303
75a27c2e
ER
304sh -x clean-source.sh \
305 %{!?with_nacl:nacl=0} \
bbdce24d
ER
306 %{!?with_system_libvpx:libvpx=0} \
307 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 308 %{!?with_system_mesa:mesa=0} \
75a27c2e 309 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 310 %{!?with_system_re2:re2=0} \
7e634b46 311 %{!?with_system_snappy:snappy=0} \
5048b37a 312 %{!?with_system_sqlite:sqlite=0} \
75a27c2e
ER
313 %{!?with_system_v8:v8=0} \
314 %{!?with_system_zlib:zlib=0} \
315 %{nil}
fded59be 316
e266589e 317%build
5997e180 318%if %{with nacl}
108c5f7c 319rm -rf native_client/toolchain/linux_x86_newlib
fded59be 320if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 321# Make symlinks for NaCL
108c5f7c 322install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 323
108c5f7c
ER
324cd native_client/toolchain/linux_x86_newlib
325ln -s x86_64-nacl/bin bin
326cd x86_64-nacl/bin
2e4113fd 327__cc='%{__cc}'
f64e73f6 328if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
329 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
330 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
331 %{__sed} -i -e '1i#!/bin/sh' gcc g++
332 chmod +x gcc g++
333else
334 ln -s %{_bindir}/x86_64-nacl-gcc gcc
335 ln -s %{_bindir}/x86_64-nacl-g++ g++
336fi
108c5f7c
ER
337ln -s gcc x86_64-nacl-gcc
338ln -s g++ x86_64-nacl-g++
339ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
340ln -s %{_bindir}/x86_64-nacl-ar ar
341ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 342ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 343ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 344ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 345ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 346ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
347ln -s %{_prefix}/x86_64-nacl/lib ../lib
348ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
349ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
350cd ../../../../..
fded59be 351fi
5997e180
ER
352%endif
353
7879021e 354flags="
f1b276d4
ER
355%ifarch %{ix86}
356 -Dtarget_arch=ia32 \
357%endif
358%ifarch %{x8664}
0c480b89
ER
359 -Dtarget_arch=x64 \
360%endif
7b454a31
AM
361%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
362 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
363%endif
364%if %{with sandboxing}
365 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
366 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
367%endif
368 %{!?debug:-Dwerror=} \
c980b122 369 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 370 %{?with_shared_libs:-Dlibrary=shared_library} \
9da385b7 371 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
b5a3dda3 372 -Dinclude_tests=0 \
c0808220 373%if %{with nacl}
038f76b9 374 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
375 -Ddisable_glibc_untar=1 \
376 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
377 -Ddisable_glibc=1 \
378 -Ddisable_pnacl=1 \
379 -Dbuild_pnacl_newlib=0 \
c0808220 380%else
8fb1dc98 381 -Ddisable_pnacl_untar=1 \
c0808220
ER
382 -Ddisable_nacl=1 \
383%endif
a3140cd1
ER
384 %{!?with_sse2:-Ddisable_sse2=1} \
385 %{?with_selinux:-Dselinux=1} \
7d1152d4 386 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 387 -Dlinux_link_libpci=1 \
7879021e 388 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
05998197 389 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
71d49434 390 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
05998197
ER
391 -Dlinux_use_gold_binary=0 \
392 -Dlinux_use_gold_flags=0 \
71581184 393 -Dlogging_like_official_build=1 \
319f81f7
ER
394 -Dgoogle_api_key=%{google_api_key} \
395 -Dgoogle_default_client_id=%{google_default_client_id} \
396 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 397 %{gyp_with cups} \
8dda6bbc 398 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 399 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
400 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
401 %{gyp_with pulseaudio} \
41d6a4b1 402 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 403 %{gyp_with system_flac} \
01b4dc8e 404 %{gyp_with system_harfbuzz} \
2d65d095 405 %{gyp_with system_jsoncpp} \
62950103
ER
406 %{gyp_with system_libexif} \
407 %{gyp_with system_libmtp} \
9bd2659c 408 %{gyp_with system_libsrtp} \
581aec44 409 %{gyp_with system_libusb} \
41d6a4b1 410 %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
ba685303 411 %{gyp_with system_libwebp} \
4884fc99 412 %{gyp_with system_libxnvctrl} \
7b8f219a 413 %{gyp_with system_mesa} \
126ea630 414 %{gyp_with system_minizip} \
62950103 415 %{gyp_with system_opus} \
75a27c2e 416 %{gyp_with system_protobuf} \
bbdce24d 417 %{gyp_with system_re2} \
7e634b46 418 %{gyp_with system_snappy} \
e7fa0817 419 %{gyp_with system_speex} \
914ee37c 420 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
421 %{gyp_with system_v8} \
422 %{gyp_with system_yasm} \
423 %{gyp_with system_zlib} \
0c480b89 424 -Duse_system_bzip2=1 \
62950103 425 -Duse_system_expat=1 \
0b214002 426 -Duse_system_icu=1 \
f1b276d4 427 -Duse_system_libevent=1 \
0c480b89 428 -Duse_system_libjpeg=1 \
f1b276d4
ER
429 -Duse_system_libpng=1 \
430 -Duse_system_libxml=1 \
431 -Duse_system_libxslt=1 \
b363f856 432 -Duse_system_nspr=1 \
7f40f3f4 433 -Duse_system_xdg_utils=1 \
7879021e
ER
434"
435
436build/linux/unbundle/replace_gyp_files.py $flags
437
438test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
439test -e Makefile || \
440 CC="%{__cc}" \
441 CXX="%{__cxx}" \
442 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
443 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
444 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
445 CC_host="%{__cc}" \
446 CXX_host="%{__cxx}" \
447 LD_host="%{__cxx}" \
448%{__python} build/gyp_chromium \
449 --format=make \
450 --depth=. \
451 build/all.gyp \
452 $flags
11ad81c4 453
b4d75247 454# need {CC/CXX/LDFLAGS}.host overrides for v8 build
48ffbc5e 455%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
456 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
457 %{?with_verbose:V=1} \
f1b276d4
ER
458 CC.host="%{__cc}" \
459 CXX.host="%{__cxx}" \
b4d75247 460 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
11ad81c4 461
75f96a39 462cd out/%{!?debug:Release}%{?debug:Debug}
535cb410
ER
463MANWIDTH=80 man ./chrome.1 > man.out
464%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
465
11ad81c4
AM
466%install
467rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
468install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
469 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
37ceaf05 470 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 471
673aee14 472cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 473cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 474install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
475%{__sed} -i -e '
476 s,@libdir@,%{_libdir}/%{name},
477
478 /@OPTIONS@/ {
479 r options.txt
480 d
481 }
482' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b
ER
483cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
484cp -a *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
485ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
486ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 487cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 488install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 489install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
fcc48c19 490%if %{without system_ffmpeg}
f1b276d4 491install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 492%endif
e7fa0817 493cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 494cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 495
8da7b90b 496%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 497
164020eb
ER
498%if %{with nacl}
499# Install Native Client files on platforms that support it.
500install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
501install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
502%ifarch %{x8664}
503install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
504%endif
505%ifarch %{ix86}
506install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
507%endif
508%endif
509
0c480b89
ER
510cd -
511
75f96a39 512for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
513 size=${icon##*/product_logo_}
514 size=${size%.png}
515
516 # this will skip non-numeric (22_mono_invert, 22_mono)
517 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
518 test -d "$dir" || continue
519
520 install -d $RPM_BUILD_ROOT$dir
521 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
522done
7f40f3f4 523
13840bc2
AM
524%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
525# http://code.google.com/p/chromium/issues/detail?id=24507
526gecko-mediaplayer*.so
527EOF
11ad81c4 528
589d90ea
ER
529# find locales
530%find_lang %{name}.lang
e7fa0817 531# always package en-US
f1b276d4 532%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 533
11ad81c4
AM
534%clean
535rm -rf $RPM_BUILD_ROOT
536
8da7b90b
ER
537%pretrans
538for d in locales resources; do
539 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
540 install -d %{_datadir}/%{name}
541 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
542 fi
543done
544exit 0
545
f1b276d4 546%post
0eb19b0b 547%update_icon_cache hicolor
b7a6e4ee 548%update_desktop_database
f1b276d4
ER
549%update_browser_plugins
550
551%postun
552if [ "$1" = 0 ]; then
0eb19b0b 553 %update_icon_cache hicolor
f1b276d4
ER
554 %update_browser_plugins
555fi
556
1d2b9616 557%files
11ad81c4 558%defattr(644,root,root,755)
75f96a39 559%doc AUTHORS LICENSE
f1b276d4
ER
560%{_browserpluginsconfdir}/browsers.d/%{name}.*
561%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
562%dir %{_sysconfdir}/%{name}
563%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 564%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
565%attr(755,root,root) %{_bindir}/%{name}
566%{_mandir}/man1/%{name}.1*
11ad81c4 567%{_desktopdir}/*.desktop
0eb19b0b 568%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 569%dir %{_libdir}/%{name}
e9abb380 570%{_libdir}/%{name}/chrome*.pak
c14cd342 571%{_libdir}/%{name}/content_resources.pak
97fac491 572%{_libdir}/%{name}/resources.pak
8da7b90b
ER
573%{_libdir}/%{name}/locales
574%{_libdir}/%{name}/resources
575
576%dir %{_datadir}/%{name}
577%dir %{_datadir}/%{name}/locales
578%{_datadir}/%{name}/locales/en-US.pak
579%dir %{_datadir}/%{name}/resources
580%{_datadir}/%{name}/resources/inspector
581
f1b276d4
ER
582%dir %{_libdir}/%{name}/plugins
583%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 584# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 585%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
586
587# ffmpeg libs
fcc48c19 588%if %{without system_ffmpeg}
f1b276d4 589%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 590%endif
f1b276d4 591
164020eb
ER
592%if %{with nacl}
593%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
594%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
595%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
596%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
597%endif
598
f1b276d4
ER
599%files l10n -f %{name}.lang
600%defattr(644,root,root,755)
This page took 0.202434 seconds and 4 git commands to generate.