]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
up to 34.0.1847.116
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
75f96a39 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 8%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
3aa67e11 10%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
41a57b3c 11%bcond_with ninja # use Ninja instead of make to build
ba685303 12%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
13%bcond_without sandboxing # with sandboxing
14%bcond_with selinux # with SELinux (need policy first)
15%bcond_with shared_libs # with shared libs
16%bcond_with sse2 # use SSE2 instructions
ba685303 17%bcond_without system_flac # system flac
a323900c 18%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 19%bcond_without system_harfbuzz # system harfbuzz
ba685303 20%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
21%bcond_without system_libexif # system libexif
22%bcond_without system_libmtp # system libmtp
3934d767 23%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
88171dca 24%bcond_without system_libwebp # system libwebp
4884fc99 25%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 26%bcond_with system_mesa # system Mesa
126ea630 27%bcond_without system_minizip # system minizip
62950103 28%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 29%bcond_without system_protobuf # system protobuf
543e99ac 30%bcond_without system_re2 # system re2
7e634b46 31%bcond_without system_snappy # system snappy
ba685303 32%bcond_without system_speex # system speex
a8f4f3ac 33%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 34%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 35%bcond_with system_v8 # system v8
4b411ffe 36%bcond_without system_libvpx # system libvpx
ba685303 37%bcond_without system_yasm # system yasm
1c00315b 38%bcond_without system_zlib # system zlib
d2781a31 39%bcond_without tcmalloc # use tcmalloc
7e136323 40%bcond_without verbose # verbose build (V=1)
0c480b89 41
b3fc6cb2
ER
42%ifarch %{ix86}
43# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
44%undefine with_system_mesa
45%endif
46
6d92f81c 47# TODO
b363f856 48# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 49# - use_system_skia
a3140cd1 50# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 51# - use_system_stlport (android specific)
7b8f219a 52# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 53
e53ecfb5 54# NOTES:
4fe038cb
ER
55# - mute BEEP mixer if you do not want to hear horrible system bell when
56# pressing home/end in url bar or more ^F search results on page.
7c638678 57# - space considerations:
0bb93ab2 58# - unpacked sources: ~490MiB
c1ecd31f 59# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 60# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 61# - to look for new tarball, use update-source.sh script
f1b276d4 62
c6a6fa95
ER
63%define branch 34.0.1847
64%define basever 116
65#define patchver 152
a3140cd1 66%define gyp_rev 1014
11ad81c4 67Summary: A WebKit powered web browser
05f72ae2 68Name: chromium-browser
f73369da
ER
69%if "%{?patchver}" != ""
70Version: %{branch}.%{patchver}
71%else
72Version: %{branch}.%{basever}
73%endif
537abf9b 74Release: 1
5bb99ef4 75License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 76Group: X11/Applications/Networking
f177fdad 77Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
c6a6fa95 78# Source0-md5: bd73f999cd1716deafd19c41b13c318c
3c73e180
ER
79%if "%{?patchver}" != ""
80Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
44c11196 81# Patch0-md5: 194579901c234fbce9e1538e7956d36c
3c73e180 82%endif
37ceaf05 83Source1: %{name}.default
8b53130d
ER
84Source2: %{name}.sh
85Source3: %{name}.desktop
56c6e811
ER
86Source5: find-lang.sh
87Source6: update-source.sh
88Source7: clean-source.sh
836b1cac 89Source8: get-source.sh
0562b864 90Source9: master_preferences.json
48b341f5 91Patch1: plugin-searchdirs.patch
627e6027 92Patch2: enable-video-decode-accel.patch
72cb20c1 93Patch4: path-libpdf.patch
5aa5df39 94Patch7: dlopen_sonamed_gl.patch
4765ddf1 95Patch8: chromium_useragent.patch.in
8456d676 96Patch10: system-libxnvctrl.patch
1347c76c
AM
97# https://bugs.gentoo.org/show_bug.cgi?id=393471
98# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 99Patch11: chromium-revert-jpeg-swizzle-r2.patch
108c5f7c 100Patch12: system-ffmpeg.patch
5997e180
ER
101Patch15: nacl-build-irt.patch
102Patch16: nacl-linkingfix.patch
9516ca97 103Patch18: nacl-no-untar.patch
6897926c 104Patch24: nacl-verbose.patch
c5b396f3
ER
105Patch25: gnome3-volume-control.patch
106Patch26: master-prefs-path.patch
25d4e23c 107Patch28: system-mesa.patch
e0a7fe40 108Patch30: system-ply.patch
9cce36cb 109Patch31: system-jinja.patch
708e64c2 110Patch32: remove_bundled_libraries-stale.patch
a323900c 111Patch33: gn.patch
750b48f7 112URL: http://www.chromium.org/Home
ae3fe89f 113%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3 114%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
3a3b7da9 115BuildRequires: Mesa-libGLES-devel >= 9.1
7b8f219a 116%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 117%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
118BuildRequires: alsa-lib-devel
119BuildRequires: atk-devel
120BuildRequires: bison
11ad81c4 121BuildRequires: bzip2-devel
5997e180
ER
122%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
123%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
124%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 125%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 126%{?with_cups:BuildRequires: cups-devel}
92965b0e 127BuildRequires: elfutils-devel
77f32fa3 128BuildRequires: expat-devel
7d0dbc8d 129%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 130%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 131BuildRequires: fontconfig-devel
f1b276d4 132BuildRequires: glib2-devel
05f72ae2 133BuildRequires: gperf
71d49434 134%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 135BuildRequires: gtest-devel
8b53130d 136BuildRequires: gtk+2-devel
01b4dc8e 137%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 138%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 139%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 140BuildRequires: hicolor-icon-theme
ed514974 141%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 142%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 143BuildRequires: libevent-devel
8456d676 144%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 145%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 146BuildRequires: libicu-devel >= 4.6
39c71b4c 147%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 148%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 149%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 150BuildRequires: libpng-devel
e266589e 151%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 152BuildRequires: libstdc++-devel
ba685303 153%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
88171dca
ER
154%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.3.0}
155%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
f1b276d4 156BuildRequires: libxml2-devel
11ad81c4 157BuildRequires: libxslt-devel
535cb410 158BuildRequires: man-db
62950103 159%{?with_system_minizip:BuildRequires: minizip-devel}
f8597c6e 160%{?with_ninja:BuildRequires: ninja >= 1.3.0}
05f72ae2 161BuildRequires: nspr-devel
f1b276d4 162BuildRequires: nss-devel >= 1:3.12.3
8456d676 163%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 164BuildRequires: pam-devel
f1b276d4 165BuildRequires: pango-devel
ef121064 166BuildRequires: pciutils-devel
3a3b7da9 167BuildRequires: perl-JSON
48b341f5 168BuildRequires: perl-modules
169BuildRequires: pkgconfig
75a27c2e 170%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 171%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 172BuildRequires: python
46cdefee 173#BuildRequires: python-gyp >= 1-%{gyp_rev}
9cce36cb 174BuildRequires: python-jinja2 >= 2.7
48b341f5 175BuildRequires: python-modules
e0a7fe40 176BuildRequires: python-ply >= 3.4
543e99ac 177%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 178BuildRequires: rpm >= 4.4.9-56
f1b276d4 179BuildRequires: rpmbuild(macros) >= 1.453
f099161f 180%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 181BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 182%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 183%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 184%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
0cad051b 185BuildRequires: tar >= 1:1.22
0a424ee2 186BuildRequires: udev-devel
7d1152d4 187BuildRequires: usbutils
2303ed45 188BuildRequires: util-linux
c14cd342 189%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 190BuildRequires: which
f1b276d4 191BuildRequires: xorg-lib-libXScrnSaver-devel
3a3b7da9 192BuildRequires: xorg-lib-libXtst-devel
836b1cac 193BuildRequires: xz
a3140cd1 194%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 195%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 196Requires: browser-plugins >= 2.0
0cad051b 197Requires: desktop-file-utils
8f5f6775 198%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
199# crashes if no fontconfig font present
200Requires: fonts-Type1-urw
0eb19b0b 201Requires: hicolor-icon-theme
56403697 202Requires: libevent >= 2.0.21
c1edaafa 203%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
88171dca 204%{?with_system_libvpx:Requires: libvpx >= 1.3.0}
b809ab60 205Requires: lsb-release
b2c4ae39 206%{?with_system_re2:Requires: re2 >= 20130115-2}
3700ba38 207Requires: shared-mime-info
f7b16691 208%{?with_system_sqlite:Requires: sqlite3(icu)}
4dc49133 209Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 210Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 211Provides: wwwbrowser
c3582150 212Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 213Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 214ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 215BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 216
319f81f7
ER
217# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
218# Note: these are for PLD Linux use ONLY.
219# For your own distribution, please get your own set of keys.
220%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
221%define google_default_client_id 724288223830.apps.googleusercontent.com
222%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
223
7ebeabb6 224%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 225
e7fa0817
ER
226# Usage: gyp_with BCOND_NAME [OPTION_NAME]
227%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 228
a323900c
ER
229%ifarch %{ix86}
230%define target_arch ia32
231%endif
232%ifarch %{x8664}
233%define target_arch x64
234%endif
235
f8597c6e
ER
236%define buildtype %{?debug:Debug}%{!?debug:Release}
237%define builddir out/%{buildtype}
238
6b113615
ER
239%if %{without debuginfo}
240%define _enable_debug_packages 0
241%endif
242
11ad81c4 243%description
80838854
ER
244Chromium is an open-source browser project that aims to build a safer,
245faster, and more stable way for all Internet users to experience the
246web.
247
248Chromium serves as a base for Google Chrome, which is Chromium
249rebranded (name and logo) with very few additions such as usage
250tracking and an auto-updater system.
251
f1b276d4
ER
252%package l10n
253Summary: chromium-browser language packages
254Group: I18n
255Requires: %{name} = %{version}-%{release}
8da7b90b
ER
256%if "%{_rpmversion}" >= "5"
257BuildArch: noarch
258%endif
f1b276d4
ER
259
260%description l10n
261Chromium is an open-source browser project that aims to build a safer,
262faster, and more stable way for all Internet users to experience the
263web.
264
265This package contains language packages for 50 languages:
266
e7fa0817
ER
267ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
268he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
269pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
270zh-TW
f1b276d4
ER
271
272%prep
3c73e180
ER
273%setup -qc
274%if "%{?patchver}" != ""
275cd %{name}-%{branch}.%{basever}
276%patch0 -p1
277cd ..
278%endif
75f96a39 279mv %{name}-%{branch}.%{basever}/* .
589d90ea 280
05f72ae2
ER
281# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
282# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 283. ./chrome/VERSION
e00e4177
ER
284chrome=$MAJOR.$MINOR.$BUILD.$PATCH
285test "$chrome" = %{version}
a3140cd1 286
75f96a39 287gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 288test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 289
e00e4177
ER
290. ./v8.sh
291v8=$MAJOR_VERSION.$MINOR_VERSION.$BUILD_NUMBER.$PATCH_LEVEL
33b04c7d 292
4765ddf1
ER
293# add chromium and pld to useragent
294%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
295sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
296 -e 's/@BUILD_DIST_NAME@/PLD/g' \
297 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 298 < %{PATCH8} | %{__patch} -p1
4765ddf1 299
8da7b90b 300%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
301ln -s %{SOURCE7} .
302
fb336f24 303%patch1 -p1
12dc0aee 304#%patch2 -p1 NOT COMPILING
75f96a39 305%patch4 -p3
7879021e
ER
306%patch7 -p1
307%patch10 -p1
75f96a39 308%patch15 -p2
f4a8da6a 309%{!?with_libjpegturbo:%patch11 -p0}
108c5f7c 310%patch12 -p1
5997e180 311%patch16 -p1
41d6a4b1 312%patch28 -p1
a323900c 313%patch25 -p1
3aa67e11 314%{?with_nacl:%patch18 -p1}
75f96a39
ER
315%patch24 -p2
316%patch26 -p2
63c64837 317%patch30 -p1
9cce36cb 318%patch31 -p0
708e64c2 319%patch32 -p1
a323900c 320%patch33 -p0
e9abb380 321
75a27c2e
ER
322sh -x clean-source.sh \
323 %{!?with_nacl:nacl=0} \
bbdce24d
ER
324 %{!?with_system_libvpx:libvpx=0} \
325 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 326 %{!?with_system_mesa:mesa=0} \
75a27c2e 327 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 328 %{!?with_system_re2:re2=0} \
7e634b46 329 %{!?with_system_snappy:snappy=0} \
5048b37a 330 %{!?with_system_sqlite:sqlite=0} \
75a27c2e 331 %{!?with_system_v8:v8=0} \
0767a7a0 332 %{!?with_system_libwebp:libwebp=0} \
75a27c2e 333 %{!?with_system_zlib:zlib=0} \
f177fdad 334 %{!?with_system_ffmpeg:ffmpeg=0} \
75a27c2e 335 %{nil}
fded59be 336
e266589e 337%build
5997e180 338%if %{with nacl}
108c5f7c 339rm -rf native_client/toolchain/linux_x86_newlib
fded59be 340if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 341# Make symlinks for NaCL
108c5f7c 342install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 343
108c5f7c
ER
344cd native_client/toolchain/linux_x86_newlib
345ln -s x86_64-nacl/bin bin
346cd x86_64-nacl/bin
2e4113fd 347__cc='%{__cc}'
f64e73f6 348if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
349 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
350 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
351 %{__sed} -i -e '1i#!/bin/sh' gcc g++
352 chmod +x gcc g++
353else
354 ln -s %{_bindir}/x86_64-nacl-gcc gcc
355 ln -s %{_bindir}/x86_64-nacl-g++ g++
356fi
108c5f7c
ER
357ln -s gcc x86_64-nacl-gcc
358ln -s g++ x86_64-nacl-g++
359ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
360ln -s %{_bindir}/x86_64-nacl-ar ar
361ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 362ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 363ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 364ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 365ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 366ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
367ln -s %{_prefix}/x86_64-nacl/lib ../lib
368ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
369ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
370cd ../../../../..
fded59be 371fi
5997e180
ER
372%endif
373
a323900c 374%if %{without system_ffmpeg}
f8597c6e
ER
375if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
376 # Re-configure bundled ffmpeg
377 cd third_party/ffmpeg
378 chromium/scripts/build_ffmpeg.sh linux %{target_arch} "$PWD" config-only
379 chromium/scripts/copy_config.sh
380 cd -
381fi
0c480b89 382%endif
a323900c
ER
383
384flags="
385 -Dtarget_arch=%{target_arch} \
386 -Dpython_arch=%{target_arch} \
b91ce587 387 -Dsystem_libdir=%{_lib} \
a323900c 388 -Dpython_ver=%{py_ver} \
7b454a31
AM
389%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
390 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
391%endif
392 %{!?debug:-Dwerror=} \
c980b122 393 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 394 %{?with_shared_libs:-Dlibrary=shared_library} \
9da385b7 395 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
b5a3dda3 396 -Dinclude_tests=0 \
c0808220 397%if %{with nacl}
038f76b9 398 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
399 -Ddisable_glibc_untar=1 \
400 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
401 -Ddisable_glibc=1 \
402 -Ddisable_pnacl=1 \
403 -Dbuild_pnacl_newlib=0 \
c0808220 404%else
8fb1dc98 405 -Ddisable_pnacl_untar=1 \
c0808220
ER
406 -Ddisable_nacl=1 \
407%endif
a3140cd1
ER
408 %{!?with_sse2:-Ddisable_sse2=1} \
409 %{?with_selinux:-Dselinux=1} \
7d1152d4 410 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 411 -Dlinux_link_libpci=1 \
7879021e 412 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
05998197 413 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
71d49434 414 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
05998197
ER
415 -Dlinux_use_gold_binary=0 \
416 -Dlinux_use_gold_flags=0 \
71581184 417 -Dlogging_like_official_build=1 \
319f81f7
ER
418 -Dgoogle_api_key=%{google_api_key} \
419 -Dgoogle_default_client_id=%{google_default_client_id} \
420 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 421 %{gyp_with cups} \
8dda6bbc 422 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 423 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
424 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
425 %{gyp_with pulseaudio} \
41d6a4b1 426 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 427 %{gyp_with system_flac} \
01b4dc8e 428 %{gyp_with system_harfbuzz} \
2d65d095 429 %{gyp_with system_jsoncpp} \
62950103
ER
430 %{gyp_with system_libexif} \
431 %{gyp_with system_libmtp} \
9bd2659c 432 %{gyp_with system_libsrtp} \
581aec44 433 %{gyp_with system_libusb} \
88171dca 434 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
ba685303 435 %{gyp_with system_libwebp} \
4884fc99 436 %{gyp_with system_libxnvctrl} \
7b8f219a 437 %{gyp_with system_mesa} \
126ea630 438 %{gyp_with system_minizip} \
62950103 439 %{gyp_with system_opus} \
75a27c2e 440 %{gyp_with system_protobuf} \
bbdce24d 441 %{gyp_with system_re2} \
7e634b46 442 %{gyp_with system_snappy} \
e7fa0817 443 %{gyp_with system_speex} \
914ee37c 444 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
445 %{gyp_with system_v8} \
446 %{gyp_with system_yasm} \
447 %{gyp_with system_zlib} \
0c480b89 448 -Duse_system_bzip2=1 \
62950103 449 -Duse_system_expat=1 \
0b214002 450 -Duse_system_icu=1 \
f1b276d4 451 -Duse_system_libevent=1 \
0c480b89 452 -Duse_system_libjpeg=1 \
f1b276d4
ER
453 -Duse_system_libpng=1 \
454 -Duse_system_libxml=1 \
455 -Duse_system_libxslt=1 \
b363f856 456 -Duse_system_nspr=1 \
7f40f3f4 457 -Duse_system_xdg_utils=1 \
7879021e
ER
458"
459
460build/linux/unbundle/replace_gyp_files.py $flags
461
f8597c6e
ER
462%if %{with ninja}
463chkfile=%{builddir}/build.ninja
464%else
465chkfile=Makefile
466%endif
467test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
468test -e $chkfile || \
7879021e
ER
469 CC="%{__cc}" \
470 CXX="%{__cxx}" \
471 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
472 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
473 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
474 CC_host="%{__cc}" \
475 CXX_host="%{__cxx}" \
476 LD_host="%{__cxx}" \
477%{__python} build/gyp_chromium \
f8597c6e 478 --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
7879021e
ER
479 --depth=. \
480 build/all.gyp \
481 $flags
11ad81c4 482
f8597c6e
ER
483%if %{with ninja}
484ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
485%else
b4d75247 486# need {CC/CXX/LDFLAGS}.host overrides for v8 build
f8597c6e
ER
487%{__make} -r \
488 BUILDTYPE=%{buildtype} \
f1b276d4 489 %{?with_verbose:V=1} \
f1b276d4
ER
490 CC.host="%{__cc}" \
491 CXX.host="%{__cxx}" \
b4d75247 492 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
f8597c6e
ER
493%endif
494 chrome %{?with_sandboxing:chrome_sandbox} \
495 %{nil}
11ad81c4 496
f8597c6e 497cd %{builddir}
535cb410
ER
498MANWIDTH=80 man ./chrome.1 > man.out
499%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
500
11ad81c4
AM
501%install
502rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
503install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
504 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
37ceaf05 505 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 506
f8597c6e 507cd %{builddir}
37ceaf05 508cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 509install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
510%{__sed} -i -e '
511 s,@libdir@,%{_libdir}/%{name},
512
513 /@OPTIONS@/ {
514 r options.txt
515 d
516 }
517' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b
ER
518cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
519cp -a *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
520ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
521ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 522cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 523install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
d1a83042 524install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
fcc48c19 525%if %{without system_ffmpeg}
f1b276d4 526install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 527%endif
e7fa0817 528cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 529cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 530
8da7b90b 531%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 532
164020eb
ER
533%if %{with nacl}
534# Install Native Client files on platforms that support it.
535install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
536install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
537%ifarch %{x8664}
538install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
539%endif
540%ifarch %{ix86}
541install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
542%endif
543%endif
544
0c480b89
ER
545cd -
546
75f96a39 547for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
548 size=${icon##*/product_logo_}
549 size=${size%.png}
550
551 # this will skip non-numeric (22_mono_invert, 22_mono)
552 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
553 test -d "$dir" || continue
554
555 install -d $RPM_BUILD_ROOT$dir
556 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
557done
7f40f3f4 558
13840bc2
AM
559%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
560# http://code.google.com/p/chromium/issues/detail?id=24507
561gecko-mediaplayer*.so
562EOF
11ad81c4 563
589d90ea
ER
564# find locales
565%find_lang %{name}.lang
e7fa0817 566# always package en-US
f1b276d4 567%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 568
11ad81c4
AM
569%clean
570rm -rf $RPM_BUILD_ROOT
571
8da7b90b
ER
572%pretrans
573for d in locales resources; do
574 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
575 install -d %{_datadir}/%{name}
576 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
577 fi
578done
579exit 0
580
f1b276d4 581%post
0eb19b0b 582%update_icon_cache hicolor
b7a6e4ee 583%update_desktop_database
f1b276d4
ER
584%update_browser_plugins
585
586%postun
587if [ "$1" = 0 ]; then
0eb19b0b 588 %update_icon_cache hicolor
f1b276d4
ER
589 %update_browser_plugins
590fi
591
1d2b9616 592%files
11ad81c4 593%defattr(644,root,root,755)
75f96a39 594%doc AUTHORS LICENSE
f1b276d4
ER
595%{_browserpluginsconfdir}/browsers.d/%{name}.*
596%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
597%dir %{_sysconfdir}/%{name}
598%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 599%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
600%attr(755,root,root) %{_bindir}/%{name}
601%{_mandir}/man1/%{name}.1*
11ad81c4 602%{_desktopdir}/*.desktop
0eb19b0b 603%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 604%dir %{_libdir}/%{name}
e9abb380 605%{_libdir}/%{name}/chrome*.pak
c14cd342 606%{_libdir}/%{name}/content_resources.pak
97fac491 607%{_libdir}/%{name}/resources.pak
8da7b90b
ER
608%{_libdir}/%{name}/locales
609%{_libdir}/%{name}/resources
610
611%dir %{_datadir}/%{name}
612%dir %{_datadir}/%{name}/locales
613%{_datadir}/%{name}/locales/en-US.pak
614%dir %{_datadir}/%{name}/resources
615%{_datadir}/%{name}/resources/inspector
616
f1b276d4
ER
617%dir %{_libdir}/%{name}/plugins
618%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 619# These unique permissions are intentional and necessary for the sandboxing
d1a83042 620%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
f1b276d4
ER
621
622# ffmpeg libs
fcc48c19 623%if %{without system_ffmpeg}
f1b276d4 624%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 625%endif
f1b276d4 626
164020eb
ER
627%if %{with nacl}
628%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
629%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
630%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
631%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
632%endif
633
f1b276d4
ER
634%files l10n -f %{name}.lang
635%defattr(644,root,root,755)
This page took 0.223117 seconds and 4 git commands to generate.