]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
synced remove_bundled_libraries with gentoo ebuild
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
f684992e 5%bcond_with dev # with dev optimizations (skip clean source)
ba685303 6%bcond_without gconf # with GConf
75f96a39 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 9%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 10%bcond_without libjpegturbo # use libjpeg-turbo features
3aa67e11 11%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
db3fa756 12%bcond_without ninja # use Ninja instead of make to build
ba685303 13%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
14%bcond_without sandboxing # with sandboxing
15%bcond_with selinux # with SELinux (need policy first)
16%bcond_with shared_libs # with shared libs
17%bcond_with sse2 # use SSE2 instructions
ba685303 18%bcond_without system_flac # system flac
a323900c 19%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 20%bcond_without system_harfbuzz # system harfbuzz
cb6dde87 21%bcond_without system_icu # system icu
ba685303 22%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
23%bcond_without system_libexif # system libexif
24%bcond_without system_libmtp # system libmtp
3934d767 25%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
88171dca 26%bcond_without system_libwebp # system libwebp
4884fc99 27%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 28%bcond_with system_mesa # system Mesa
126ea630 29%bcond_without system_minizip # system minizip
62950103 30%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
e7b1e97c
ER
31# protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
32%bcond_with system_protobuf # system protobuf
543e99ac 33%bcond_without system_re2 # system re2
7e634b46 34%bcond_without system_snappy # system snappy
ba685303 35%bcond_without system_speex # system speex
a8f4f3ac 36%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 37%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 38%bcond_with system_v8 # system v8
f047b07c 39%bcond_with system_libvpx # system libvpx
ba685303 40%bcond_without system_yasm # system yasm
1c00315b 41%bcond_without system_zlib # system zlib
14c8ce0e 42%bcond_with tcmalloc # use tcmalloc
7e136323 43%bcond_without verbose # verbose build (V=1)
0c480b89 44
b3fc6cb2
ER
45%ifarch %{ix86}
46# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
47%undefine with_system_mesa
5e3c5baa
ER
48
49# unable build with debuginfo on 32bit build systems
313715ac
ER
50# /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
51%undefine with_debuginfo
52%endif
53
54%ifarch %{x8664}
55# x86_64 systems fail with debugedit crashing
56# /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
5e3c5baa 57%undefine with_debuginfo
b3fc6cb2
ER
58%endif
59
6d92f81c 60# TODO
b363f856 61# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 62# - use_system_skia
a3140cd1 63# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 64# - use_system_stlport (android specific)
7b8f219a 65# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 66
e53ecfb5 67# NOTES:
4fe038cb
ER
68# - mute BEEP mixer if you do not want to hear horrible system bell when
69# pressing home/end in url bar or more ^F search results on page.
7c638678 70# - space considerations:
0bb93ab2 71# - unpacked sources: ~490MiB
c1ecd31f 72# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 73# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 74# - to look for new tarball, use update-source.sh script
f1b276d4 75
284d4c06
ER
76%define branch 42.0.2311
77%define basever 82
78#define patchver 118
a3140cd1 79%define gyp_rev 1014
11ad81c4 80Summary: A WebKit powered web browser
05f72ae2 81Name: chromium-browser
f73369da
ER
82%if "%{?patchver}" != ""
83Version: %{branch}.%{patchver}
84%else
85Version: %{branch}.%{basever}
86%endif
284d4c06 87Release: 0.1
5bb99ef4 88License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 89Group: X11/Applications/Networking
284d4c06
ER
90Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
91# Source0-md5: 7bdbf015d663e082f5bbe4cf24907049
3c73e180
ER
92%if "%{?patchver}" != ""
93Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
063b4989 94# Patch0-md5: fc9cd6fd3392142db2ada6b98b89fa80
3c73e180 95%endif
37ceaf05 96Source1: %{name}.default
8b53130d
ER
97Source2: %{name}.sh
98Source3: %{name}.desktop
56c6e811
ER
99Source5: find-lang.sh
100Source6: update-source.sh
101Source7: clean-source.sh
836b1cac 102Source8: get-source.sh
0562b864 103Source9: master_preferences.json
a198be7c 104# https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
706f2712 105Patch2: enable-video-decode-accel.patch
5aa5df39 106Patch7: dlopen_sonamed_gl.patch
4765ddf1 107Patch8: chromium_useragent.patch.in
1347c76c
AM
108# https://bugs.gentoo.org/show_bug.cgi?id=393471
109# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 110Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
111Patch15: nacl-build-irt.patch
112Patch16: nacl-linkingfix.patch
9516ca97 113Patch18: nacl-no-untar.patch
6897926c 114Patch24: nacl-verbose.patch
c5b396f3
ER
115Patch25: gnome3-volume-control.patch
116Patch26: master-prefs-path.patch
25d4e23c 117Patch28: system-mesa.patch
9cce36cb 118Patch31: system-jinja.patch
708e64c2 119Patch32: remove_bundled_libraries-stale.patch
d7fca4aa 120Patch35: etc-dir.patch
6e3c39b4 121Patch36: angle.patch
a20f29ed 122Patch37: %{name}-build.patch
a198be7c 123Patch38: vaapi_include.patch
750b48f7 124URL: http://www.chromium.org/Home
ae3fe89f 125%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3 126%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
3a3b7da9 127BuildRequires: Mesa-libGLES-devel >= 9.1
7b8f219a 128%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 129%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
130BuildRequires: alsa-lib-devel
131BuildRequires: atk-devel
132BuildRequires: bison
11ad81c4 133BuildRequires: bzip2-devel
5997e180
ER
134%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
135%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
136%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 137%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 138%{?with_cups:BuildRequires: cups-devel}
92965b0e 139BuildRequires: elfutils-devel
77f32fa3 140BuildRequires: expat-devel
7d0dbc8d 141%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 142%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 143BuildRequires: fontconfig-devel
f1b276d4 144BuildRequires: glib2-devel
05f72ae2 145BuildRequires: gperf
71d49434 146%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 147BuildRequires: gtest-devel
8b53130d 148BuildRequires: gtk+2-devel
01b4dc8e 149%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 150%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 151%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 152BuildRequires: hicolor-icon-theme
ed514974 153%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 154%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 155BuildRequires: libevent-devel
8456d676 156%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 157%{?with_keyring:BuildRequires: libgnome-keyring-devel}
cb6dde87 158%{?with_system_icu:BuildRequires: libicu-devel >= 4.6}
39c71b4c 159%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 160%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 161%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 162BuildRequires: libpng-devel
e266589e 163%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 164BuildRequires: libstdc++-devel
ba685303 165%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
88171dca
ER
166%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.3.0}
167%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
f1b276d4 168BuildRequires: libxml2-devel
11ad81c4 169BuildRequires: libxslt-devel
535cb410 170BuildRequires: man-db
62950103 171%{?with_system_minizip:BuildRequires: minizip-devel}
f8597c6e 172%{?with_ninja:BuildRequires: ninja >= 1.3.0}
05f72ae2 173BuildRequires: nspr-devel
f1b276d4 174BuildRequires: nss-devel >= 1:3.12.3
8456d676 175%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 176BuildRequires: pam-devel
f1b276d4 177BuildRequires: pango-devel
ef121064 178BuildRequires: pciutils-devel
3a3b7da9 179BuildRequires: perl-JSON
48b341f5 180BuildRequires: perl-modules
181BuildRequires: pkgconfig
75a27c2e 182%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 183%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 184BuildRequires: python
e2f921c3 185BuildRequires: python-BeautifulSoup
46cdefee 186#BuildRequires: python-gyp >= 1-%{gyp_rev}
9cce36cb 187BuildRequires: python-jinja2 >= 2.7
48b341f5 188BuildRequires: python-modules
e0a7fe40 189BuildRequires: python-ply >= 3.4
543e99ac 190%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 191BuildRequires: rpm >= 4.4.9-56
f1b276d4 192BuildRequires: rpmbuild(macros) >= 1.453
f099161f 193%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 194BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 195%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 196%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 197%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
0cad051b 198BuildRequires: tar >= 1:1.22
0a424ee2 199BuildRequires: udev-devel
7d1152d4 200BuildRequires: usbutils
2303ed45 201BuildRequires: util-linux
c14cd342 202%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 203BuildRequires: which
f1b276d4 204BuildRequires: xorg-lib-libXScrnSaver-devel
3a3b7da9 205BuildRequires: xorg-lib-libXtst-devel
836b1cac 206BuildRequires: xz
a3140cd1 207%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 208%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 209Requires: browser-plugins >= 2.0
0cad051b 210Requires: desktop-file-utils
8f5f6775 211%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
212# crashes if no fontconfig font present
213Requires: fonts-Type1-urw
0eb19b0b 214Requires: hicolor-icon-theme
56403697 215Requires: libevent >= 2.0.21
c1edaafa 216%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
88171dca 217%{?with_system_libvpx:Requires: libvpx >= 1.3.0}
b809ab60 218Requires: lsb-release
b2c4ae39 219%{?with_system_re2:Requires: re2 >= 20130115-2}
4b2f9b57 220%{?with_system_protobuf:Requires: protobuf-libs >= 2.5.0-2}
3700ba38 221Requires: shared-mime-info
f7b16691 222%{?with_system_sqlite:Requires: sqlite3(icu)}
4dc49133 223Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 224Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 225Provides: wwwbrowser
c3582150 226Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 227Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 228ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 229BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 230
319f81f7
ER
231# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
232# Note: these are for PLD Linux use ONLY.
233# For your own distribution, please get your own set of keys.
234%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
235%define google_default_client_id 724288223830.apps.googleusercontent.com
236%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
237
7ebeabb6 238%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 239
e7fa0817
ER
240# Usage: gyp_with BCOND_NAME [OPTION_NAME]
241%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 242
a323900c
ER
243%ifarch %{ix86}
244%define target_arch ia32
245%endif
246%ifarch %{x8664}
247%define target_arch x64
248%endif
249
f8597c6e
ER
250%define buildtype %{?debug:Debug}%{!?debug:Release}
251%define builddir out/%{buildtype}
252
6b113615
ER
253%if %{without debuginfo}
254%define _enable_debug_packages 0
255%endif
256
11ad81c4 257%description
80838854
ER
258Chromium is an open-source browser project that aims to build a safer,
259faster, and more stable way for all Internet users to experience the
260web.
261
262Chromium serves as a base for Google Chrome, which is Chromium
263rebranded (name and logo) with very few additions such as usage
264tracking and an auto-updater system.
265
f1b276d4
ER
266%package l10n
267Summary: chromium-browser language packages
268Group: I18n
269Requires: %{name} = %{version}-%{release}
8da7b90b
ER
270%if "%{_rpmversion}" >= "5"
271BuildArch: noarch
272%endif
f1b276d4
ER
273
274%description l10n
275Chromium is an open-source browser project that aims to build a safer,
276faster, and more stable way for all Internet users to experience the
277web.
278
279This package contains language packages for 50 languages:
280
e7fa0817
ER
281ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
282he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
283pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
284zh-TW
f1b276d4
ER
285
286%prep
3c73e180
ER
287%setup -qc
288%if "%{?patchver}" != ""
77bd7e0a 289cd chromium*-%{branch}.%{basever}
3c73e180
ER
290%patch0 -p1
291cd ..
292%endif
77bd7e0a 293mv chromium*-%{branch}.%{basever}/* .
589d90ea 294
05f72ae2
ER
295# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
296# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 297. ./chrome/VERSION
e00e4177
ER
298chrome=$MAJOR.$MINOR.$BUILD.$PATCH
299test "$chrome" = %{version}
a3140cd1 300
75f96a39 301gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 302test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 303
4765ddf1
ER
304# add chromium and pld to useragent
305%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
306sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
307 -e 's/@BUILD_DIST_NAME@/PLD/g' \
308 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 309 < %{PATCH8} | %{__patch} -p1
4765ddf1 310
8da7b90b 311%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
312ln -s %{SOURCE7} .
313
810e0294 314#%patch2 -p1 CHECK
7879021e 315%patch7 -p1
75f96a39 316%patch15 -p2
f4a8da6a 317%{!?with_libjpegturbo:%patch11 -p0}
5997e180 318%patch16 -p1
41d6a4b1 319%patch28 -p1
a323900c 320%patch25 -p1
3aa67e11 321%{?with_nacl:%patch18 -p1}
ffb05754 322%patch24 -p1
75f96a39 323%patch26 -p2
cb6dde87 324%patch31 -p0
708e64c2 325%patch32 -p1
d7fca4aa 326%patch35 -p1
6e3c39b4 327%patch36 -p1
a20f29ed 328%patch37 -p1
810e0294 329#%patch38 -p1 CHECK
e9abb380 330
f684992e
ER
331%{?with_dev:exit 0}
332
75a27c2e
ER
333sh -x clean-source.sh \
334 %{!?with_nacl:nacl=0} \
bbdce24d
ER
335 %{!?with_system_libvpx:libvpx=0} \
336 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 337 %{!?with_system_mesa:mesa=0} \
75a27c2e 338 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 339 %{!?with_system_re2:re2=0} \
7e634b46 340 %{!?with_system_snappy:snappy=0} \
5048b37a 341 %{!?with_system_sqlite:sqlite=0} \
75a27c2e 342 %{!?with_system_v8:v8=0} \
0767a7a0 343 %{!?with_system_libwebp:libwebp=0} \
75a27c2e 344 %{!?with_system_zlib:zlib=0} \
f177fdad 345 %{!?with_system_ffmpeg:ffmpeg=0} \
75a27c2e 346 %{nil}
fded59be 347
e266589e 348%build
5997e180 349%if %{with nacl}
108c5f7c 350rm -rf native_client/toolchain/linux_x86_newlib
fded59be 351if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 352# Make symlinks for NaCL
108c5f7c 353install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 354
108c5f7c
ER
355cd native_client/toolchain/linux_x86_newlib
356ln -s x86_64-nacl/bin bin
357cd x86_64-nacl/bin
2e4113fd 358__cc='%{__cc}'
f64e73f6 359if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
360 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
361 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
362 %{__sed} -i -e '1i#!/bin/sh' gcc g++
363 chmod +x gcc g++
364else
365 ln -s %{_bindir}/x86_64-nacl-gcc gcc
366 ln -s %{_bindir}/x86_64-nacl-g++ g++
367fi
108c5f7c
ER
368ln -s gcc x86_64-nacl-gcc
369ln -s g++ x86_64-nacl-g++
370ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
371ln -s %{_bindir}/x86_64-nacl-ar ar
372ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 373ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 374ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 375ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 376ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 377ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
378ln -s %{_prefix}/x86_64-nacl/lib ../lib
379ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
380ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
381cd ../../../../..
fded59be 382fi
5997e180
ER
383%endif
384
a323900c 385%if %{without system_ffmpeg}
f8597c6e
ER
386if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
387 # Re-configure bundled ffmpeg
388 cd third_party/ffmpeg
50d701c6
ER
389 chromium/scripts/build_ffmpeg.py linux %{target_arch} \
390 --branding Chromium
f8597c6e 391 chromium/scripts/copy_config.sh
6e3c39b4 392 chromium/scripts/generate_gyp.py
f8597c6e
ER
393 cd -
394fi
0c480b89 395%endif
a323900c 396
6e3c39b4
ER
397third_party/libaddressinput/chromium/tools/update-strings.py
398
a323900c
ER
399flags="
400 -Dtarget_arch=%{target_arch} \
401 -Dpython_arch=%{target_arch} \
6e3c39b4 402 -Dffmpeg_branding=Chromium \
b91ce587 403 -Dsystem_libdir=%{_lib} \
a323900c 404 -Dpython_ver=%{py_ver} \
7b454a31
AM
405%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
406 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4 407%endif
f047b07c 408 %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
c980b122 409 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 410 %{?with_shared_libs:-Dlibrary=shared_library} \
b6942fc6 411 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
77bd7e0a 412 -Dinclude_tests__=0 \
c0808220 413%if %{with nacl}
038f76b9 414 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
415 -Ddisable_glibc_untar=1 \
416 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
417 -Ddisable_glibc=1 \
418 -Ddisable_pnacl=1 \
419 -Dbuild_pnacl_newlib=0 \
c0808220 420%else
8fb1dc98 421 -Ddisable_pnacl_untar=1 \
c0808220
ER
422 -Ddisable_nacl=1 \
423%endif
a3140cd1
ER
424 %{!?with_sse2:-Ddisable_sse2=1} \
425 %{?with_selinux:-Dselinux=1} \
7d1152d4 426 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 427 -Dlinux_link_libpci=1 \
7879021e 428 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
14c8ce0e 429 -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
71d49434 430 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
2983aa41
ER
431 -Dclang=0 \
432 -Dhost_clang=0 \
14c8ce0e
ER
433 -Dlinux_use_bundled_binutils=0 \
434 -Dlinux_use_bundled_gold=0 \
05998197 435 -Dlinux_use_gold_flags=0 \
71581184 436 -Dlogging_like_official_build=1 \
319f81f7
ER
437 -Dgoogle_api_key=%{google_api_key} \
438 -Dgoogle_default_client_id=%{google_default_client_id} \
439 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 440 %{gyp_with cups} \
8dda6bbc 441 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 442 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
443 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
444 %{gyp_with pulseaudio} \
41d6a4b1 445 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 446 %{gyp_with system_flac} \
01b4dc8e 447 %{gyp_with system_harfbuzz} \
cb6dde87 448 %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
2d65d095 449 %{gyp_with system_jsoncpp} \
62950103
ER
450 %{gyp_with system_libexif} \
451 %{gyp_with system_libmtp} \
9bd2659c 452 %{gyp_with system_libsrtp} \
581aec44 453 %{gyp_with system_libusb} \
88171dca 454 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
ba685303 455 %{gyp_with system_libwebp} \
4884fc99 456 %{gyp_with system_libxnvctrl} \
7b8f219a 457 %{gyp_with system_mesa} \
126ea630 458 %{gyp_with system_minizip} \
62950103 459 %{gyp_with system_opus} \
75a27c2e 460 %{gyp_with system_protobuf} \
bbdce24d 461 %{gyp_with system_re2} \
7e634b46 462 %{gyp_with system_snappy} \
e7fa0817 463 %{gyp_with system_speex} \
914ee37c 464 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
465 %{gyp_with system_v8} \
466 %{gyp_with system_yasm} \
467 %{gyp_with system_zlib} \
0c480b89 468 -Duse_system_bzip2=1 \
62950103 469 -Duse_system_expat=1 \
f1b276d4 470 -Duse_system_libevent=1 \
0c480b89 471 -Duse_system_libjpeg=1 \
f1b276d4
ER
472 -Duse_system_libpng=1 \
473 -Duse_system_libxml=1 \
474 -Duse_system_libxslt=1 \
b363f856 475 -Duse_system_nspr=1 \
7f40f3f4 476 -Duse_system_xdg_utils=1 \
7879021e
ER
477"
478
479build/linux/unbundle/replace_gyp_files.py $flags
480
f8597c6e
ER
481%if %{with ninja}
482chkfile=%{builddir}/build.ninja
483%else
484chkfile=Makefile
485%endif
486test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
487test -e $chkfile || \
7879021e
ER
488 CC="%{__cc}" \
489 CXX="%{__cxx}" \
490 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
491 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
492 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
493 CC_host="%{__cc}" \
494 CXX_host="%{__cxx}" \
495 LD_host="%{__cxx}" \
496%{__python} build/gyp_chromium \
f8597c6e 497 --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
7879021e
ER
498 --depth=. \
499 build/all.gyp \
500 $flags
11ad81c4 501
f8597c6e
ER
502%if %{with ninja}
503ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
504%else
b4d75247 505# need {CC/CXX/LDFLAGS}.host overrides for v8 build
f8597c6e
ER
506%{__make} -r \
507 BUILDTYPE=%{buildtype} \
f1b276d4 508 %{?with_verbose:V=1} \
f1b276d4
ER
509 CC.host="%{__cc}" \
510 CXX.host="%{__cxx}" \
b4d75247 511 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
f8597c6e
ER
512%endif
513 chrome %{?with_sandboxing:chrome_sandbox} \
514 %{nil}
11ad81c4 515
f8597c6e 516cd %{builddir}
535cb410
ER
517MANWIDTH=80 man ./chrome.1 > man.out
518%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
519
11ad81c4
AM
520%install
521rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
522install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
523 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
3b9998d5
ER
524 $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
525 $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
e266589e 526
f8597c6e 527cd %{builddir}
37ceaf05 528cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 529install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
530%{__sed} -i -e '
531 s,@libdir@,%{_libdir}/%{name},
532
533 /@OPTIONS@/ {
534 r options.txt
535 d
536 }
537' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b 538cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
fa8317a0 539cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
8da7b90b
ER
540ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
541ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 542cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 543install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
d1a83042 544install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
fcc48c19 545%if %{without system_ffmpeg}
f1b276d4 546install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 547%endif
e7fa0817 548cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 549cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 550
8da7b90b 551%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 552
164020eb
ER
553%if %{with nacl}
554# Install Native Client files on platforms that support it.
555install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
556install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
557%ifarch %{x8664}
558install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
559%endif
560%ifarch %{ix86}
561install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
562%endif
563%endif
564
0c480b89
ER
565cd -
566
75f96a39 567for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
568 size=${icon##*/product_logo_}
569 size=${size%.png}
570
571 # this will skip non-numeric (22_mono_invert, 22_mono)
572 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
573 test -d "$dir" || continue
574
575 install -d $RPM_BUILD_ROOT$dir
576 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
577done
7f40f3f4 578
13840bc2
AM
579%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
580# http://code.google.com/p/chromium/issues/detail?id=24507
581gecko-mediaplayer*.so
582EOF
11ad81c4 583
589d90ea
ER
584# find locales
585%find_lang %{name}.lang
e7fa0817 586# always package en-US
f1b276d4 587%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 588
11ad81c4
AM
589%clean
590rm -rf $RPM_BUILD_ROOT
591
8da7b90b
ER
592%pretrans
593for d in locales resources; do
594 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
595 install -d %{_datadir}/%{name}
596 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
597 fi
598done
599exit 0
600
f1b276d4 601%post
0eb19b0b 602%update_icon_cache hicolor
b7a6e4ee 603%update_desktop_database
f1b276d4
ER
604%update_browser_plugins
605
606%postun
607if [ "$1" = 0 ]; then
0eb19b0b 608 %update_icon_cache hicolor
f1b276d4
ER
609 %update_browser_plugins
610fi
611
1d2b9616 612%files
11ad81c4 613%defattr(644,root,root,755)
75f96a39 614%doc AUTHORS LICENSE
f1b276d4
ER
615%{_browserpluginsconfdir}/browsers.d/%{name}.*
616%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
617%dir %{_sysconfdir}/%{name}
618%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 619%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
3b9998d5
ER
620%dir %{_sysconfdir}/%{name}/native-messaging-hosts
621%dir %{_sysconfdir}/%{name}/policies
622%dir %{_sysconfdir}/%{name}/policies/managed
f1b276d4
ER
623%attr(755,root,root) %{_bindir}/%{name}
624%{_mandir}/man1/%{name}.1*
11ad81c4 625%{_desktopdir}/*.desktop
0eb19b0b 626%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 627%dir %{_libdir}/%{name}
e9abb380 628%{_libdir}/%{name}/chrome*.pak
c14cd342 629%{_libdir}/%{name}/content_resources.pak
f047b07c 630%{_libdir}/%{name}/keyboard_resources.pak
97fac491 631%{_libdir}/%{name}/resources.pak
fa8317a0
ER
632%{_libdir}/%{name}/natives_blob.bin
633%{_libdir}/%{name}/snapshot_blob.bin
8da7b90b
ER
634%{_libdir}/%{name}/locales
635%{_libdir}/%{name}/resources
636
637%dir %{_datadir}/%{name}
638%dir %{_datadir}/%{name}/locales
639%{_datadir}/%{name}/locales/en-US.pak
640%dir %{_datadir}/%{name}/resources
641%{_datadir}/%{name}/resources/inspector
642
f1b276d4
ER
643%dir %{_libdir}/%{name}/plugins
644%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 645# These unique permissions are intentional and necessary for the sandboxing
d1a83042 646%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
f1b276d4
ER
647
648# ffmpeg libs
fcc48c19 649%if %{without system_ffmpeg}
f1b276d4 650%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 651%endif
f1b276d4 652
164020eb
ER
653%if %{with nacl}
654%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
655%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
656%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
657%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
658%endif
659
f1b276d4
ER
660%files l10n -f %{name}.lang
661%defattr(644,root,root,755)
This page took 0.203337 seconds and 4 git commands to generate.