]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
synced remove_bundled_libraries with gentoo ebuild
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_with     dev                     # with dev optimizations (skip clean source)
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
10 %bcond_without  libjpegturbo    # use libjpeg-turbo features
11 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
12 %bcond_without  ninja                   # use Ninja instead of make to build
13 %bcond_without  pulseaudio              # with pulseaudio
14 %bcond_without  sandboxing              # with sandboxing
15 %bcond_with             selinux                 # with SELinux (need policy first)
16 %bcond_with             shared_libs             # with shared libs
17 %bcond_with             sse2                    # use SSE2 instructions
18 %bcond_without  system_flac             # system flac
19 %bcond_with     system_ffmpeg   # system ffmpeg instead of ffmpegsumo
20 %bcond_without  system_harfbuzz # system harfbuzz
21 %bcond_without  system_icu      # system icu
22 %bcond_without  system_jsoncpp  # system jsoncpp
23 %bcond_without  system_libexif  # system libexif
24 %bcond_without  system_libmtp   # system libmtp
25 %bcond_with     system_libusb   # system libusb-1, disabled: http://crbug.com/266149
26 %bcond_without  system_libwebp  # system libwebp
27 %bcond_without  system_libxnvctrl       # system libxnvctrl
28 %bcond_with     system_mesa             # system Mesa
29 %bcond_without  system_minizip  # system minizip
30 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
31 # protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
32 %bcond_with     system_protobuf # system protobuf
33 %bcond_without  system_re2              # system re2
34 %bcond_without  system_snappy   # system snappy
35 %bcond_without  system_speex    # system speex
36 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
37 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
38 %bcond_with             system_v8               # system v8
39 %bcond_with     system_libvpx   # system libvpx
40 %bcond_without  system_yasm             # system yasm
41 %bcond_without  system_zlib             # system zlib
42 %bcond_with     tcmalloc                # use tcmalloc
43 %bcond_without  verbose                 # verbose build (V=1)
44
45 %ifarch %{ix86}
46 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
47 %undefine       with_system_mesa
48
49 # unable build with debuginfo on 32bit build systems
50 # /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
51 %undefine       with_debuginfo
52 %endif
53
54 %ifarch %{x8664}
55 # x86_64 systems fail with debugedit crashing
56 # /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
57 %undefine       with_debuginfo
58 %endif
59
60 # TODO
61 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
62 # - use_system_skia
63 # - use_system_ssl (use_openssl: http://crbug.com/62803)
64 # - use_system_stlport (android specific)
65 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
66
67 # NOTES:
68 # - mute BEEP mixer if you do not want to hear horrible system bell when
69 #   pressing home/end in url bar or more ^F search results on page.
70 # - space considerations:
71 #   - unpacked sources: ~490MiB
72 #   - built code: ~1.4GiB (x86_64/i686)
73 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
74 # - to look for new tarball, use update-source.sh script
75
76 %define         branch          42.0.2311
77 %define         basever         82
78 #define         patchver        118
79 %define         gyp_rev 1014
80 Summary:        A WebKit powered web browser
81 Name:           chromium-browser
82 %if "%{?patchver}" != ""
83 Version:        %{branch}.%{patchver}
84 %else
85 Version:        %{branch}.%{basever}
86 %endif
87 Release:        0.1
88 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
89 Group:          X11/Applications/Networking
90 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
91 # Source0-md5:  7bdbf015d663e082f5bbe4cf24907049
92 %if "%{?patchver}" != ""
93 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
94 # Patch0-md5:   fc9cd6fd3392142db2ada6b98b89fa80
95 %endif
96 Source1:        %{name}.default
97 Source2:        %{name}.sh
98 Source3:        %{name}.desktop
99 Source5:        find-lang.sh
100 Source6:        update-source.sh
101 Source7:        clean-source.sh
102 Source8:        get-source.sh
103 Source9:        master_preferences.json
104 # https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
105 Patch2:         enable-video-decode-accel.patch
106 Patch7:         dlopen_sonamed_gl.patch
107 Patch8:         chromium_useragent.patch.in
108 # https://bugs.gentoo.org/show_bug.cgi?id=393471
109 # libjpeg-turbo >= 1.1.90 supports that feature
110 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
111 Patch15:        nacl-build-irt.patch
112 Patch16:        nacl-linkingfix.patch
113 Patch18:        nacl-no-untar.patch
114 Patch24:        nacl-verbose.patch
115 Patch25:        gnome3-volume-control.patch
116 Patch26:        master-prefs-path.patch
117 Patch28:        system-mesa.patch
118 Patch31:        system-jinja.patch
119 Patch32:        remove_bundled_libraries-stale.patch
120 Patch35:        etc-dir.patch
121 Patch36:        angle.patch
122 Patch37:        %{name}-build.patch
123 Patch38:        vaapi_include.patch
124 URL:            http://www.chromium.org/Home
125 %{?with_gconf:BuildRequires:    GConf2-devel}
126 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
127 BuildRequires:  Mesa-libGLES-devel >= 9.1
128 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
129 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
130 BuildRequires:  alsa-lib-devel
131 BuildRequires:  atk-devel
132 BuildRequires:  bison
133 BuildRequires:  bzip2-devel
134 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
135 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
136 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
137 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
138 %{?with_cups:BuildRequires:     cups-devel}
139 BuildRequires:  elfutils-devel
140 BuildRequires:  expat-devel
141 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
142 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
143 BuildRequires:  fontconfig-devel
144 BuildRequires:  glib2-devel
145 BuildRequires:  gperf
146 %{?with_gps:BuildRequires:      gpsd-devel}
147 BuildRequires:  gtest-devel
148 BuildRequires:  gtk+2-devel
149 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
150 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
151 %{?with_kerberos:BuildRequires: heimdal-devel}
152 BuildRequires:  hicolor-icon-theme
153 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
154 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
155 BuildRequires:  libevent-devel
156 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
157 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
158 %{?with_system_icu:BuildRequires:       libicu-devel >= 4.6}
159 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
160 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
161 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
162 BuildRequires:  libpng-devel
163 %{?with_selinux:BuildRequires:  libselinux-devel}
164 BuildRequires:  libstdc++-devel
165 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
166 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 1.3.0}
167 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.4.0}
168 BuildRequires:  libxml2-devel
169 BuildRequires:  libxslt-devel
170 BuildRequires:  man-db
171 %{?with_system_minizip:BuildRequires:   minizip-devel}
172 %{?with_ninja:BuildRequires:    ninja >= 1.3.0}
173 BuildRequires:  nspr-devel
174 BuildRequires:  nss-devel >= 1:3.12.3
175 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
176 BuildRequires:  pam-devel
177 BuildRequires:  pango-devel
178 BuildRequires:  pciutils-devel
179 BuildRequires:  perl-JSON
180 BuildRequires:  perl-modules
181 BuildRequires:  pkgconfig
182 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
183 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
184 BuildRequires:  python
185 BuildRequires:  python-BeautifulSoup
186 #BuildRequires: python-gyp >= 1-%{gyp_rev}
187 BuildRequires:  python-jinja2 >= 2.7
188 BuildRequires:  python-modules
189 BuildRequires:  python-ply >= 3.4
190 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
191 BuildRequires:  rpm >= 4.4.9-56
192 BuildRequires:  rpmbuild(macros) >= 1.453
193 %{?with_system_snappy:BuildRequires:    snappy-devel}
194 BuildRequires:  speech-dispatcher-devel >= 0.8
195 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
196 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
197 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
198 BuildRequires:  tar >= 1:1.22
199 BuildRequires:  udev-devel
200 BuildRequires:  usbutils
201 BuildRequires:  util-linux
202 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
203 BuildRequires:  which
204 BuildRequires:  xorg-lib-libXScrnSaver-devel
205 BuildRequires:  xorg-lib-libXtst-devel
206 BuildRequires:  xz
207 %{?with_system_yasm:BuildRequires:      yasm}
208 %{?with_system_zlib:BuildRequires:      zlib-devel}
209 Requires:       browser-plugins >= 2.0
210 Requires:       desktop-file-utils
211 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
212 # crashes if no fontconfig font present
213 Requires:       fonts-Type1-urw
214 Requires:       hicolor-icon-theme
215 Requires:       libevent >= 2.0.21
216 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
217 %{?with_system_libvpx:Requires: libvpx >= 1.3.0}
218 Requires:       lsb-release
219 %{?with_system_re2:Requires:    re2 >= 20130115-2}
220 %{?with_system_protobuf:Requires:       protobuf-libs >= 2.5.0-2}
221 Requires:       shared-mime-info
222 %{?with_system_sqlite:Requires: sqlite3(icu)}
223 Requires:       xdg-utils >= 1.0.2-4
224 Requires:       xorg-lib-libX11 >= 1.4.99.1
225 Provides:       wwwbrowser
226 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
227 Obsoletes:      chromium-browser-inspector < 15.0.863.0
228 ExclusiveArch:  %{ix86} %{x8664} arm
229 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
230
231 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
232 # Note: these are for PLD Linux use ONLY.
233 # For your own distribution, please get your own set of keys.
234 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
235 %define         google_default_client_id 724288223830.apps.googleusercontent.com
236 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
237
238 %define         find_lang       sh find-lang.sh %{buildroot}
239
240 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
241 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
242
243 %ifarch %{ix86}
244 %define         target_arch ia32
245 %endif
246 %ifarch %{x8664}
247 %define         target_arch x64
248 %endif
249
250 %define         buildtype       %{?debug:Debug}%{!?debug:Release}
251 %define         builddir        out/%{buildtype}
252
253 %if %{without debuginfo}
254 %define         _enable_debug_packages  0
255 %endif
256
257 %description
258 Chromium is an open-source browser project that aims to build a safer,
259 faster, and more stable way for all Internet users to experience the
260 web.
261
262 Chromium serves as a base for Google Chrome, which is Chromium
263 rebranded (name and logo) with very few additions such as usage
264 tracking and an auto-updater system.
265
266 %package l10n
267 Summary:        chromium-browser language packages
268 Group:          I18n
269 Requires:       %{name} = %{version}-%{release}
270 %if "%{_rpmversion}" >= "5"
271 BuildArch:      noarch
272 %endif
273
274 %description l10n
275 Chromium is an open-source browser project that aims to build a safer,
276 faster, and more stable way for all Internet users to experience the
277 web.
278
279 This package contains language packages for 50 languages:
280
281 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
282 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
283 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
284 zh-TW
285
286 %prep
287 %setup -qc
288 %if "%{?patchver}" != ""
289 cd chromium*-%{branch}.%{basever}
290 %patch0 -p1
291 cd ..
292 %endif
293 mv chromium*-%{branch}.%{basever}/* .
294
295 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
296 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
297 . ./chrome/VERSION
298 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
299 test "$chrome" = %{version}
300
301 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
302 test "$gyp_rev" = %{gyp_rev} || :
303
304 # add chromium and pld to useragent
305 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
306 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
307         -e 's/@BUILD_DIST_NAME@/PLD/g' \
308         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
309         < %{PATCH8} | %{__patch} -p1
310
311 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
312 ln -s %{SOURCE7} .
313
314 #%patch2 -p1 CHECK
315 %patch7 -p1
316 %patch15 -p2
317 %{!?with_libjpegturbo:%patch11 -p0}
318 %patch16 -p1
319 %patch28 -p1
320 %patch25 -p1
321 %{?with_nacl:%patch18 -p1}
322 %patch24 -p1
323 %patch26 -p2
324 %patch31 -p0
325 %patch32 -p1
326 %patch35 -p1
327 %patch36 -p1
328 %patch37 -p1
329 #%patch38 -p1 CHECK
330
331 %{?with_dev:exit 0}
332
333 sh -x clean-source.sh \
334         %{!?with_nacl:nacl=0} \
335         %{!?with_system_libvpx:libvpx=0} \
336         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
337         %{!?with_system_mesa:mesa=0} \
338         %{!?with_system_protobuf:protobuf=0} \
339         %{!?with_system_re2:re2=0} \
340         %{!?with_system_snappy:snappy=0} \
341         %{!?with_system_sqlite:sqlite=0} \
342         %{!?with_system_v8:v8=0} \
343         %{!?with_system_libwebp:libwebp=0} \
344         %{!?with_system_zlib:zlib=0} \
345         %{!?with_system_ffmpeg:ffmpeg=0} \
346         %{nil}
347
348 %build
349 %if %{with nacl}
350 rm -rf native_client/toolchain/linux_x86_newlib
351 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
352 # Make symlinks for NaCL
353 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
354
355 cd native_client/toolchain/linux_x86_newlib
356 ln -s x86_64-nacl/bin bin
357 cd x86_64-nacl/bin
358 __cc='%{__cc}'
359 if [ "${__cc#ccache}" != "$__cc" ]; then
360         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
361         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
362         %{__sed} -i -e '1i#!/bin/sh' gcc g++
363         chmod +x gcc g++
364 else
365         ln -s %{_bindir}/x86_64-nacl-gcc gcc
366         ln -s %{_bindir}/x86_64-nacl-g++ g++
367 fi
368 ln -s gcc x86_64-nacl-gcc
369 ln -s g++ x86_64-nacl-g++
370 ln -s %{_bindir}/x86_64-nacl-ar .
371 ln -s %{_bindir}/x86_64-nacl-ar ar
372 ln -s %{_bindir}/x86_64-nacl-as as
373 ln -s %{_bindir}/x86_64-nacl-ranlib .
374 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
375 ln -s %{_bindir}/x86_64-nacl-strip .
376 ln -s %{_bindir}/x86_64-nacl-strip strip
377 ln -s %{_bindir}/x86_64-nacl-objcopy .
378 ln -s %{_prefix}/x86_64-nacl/lib ../lib
379 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
380 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
381 cd ../../../../..
382 fi
383 %endif
384
385 %if %{without system_ffmpeg}
386 if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
387         # Re-configure bundled ffmpeg
388         cd third_party/ffmpeg
389         chromium/scripts/build_ffmpeg.py linux %{target_arch} \
390                 --branding Chromium
391         chromium/scripts/copy_config.sh
392         chromium/scripts/generate_gyp.py
393         cd -
394 fi
395 %endif
396
397 third_party/libaddressinput/chromium/tools/update-strings.py
398
399 flags="
400         -Dtarget_arch=%{target_arch} \
401         -Dpython_arch=%{target_arch} \
402         -Dffmpeg_branding=Chromium \
403         -Dsystem_libdir=%{_lib} \
404         -Dpython_ver=%{py_ver} \
405 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
406         -Dno_strict_aliasing=1 -Dgcc_version=44 \
407 %endif
408         %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
409         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
410         %{?with_shared_libs:-Dlibrary=shared_library} \
411         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
412         -Dinclude_tests__=0 \
413 %if %{with nacl}
414         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
415         -Ddisable_glibc_untar=1 \
416         -Ddisable_newlib_untar=1 \
417         -Ddisable_glibc=1 \
418         -Ddisable_pnacl=1 \
419         -Dbuild_pnacl_newlib=0 \
420 %else
421         -Ddisable_pnacl_untar=1 \
422         -Ddisable_nacl=1 \
423 %endif
424         %{!?with_sse2:-Ddisable_sse2=1} \
425         %{?with_selinux:-Dselinux=1} \
426         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
427         -Dlinux_link_libpci=1 \
428         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
429         -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
430         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
431         -Dclang=0 \
432         -Dhost_clang=0 \
433         -Dlinux_use_bundled_binutils=0 \
434         -Dlinux_use_bundled_gold=0 \
435         -Dlinux_use_gold_flags=0 \
436         -Dlogging_like_official_build=1 \
437         -Dgoogle_api_key=%{google_api_key} \
438         -Dgoogle_default_client_id=%{google_default_client_id} \
439         -Dgoogle_default_client_secret=%{google_default_client_secret} \
440         %{gyp_with cups} \
441         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
442         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
443         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
444         %{gyp_with pulseaudio} \
445         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
446         %{gyp_with system_flac} \
447         %{gyp_with system_harfbuzz} \
448         %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
449         %{gyp_with system_jsoncpp} \
450         %{gyp_with system_libexif} \
451         %{gyp_with system_libmtp} \
452         %{gyp_with system_libsrtp} \
453         %{gyp_with system_libusb} \
454         %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
455         %{gyp_with system_libwebp} \
456         %{gyp_with system_libxnvctrl} \
457         %{gyp_with system_mesa} \
458         %{gyp_with system_minizip} \
459         %{gyp_with system_opus} \
460         %{gyp_with system_protobuf} \
461         %{gyp_with system_re2} \
462         %{gyp_with system_snappy} \
463         %{gyp_with system_speex} \
464         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
465         %{gyp_with system_v8} \
466         %{gyp_with system_yasm} \
467         %{gyp_with system_zlib} \
468         -Duse_system_bzip2=1 \
469         -Duse_system_expat=1 \
470         -Duse_system_libevent=1 \
471         -Duse_system_libjpeg=1 \
472         -Duse_system_libpng=1 \
473         -Duse_system_libxml=1 \
474         -Duse_system_libxslt=1 \
475         -Duse_system_nspr=1 \
476         -Duse_system_xdg_utils=1 \
477 "
478
479 build/linux/unbundle/replace_gyp_files.py $flags
480
481 %if %{with ninja}
482 chkfile=%{builddir}/build.ninja
483 %else
484 chkfile=Makefile
485 %endif
486 test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
487 test -e $chkfile || \
488         CC="%{__cc}" \
489         CXX="%{__cxx}" \
490         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
491         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
492         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
493         CC_host="%{__cc}" \
494         CXX_host="%{__cxx}" \
495         LD_host="%{__cxx}" \
496 %{__python} build/gyp_chromium \
497         --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
498         --depth=. \
499         build/all.gyp \
500         $flags
501
502 %if %{with ninja}
503 ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
504 %else
505 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
506 %{__make} -r \
507         BUILDTYPE=%{buildtype} \
508         %{?with_verbose:V=1} \
509         CC.host="%{__cc}" \
510         CXX.host="%{__cxx}" \
511         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
512 %endif
513         chrome %{?with_sandboxing:chrome_sandbox} \
514         %{nil}
515
516 cd %{builddir}
517 MANWIDTH=80 man ./chrome.1 > man.out
518 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
519
520 %install
521 rm -rf $RPM_BUILD_ROOT
522 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
523         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
524         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
525         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
526
527 cd %{builddir}
528 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
529 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
530 %{__sed} -i -e '
531         s,@libdir@,%{_libdir}/%{name},
532
533         /@OPTIONS@/ {
534                 r options.txt
535                 d
536         }
537 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
538 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
539 cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
540 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
541 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
542 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
543 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
544 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
545 %if %{without system_ffmpeg}
546 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
547 %endif
548 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
549 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
550
551 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
552
553 %if %{with nacl}
554 # Install Native Client files on platforms that support it.
555 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
556 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
557 %ifarch %{x8664}
558 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
559 %endif
560 %ifarch %{ix86}
561 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
562 %endif
563 %endif
564
565 cd -
566
567 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
568         size=${icon##*/product_logo_}
569         size=${size%.png}
570
571         # this will skip non-numeric (22_mono_invert, 22_mono)
572         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
573         test -d "$dir" || continue
574
575         install -d $RPM_BUILD_ROOT$dir
576         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
577 done
578
579 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
580 # http://code.google.com/p/chromium/issues/detail?id=24507
581 gecko-mediaplayer*.so
582 EOF
583
584 # find locales
585 %find_lang %{name}.lang
586 # always package en-US
587 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
588
589 %clean
590 rm -rf $RPM_BUILD_ROOT
591
592 %pretrans
593 for d in locales resources; do
594         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
595                 install -d %{_datadir}/%{name}
596                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
597         fi
598 done
599 exit 0
600
601 %post
602 %update_icon_cache hicolor
603 %update_desktop_database
604 %update_browser_plugins
605
606 %postun
607 if [ "$1" = 0 ]; then
608         %update_icon_cache hicolor
609         %update_browser_plugins
610 fi
611
612 %files
613 %defattr(644,root,root,755)
614 %doc AUTHORS LICENSE
615 %{_browserpluginsconfdir}/browsers.d/%{name}.*
616 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
617 %dir %{_sysconfdir}/%{name}
618 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
619 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
620 %dir %{_sysconfdir}/%{name}/native-messaging-hosts
621 %dir %{_sysconfdir}/%{name}/policies
622 %dir %{_sysconfdir}/%{name}/policies/managed
623 %attr(755,root,root) %{_bindir}/%{name}
624 %{_mandir}/man1/%{name}.1*
625 %{_desktopdir}/*.desktop
626 %{_iconsdir}/hicolor/*/apps/%{name}.png
627 %dir %{_libdir}/%{name}
628 %{_libdir}/%{name}/chrome*.pak
629 %{_libdir}/%{name}/content_resources.pak
630 %{_libdir}/%{name}/keyboard_resources.pak
631 %{_libdir}/%{name}/resources.pak
632 %{_libdir}/%{name}/natives_blob.bin
633 %{_libdir}/%{name}/snapshot_blob.bin
634 %{_libdir}/%{name}/locales
635 %{_libdir}/%{name}/resources
636
637 %dir %{_datadir}/%{name}
638 %dir %{_datadir}/%{name}/locales
639 %{_datadir}/%{name}/locales/en-US.pak
640 %dir %{_datadir}/%{name}/resources
641 %{_datadir}/%{name}/resources/inspector
642
643 %dir %{_libdir}/%{name}/plugins
644 %attr(755,root,root) %{_libdir}/%{name}/%{name}
645 # These unique permissions are intentional and necessary for the sandboxing
646 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
647
648 # ffmpeg libs
649 %if %{without system_ffmpeg}
650 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
651 %endif
652
653 %if %{with nacl}
654 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
655 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
656 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
657 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
658 %endif
659
660 %files l10n -f %{name}.lang
661 %defattr(644,root,root,755)
This page took 0.071573 seconds and 3 git commands to generate.