]> git.pld-linux.org Git - packages/chef.git/blame - chef.spec
drop unneccessary pinned deps from .gem
[packages/chef.git] / chef.spec
CommitLineData
8354a17e
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
e307965b
ER
5Summary: A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
6Name: chef
23fa8236 7Version: 11.8.2
2e351fff 8Release: 0.14
e307965b
ER
9License: Apache v2.0
10Group: Development/Languages
e307965b 11Source0: http://rubygems.org/downloads/%{name}-%{version}.gem
23fa8236 12# Source0-md5: 7d3c2e8b98ec8df050d92686f1429d8f
5cb2f1b0 13Source1: %{name}.rb
02d95ccd 14Source2: %{name}.tmpfiles
7abbc83b 15Patch0: platform-pld.patch
bc8e6547 16Patch1: FHS.patch
31feaf16 17Patch2: https://github.com/glensc/chef/compare/poldek.patch
3f49fa87 18# Patch2-md5: 5a0fc35de33910b41cba4e87dcb4bf9a
7fbe09ae 19Patch3: https://github.com/glensc/chef/compare/pld-knife-boostrap.patch
d261b596 20# Patch3-md5: bfc884469fad7b5aa46341402be5fccd
2a1bbc08 21URL: http://wiki.opscode.com/display/chef
303651f6
ER
22BuildRequires: rpm-rubyprov
23BuildRequires: rpmbuild(macros) >= 1.656
68cfa14e
ER
24BuildRequires: sed >= 4.0
25%if %{with tests}
8354a17e
ER
26BuildRequires: ruby-abstract
27BuildRequires: ruby-mixlib-authentication >= 1.3.0
55a45456 28BuildRequires: ruby-net-ssh-multi >= 1.1.0
68cfa14e
ER
29BuildRequires: ruby-rack
30BuildRequires: ruby-rake
8354a17e 31#BuildRequires: ruby-rdoc
55a45456 32BuildRequires: ruby-rest-client >= 1.0.4
e8757686
ER
33BuildRequires: ruby-rspec-core < 2.14
34BuildRequires: ruby-rspec-core >= 2.13.0
35BuildRequires: ruby-rspec-expectations < 2.14
36BuildRequires: ruby-rspec-expectations >= 2.13.0
37BuildRequires: ruby-rspec-mocks < 2.14
38BuildRequires: ruby-rspec-mocks >= 2.13.0
8354a17e
ER
39#BuildRequires: ruby-rspec_junit_formatter
40#BuildRequires: ruby-sdoc
68cfa14e 41%endif
97e7edae 42Requires: lsb-release
31feaf16 43Requires: poldek >= 0.30
f0820095 44Requires: ruby >= 1:1.9.3.429-4
e8757686
ER
45Requires: ruby-diff-lcs < 2
46Requires: ruby-diff-lcs >= 1.2
47Requires: ruby-diff-lcs >= 1.2.4
bce16be1 48Requires: ruby-erubis
2a1bbc08 49Requires: ruby-highline >= 1.6.9
2a1bbc08 50Requires: ruby-json >= 1.4.4
e8757686
ER
51Requires: ruby-mime-types < 2
52Requires: ruby-mime-types >= 1.16
2a1bbc08
ER
53Requires: ruby-mixlib-authentication >= 1.3.0
54Requires: ruby-mixlib-cli >= 1.3.0
e8757686
ER
55Requires: ruby-mixlib-config < 3
56Requires: ruby-mixlib-config >= 2.0
bce16be1 57Requires: ruby-mixlib-log >= 1.3.0
e8757686 58Requires: ruby-mixlib-shellout >= 1.2
2a1bbc08
ER
59Requires: ruby-net-ssh >= 2.6
60Requires: ruby-net-ssh-multi >= 1.1.0
e8757686
ER
61Requires: ruby-ohai < 7
62Requires: ruby-ohai >= 6.0
2a1bbc08 63Requires: ruby-rest-client >= 1.0.4
bce16be1 64Requires: ruby-rubygems
2a1bbc08 65Requires: ruby-yajl >= 1.1
cce1595a 66Suggests: chef-zero >= 1.6.2
e307965b
ER
67BuildArch: noarch
68BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
820f7abc
ER
70# do not generate python dependency, yum support is optional
71%define _noautoreqfiles %{ruby_vendorlibdir}/chef/provider/package/yum-dump.py
72
e307965b
ER
73%description
74A systems integration framework, built to bring the benefits of
75configuration management to your entire infrastructure.
76
be8cf7bb
ER
77%package -n knife
78Summary: knife - Chef Server API client utility
79Group: Development/Languages
80Requires: %{name} = %{version}-%{release}
81
82%description -n knife
83Knife is a command-line utility used to manage data on a Chef server
84through the HTTP(S) API. Knife is organized into groups of subcommands
85centered around the various object types in Chef. Each category of
86subcommand is documented in its own manual page.
87
e307965b 88%prep
303651f6 89%setup -q
7abbc83b 90%patch0 -p1
bc8e6547 91%patch1 -p1
31feaf16 92%patch2 -p1
7fbe09ae 93%patch3 -p1
e307965b 94
a58665ad
ER
95grep --exclude-dir=spec --exclude-dir=distro -r /var/chef . && exit 1
96
68cfa14e
ER
97%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
98
8354a17e
ER
99%build
100%if %{with tests}
101rspec spec
102%endif
103
e307965b
ER
104%install
105rm -rf $RPM_BUILD_ROOT
02d95ccd
ER
106install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir},%{_mandir}/man1,%{systemdtmpfilesdir}} \
107 $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},/var/{run/%{name},cache/%{name},lib/%{name}/{roles,data_bags,environments}}}
66164e90 108
68cfa14e 109cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
e307965b 110cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
958b507e 111cp -a distro/common/man/* $RPM_BUILD_ROOT%{_mandir}
23fa8236 112%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/README.md
e307965b 113
5cb2f1b0 114cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/chef.rb
02d95ccd 115cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
303651f6 116
bce16be1
ER
117%clean
118rm -rf $RPM_BUILD_ROOT
119
e307965b
ER
120%files
121%defattr(644,root,root,755)
2a1bbc08 122%doc README.md CONTRIBUTING.md
303651f6 123%dir %{_sysconfdir}/%{name}
5cb2f1b0 124%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/chef.rb
2a1bbc08 125%attr(755,root,root) %{_bindir}/chef-apply
e307965b 126%attr(755,root,root) %{_bindir}/chef-client
f0820095 127%attr(755,root,root) %{_bindir}/chef-service-manager
2a1bbc08 128%attr(755,root,root) %{_bindir}/chef-shell
e307965b 129%attr(755,root,root) %{_bindir}/chef-solo
e307965b 130%attr(755,root,root) %{_bindir}/shef
958b507e 131%{_mandir}/man1/chef-shell.1*
be8cf7bb
ER
132%{_mandir}/man8/chef-client.8*
133%{_mandir}/man8/chef-solo.8*
134%{ruby_vendorlibdir}/chef.rb
135%{ruby_vendorlibdir}/chef
136%exclude %{ruby_vendorlibdir}/chef/knife
137%exclude %{ruby_vendorlibdir}/chef/application/knife.rb
138%exclude %{ruby_vendorlibdir}/chef/chef_fs/knife.rb
139%exclude %{ruby_vendorlibdir}/chef/knife.rb
140%{systemdtmpfilesdir}/chef.conf
141
142%dir /var/lib/%{name}
143%dir /var/lib/%{name}/roles
144%dir /var/lib/%{name}/data_bags
145%dir /var/lib/%{name}/environments
146
147%dir /var/cache/%{name}
148%dir /var/run/%{name}
149
150%files -n knife
151%defattr(644,root,root,755)
152%attr(755,root,root) %{_bindir}/knife
153%{ruby_vendorlibdir}/chef/knife.rb
154%{ruby_vendorlibdir}/chef/knife
155%{ruby_vendorlibdir}/chef/application/knife.rb
156%{ruby_vendorlibdir}/chef/chef_fs/knife.rb
958b507e
ER
157%{_mandir}/man1/knife-bootstrap.1*
158%{_mandir}/man1/knife-client.1*
159%{_mandir}/man1/knife-configure.1*
160%{_mandir}/man1/knife-cookbook-site.1*
161%{_mandir}/man1/knife-cookbook.1*
162%{_mandir}/man1/knife-data-bag.1*
23fa8236
ER
163%{_mandir}/man1/knife-delete.1*
164%{_mandir}/man1/knife-deps.1*
165%{_mandir}/man1/knife-diff.1*
166%{_mandir}/man1/knife-download.1*
167%{_mandir}/man1/knife-edit.1*
958b507e
ER
168%{_mandir}/man1/knife-environment.1*
169%{_mandir}/man1/knife-exec.1*
23fa8236
ER
170%{_mandir}/man1/knife-index-rebuild.1*
171%{_mandir}/man1/knife-list.1*
958b507e 172%{_mandir}/man1/knife-node.1*
23fa8236
ER
173%{_mandir}/man1/knife-raw.1*
174%{_mandir}/man1/knife-recipe-list.1*
958b507e
ER
175%{_mandir}/man1/knife-role.1*
176%{_mandir}/man1/knife-search.1*
23fa8236 177%{_mandir}/man1/knife-show.1*
958b507e
ER
178%{_mandir}/man1/knife-ssh.1*
179%{_mandir}/man1/knife-status.1*
180%{_mandir}/man1/knife-tag.1*
23fa8236
ER
181%{_mandir}/man1/knife-upload.1*
182%{_mandir}/man1/knife-user.1*
183%{_mandir}/man1/knife-xargs.1*
958b507e 184%{_mandir}/man1/knife.1*
This page took 0.893407 seconds and 4 git commands to generate.